Resolves: rhbz#674328 yet more ways that freeserif crashes libicu
This commit is contained in:
parent
6c883575a1
commit
492b56eed1
@ -49,3 +49,14 @@
|
|||||||
le_int32 count, order = 0;
|
le_int32 count, order = 0;
|
||||||
le_int32 featureReferences = 0;
|
le_int32 featureReferences = 0;
|
||||||
const FeatureTable *featureTable = NULL;
|
const FeatureTable *featureTable = NULL;
|
||||||
|
@@ -186,6 +195,10 @@
|
||||||
|
le_uint16 featureIndex = SWAPW(langSysTable->featureIndexArray[feature]);
|
||||||
|
|
||||||
|
featureTable = featureListTable->getFeatureTable(featureIndex, &featureTag);
|
||||||
|
+
|
||||||
|
+ if (!featureTable)
|
||||||
|
+ continue;
|
||||||
|
+
|
||||||
|
featureReferences += SWAPW(featureTable->lookupCount);
|
||||||
|
}
|
||||||
|
|
||||||
|
5
icu.spec
5
icu.spec
@ -1,6 +1,6 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 4.4.2
|
Version: 4.4.2
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
@ -148,6 +148,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 11 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-7
|
||||||
|
- Resolves: rhbz#674328 yet more ways that freeserif crashes libicu
|
||||||
|
|
||||||
* Thu Feb 03 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-6
|
* Thu Feb 03 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-6
|
||||||
- Resolves: rhbz#674328 more ways that freeserif crashes libicu
|
- Resolves: rhbz#674328 more ways that freeserif crashes libicu
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user