Resolves: rhbz#747193 try and enable ccmp for Indic fonts
This commit is contained in:
parent
877bd73bd3
commit
4511ad6d78
43
icu.7601.Indic-ccmp.patch
Normal file
43
icu.7601.Indic-ccmp.patch
Normal file
@ -0,0 +1,43 @@
|
||||
--- icu/source/layout/IndicReordering.cpp 2009-07-01 20:51:26.000000000 +0200
|
||||
+++ icu/source/layout/IndicReordering.cpp 2011-01-08 11:12:49.950566538 +0100
|
||||
@@ -13,6 +13,7 @@
|
||||
|
||||
U_NAMESPACE_BEGIN
|
||||
|
||||
+#define ccmpFeatureTag LE_CCMP_FEATURE_TAG
|
||||
#define loclFeatureTag LE_LOCL_FEATURE_TAG
|
||||
#define initFeatureTag LE_INIT_FEATURE_TAG
|
||||
#define nuktFeatureTag LE_NUKT_FEATURE_TAG
|
||||
@@ -35,6 +36,7 @@
|
||||
#define caltFeatureTag LE_CALT_FEATURE_TAG
|
||||
#define kernFeatureTag LE_KERN_FEATURE_TAG
|
||||
|
||||
+#define ccmpFeatureMask 0x00000001UL
|
||||
#define loclFeatureMask 0x80000000UL
|
||||
#define rphfFeatureMask 0x40000000UL
|
||||
#define blwfFeatureMask 0x20000000UL
|
||||
@@ -73,7 +75,7 @@
|
||||
|
||||
#define repositionedGlyphMask 0x00000002UL
|
||||
|
||||
-#define basicShapingFormsMask ( loclFeatureMask | nuktFeatureMask | akhnFeatureMask | rkrfFeatureMask | blwfFeatureMask | halfFeatureMask | vatuFeatureMask | cjctFeatureMask )
|
||||
+#define basicShapingFormsMask ( ccmpFeatureMask | loclFeatureMask | nuktFeatureMask | akhnFeatureMask | rkrfFeatureMask | blwfFeatureMask | halfFeatureMask | vatuFeatureMask | cjctFeatureMask )
|
||||
#define positioningFormsMask ( kernFeatureMask | distFeatureMask | abvmFeatureMask | blwmFeatureMask )
|
||||
#define presentationFormsMask ( presFeatureMask | abvsFeatureMask | blwsFeatureMask | pstsFeatureMask | halnFeatureMask | caltFeatureMask )
|
||||
|
||||
@@ -480,6 +482,7 @@
|
||||
#define tagArray0 (rphfFeatureMask | tagArray1)
|
||||
|
||||
static const FeatureMap featureMap[] = {
|
||||
+ {ccmpFeatureTag, ccmpFeatureMask},
|
||||
{loclFeatureTag, loclFeatureMask},
|
||||
{initFeatureTag, initFeatureMask},
|
||||
{nuktFeatureTag, nuktFeatureMask},
|
||||
@@ -502,6 +505,7 @@
|
||||
static const le_int32 featureCount = LE_ARRAY_SIZE(featureMap);
|
||||
|
||||
static const FeatureMap v2FeatureMap[] = {
|
||||
+ {ccmpFeatureTag, ccmpFeatureMask},
|
||||
{loclFeatureTag, loclFeatureMask},
|
||||
{nuktFeatureTag, nuktFeatureMask},
|
||||
{akhnFeatureTag, akhnFeatureMask},
|
7
icu.spec
7
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 4.8.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT and UCD and Public Domain
|
||||
@ -12,6 +12,7 @@ Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
Patch1: icu.8198.revert.icu5431.patch
|
||||
Patch2: icu.8800.freeserif.crash.patch
|
||||
Patch3: icu.7601.Indic-ccmp.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -53,6 +54,7 @@ BuildArch: noarch
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
||||
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -140,6 +142,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 24 2011 Caolán McNamara <caolanm@redhat.com> - 4.8.1-2
|
||||
- Resolves: rhbz#747193 try and enable ccmp for Indic fonts
|
||||
|
||||
* Wed Sep 07 2011 Caolán McNamara <caolanm@redhat.com> - 4.8.1-1
|
||||
- Resolves: rhbz#681941 don't link unneccessary -lm, etc.
|
||||
- add icu.8800.freeserif.crash.patch
|
||||
|
Loading…
Reference in New Issue
Block a user