add upstream make install fix
This commit is contained in:
parent
a41abe38cd
commit
447931d632
31
icu.icu7567.libctest.patch
Normal file
31
icu.icu7567.libctest.patch
Normal file
@ -0,0 +1,31 @@
|
||||
Index: /icu/trunk/source/tools/ctestfw/Makefile.in
|
||||
===================================================================
|
||||
--- icu/source/tools/ctestfw/Makefile.in (revision 26596)
|
||||
+++ icu/source/tools/ctestfw/Makefile.in (revision 27878)
|
||||
@@ -80,4 +80,26 @@
|
||||
|
||||
install-library: all-local
|
||||
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
|
||||
+ifneq ($(ENABLE_STATIC),)
|
||||
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
|
||||
+endif
|
||||
+ifneq ($(ENABLE_SHARED),)
|
||||
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
|
||||
+ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
|
||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
|
||||
+ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
|
||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
|
||||
+endif
|
||||
+endif
|
||||
+ifneq ($(IMPORT_LIB_EXT),)
|
||||
+ $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
|
||||
+ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
|
||||
+endif
|
||||
+ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
|
||||
dist-local:
|
4
icu.spec
4
icu.spec
@ -15,6 +15,7 @@ Patch1: icu-3.4-multiarchdevel.patch
|
||||
Patch2: icu.icu6284.strictalias.patch
|
||||
Patch3: icu.6995.kannada.patch
|
||||
Patch4: icu.XXXX.buildfix.patch
|
||||
Patch5: icu.icu7567.libctest.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -58,6 +59,7 @@ BuildArch: noarch
|
||||
%patch2 -p1 -b .icu6284.strictalias.patch
|
||||
%patch3 -p1 -b .icu6995.kannada.patch
|
||||
%patch4 -p1 -b .icuXXXX.buildfix.patch
|
||||
%patch5 -p1 -b .icu7567.libctest.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -72,8 +74,6 @@ make doc
|
||||
rm -rf $RPM_BUILD_ROOT source/__docs
|
||||
make -C source install DESTDIR=$RPM_BUILD_ROOT
|
||||
make -C source install-doc docdir=__docs
|
||||
cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
|
||||
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/*.so.*
|
||||
cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-config
|
||||
chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{name}-config
|
||||
sed -i s/\\\$\(THREADSCXXFLAGS\)// $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/icu.pc
|
||||
|
Loading…
Reference in New Issue
Block a user