Update to 49.1.1
This commit is contained in:
parent
084f6f814b
commit
4137938c60
@ -1,20 +0,0 @@
|
|||||||
--- icu/source/common/uloc.c
|
|
||||||
+++ icu/source/common/uloc.c
|
|
||||||
@@ -1797,7 +1797,7 @@
|
|
||||||
int32_t variantLen = _deleteVariant(variant, uprv_min(variantSize, (nameCapacity-len)), variantToCompare, n);
|
|
||||||
len -= variantLen;
|
|
||||||
if (variantLen > 0) {
|
|
||||||
- if (name[len-1] == '_') { /* delete trailing '_' */
|
|
||||||
+ if (len > 0 && name[len-1] == '_') { /* delete trailing '_' */
|
|
||||||
--len;
|
|
||||||
}
|
|
||||||
addKeyword = VARIANT_MAP[j].keyword;
|
|
||||||
@@ -1805,7 +1805,7 @@
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- if (name[len-1] == '_') { /* delete trailing '_' */
|
|
||||||
+ if (len > 0 && len <= nameCapacity && name[len-1] == '_') { /* delete trailing '_' */
|
|
||||||
--len;
|
|
||||||
}
|
|
||||||
}
|
|
11
icu.spec
11
icu.spec
@ -1,18 +1,17 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 4.8.1.1
|
Version: 49.1.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
URL: http://www.icu-project.org/
|
URL: http://www.icu-project.org/
|
||||||
Source: http://download.icu-project.org/files/icu4c/4.8.1.1/icu4c-4_8_1_1-src.tgz
|
Source: http://download.icu-project.org/files/icu4c/49.1.1/icu4c-49_1_1-src.tgz
|
||||||
BuildRequires: doxygen, autoconf
|
BuildRequires: doxygen, autoconf
|
||||||
Requires: lib%{name} = %{version}-%{release}
|
Requires: lib%{name} = %{version}-%{release}
|
||||||
|
|
||||||
Patch1: icu.8198.revert.icu5431.patch
|
Patch1: icu.8198.revert.icu5431.patch
|
||||||
Patch2: icu.8800.freeserif.crash.patch
|
Patch2: icu.8800.freeserif.crash.patch
|
||||||
Patch3: icu.7601.Indic-ccmp.patch
|
Patch3: icu.7601.Indic-ccmp.patch
|
||||||
Patch4: icu.8984.CVE-2011-4599.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tools and utilities for developing with icu.
|
Tools and utilities for developing with icu.
|
||||||
@ -55,7 +54,6 @@ BuildArch: noarch
|
|||||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||||
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
||||||
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
||||||
%patch4 -p1 -b .icu8984.CVE-2011-4599.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -142,6 +140,9 @@ make -C source check
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 19 2012 Eike Rathke <erack@redhat.com> - 49.1.1-1
|
||||||
|
- Update to 49.1.1
|
||||||
|
|
||||||
* Thu Apr 19 2012 Eike Rathke <erack@redhat.com> - 4.8.1.1-3
|
* Thu Apr 19 2012 Eike Rathke <erack@redhat.com> - 4.8.1.1-3
|
||||||
- Resolves: rhbz#813484 doxygen 1.8.0 does not provide installdox, omit from install
|
- Resolves: rhbz#813484 doxygen 1.8.0 does not provide installdox, omit from install
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user