rh#206615# malayam rendering
This commit is contained in:
parent
fb8ebafb4c
commit
3ee9efd547
39
icu.icu5418.malayam.patch
Normal file
39
icu.icu5418.malayam.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- icu/source/layout/IndicClassTables.cpp.orig 2006-08-23 01:12:40.000000000 +0100
|
||||||
|
+++ icu/source/layout/IndicClassTables.cpp 2006-09-25 09:06:38.000000000 +0100
|
||||||
|
@@ -173,6 +173,19 @@
|
||||||
|
_iv, _iv, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx // 0CE0 - 0CEF
|
||||||
|
};
|
||||||
|
|
||||||
|
+#if 1
|
||||||
|
+//use the pango char class table here
|
||||||
|
+static const IndicClassTable::CharClass mlymCharClasses[] =
|
||||||
|
+{
|
||||||
|
+ _xx, _xx, _mp, _mp, _xx, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _xx, _iv, _iv, /* 0D00 - 0D0F */
|
||||||
|
+ _iv, _xx, _iv, _iv, _iv, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, /* 0D10 - 0D1F */
|
||||||
|
+ _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _ct, _xx, _ct, _ct, _ct, _ct, _ct, _pb, /* 0D20 - 0D2F */
|
||||||
|
+ _pb, _cn, _ct, _ct, _ct, _pb, _ct, _ct, _ct, _ct, _xx, _xx, _xx, _xx, _dr, _dr, /* 0D30 - 0D3F */
|
||||||
|
+ _dr, _dr, _dr, _dr, _xx, _xx, _dl, _dl, _dl, _xx, _s1, _s2, _s3, _vr, _xx, _xx, /* 0D40 - 0D4F */
|
||||||
|
+ _xx, _xx, _xx, _xx, _xx, _xx, _xx, _dr, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, /* 0D50 - 0D5F */
|
||||||
|
+ _iv, _iv, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx /* 0D60 - 0D6F */
|
||||||
|
+};
|
||||||
|
+#else
|
||||||
|
// FIXME: this is correct for old-style Malayalam (MAL) but not for reformed Malayalam (MLR)
|
||||||
|
// FIXME: should there be a REPH for old-style Malayalam?
|
||||||
|
static const IndicClassTable::CharClass mlymCharClasses[] =
|
||||||
|
@@ -185,6 +198,7 @@
|
||||||
|
_xx, _xx, _xx, _xx, _xx, _xx, _xx, _m2, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, // 0D50 - 0D5F
|
||||||
|
_iv, _iv, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx, _xx // 0D60 - 0D6F
|
||||||
|
};
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
static const IndicClassTable::CharClass sinhCharClasses[] =
|
||||||
|
{
|
||||||
|
@@ -232,7 +246,7 @@
|
||||||
|
#define TAML_SCRIPT_FLAGS (SF_MPRE_FIXUP | SF_NO_POST_BASE_LIMIT | SF_FILTER_ZERO_WIDTH)
|
||||||
|
#define TELU_SCRIPT_FLAGS (SF_MATRAS_AFTER_BASE | SF_FILTER_ZERO_WIDTH | 3)
|
||||||
|
#define KNDA_SCRIPT_FLAGS (SF_MATRAS_AFTER_BASE | SF_FILTER_ZERO_WIDTH | 3)
|
||||||
|
-#define MLYM_SCRIPT_FLAGS (SF_MPRE_FIXUP | SF_NO_POST_BASE_LIMIT | SF_FILTER_ZERO_WIDTH)
|
||||||
|
+#define MLYM_SCRIPT_FLAGS (SF_MPRE_FIXUP | SF_NO_POST_BASE_LIMIT)
|
||||||
|
#define SINH_SCRIPT_FLAGS (SF_MPRE_FIXUP | SF_NO_POST_BASE_LIMIT)
|
||||||
|
|
||||||
|
//
|
7
icu.spec
7
icu.spec
@ -1,6 +1,6 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 3.6
|
Version: 3.6
|
||||||
Release: 2
|
Release: 3
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -13,6 +13,7 @@ BuildRequires: doxygen, autoconf
|
|||||||
Patch1: icu-3.4-multiarchdevel.patch
|
Patch1: icu-3.4-multiarchdevel.patch
|
||||||
Patch2: icu-config
|
Patch2: icu-config
|
||||||
Patch3: icu.icu5365.dependantvowels.patch
|
Patch3: icu.icu5365.dependantvowels.patch
|
||||||
|
Patch4: icu.icu5418.malayam.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The International Components for Unicode (ICU) libraries provide
|
The International Components for Unicode (ICU) libraries provide
|
||||||
@ -53,6 +54,7 @@ Group: Documentation
|
|||||||
%setup -q -n %{name}
|
%setup -q -n %{name}
|
||||||
%patch1 -p1 -b .multiarchdevel
|
%patch1 -p1 -b .multiarchdevel
|
||||||
%patch3 -p1 -b .dependantvowels
|
%patch3 -p1 -b .dependantvowels
|
||||||
|
%patch4 -p1 -b .malayam.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -133,6 +135,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 25 2006 Caolan McNamara <caolanm@redhat.com> - 3.6-3
|
||||||
|
- rh#206615# render malayam like pango
|
||||||
|
|
||||||
* Wed Sep 06 2006 Caolan McNamara <caolanm@redhat.com> - 3.6-2
|
* Wed Sep 06 2006 Caolan McNamara <caolanm@redhat.com> - 3.6-2
|
||||||
- fix rh#205252#/icu#5365 (gnome#121882#/#icu#4026#) to make icu
|
- fix rh#205252#/icu#5365 (gnome#121882#/#icu#4026#) to make icu
|
||||||
like pango for multiple dependant vowels
|
like pango for multiple dependant vowels
|
||||||
|
Loading…
Reference in New Issue
Block a user