bump and drop integrated patches
This commit is contained in:
parent
749d073a00
commit
3c488ab23b
@ -1,3 +1,2 @@
|
||||
icu4c-4_0-src.tgz
|
||||
icu-config
|
||||
icu4c-4_0_1-src.tgz
|
||||
icu4c-4_2_d03-src.tgz
|
||||
|
@ -1,13 +1,13 @@
|
||||
--- icu/source/configure.in.orig 2006-05-02 12:10:31.000000000 +0100
|
||||
+++ icu/source/configure.in 2006-05-02 15:06:07.000000000 +0100
|
||||
@@ -1011,6 +1011,7 @@
|
||||
@@ -1117,6 +1117,7 @@
|
||||
Makefile \
|
||||
data/icupkg.inc \
|
||||
data/pkgdataMakefile \
|
||||
config/Makefile.inc \
|
||||
+ config/icu.pc \
|
||||
config/pkgdataMakefile \
|
||||
data/Makefile \
|
||||
stubdata/Makefile \
|
||||
common/Makefile \
|
||||
--- /dev/null 2006-04-29 13:38:37.035974750 +0100
|
||||
+++ icu/source/config/icu.pc.in 2006-05-02 15:03:14.000000000 +0100
|
||||
@@ -0,0 +1,46 @@
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -ru icu.orig/source/common/unames.c icu/source/common/unames.c
|
||||
--- icu.orig/source/common/unames.c 2007-10-27 11:51:32.000000000 +0100
|
||||
+++ icu/source/common/unames.c 2007-10-27 11:52:09.000000000 +0100
|
||||
@@ -37,10 +37,16 @@
|
||||
#define LINES_PER_GROUP (1UL<<GROUP_SHIFT)
|
||||
#define GROUP_MASK (LINES_PER_GROUP-1)
|
||||
|
||||
+#ifdef __GNUC__
|
||||
+#define PACKED __attribute__ ((packed))
|
||||
+#else
|
||||
+#define PACKED
|
||||
+#endif
|
||||
+
|
||||
typedef struct {
|
||||
uint16_t groupMSB,
|
||||
offsetHigh, offsetLow; /* avoid padding */
|
||||
-} Group;
|
||||
+} PACKED Group;
|
||||
|
||||
typedef struct {
|
||||
uint32_t start, end;
|
@ -1,11 +0,0 @@
|
||||
--- icu.orig/source/layoutex/ParagraphLayout.cpp 2009-02-03 16:29:07.000000000 +0000
|
||||
+++ icu/source/layoutex/ParagraphLayout.cpp 2009-02-03 16:29:19.000000000 +0000
|
||||
@@ -868,7 +868,7 @@
|
||||
|
||||
return nullLanguageCode;
|
||||
}
|
||||
-#elif
|
||||
+#else
|
||||
|
||||
// TODO - dummy implementation for right now...
|
||||
le_int32 ParagraphLayout::getLanguageCode(const Locale *locale)
|
27
icu.spec
27
icu.spec
@ -1,22 +1,20 @@
|
||||
Name: icu
|
||||
Version: 4.0.1
|
||||
Release: 3%{?dist}
|
||||
Version: 4.2
|
||||
Release: 0.1.d03%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
URL: http://www.icu-project.org/
|
||||
Source0: http://download.icu-project.org/files/icu4c/%{version}/icu4c-4_0_1-src.tgz
|
||||
Source0: http://download.icu-project.org/files/icu4c/4.2/icu4c-4_2_d03-src.tgz
|
||||
Source1: icu-config
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: doxygen, autoconf
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
Patch1: icu-3.4-multiarchdevel.patch
|
||||
Patch2: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch3: icu.icu6008.arm.padding.patch
|
||||
Patch2: icu.icu6284.strictalias.patch
|
||||
Patch3: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch4: icu.icu6213.worstcase.patch
|
||||
Patch5: icu.icu6284.strictalias.patch
|
||||
Patch6: icu.icu6439.bare.elif.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -56,11 +54,10 @@ Group: Documentation
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p1 -b .multiarchdevel
|
||||
%patch2 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
%patch3 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch4 -p1 -b .icu6213.worstcase.patch
|
||||
%patch5 -p1 -b .icu6284.strictalias.patch
|
||||
%patch6 -p1 -b .icu6439.bare.elif.patch
|
||||
%patch2 -p1 -b .icu6284.strictalias.patch
|
||||
#let's skip these for now, hopefully unneccessary
|
||||
#%patch3 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
#%patch4 -p1 -b .icu6213.worstcase.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -95,6 +92,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc license.html readme.html
|
||||
%{_bindir}/derb
|
||||
%{_bindir}/genbrk
|
||||
%{_bindir}/gencfu
|
||||
%{_bindir}/gencnval
|
||||
%{_bindir}/genctd
|
||||
%{_bindir}/genrb
|
||||
@ -137,6 +135,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Sun May 03 2009 Caolan McNamara <caolanm@redhat.com> - 4.2-0.1.d03
|
||||
- 4.2 release candidate
|
||||
- drop resolved icu.icu6008.arm.padding.patch
|
||||
- drop resolved icu.icu6439.bare.elif.patch
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user