Resolves: rhbz#431029, rhbz#424661 Remove workaround for 0D31 characters
This commit is contained in:
parent
72806f5d3d
commit
3828d3d40e
@ -75,15 +75,14 @@
|
||||
if (IndicClassTable::isConsonant(charClass)) {
|
||||
if (postBaseLimit == 0 || seenVattu ||
|
||||
(baseConsonant > baseLimit && !classTable->isVirama(chars[baseConsonant - 1])) ||
|
||||
@@ -645,6 +720,21 @@
|
||||
@@ -645,6 +720,20 @@
|
||||
output.writeChar(chars[i], i, tagArray4);
|
||||
}
|
||||
|
||||
+ /* for the special conjuction of Cons+0x0d4d+0x0d31 or Cons+0x0d4d+0x0d30 of Malayalam */
|
||||
+ /* for the special conjuction of Cons+0x0d4d+0x0d30 of Malayalam */
|
||||
+ if ((baseConsonant - 2 >= 0) &&
|
||||
+ (chars[baseConsonant - 1] == 0x0d4d) &&
|
||||
+ ((chars[baseConsonant] == 0x0d31) ||
|
||||
+ (chars[baseConsonant] == 0x0d30)) &&
|
||||
+ (chars[baseConsonant] == 0x0d30) &&
|
||||
+ ((chars[baseConsonant - 2] >= 0x0d15) &&
|
||||
+ (chars[baseConsonant - 2] <= 0x0d39))) {
|
||||
+ if (baseConsonant < 3 || chars[baseConsonant - 3] != 0x0d4d) {
|
||||
|
5
icu.spec
5
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 3.8.1
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
@ -145,6 +145,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 31 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-4
|
||||
- Resolves: rhbz#431029, rhbz#424661 Remove workaround for 0D31 characters
|
||||
|
||||
* Fri Jan 25 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-3
|
||||
- CVE-2007-4770 CVE-2007-4771 add icu.regexp.patch
|
||||
- Resolves: rhbz#423211 fix malalayam stuff in light of syllable
|
||||
|
Loading…
Reference in New Issue
Block a user