add icu.icu6008.arm.padding.patch
This commit is contained in:
parent
f69eaac32c
commit
32865df6f5
21
icu.icu6008.arm.padding.patch
Normal file
21
icu.icu6008.arm.padding.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -ru icu.orig/source/common/unames.c icu/source/common/unames.c
|
||||||
|
--- icu.orig/source/common/unames.c 2007-10-27 11:51:32.000000000 +0100
|
||||||
|
+++ icu/source/common/unames.c 2007-10-27 11:52:09.000000000 +0100
|
||||||
|
@@ -37,10 +37,16 @@
|
||||||
|
#define LINES_PER_GROUP (1UL<<GROUP_SHIFT)
|
||||||
|
#define GROUP_MASK (LINES_PER_GROUP-1)
|
||||||
|
|
||||||
|
+#ifdef __GNUC__
|
||||||
|
+#define PACKED __attribute__ ((packed))
|
||||||
|
+#else
|
||||||
|
+#define PACKED
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
typedef struct {
|
||||||
|
uint16_t groupMSB,
|
||||||
|
offsetHigh, offsetLow; /* avoid padding */
|
||||||
|
-} Group;
|
||||||
|
+} PACKED Group;
|
||||||
|
|
||||||
|
typedef struct {
|
||||||
|
uint32_t start, end;
|
7
icu.spec
7
icu.spec
@ -1,6 +1,6 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 3.8
|
Version: 3.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -18,6 +18,7 @@ Patch6: icu.icuXXXX.virama.prevnext.patch
|
|||||||
Patch7: icu.icu5557.safety.patch
|
Patch7: icu.icu5557.safety.patch
|
||||||
Patch8: icu.icu5506.multiplevowels.patch
|
Patch8: icu.icu5506.multiplevowels.patch
|
||||||
Patch9: icu.icuXXXX.malayalam.bysyllable.patch
|
Patch9: icu.icuXXXX.malayalam.bysyllable.patch
|
||||||
|
Patch10: icu.icu6008.arm.padding.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tools and utilities for developing with icu.
|
Tools and utilities for developing with icu.
|
||||||
@ -64,6 +65,7 @@ Group: Documentation
|
|||||||
%patch7 -p1 -b .icu5557.safety.patch
|
%patch7 -p1 -b .icu5557.safety.patch
|
||||||
%patch8 -p1 -b .icu5506.multiplevowels.patch
|
%patch8 -p1 -b .icu5506.multiplevowels.patch
|
||||||
%patch9 -p1 -b .icuXXXX.malayalam.bysyllable.patch
|
%patch9 -p1 -b .icuXXXX.malayalam.bysyllable.patch
|
||||||
|
%patch10 -p1 -b .icu6008.arm.padding.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -140,6 +142,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 27 2007 Caolan McNamara <caolanm@redhat.com> - 3.8-2
|
||||||
|
- add icu.icu6008.arm.padding.patch to fix an arm problem
|
||||||
|
|
||||||
* Tue Oct 02 2007 Caolan McNamara <caolanm@redhat.com> - 3.8-1
|
* Tue Oct 02 2007 Caolan McNamara <caolanm@redhat.com> - 3.8-1
|
||||||
- latest version
|
- latest version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user