next version
This commit is contained in:
parent
a37b20a1f1
commit
318d8b5550
@ -1 +1 @@
|
||||
icu4c-3_8-src.tgz
|
||||
icu4c-3_8_1-src.tgz
|
||||
|
@ -59,10 +59,10 @@
|
||||
+Libs: @LDFLAGS@ ${ICULIBS} @LIBS@
|
||||
--- icu/source/Makefile.in.orig 2006-05-02 12:10:31.000000000 +0100
|
||||
+++ icu/source/Makefile.in 2006-05-02 15:18:15.000000000 +0100
|
||||
@@ -125,6 +125,8 @@
|
||||
@$(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
|
||||
@@ -126,6 +126,8 @@
|
||||
$(INSTALL_DATA) @platform_make_fragment@ $(DESTDIR)$(pkgdatadir)/config/@platform_make_fragment_name@
|
||||
$(INSTALL_SCRIPT) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(pkgdatadir)/mkinstalldirs
|
||||
$(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
|
||||
+ @$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
|
||||
+ $(INSTALL_DATA) $(top_srcdir)/config/icu.pc $(DESTDIR)$(libdir)/pkgconfig/icu.pc
|
||||
$(INSTALL_DATA) $(top_srcdir)/../license.html $(DESTDIR)$(pkgdatadir)/license.html
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- icu.orig/source/layout/OpenTypeLayoutEngine.cpp 2007-12-11 11:18:20.000000000 +0000
|
||||
+++ icu/source/layout/OpenTypeLayoutEngine.cpp 2007-12-11 11:19:22.000000000 +0000
|
||||
@@ -338,7 +338,9 @@
|
||||
for (le_int32 g = 0; g < glyphCount; g += 1) {
|
||||
LEGlyphID glyph = glyphStorage[g];
|
||||
|
||||
- if (glyph == zwnj) {
|
||||
+ if (!glyph) {
|
||||
+ continue;
|
||||
+ } else if (glyph == zwnj) {
|
||||
glyphStorage[g] = LE_SET_GLYPH(glyph, 0xFFFF);
|
||||
} else if (glyph == nbsp) {
|
||||
glyphStorage[g] = LE_SET_GLYPH(glyph, 0x0003);
|
13
icu.spec
13
icu.spec
@ -1,11 +1,11 @@
|
||||
Name: icu
|
||||
Version: 3.8
|
||||
Release: 6%{?dist}
|
||||
Version: 3.8.1
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
URL: http://www.icu-project.org/
|
||||
Source0: http://download.icu-project.org/files/icu4c/3.8/icu4c-3_8-src.tgz
|
||||
Source0: http://download.icu-project.org/files/icu4c/3.8.1/icu4c-3_8_1-src.tgz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: doxygen, autoconf
|
||||
|
||||
@ -20,7 +20,6 @@ Patch8: icu.icu5506.multiplevowels.patch
|
||||
Patch9: icu.icuXXXX.malayalam.bysyllable.patch
|
||||
Patch10: icu.icu6008.arm.padding.patch
|
||||
Patch11: icu.icu5498.openoffice.org.patch
|
||||
Patch12: icu.icu6084.zwnj.notdef.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -69,7 +68,6 @@ Group: Documentation
|
||||
%patch9 -p1 -b .icuXXXX.malayalam.bysyllable.patch
|
||||
%patch10 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch11 -p1 -b .icu5498.openoffice.org.patch
|
||||
%patch12 -p1 -b .icu6084.zwnj.notdef.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -137,6 +135,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/icu.pc
|
||||
%dir %{_datadir}/%{name}
|
||||
%dir %{_datadir}/%{name}/%{version}
|
||||
%{_datadir}/%{name}/%{version}/install-sh
|
||||
%{_datadir}/%{name}/%{version}/mkinstalldirs
|
||||
%{_datadir}/%{name}/%{version}/config
|
||||
%doc %{_datadir}/%{name}/%{version}/license.html
|
||||
@ -146,6 +145,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 11 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-1
|
||||
- latest version
|
||||
- drop fixed icu.icu6084.zwnj.notdef.patch
|
||||
|
||||
* Thu Dec 13 2007 Caolan McNamara <caolanm@redhat.com> - 3.8-6
|
||||
- Resolves: rhbz#423211 experimental hack for 0d15+0d4d+0d30
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user