Update to 72.1
This commit is contained in:
parent
59aa953d77
commit
2d9c531428
16
icu.spec
16
icu.spec
@ -2,20 +2,20 @@
|
||||
|
||||
# Set to 0 when upgrading to a new ICU release that contains up-to-date timezone data.
|
||||
# (or update the timezone data update..).
|
||||
%global use_tzdata_update 1
|
||||
%global use_tzdata_update 0
|
||||
# Adjust to version major; used in tzdata update.
|
||||
%global icu_major 71
|
||||
%global icu_major 72
|
||||
|
||||
Name: icu
|
||||
Version: 71.1
|
||||
Release: 2%{?dist}
|
||||
Version: 72.1
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
|
||||
License: MIT and UCD and Public Domain
|
||||
URL: http://site.icu-project.org/
|
||||
Source0: https://github.com/unicode-org/icu/releases/download/release-71-1/icu4c-71_1-src.tgz
|
||||
Source0: https://github.com/unicode-org/icu/releases/download/release-72-1/icu4c-72_1-src.tgz
|
||||
%if 0%{?use_tzdata_update}
|
||||
Source1: https://github.com/unicode-org/icu/releases/download/release-71-1/icu4c-71_1-data.zip
|
||||
Source1: https://github.com/unicode-org/icu/releases/download/release-72-1/icu4c-72_1-data.zip
|
||||
Source2: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/metaZones.txt
|
||||
Source3: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/timezoneTypes.txt
|
||||
Source4: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/windowsZones.txt
|
||||
@ -31,7 +31,6 @@ Requires: lib%{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
Patch4: gennorm2-man.patch
|
||||
Patch5: icuinfo-man.patch
|
||||
Patch10: timezone-update-2022b.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -194,6 +193,9 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 28 2022 Pete Walter <pwalter@fedoraproject.org> - 72.1-1
|
||||
- Update to 72.1
|
||||
|
||||
* Fri Sep 23 2022 Mike FABIAN <mfabian@redhat.com> - 71.1-2
|
||||
- Update timezone data to 2022b
|
||||
|
||||
|
4
sources
4
sources
@ -3,5 +3,5 @@ SHA512 (timezoneTypes.txt) = 11fa693a0cc1a232ea23befdf9906f04896190210e85ecad82c
|
||||
SHA512 (windowsZones.txt) = 0244076828692df657b48f05d0f1537ae0fb08f5f91ef8858e08097ce5df70363e11594ca24c735e71620504b68241ae4901a481ad59f1b6ec6b9eb28a30eda5
|
||||
SHA512 (zoneinfo64.txt) = 289ac8dbdcdf39221d0cc41562134270433210658acd57d20c3ba3d727bfeba007ddcc7123634300b7a93cccafe8bb367f8c134e3414dc00d0dd309a29dd9373
|
||||
SHA512 (icu-config.sh) = 04e00dbbd40c84ef355f149ab8d20dd0fa7fa7abacac849ea065ebab5de2746c13626e61f2a543c5207aa246a5805d2d9e64be9221a40eb8314d720c7824d314
|
||||
SHA512 (icu4c-71_1-src.tgz) = 1fd2a20aef48369d1f06e2bb74584877b8ad0eb529320b976264ec2db87420bae242715795f372dbc513ea80047bc49077a064e78205cd5e8b33d746fd2a2912
|
||||
SHA512 (icu4c-71_1-data.zip) = 05eb134a963a541a280e49e4d0aca07e480fef14daa0108c8fb9add18c150c9d34c8cbc46386c07909d511f7777eb3ea9f494001f191b84a7de0be8047da8b56
|
||||
SHA512 (icu4c-72_1-src.tgz) = 848c341b37c0ff077e34a95d92c6200d5aaddd0ee5e06134101a74e04deb08256a5e817c8aefab020986abe810b7827dd7b2169a60dacd250c298870518dcae8
|
||||
SHA512 (icu4c-72_1-data.zip) = 9c7a85d22bcd27ccb8503ce3a64a0f88c6c495d6c0619398ec3a693f156dadd22bbc5c2993730cf6f25b4869206562f875c35ba35c462c6d3420d5d4e8de4faf
|
||||
|
@ -1,37 +0,0 @@
|
||||
diff -ru icu.orig/source/test/intltest/tztest.cpp icu/source/test/intltest/tztest.cpp
|
||||
--- icu.orig/source/test/intltest/tztest.cpp 2022-04-08 00:41:55.000000000 +0200
|
||||
+++ icu/source/test/intltest/tztest.cpp 2022-09-27 17:15:20.860744015 +0200
|
||||
@@ -2049,6 +2049,33 @@
|
||||
const char *alias; // link-from
|
||||
const char *zone; // link-to (A zone ID with "Zone" rule)
|
||||
} excluded1[] = {
|
||||
+ {"Atlantic/Reykjavik", "Africa/Abidjan"},
|
||||
+ {"Iceland", "Africa/Abidjan"},
|
||||
+ {"Pacific/Chuuk", "Pacific/Port_Moresby"},
|
||||
+ {"Pacific/Truk", "Pacific/Port_Moresby"},
|
||||
+ {"Pacific/Yap", "Pacific/Port_Moresby"},
|
||||
+ {"Asia/Kashgar", "Anarctica/Vostok"},
|
||||
+ {"Asia/Urumqi", "Antarctica/Vostok"},
|
||||
+ {"Asia/Kuching", "Asia/Brunei"},
|
||||
+ {"Europe/Berlin", "Europe/Oslo"},
|
||||
+ {"Europe/Copenhagen", "Europe/Oslo"},
|
||||
+ {"Europe/Stockholm", "Europe/Oslo"},
|
||||
+ {"Europe/Brussels", "Europe/Amsterdam"},
|
||||
+ {"Europe/Luxembourg", "Europe/Amsterdam"},
|
||||
+ {"Europe/Monaco", "Europe/Paris"},
|
||||
+ {"Indian/Christmas", "Asia/Bangkok"},
|
||||
+ {"Indian/Cocos", "Asia/Rangoon"},
|
||||
+ {"Indian/Maldives", "Indian/Kerguelen"},
|
||||
+ {"Indian/Mahe", "Asia/Dubai"},
|
||||
+ {"Indian/Reunion", "Asia/Dubai"},
|
||||
+ {"Pacific/Majuro", "Pacific/Funafuti"},
|
||||
+ {"Pacific/Tarawa", "Pacific/Funafuti"},
|
||||
+ {"Pacific/Wake", "Pacific/Funafuti"},
|
||||
+ {"Pacific/Wallis", "Pacific/Funafuti"},
|
||||
+ {"Pacific/Pohnpei", "Pacific/Port_Moresby"},
|
||||
+ {"Pacific/Ponape", "Pacific/Guadalcanal"},
|
||||
+ {"Asia/Singapore", "Asia/Kuala_Lumpur"},
|
||||
+ {"Singapore", "Asia/Kuala_Lumpur"},
|
||||
{"Africa/Accra", "Africa/Abidjan"},
|
||||
{"Africa/Addis_Ababa", "Africa/Nairobi"},
|
||||
{"Africa/Asmera", "Africa/Nairobi"},
|
Loading…
Reference in New Issue
Block a user