added manpages for gennorm2 and icuinfo, rhbz#884035 related
Rebased patch from http://patch-tracker.debian.org/patch/series/view/icu/4.8.1.1-10/gennorm2-man.patch Upstream tracked as https://ssl.icu-project.org/trac/ticket/7554 Rebased patch from http://patch-tracker.debian.org/patch/series/view/icu/4.8.1.1-10/icuinfo-man.patch Upstream tracked as https://ssl.icu-project.org/trac/ticket/7665
This commit is contained in:
parent
5781d64342
commit
233661ec99
128
gennorm2-man.patch
Normal file
128
gennorm2-man.patch
Normal file
@ -0,0 +1,128 @@
|
||||
Description: supply manual page for program that doesn't have one
|
||||
Author: Jay Berkenbilt <qjb@debian.org>
|
||||
Bug: http://bugs.icu-project.org/trac/ticket/7554
|
||||
|
||||
diff -r -u -N icu.orig/source/tools/gennorm2/gennorm2.8.in icu/source/tools/gennorm2/gennorm2.8.in
|
||||
--- icu.orig/source/tools/gennorm2/gennorm2.8.in 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ icu/source/tools/gennorm2/gennorm2.8.in 2013-02-25 16:43:28.297062638 +0100
|
||||
@@ -0,0 +1,71 @@
|
||||
+.\" Hey, Emacs! This is -*-nroff-*- you know...
|
||||
+.\"
|
||||
+.\" gennorm2.8: manual page for the gennorm2 utility
|
||||
+.\"
|
||||
+.\" Copyright (C) 2005-2006 International Business Machines Corporation and others
|
||||
+.\"
|
||||
+.TH GENNORM2 8 "15 March 2010" "ICU MANPAGE" "ICU @VERSION@ Manual"
|
||||
+.SH NAME
|
||||
+.B gennorm2
|
||||
+\- Builds binary data file with Unicode normalization data.
|
||||
+.SH SYNOPSIS
|
||||
+.B gennorm2
|
||||
+[
|
||||
+.BR "\-h\fP, \fB\-?\fP, \fB\-\-help"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-V\fP, \fB\-\-version"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-c\fP, \fB\-\-copyright"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-v\fP, \fB\-\-verbose"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-u\fP, \fB\-\-unicode" " unicode\-version\-number"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-s\fP, \fB\-\-sourcedir" " source\-directory"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-o\fP, \fB\-\-output" " output\-filename"
|
||||
+]
|
||||
+.BI "\fB\-\-fast"
|
||||
+.SH DESCRIPTION
|
||||
+.B gennorm2
|
||||
+reads text files that define Unicode normalization,
|
||||
+them, and builds a binary data file.
|
||||
+.SH OPTIONS
|
||||
+.TP
|
||||
+.BR "\-h\fP, \fB\-?\fP, \fB\-\-help"
|
||||
+Print help about usage and exit.
|
||||
+.TP
|
||||
+.BR "\-V\fP, \fB\-\-version"
|
||||
+Print the version of
|
||||
+.B gennorm2
|
||||
+and exit.
|
||||
+.TP
|
||||
+.BR "\-c\fP, \fB\-\-copyright"
|
||||
+Include a copyright notice.
|
||||
+.TP
|
||||
+.BR "\-v\fP, \fB\-\-verbose"
|
||||
+Display extra informative messages during execution.
|
||||
+.TP
|
||||
+.BR "\-u\fP, \fB\-\-unicode"
|
||||
+Specify Unicode version number, such as 5.2.0.
|
||||
+.TP
|
||||
+.BI "\-s\fP, \fB\-\-sourcedir" " source\-directory"
|
||||
+Specify the input directory.
|
||||
+.TP
|
||||
+.BI "\-s\fP, \fB\-\-sourcedir" " source\-directory"
|
||||
+Set the name of the output file.
|
||||
+.TP
|
||||
+.BI "\fB\-\-fast"
|
||||
+optimize the .nrm file for fast normalization,
|
||||
+which might increase its size (Writes fully decomposed
|
||||
+regular mappings instead of delta mappings.
|
||||
+You should measure the runtime speed to make sure that
|
||||
+this is a good trade-off.)
|
||||
+.SH COPYRIGHT
|
||||
+Copyright (C) 2009-2010 International Business Machines Corporation and others
|
||||
diff -r -u -N icu.orig/source/tools/gennorm2/Makefile.in icu/source/tools/gennorm2/Makefile.in
|
||||
--- icu.orig/source/tools/gennorm2/Makefile.in 2013-01-11 01:23:32.000000000 +0100
|
||||
+++ icu/source/tools/gennorm2/Makefile.in 2013-02-25 16:43:28.296062632 +0100
|
||||
@@ -16,8 +16,13 @@
|
||||
|
||||
TARGET_STUB_NAME = gennorm2
|
||||
|
||||
+SECTION = 8
|
||||
+
|
||||
+MAN_FILES = $(TARGET_STUB_NAME).$(SECTION)
|
||||
+
|
||||
+
|
||||
## Extra files to remove for 'make clean'
|
||||
-CLEANFILES = *~ $(DEPS)
|
||||
+CLEANFILES = *~ $(DEPS) $(MAN_FILES)
|
||||
|
||||
## Target information
|
||||
TARGET = $(BINDIR)/$(TARGET_STUB_NAME)$(EXEEXT)
|
||||
@@ -44,12 +49,16 @@
|
||||
dist: dist-local
|
||||
check: all check-local
|
||||
|
||||
-all-local: $(TARGET)
|
||||
+all-local: $(TARGET) $(MAN_FILES)
|
||||
|
||||
-install-local: all-local
|
||||
+install-local: all-local install-man
|
||||
$(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
|
||||
$(INSTALL) $(TARGET) $(DESTDIR)$(sbindir)
|
||||
|
||||
+install-man: $(MAN_FILES)
|
||||
+ $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man$(SECTION)
|
||||
+ $(INSTALL_DATA) $? $(DESTDIR)$(mandir)/man$(SECTION)
|
||||
+
|
||||
dist-local:
|
||||
|
||||
clean-local:
|
||||
@@ -70,6 +79,11 @@
|
||||
$(POST_BUILD_STEP)
|
||||
|
||||
|
||||
+%.$(SECTION): $(srcdir)/%.$(SECTION).in
|
||||
+ cd $(top_builddir) \
|
||||
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
+
|
||||
+
|
||||
ifeq (,$(MAKECMDGOALS))
|
||||
-include $(DEPS)
|
||||
else
|
10
icu.spec
10
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 50.1.2
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT and UCD and Public Domain
|
||||
@ -14,6 +14,8 @@ Patch1: icu.8198.revert.icu5431.patch
|
||||
Patch2: icu.8800.freeserif.crash.patch
|
||||
Patch3: icu.7601.Indic-ccmp.patch
|
||||
Patch4: icu.9948.mlym-crash.patch
|
||||
Patch5: gennorm2-man.patch
|
||||
Patch6: icuinfo-man.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -60,6 +62,8 @@ BuildArch: noarch
|
||||
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
||||
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
||||
%patch4 -p1 -b .icu9948.mlym-crash.patch
|
||||
%patch5 -p1 -b .gennorm2-man.patch
|
||||
%patch6 -p1 -b .icuinfo-man.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -148,6 +152,7 @@ make %{?_smp_mflags} -C source check
|
||||
%{_bindir}/%{name}-config*
|
||||
%{_bindir}/icuinfo
|
||||
%{_mandir}/man1/%{name}-config.1*
|
||||
%{_mandir}/man1/icuinfo.1*
|
||||
%{_includedir}/layout
|
||||
%{_includedir}/unicode
|
||||
%{_libdir}/*.so
|
||||
@ -166,6 +171,9 @@ make %{?_smp_mflags} -C source check
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 25 2013 Eike Rathke <erack@redhat.com> - 50.1.2-5
|
||||
- added manpages for gennorm2 and icuinfo, rhbz#884035 related
|
||||
|
||||
* Tue Feb 19 2013 Caolán McNamara <caolanm@redhat.com> - 50.1.2-4
|
||||
- Resolves: fdo#52519 crash on typing some Malayalam
|
||||
|
||||
|
143
icuinfo-man.patch
Normal file
143
icuinfo-man.patch
Normal file
@ -0,0 +1,143 @@
|
||||
Description: supply manual page for program that doesn't have one
|
||||
Author: Jay Berkenbilt <qjb@debian.org>
|
||||
Bug: http://bugs.icu-project.org/trac/ticket/7665
|
||||
|
||||
diff -r -u -N icu.orig/source/tools/icuinfo/icuinfo.1.in icu/source/tools/icuinfo/icuinfo.1.in
|
||||
--- icu.orig/source/tools/icuinfo/icuinfo.1.in 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ icu/source/tools/icuinfo/icuinfo.1.in 2013-02-25 16:51:23.387606462 +0100
|
||||
@@ -0,0 +1,76 @@
|
||||
+.\" Hey, Emacs! This is -*-nroff-*- you know...
|
||||
+.\"
|
||||
+.\" icuinfo.1: manual page for the icuinfo utility
|
||||
+.\"
|
||||
+.\" Copyright (C) 2005-2006 International Business Machines Corporation and others
|
||||
+.\"
|
||||
+.TH ICUINFO 1 "1 May 2010" "ICU MANPAGE" "ICU @VERSION@ Manual"
|
||||
+.SH NAME
|
||||
+.B icuinfo
|
||||
+\- Shows some basic info about the current ICU
|
||||
+.SH SYNOPSIS
|
||||
+.B icuinfo
|
||||
+[
|
||||
+.BR "\-h\fP, \fB\-?\fP, \fB\-\-help"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-V\fP, \fB\-\-version"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-c\fP, \fB\-\-copyright"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-i\fP, \fB\-\-icudatadir" " directory"
|
||||
+]
|
||||
+[
|
||||
+.BR "\-v\fP, \fB\-\-verbose"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-L\fP, \fB\-\-list-plugins"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-m\fP, \fB\-\-milisecond-time"
|
||||
+]
|
||||
+[
|
||||
+.BI "\-K\fP, \fB\-\-cleanup"
|
||||
+]
|
||||
+.SH DESCRIPTION
|
||||
+.B icuinfo
|
||||
+prints basic information about the current version of ICU.
|
||||
+.SH OPTIONS
|
||||
+.TP
|
||||
+.BR "\-h\fP, \fB\-?\fP, \fB\-\-help"
|
||||
+Print help about usage and exit.
|
||||
+.TP
|
||||
+.BR "\-V\fP, \fB\-\-version"
|
||||
+Print the version of
|
||||
+.B icuinfo
|
||||
+and exit.
|
||||
+.TP
|
||||
+.BR "\-c\fP, \fB\-\-copyright"
|
||||
+Embeds the standard ICU copyright into the
|
||||
+.IR output-file .
|
||||
+.TP
|
||||
+.BR "\-v\fP, \fB\-\-verbose"
|
||||
+Display extra informative messages during execution.
|
||||
+.TP
|
||||
+.BI "\-i\fP, \fB\-\-icudatadir" " directory"
|
||||
+Look for any necessary ICU data files in
|
||||
+.IR directory .
|
||||
+For example, the file
|
||||
+.B pnames.icu
|
||||
+must be located when ICU's data is not built as a shared library.
|
||||
+The default ICU data directory is specified by the environment variable
|
||||
+.BR ICU_DATA .
|
||||
+Most configurations of ICU do not require this argument.
|
||||
+.TP
|
||||
+.BI "\-L\fP, \fB\-\-list-plugins"
|
||||
+If specified, list and diagnose issues with ICU plugins.
|
||||
+.TP
|
||||
+.BI "\-K\fP, \fB\-\-cleanup"
|
||||
+Attempt to unload plugins before exiting.
|
||||
+.TP
|
||||
+.BI "\-m\fP, \fB\-\-milisecond-time"
|
||||
+Print the current UTC time in milliseconds.
|
||||
+.SH COPYRIGHT
|
||||
+Copyright (C) 2010 International Business Machines Corporation and others
|
||||
diff -r -u -N icu.orig/source/tools/icuinfo/Makefile.in icu/source/tools/icuinfo/Makefile.in
|
||||
--- icu.orig/source/tools/icuinfo/Makefile.in 2013-01-11 01:23:34.000000000 +0100
|
||||
+++ icu/source/tools/icuinfo/Makefile.in 2013-02-25 16:51:20.637590947 +0100
|
||||
@@ -14,8 +14,15 @@
|
||||
## Build directory information
|
||||
subdir = tools/icuinfo
|
||||
|
||||
+TARGET_STUB_NAME = icuinfo
|
||||
+
|
||||
+SECTION = 1
|
||||
+
|
||||
+MAN_FILES = $(TARGET_STUB_NAME).$(SECTION)
|
||||
+
|
||||
+
|
||||
## Extra files to remove for 'make clean'
|
||||
-CLEANFILES = *~ $(DEPS) $(PLUGIN_OBJECTS) $(PLUGINFILE) $(PLUGIN)
|
||||
+CLEANFILES = *~ $(DEPS) $(PLUGIN_OBJECTS) $(PLUGINFILE) $(PLUGIN) $(MAN_FILES)
|
||||
|
||||
## Target information
|
||||
TARGET = icuinfo$(EXEEXT)
|
||||
@@ -35,7 +42,8 @@
|
||||
|
||||
## List of phony targets
|
||||
.PHONY : all all-local install install-local clean clean-local \
|
||||
-distclean distclean-local dist dist-local check check-local plugin-check
|
||||
+distclean distclean-local dist dist-local check check-local plugin-check \
|
||||
+install-man
|
||||
|
||||
## Clear suffix list
|
||||
.SUFFIXES :
|
||||
@@ -48,12 +56,16 @@
|
||||
dist: dist-local
|
||||
check: all check-local
|
||||
|
||||
-all-local: $(TARGET)
|
||||
+all-local: $(TARGET) $(MAN_FILES)
|
||||
|
||||
-install-local: all-local
|
||||
+install-local: all-local install-man
|
||||
$(MKINSTALLDIRS) $(DESTDIR)$(bindir)
|
||||
$(INSTALL) $(TARGET) $(DESTDIR)$(bindir)
|
||||
|
||||
+install-man: $(MAN_FILES)
|
||||
+ $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man$(SECTION)
|
||||
+ $(INSTALL_DATA) $? $(DESTDIR)$(mandir)/man$(SECTION)
|
||||
+
|
||||
dist-local:
|
||||
|
||||
clean-local:
|
||||
@@ -95,6 +107,9 @@
|
||||
plugin-check: $(PLUGIN) $(PLUGINFILE)
|
||||
$(INVOKE) ICU_PLUGINS="$(CURR_FULL_DIR)" ./$(TARGET) -v -L
|
||||
|
||||
+%.$(SECTION): $(srcdir)/%.$(SECTION).in
|
||||
+ cd $(top_builddir) \
|
||||
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
|
||||
ifeq (,$(MAKECMDGOALS))
|
||||
-include $(DEPS)
|
Loading…
Reference in New Issue
Block a user