ibus-table/Use-from-unittest-import-mock-instead-of-just-import.patch
DistroBaker 7427707001 Merged update from upstream sources
This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/ibus-table.git#849db7c1a6b32a8b6459bd24399c06be3a8c20f6
2021-02-06 13:56:27 +00:00

37 lines
1.0 KiB
Diff

From f41791d752a7a398b57f88e07bb2871ae533ca1c Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Tue, 2 Feb 2021 11:42:49 +0100
Subject: [PATCH] =?UTF-8?q?Use=20=E2=80=9Cfrom=20unittest=20import=20mock?=
=?UTF-8?q?=E2=80=9D=20instead=20of=20just=20=E2=80=9Cimport=20mock?=
=?UTF-8?q?=E2=80=9D.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Since Python 3.3, mock is part of unittest in the standard
library. The third-party `mock` library is a backport for older Python
versions.
This makes it possible to remove the “BuildRequires: python3-mock”
from the ibus-table.spec file.
---
tests/test_it.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test_it.py b/tests/test_it.py
index a4b6ba6..cad55c1 100755
--- a/tests/test_it.py
+++ b/tests/test_it.py
@@ -29,7 +29,7 @@ import logging
import time
import unittest
import importlib
-import mock
+from unittest import mock
from gi import require_version
require_version('IBus', '1.0')
--
2.29.2