ibus-table/Use-from-unittest-import-mock-instead-of-just-import.patch
2021-02-02 11:49:48 +01:00

37 lines
1.0 KiB
Diff

From f41791d752a7a398b57f88e07bb2871ae533ca1c Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Tue, 2 Feb 2021 11:42:49 +0100
Subject: [PATCH] =?UTF-8?q?Use=20=E2=80=9Cfrom=20unittest=20import=20mock?=
=?UTF-8?q?=E2=80=9D=20instead=20of=20just=20=E2=80=9Cimport=20mock?=
=?UTF-8?q?=E2=80=9D.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Since Python 3.3, mock is part of unittest in the standard
library. The third-party `mock` library is a backport for older Python
versions.
This makes it possible to remove the “BuildRequires: python3-mock”
from the ibus-table.spec file.
---
tests/test_it.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test_it.py b/tests/test_it.py
index a4b6ba6..cad55c1 100755
--- a/tests/test_it.py
+++ b/tests/test_it.py
@@ -29,7 +29,7 @@ import logging
import time
import unittest
import importlib
-import mock
+from unittest import mock
from gi import require_version
require_version('IBus', '1.0')
--
2.29.2