update to latest upstream 1.5.0.20140218

- Resolves: rhbz#1061345 - ibus-table shows entered text in password fields
- remove patches which are included upstream
- remove old, unused patches
This commit is contained in:
Mike FABIAN 2014-02-03 11:49:12 +01:00
parent f695188c13
commit 557180f958
10 changed files with 21 additions and 478 deletions

3
.gitignore vendored
View File

@ -7,3 +7,6 @@ ibus-table-1.3.0.20100621.tar.gz
/ibus-table-1.4.99.20130110.tar.gz
/ibus-table-1.5.0.tar.gz
/ibus-table-1.5.0.20130419.tar.gz
/ibus-table-1.5.0.20140203.tar.gz
/ibus-table-1.5.0.20140205.tar.gz
/ibus-table-1.5.0.20140218.tar.gz

View File

@ -1,26 +0,0 @@
From 783d52a211b0e12f0c830e8c96a49682647faaf1 Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Wed, 22 Jan 2014 12:11:18 +0100
Subject: [PATCH 1/2] Fix typo in ibus-table-createdb man-page
"for for" -> "for"
---
engine/ibus-table-createdb.sgml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/engine/ibus-table-createdb.sgml b/engine/ibus-table-createdb.sgml
index 86c8336..6a1e439 100644
--- a/engine/ibus-table-createdb.sgml
+++ b/engine/ibus-table-createdb.sgml
@@ -142,7 +142,7 @@ manpage.1: manpage.sgml
<option>--no-create-index</option>
</term>
<listitem>
- <para>Do not create an index for for a database (Only for distribution purposes, a normal user should not use this flag!)</para>
+ <para>Do not create an index for a database (Only for distribution purposes, a normal user should not use this flag!)</para>
</listitem>
</varlistentry>
<varlistentry>
--
1.8.4.2

View File

@ -1,135 +0,0 @@
From 87cb7fb1ee81da34e0a6b40efba561236dff772a Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Thu, 23 Jan 2014 23:26:57 +0100
Subject: [PATCH 2/2] When tabcreatedb.py is called without any options, print
a usage message
Do not just show a cryptic backtrace.
Resolves: rhbz#1049760
See: https://bugzilla.redhat.com/show_bug.cgi?id=1049760
---
engine/ibus-table-createdb.sgml | 8 ++++----
engine/tabcreatedb.py | 43 +++++++++++++++++++++++++----------------
2 files changed, 30 insertions(+), 21 deletions(-)
diff --git a/engine/ibus-table-createdb.sgml b/engine/ibus-table-createdb.sgml
index 6a1e439..e14ffb2 100644
--- a/engine/ibus-table-createdb.sgml
+++ b/engine/ibus-table-createdb.sgml
@@ -108,7 +108,7 @@ manpage.1: manpage.sgml
<option><replaceable>database-file</replaceable></option>
</term>
<listitem>
- <para><replaceable>database-file</replaceable> specifies the file which will contain the binary database for the IME. The default is ''.</para>
+ <para><replaceable>database-file</replaceable> specifies the file name for the binary database for the IME. The default is ''. If the file name of the database is not specified, the file name of the source file before the first '.' will be appended with '.db' and that will be used as the file name of the database.</para>
</listitem>
</varlistentry>
<term><option>-s</option>
@@ -125,7 +125,7 @@ manpage.1: manpage.sgml
<option><replaceable>extra-words-file</replaceable></option>
</term>
<listitem>
- <para><replaceable>extra-words-file</replaceable> specifies the file for the extra words for the IME. The default is ''.</para>
+ <para><replaceable>extra-words-file</replaceable> specifies the file name for the extra words for the IME. The default is ''.</para>
</listitem>
</varlistentry>
<varlistentry>
@@ -134,7 +134,7 @@ manpage.1: manpage.sgml
<option><replaceable>pinyin-file</replaceable></option>
</term>
<listitem>
- <para><replaceable>pinyin-file</replaceable> specifies the source file for the pinyin. The default is /usr/share/ibus-table/data/pinyin_table.txt.bz2.</para>
+ <para><replaceable>pinyin-file</replaceable> specifies the source file for the pinyin. The default is '/usr/share/ibus-table/data/pinyin_table.txt.bz2'.</para>
</listitem>
</varlistentry>
<varlistentry>
@@ -150,7 +150,7 @@ manpage.1: manpage.sgml
<option>--create-index-only</option>
</term>
<listitem>
- <para>Only create an index for an existing database.</para>
+ <para>Only create an index for an existing database. Specifying the file name of the binary database with the -n or --name option is required when this option is used.</para>
</listitem>
</varlistentry>
<varlistentry>
diff --git a/engine/tabcreatedb.py b/engine/tabcreatedb.py
index 6694b13..fb6d7e2 100644
--- a/engine/tabcreatedb.py
+++ b/engine/tabcreatedb.py
@@ -62,46 +62,55 @@ class InvalidTableName(Exception):
return 'Value of NAME attribute (%s) cannot contain any of %r and must be all ascii' % (self.table_name, _invalid_keyname_chars)
# we use OptionParser to parse the cmd arguments :)
-opt_parser = OptionParser()
+usage = "usage: %prog [options]"
+opt_parser = OptionParser(usage=usage)
opt_parser.add_option( '-n', '--name',
- action = 'store', dest='name',default = None,
- help = 'set the database name we will use, default is %default')
+ action = 'store', dest='name',default = '',
+ help = "specifies the file name for the binary database for the IME. The default is '%default'. If the file name of the database is not specified, the file name of the source file before the first '.' will be appended with '.db' and that will be used as the file name of the database.")
opt_parser.add_option( '-s', '--source',
- action = 'store', dest='source', default = 'xingma.txt.bz2',
- help = 'specifies the file which contains the source file of the IME. The default is %default')
+ action = 'store', dest='source', default = '',
+ help = "specifies the file which contains the source of the IME. The default is '%default'.")
opt_parser.add_option( '-e', '--extra',
action = 'store', dest='extra', default = '',
- help = 'specifies the file for the extra words for the IME. The default is %default')
+ help = "specifies the file name for the extra words for the IME. The default is '%default'.")
opt_parser.add_option( '-p', '--pinyin',
action = 'store', dest='pinyin', default = '/usr/share/ibus-table/data/pinyin_table.txt.bz2',
- help = 'specifies the source file for the pinyin. The default is %default')
+ help = "specifies the source file for the pinyin. The default is '%default'.")
opt_parser.add_option( '-o', '--no-create-index',
action = 'store_false', dest='index', default = True,
- help = 'do not create an index for a database (Only for distrubution purposes, a normal user should not use this flag!)')
+ help = 'Do not create an index for a database (Only for distrubution purposes, a normal user should not use this flag!)')
opt_parser.add_option( '-i', '--create-index-only',
action = 'store_true', dest='only_index', default = False,
- help = 'only create an index for an existing database')
+ help = 'Only create an index for an existing database. Specifying the file name of the binary database with the -n or --name option is required when this option is used.')
opt_parser.add_option( '-d', '--debug',
action = 'store_true', dest='debug', default = False,
- help = 'print extra debug messages')
-
-
+ help = 'Print extra debug messages.')
opts,args = opt_parser.parse_args()
-if not opts.name and opts.only_index:
- print 'Please give me the database you want to create index on'
- sys.exit(2)
-
-if not opts.name:
+if opts.only_index:
+ if not opts.name:
+ opt_parser.print_help()
+ print('\nPlease specify the file name of the database you want to create an index on!')
+ sys.exit(2)
+ if not os.path.exists(opts.name) or not os.path.isfile(opts.name):
+ opt_parser.print_help()
+ print("\nThe database file '%s' does not exist." %opts.name)
+ sys.exit(2)
+
+if not opts.name and opts.source:
opts.name = os.path.basename(opts.source).split('.')[0] + '.db'
+if not opts.name:
+ opt_parser.print_help()
+ print '\nYou need to specify the file which contains the source of the IME!'
+ sys.exit(2)
def main ():
def debug_print ( message ):
--
1.8.4.2

View File

@ -1,255 +0,0 @@
diff -Nru ibus-table-1.5.0.orig/engine/Makefile.in ibus-table-1.5.0/engine/Makefile.in
--- ibus-table-1.5.0.orig/engine/Makefile.in 2014-01-24 09:07:09.814525660 +0100
+++ ibus-table-1.5.0/engine/Makefile.in 2014-01-24 09:07:34.954690472 +0100
@@ -1,7 +1,7 @@
-# Makefile.in generated by automake 1.12.2 from Makefile.am.
+# Makefile.in generated by automake 1.13.4 from Makefile.am.
# @configure_input@
-# Copyright (C) 1994-2012 Free Software Foundation, Inc.
+# Copyright (C) 1994-2013 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
@@ -37,23 +37,51 @@
VPATH = @srcdir@
-am__make_dryrun = \
- { \
- am__dry=no; \
+am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
+am__make_running_with_option = \
+ case $${target_option-} in \
+ ?) ;; \
+ *) echo "am__make_running_with_option: internal error: invalid" \
+ "target option '$${target_option-}' specified" >&2; \
+ exit 1;; \
+ esac; \
+ has_opt=no; \
+ sane_makeflags=$$MAKEFLAGS; \
+ if $(am__is_gnu_make); then \
+ sane_makeflags=$$MFLAGS; \
+ else \
case $$MAKEFLAGS in \
*\\[\ \ ]*) \
- echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
- | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
- *) \
- for am__flg in $$MAKEFLAGS; do \
- case $$am__flg in \
- *=*|--*) ;; \
- *n*) am__dry=yes; break;; \
- esac; \
- done;; \
+ bs=\\; \
+ sane_makeflags=`printf '%s\n' "$$MAKEFLAGS" \
+ | sed "s/$$bs$$bs[$$bs $$bs ]*//g"`;; \
esac; \
- test $$am__dry = yes; \
- }
+ fi; \
+ skip_next=no; \
+ strip_trailopt () \
+ { \
+ flg=`printf '%s\n' "$$flg" | sed "s/$$1.*$$//"`; \
+ }; \
+ for flg in $$sane_makeflags; do \
+ test $$skip_next = yes && { skip_next=no; continue; }; \
+ case $$flg in \
+ *=*|--*) continue;; \
+ -*I) strip_trailopt 'I'; skip_next=yes;; \
+ -*I?*) strip_trailopt 'I';; \
+ -*O) strip_trailopt 'O'; skip_next=yes;; \
+ -*O?*) strip_trailopt 'O';; \
+ -*l) strip_trailopt 'l'; skip_next=yes;; \
+ -*l?*) strip_trailopt 'l';; \
+ -[dEDm]) skip_next=yes;; \
+ -[JT]) skip_next=yes;; \
+ esac; \
+ case $$flg in \
+ *$$target_option*) has_opt=yes; break;; \
+ esac; \
+ done; \
+ test $$has_opt = yes
+am__make_dryrun = (target_option=n; $(am__make_running_with_option))
+am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -73,10 +101,10 @@
build_triplet = @build@
host_triplet = @host@
subdir = engine
-DIST_COMMON = $(engine_table_PYTHON) $(srcdir)/Makefile.am \
- $(srcdir)/Makefile.in $(srcdir)/ibus-engine-table.in \
+DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
+ $(srcdir)/ibus-engine-table.in \
$(srcdir)/ibus-table-createdb.in $(srcdir)/table.xml.in.in \
- $(top_srcdir)/py-compile
+ $(engine_table_PYTHON) $(top_srcdir)/py-compile
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
@@ -120,6 +148,18 @@
"$(DESTDIR)$(engine_tabledir)" "$(DESTDIR)$(man1dir)" \
"$(DESTDIR)$(enginedir)" "$(DESTDIR)$(engine_tabledir)"
SCRIPTS = $(bin_SCRIPTS) $(libexec_SCRIPTS)
+AM_V_P = $(am__v_P_@AM_V@)
+am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
+am__v_P_0 = false
+am__v_P_1 = :
+AM_V_GEN = $(am__v_GEN_@AM_V@)
+am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
+am__v_GEN_0 = @echo " GEN " $@;
+am__v_GEN_1 =
+AM_V_at = $(am__v_at_@AM_V@)
+am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
+am__v_at_0 = @
+am__v_at_1 =
SOURCES =
DIST_SOURCES =
am__can_run_installinfo = \
@@ -128,14 +168,18 @@
*) (install-info --version) >/dev/null 2>&1;; \
esac
am__py_compile = PYTHON=$(PYTHON) $(SHELL) $(py_compile)
+am__pep3147_tweak = \
+ sed -e 's|\.py$$||' -e 's|[^/]*$$|__pycache__/&.*.py|'
py_compile = $(top_srcdir)/py-compile
man1dir = $(mandir)/man1
NROFF = nroff
MANS = $(man_MANS)
DATA = $(engine_DATA) $(engine_table_DATA)
+am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
AUTOCONF = @AUTOCONF@
AUTOHEADER = @AUTOHEADER@
AUTOMAKE = @AUTOMAKE@
@@ -435,13 +479,23 @@
uninstall-engine_tablePYTHON:
@$(NORMAL_UNINSTALL)
@list='$(engine_table_PYTHON)'; test -n "$(engine_tabledir)" || list=; \
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- test -n "$$files" || exit 0; \
+ py_files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
+ test -n "$$py_files" || exit 0; \
dir='$(DESTDIR)$(engine_tabledir)'; \
- filesc=`echo "$$files" | sed 's|$$|c|'`; \
- fileso=`echo "$$files" | sed 's|$$|o|'`; \
+ pyc_files=`echo "$$py_files" | sed 's|$$|c|'`; \
+ pyo_files=`echo "$$py_files" | sed 's|$$|o|'`; \
+ py_files_pep3147=`echo "$$py_files" | $(am__pep3147_tweak)`; \
+ echo "$$py_files_pep3147";\
+ pyc_files_pep3147=`echo "$$py_files_pep3147" | sed 's|$$|c|'`; \
+ pyo_files_pep3147=`echo "$$py_files_pep3147" | sed 's|$$|o|'`; \
st=0; \
- for files in "$$files" "$$filesc" "$$fileso"; do \
+ for files in \
+ "$$py_files" \
+ "$$pyc_files" \
+ "$$pyo_files" \
+ "$$pyc_files_pep3147" \
+ "$$pyo_files_pep3147" \
+ ; do \
$(am__uninstall_files_from_dir) || st=$$?; \
done; \
exit $$st
@@ -530,29 +584,14 @@
@list='$(engine_table_DATA)'; test -n "$(engine_tabledir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
dir='$(DESTDIR)$(engine_tabledir)'; $(am__uninstall_files_from_dir)
-tags: TAGS
-TAGS:
+tags TAGS:
-ctags: CTAGS
-CTAGS:
+ctags CTAGS:
cscope cscopelist:
distdir: $(DISTFILES)
- @list='$(MANS)'; if test -n "$$list"; then \
- list=`for p in $$list; do \
- if test -f $$p; then d=; else d="$(srcdir)/"; fi; \
- if test -f "$$d$$p"; then echo "$$d$$p"; else :; fi; done`; \
- if test -n "$$list" && \
- grep 'ab help2man is required to generate this page' $$list >/dev/null; then \
- echo "error: found man pages containing the 'missing help2man' replacement text:" >&2; \
- grep -l 'ab help2man is required to generate this page' $$list | sed 's/^/ /' >&2; \
- echo " to fix them, install help2man, remove and regenerate the man pages;" >&2; \
- echo " typically 'make maintainer-clean' will remove them" >&2; \
- exit 1; \
- else :; fi; \
- else :; fi
@srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
topsrcdirstrip=`echo "$(top_srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
list='$(DISTFILES)'; \
@@ -694,18 +733,19 @@
.MAKE: install-am install-strip
-.PHONY: all all-am check check-am clean clean-generic distclean \
- distclean-generic distdir dvi dvi-am html html-am info info-am \
- install install-am install-binSCRIPTS install-data \
- install-data-am install-dvi install-dvi-am install-engineDATA \
- install-engine_tableDATA install-engine_tablePYTHON \
- install-exec install-exec-am install-html install-html-am \
- install-info install-info-am install-libexecSCRIPTS \
- install-man install-man1 install-pdf install-pdf-am install-ps \
- install-ps-am install-strip installcheck installcheck-am \
- installdirs maintainer-clean maintainer-clean-generic \
- mostlyclean mostlyclean-generic pdf pdf-am ps ps-am uninstall \
- uninstall-am uninstall-binSCRIPTS uninstall-engineDATA \
+.PHONY: all all-am check check-am clean clean-generic cscopelist-am \
+ ctags-am distclean distclean-generic distdir dvi dvi-am html \
+ html-am info info-am install install-am install-binSCRIPTS \
+ install-data install-data-am install-dvi install-dvi-am \
+ install-engineDATA install-engine_tableDATA \
+ install-engine_tablePYTHON install-exec install-exec-am \
+ install-html install-html-am install-info install-info-am \
+ install-libexecSCRIPTS install-man install-man1 install-pdf \
+ install-pdf-am install-ps install-ps-am install-strip \
+ installcheck installcheck-am installdirs maintainer-clean \
+ maintainer-clean-generic mostlyclean mostlyclean-generic pdf \
+ pdf-am ps ps-am tags-am uninstall uninstall-am \
+ uninstall-binSCRIPTS uninstall-engineDATA \
uninstall-engine_tableDATA uninstall-engine_tablePYTHON \
uninstall-libexecSCRIPTS uninstall-man uninstall-man1
diff -Nru ibus-table-1.5.0.orig/engine/ibus-table-createdb.1 ibus-table-1.5.0/engine/ibus-table-createdb.1
--- ibus-table-1.5.0.orig/engine/ibus-table-createdb.1 2014-01-24 09:07:09.814525660 +0100
+++ ibus-table-1.5.0/engine/ibus-table-createdb.1 2014-01-24 09:07:30.058658483 +0100
@@ -17,22 +17,22 @@
options is included below.
.TP
\fB-n\fR
-\fIdatabase-file\fR specifies the file which will contain the binary database for the IME. The default is ''.
+\fIdatabase-file\fR specifies the file name for the binary database for the IME. The default is ''. If the file name of the database is not specified, the file name of the source file before the first '.' will be appended with '.db' and that will be used as the file name of the database.
.TP
\fB-s\fR
\fIsource-file\fR specifies the file which contains the source of the IME. The default is ''.
.TP
\fB-e\fR
-\fIextra-words-file\fR specifies the file for the extra words for the IME. The default is ''.
+\fIextra-words-file\fR specifies the file name for the extra words for the IME. The default is ''.
.TP
\fB-p\fR
-\fIpinyin-file\fR specifies the source file for the pinyin. The default is /usr/share/ibus-table/data/pinyin_table.txt.bz2.
+\fIpinyin-file\fR specifies the source file for the pinyin. The default is '/usr/share/ibus-table/data/pinyin_table.txt.bz2'.
.TP
\fB-o\fR
-Do not create an index for for a database (Only for distribution purposes, a normal user should not use this flag!)
+Do not create an index for a database (Only for distribution purposes, a normal user should not use this flag!)
.TP
\fB-i\fR
-Only create an index for an existing database.
+Only create an index for an existing database. Specifying the file name of the binary database with the -n or --name option is required when this option is used.
.TP
\fB-d\fR
Print extra debug messages.

View File

@ -1,13 +0,0 @@
diff -up ibus-table-1.1.0.20090316/engine/ibus-engine-table.in.orig ibus-table-1.1.0.20090316/engine/ibus-engine-table.in
--- ibus-table-1.1.0.20090316/engine/ibus-engine-table.in.orig 2009-03-16 15:11:57.000000000 +1000
+++ ibus-table-1.1.0.20090316/engine/ibus-engine-table.in 2009-03-16 15:12:41.000000000 +1000
@@ -35,7 +35,8 @@ for arg in $@; do
done
# first running speedmeter as a daemon
-python @datarootdir@/ibus-table/engine/speedmeter.py -d
+# (temporary disabled until config option is implemented)
+#python @datarootdir@/ibus-table/engine/speedmeter.py -d
# then start our IME
exec python @datarootdir@/ibus-table/engine/main.py $@

View File

@ -1,15 +0,0 @@
diff -up ibus-table-1.2.0.20090912/engine/tabcreatedb.py.orig ibus-table-1.2.0.20090912/engine/tabcreatedb.py
--- ibus-table-1.2.0.20090912/engine/tabcreatedb.py.orig 2010-01-06 12:14:40.098086168 +1000
+++ ibus-table-1.2.0.20090912/engine/tabcreatedb.py 2010-01-06 12:14:57.293835609 +1000
@@ -173,9 +173,9 @@ def main ():
def attribute_parser (f):
for l in f:
try:
- attr,val = unicode (l,"utf-8").strip().split ('=')
+ attr,val = unicode (l,"utf-8").strip().split ('=', 1)
except:
- attr,val = unicode (l,"utf-8").strip().split ('==')
+ attr,val = unicode (l,"utf-8").strip().split ('==', 1)
attr = attr.strip()
origin_attr = attr
attr = attr.lower()

View File

@ -1,12 +0,0 @@
diff -up ibus-table-1.2.0.20090912/engine/ibus-engine-table.in.orig ibus-table-1.2.0.20090912/engine/ibus-engine-table.in
--- ibus-table-1.2.0.20090912/engine/ibus-engine-table.in.orig 2009-11-11 09:45:38.806345556 +1000
+++ ibus-table-1.2.0.20090912/engine/ibus-engine-table.in 2009-11-11 09:44:58.030346537 +1000
@@ -35,7 +35,7 @@ for arg in $@; do
done
# first running speedmeter as a daemon
-python @datarootdir@/ibus-table/engine/speedmeter.py -d
+#python @datarootdir@/ibus-table/engine/speedmeter.py -d
# then start our IME
exec python @datarootdir@/ibus-table/engine/main.py $@

View File

@ -1,13 +0,0 @@
diff -u ibus-table-1.1.0.20090220/ibus-table.pc.in\~ ibus-table-1.1.0.20090220/ibus-table.pc.in
--- ibus-table-1.1.0.20090220/ibus-table.pc.in~ 2009-02-20 11:42:40.000000000 +1000
+++ ibus-table-1.1.0.20090220/ibus-table.pc.in 2009-03-06 11:45:18.001898774 +1000
@@ -1,6 +1,6 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
-libdir=@libdir@
+libdir=@datadir@
datarootdir=@datarootdir@
datadir=@datadir@
Diff finished. Fri Mar 6 11:46:24 2009

View File

@ -1,14 +1,11 @@
Name: ibus-table
Version: 1.5.0.20130419
Release: 3%{?dist}
Version: 1.5.0.20140218
Release: 1%{?dist}
Summary: The Table engine for IBus platform
License: LGPLv2+
Group: System Environment/Libraries
URL: http://code.google.com/p/ibus/
Source0: http://mfabian.fedorapeople.org/ibus-table/%{name}-%{version}.tar.gz
Patch0: 0001-Fix-typo-in-ibus-table-createdb-man-page.patch
Patch1: 0002-When-tabcreatedb.py-is-called-without-any-options-pr.patch
Patch2: 0008-prebuilt-files-for-man-page-for-ibus-table-createdb.patch
Requires: ibus > 1.3.0
BuildRequires: ibus-devel > 1.3.0
BuildRequires: python2-devel
@ -31,9 +28,6 @@ Development files for %{name}.
%prep
%setup -q
%patch0 -p1 -b .Fix-typo-in-ibus-table-createdb-man-page
%patch1 -p1 -b .When-tabcreatedb.py-is-called-without-any-options-pr
%patch2 -p1 -b .prebuilt-files-for-man-page-for-ibus-table-createdb
%build
%configure --disable-static --disable-additional
@ -57,6 +51,7 @@ Development files for %{name}.
%dir %{_datadir}/%{name}/tables
%dir %{_datadir}/%{name}/icons
%dir %{_datadir}/%{name}/data
%dir %{_datadir}/%{name}/setup
%{_datadir}/ibus/component/table.xml
%{_datadir}/%{name}/icons/%{name}.svg
%{_datadir}/%{name}/icons/full-letter.svg
@ -99,8 +94,16 @@ Development files for %{name}.
%{_datadir}/%{name}/engine/tabsqlitedb.pyc
%{_datadir}/%{name}/engine/tabsqlitedb.pyo
%{_datadir}/%{name}/tables/template.txt
%{_datadir}/%{name}/setup/ibus-table-preferences.ui
%{_datadir}/%{name}/setup/main.py
%{_datadir}/%{name}/setup/main.pyc
%{_datadir}/%{name}/setup/main.pyo
%{_datadir}/%{name}/setup/version.py
%{_datadir}/%{name}/setup/version.pyc
%{_datadir}/%{name}/setup/version.pyo
%{_bindir}/%{name}-createdb
%{_libexecdir}/ibus-engine-table
%{_libexecdir}/ibus-setup-table
%{_mandir}/man1/*
%files devel
@ -108,6 +111,12 @@ Development files for %{name}.
%{_datadir}/pkgconfig/%{name}.pc
%changelog
* Tue Feb 18 2014 Mike FABIAN <mfabian@redhat.com> - 1.5.0.20140218-1
- update to latest upstream
- Resolves: rhbz#1061345 - ibus-table shows entered text in password fields
- remove patches which are included upstream
- remove old, unused patches
* Fri Jan 24 2014 Mike FABIAN <mfabian@redhat.com> - 1.5.0.20130419-3
- Resolves: rhbz#1051365 - suggestion: move ibus-table-createdb to a subpackage
- When tabcreatedb.py is called without any options, print a usage message. Do not just show a cryptic backtrace.

View File

@ -1 +1 @@
6abf17991715afb3020bf5ed534145a7 ibus-table-1.5.0.20130419.tar.gz
4c78a2fe970b28c38145545e9de611b3 ibus-table-1.5.0.20140218.tar.gz