Resolves: #948454 - Man page scan results for ibus-table
- update to latest upstream 1.5.0.20130419 (includes the man-page I added) - remove the patches which are included upstream
This commit is contained in:
parent
afec9363fc
commit
50156f077a
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ ibus-table-1.3.0.20100621.tar.gz
|
||||
/ibus-table-1.4.99.20130108.tar.gz
|
||||
/ibus-table-1.4.99.20130110.tar.gz
|
||||
/ibus-table-1.5.0.tar.gz
|
||||
/ibus-table-1.5.0.20130419.tar.gz
|
||||
|
@ -1,113 +0,0 @@
|
||||
From fdda5c156d851446497bb042e1614ef1c55d9e92 Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Thu, 10 Jan 2013 11:37:59 +0100
|
||||
Subject: [PATCH] Changes in dconf values now get applied immediately
|
||||
|
||||
Changing values of dconf keys for example with
|
||||
|
||||
dconf write /desktop/ibus/engine/table/cangjie3/chinesemode 3
|
||||
|
||||
was not applied immediately to the ibus-table engine, only
|
||||
when changing to a different input method and back this
|
||||
change was applied.
|
||||
|
||||
This commit fixes this problem.
|
||||
---
|
||||
engine/table.py | 72 ++++++++++++++++++++++++++++++++++++++++++---------------
|
||||
1 file changed, 53 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index e171949..24ca921 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -26,6 +26,7 @@ __all__ = (
|
||||
)
|
||||
|
||||
import os
|
||||
+import string
|
||||
from gi.repository import IBus
|
||||
from gi.repository import GLib
|
||||
from curses import ascii
|
||||
@@ -1894,27 +1895,60 @@ class tabengine (IBus.Engine):
|
||||
return True
|
||||
return False
|
||||
|
||||
+ def config_section_normalize(self, section):
|
||||
+ # This function replaces _: with - in the dconf
|
||||
+ # section and converts to lower case to make
|
||||
+ # the comparison of the dconf sections work correctly.
|
||||
+ # I avoid using .lower() here because it is locale dependent,
|
||||
+ # when using .lower() this would not achieve the desired
|
||||
+ # effect of comparing the dconf sections case insentively
|
||||
+ # in some locales, it would fail for example if Turkish
|
||||
+ # locale (tr_TR.UTF-8) is set.
|
||||
+ if type(section) == type(u''):
|
||||
+ # translate() does not work in Python’s internal Unicode type
|
||||
+ section = section.encode('utf-8')
|
||||
+ return re.sub(r'[_:]', r'-', section).translate(
|
||||
+ string.maketrans(string.ascii_uppercase, string.ascii_lowercase ))
|
||||
+
|
||||
def config_value_changed_cb (self, config, section, name, value):
|
||||
+ if self.config_section_normalize(self._config_section) != self.config_section_normalize(section):
|
||||
+ return
|
||||
+ print "config value %(n)s for engine %(en)s changed" %{'n': name, 'en': self._name}
|
||||
value = variant_to_value(value)
|
||||
- if section == self._config_section:
|
||||
- if name == u'AutoCommit':
|
||||
- self._auto_commit = value
|
||||
- elif name == u'ChineseMode':
|
||||
- self._editor._chinese_mode = value
|
||||
- elif name == u'EnDefFullWidthLetter':
|
||||
- self._full_width_letter[0] = value
|
||||
- elif name == u'EnDefFullWidthPunct':
|
||||
- self._full_width_punct[0] = value
|
||||
- elif name == u'LookupTableOrientation':
|
||||
- self._editor._lookup_table.set_orientation (value)
|
||||
- elif name == u'LookupTableSelectKeys':
|
||||
- self._editor.set_select_keys (value)
|
||||
- elif name == u'OneChar':
|
||||
- self._editor._onechar = value
|
||||
- elif name == u'TabDefFullWidthLetter':
|
||||
- self._full_width_letter[1] = value
|
||||
- elif name == u'TabDefFullWidthPunct':
|
||||
- self._full_width_punct[1] = value
|
||||
+ if name == u'autocommit':
|
||||
+ self._auto_commit = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'chinesemode':
|
||||
+ self._editor._chinese_mode = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'endeffullwidthletter':
|
||||
+ self._full_width_letter[0] = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'endeffullwidthpunct':
|
||||
+ self._full_width_punct[0] = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'lookuptableorientation':
|
||||
+ self._editor._lookup_table.set_orientation (value)
|
||||
+ return
|
||||
+ elif name == u'lookuptableselectkeys':
|
||||
+ self._editor.set_select_keys (value)
|
||||
+ return
|
||||
+ elif name == u'onechar':
|
||||
+ self._editor._onechar = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'tabdeffullwidthletter':
|
||||
+ self._full_width_letter[1] = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
+ elif name == u'tabdeffullwidthpunct':
|
||||
+ self._full_width_punct[1] = value
|
||||
+ self._refresh_properties()
|
||||
+ return
|
||||
|
||||
# for further implementation :)
|
||||
@classmethod
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,75 +0,0 @@
|
||||
From 03cba776da99b05218c2b1c86f3e93d3373f253e Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Wed, 30 Jan 2013 07:41:54 +0100
|
||||
Subject: [PATCH 1/5] Fix typo, thanks to Mathieu Bridon
|
||||
|
||||
---
|
||||
engine/chinese_variants.py | 4 ++--
|
||||
tools/generate-chinese-variants.py | 8 ++++----
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/engine/chinese_variants.py b/engine/chinese_variants.py
|
||||
index e48d992..5dce934 100644
|
||||
--- a/engine/chinese_variants.py
|
||||
+++ b/engine/chinese_variants.py
|
||||
@@ -27,7 +27,7 @@ variants_table = {
|
||||
# 1 = 1 << 0 simplified Chinese
|
||||
# 2 = 1 << 1 traditional Chinese
|
||||
# 3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- # 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ # 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
u'蘄': 2,
|
||||
u'谈': 1,
|
||||
u'預': 2,
|
||||
@@ -6075,7 +6075,7 @@ def detect_chinese_category(phrase):
|
||||
1 = 1 << 0 simplified Chinese
|
||||
2 = 1 << 1 traditional Chinese
|
||||
3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
'''
|
||||
# make sure that we got a unicode string
|
||||
if type(phrase) != type(u''):
|
||||
diff --git a/tools/generate-chinese-variants.py b/tools/generate-chinese-variants.py
|
||||
index b846496..c54eaec 100755
|
||||
--- a/tools/generate-chinese-variants.py
|
||||
+++ b/tools/generate-chinese-variants.py
|
||||
@@ -58,7 +58,7 @@ variants_table_orig = {
|
||||
# 1 = 1 << 0 simplified Chinese
|
||||
# 2 = 1 << 1 traditional Chinese
|
||||
# 3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- # 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ # 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
#
|
||||
# overrides can be added manually here. For example the following
|
||||
# line marks the 〇 character as used in both
|
||||
@@ -185,7 +185,7 @@ variants_table = {
|
||||
# 1 = 1 << 0 simplified Chinese
|
||||
# 2 = 1 << 1 traditional Chinese
|
||||
# 3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- # 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ # 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
''')
|
||||
|
||||
for phrase in variants_table_orig:
|
||||
@@ -208,7 +208,7 @@ def detect_chinese_category(phrase):
|
||||
1 = 1 << 0 simplified Chinese
|
||||
2 = 1 << 1 traditional Chinese
|
||||
3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
\'\'\'
|
||||
# make sure that we got a unicode string
|
||||
if type(phrase) != type(u''):
|
||||
@@ -253,7 +253,7 @@ test_data = {
|
||||
# 1 = 1 << 0 simplified Chinese
|
||||
# 2 = 1 << 1 traditional Chinese
|
||||
# 3 = (1 | 1 << 1) used both in simplified *and* traditional Chinese
|
||||
- # 4 = 2 << 3 mixture of simplified and traditional Chinese
|
||||
+ # 4 = 1 << 2 mixture of simplified and traditional Chinese
|
||||
u'乌': 1,
|
||||
u'烏': 2,
|
||||
u'晞': 3,
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 1c316e066f88f9555de5407f00b4be0b076fd42c Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Thu, 24 Jan 2013 12:47:19 +0100
|
||||
Subject: [PATCH 1/2] Make comments about _chinese_mode clearer
|
||||
|
||||
There was one obvious typo and the comments did not explain
|
||||
the meaning of _chinese_mode clearly.
|
||||
---
|
||||
engine/table.py | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index e171949..c106a0a 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -217,11 +217,11 @@ class editor(object):
|
||||
if self._onechar == None:
|
||||
self_onechar = False
|
||||
# self._chinese_mode: the candidate filter mode,
|
||||
- # 0 is simplify Chinese
|
||||
- # 1 is traditional Chinese
|
||||
- # 2 is Big charset mode, but simplify Chinese first
|
||||
- # 3 is Big charset mode, but traditional Chinese first
|
||||
- # 4 is Big charset mode.
|
||||
+ # 0 means to show simplified Chinese only
|
||||
+ # 1 means to show traditional Chinese only
|
||||
+ # 2 means to show all characters but show simplified Chinese first
|
||||
+ # 3 means to show all characters but show traditional Chinese first
|
||||
+ # 4 means to show all characters
|
||||
# we use LC_CTYPE or LANG to determine which one to use
|
||||
self._chinese_mode = variant_to_value(self._config.get_value(
|
||||
self._config_section,
|
||||
@@ -636,13 +636,13 @@ class editor(object):
|
||||
return candidates[:]
|
||||
bm_index = self._pt.index('category')
|
||||
if self._chinese_mode == 2:
|
||||
- # big charset with SC first
|
||||
+ # All Chinese characters with simplified Chinese first
|
||||
return filter (lambda x: x[bm_index] & 1, candidates)\
|
||||
+filter (lambda x: x[bm_index] & (1 << 1) and \
|
||||
(not x[bm_index] & 1), candidates)\
|
||||
+ filter (lambda x: x[bm_index] & (1 << 2), candidates)
|
||||
elif self._chinese_mode == 3:
|
||||
- # big charset with SC first
|
||||
+ # All Chinese characters with traditional Chinese first
|
||||
return filter (lambda x: x[bm_index] & (1 << 1), candidates)\
|
||||
+filter (lambda x: x[bm_index] & 1 and\
|
||||
(not x[bm_index] & (1<<1)) , candidates)\
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,111 +0,0 @@
|
||||
From a55783887e757f02078143c2d12031a33c9e9223 Mon Sep 17 00:00:00 2001
|
||||
From: bnauwelaerts <bnauwelaerts@cli0189.fednot.be>
|
||||
Date: Sat, 2 Feb 2013 13:03:48 +0100
|
||||
Subject: [PATCH 2/5] Add auto_select functionality to select the first phrase
|
||||
when typing. Useful for Cyrillic transliteration.
|
||||
|
||||
---
|
||||
engine/table.py | 26 +++++++++++++++++++++++---
|
||||
engine/tabsqlitedb.py | 1 +
|
||||
tables/template.txt | 3 +++
|
||||
3 files changed, 27 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index c106a0a..4a10636 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -228,6 +228,13 @@ class editor(object):
|
||||
"ChineseMode"))
|
||||
if self._chinese_mode == None:
|
||||
self._chinese_mode = self.get_chinese_mode()
|
||||
+
|
||||
+ self._auto_select = variant_to_value(self._config.get_value(
|
||||
+ self._config_section,
|
||||
+ "AutoSelect"))
|
||||
+ if self._auto_select == None:
|
||||
+ self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
+
|
||||
|
||||
def init_select_keys(self):
|
||||
# __select_keys: lookup table select keys/labels
|
||||
@@ -728,7 +735,9 @@ class editor(object):
|
||||
if ascii.ispunct (self._chars[0][-1].encode('ascii')) \
|
||||
or len (self._chars[0][:-1]) \
|
||||
in self.db.pkeylens \
|
||||
- or only_one_last:
|
||||
+ or only_one_last \
|
||||
+ or self._auto_select:
|
||||
+
|
||||
# because we use [!@#$%] to denote [12345]
|
||||
# in py_mode, so we need to distinguish them
|
||||
## old manner:
|
||||
@@ -750,7 +759,7 @@ class editor(object):
|
||||
self._lookup_table.clear()
|
||||
self._lookup_table.set_cursor_visible(True)
|
||||
return False
|
||||
- else:
|
||||
+ else:
|
||||
# this is not a punct or not a valid phrase
|
||||
# last time
|
||||
self._chars[1].append( self._chars[0].pop() )
|
||||
@@ -1142,11 +1151,19 @@ class tabengine (IBus.Engine):
|
||||
self._full_width_punct[1] = self.db.get_ime_property('def_full_width_punct').lower() == u'true'
|
||||
# some properties we will involved, Property is taken from scim.
|
||||
#self._setup_property = Property ("setup", _("Setup"))
|
||||
+
|
||||
self._auto_commit = variant_to_value(self._config.get_value(
|
||||
self._config_section,
|
||||
"AutoCommit"))
|
||||
if self._auto_commit == None:
|
||||
self._auto_commit = self.db.get_ime_property('auto_commit').lower() == u'true'
|
||||
+
|
||||
+ self._auto_select = variant_to_value(self._config.get_value(
|
||||
+ self._config_section,
|
||||
+ "AutoSelect"))
|
||||
+ if self._auto_select == None:
|
||||
+ self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
+
|
||||
# the commit phrases length
|
||||
self._len_list = [0]
|
||||
# connect to SpeedMeter
|
||||
@@ -1736,7 +1753,10 @@ class tabengine (IBus.Engine):
|
||||
sp_res = self._editor.space ()
|
||||
#return (KeyProcessResult,whethercommit,commitstring)
|
||||
if sp_res[0]:
|
||||
- self.commit_string (sp_res[1])
|
||||
+ if self._auto_select:
|
||||
+ self.commit_string ("%s " %sp_res[1])
|
||||
+ else:
|
||||
+ self.commit_string (sp_res[1])
|
||||
#self.add_string_len(sp_res[1])
|
||||
self.db.check_phrase (sp_res[1], sp_res[2])
|
||||
else:
|
||||
diff --git a/engine/tabsqlitedb.py b/engine/tabsqlitedb.py
|
||||
index 78fa85d..fa56053 100644
|
||||
--- a/engine/tabsqlitedb.py
|
||||
+++ b/engine/tabsqlitedb.py
|
||||
@@ -99,6 +99,7 @@ class tabsqlitedb:
|
||||
'user_can_define_phrase':'FALSE',
|
||||
'pinyin_mode':'FALSE',
|
||||
'dynamic_adjust':'FALSE',
|
||||
+ 'auto_select':'false',
|
||||
'auto_commit':'false',
|
||||
#'no_check_chars':u'',
|
||||
'description':'A IME under IBus Table',
|
||||
diff --git a/tables/template.txt b/tables/template.txt
|
||||
index 40bc915..f51cdf8 100644
|
||||
--- a/tables/template.txt
|
||||
+++ b/tables/template.txt
|
||||
@@ -63,6 +63,9 @@ MAX_KEY_LENGTH = 4
|
||||
### Use auto_commit mode as default
|
||||
AUTO_COMMIT = FALSE
|
||||
|
||||
+### Automatically selects the first phrase when typing
|
||||
+AUTO_SELECT = FALSE
|
||||
+
|
||||
### Use full width punctuation by default
|
||||
DEF_FULL_WIDTH_PUNCT = TRUE
|
||||
### Not use full width letter by default
|
||||
--
|
||||
1.7.11.7
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,25 +0,0 @@
|
||||
From 2baa9c3ff258c0623b4777f2c537467339cdcef6 Mon Sep 17 00:00:00 2001
|
||||
From: bnauwelaerts <bnauwelaerts@cli0189.fednot.be>
|
||||
Date: Sat, 2 Feb 2013 17:22:40 +0100
|
||||
Subject: [PATCH 3/5] Update cmode pproperty in chinese mode only
|
||||
|
||||
---
|
||||
engine/table.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index 4a10636..f0a8a61 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -1304,7 +1304,7 @@ class tabengine (IBus.Engine):
|
||||
self._set_property(self._cmode_property, 'tcb-mode.svg', _('Traditional Chinese First Big Charset Mode'), _('Switch to Big Charset Mode'))
|
||||
elif self._editor._chinese_mode == 4:
|
||||
self._set_property(self._cmode_property, 'cb-mode.svg', _('Big Chinese Mode'), _('Switch to Simplified Chinese Mode'))
|
||||
- self.update_property(self._cmode_property)
|
||||
+ self.update_property(self._cmode_property)
|
||||
|
||||
def _set_property (self, property, icon, label, tooltip):
|
||||
property.set_icon ( u'%s%s' % (self._icon_dir, icon ) )
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 5b434df882093a3def36585582c84950ce7e3b52 Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Mon, 28 Jan 2013 15:15:10 +0100
|
||||
Subject: [PATCH 3/3] add engine/chinese_variants.py to engine/Makefile.am
|
||||
|
||||
Needed by
|
||||
|
||||
commit f17e9b3aecea7b6646da689a466341936bce1ee3
|
||||
Author: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Thu Jan 24 17:37:27 2013 +0100
|
||||
|
||||
Improve detection of simplified and traditional Chinese
|
||||
---
|
||||
engine/Makefile.am | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/engine/Makefile.am b/engine/Makefile.am
|
||||
index 082e177..f17afe3 100644
|
||||
--- a/engine/Makefile.am
|
||||
+++ b/engine/Makefile.am
|
||||
@@ -20,6 +20,7 @@
|
||||
#
|
||||
|
||||
engine_table_PYTHON = \
|
||||
+ chinese_variants.py \
|
||||
factory.py \
|
||||
main.py \
|
||||
table.py \
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,42 +0,0 @@
|
||||
From 3d03bd8f8c558392db42897370cef65bdbad57bd Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Tue, 5 Feb 2013 09:11:17 +0100
|
||||
Subject: [PATCH 4/5] Fall back to auto_select = False if neither dconf nor
|
||||
the table have a value for auto_select
|
||||
|
||||
---
|
||||
engine/table.py | 11 ++++++++---
|
||||
1 file changed, 8 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index f0a8a61..3999c35 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -233,8 +233,10 @@ class editor(object):
|
||||
self._config_section,
|
||||
"AutoSelect"))
|
||||
if self._auto_select == None:
|
||||
- self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
-
|
||||
+ if self.db.get_ime_property('auto_select') != None:
|
||||
+ self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
+ else:
|
||||
+ self._auto_select = False
|
||||
|
||||
def init_select_keys(self):
|
||||
# __select_keys: lookup table select keys/labels
|
||||
@@ -1162,7 +1164,10 @@ class tabengine (IBus.Engine):
|
||||
self._config_section,
|
||||
"AutoSelect"))
|
||||
if self._auto_select == None:
|
||||
- self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
+ if self.db.get_ime_property('auto_select') != None:
|
||||
+ self._auto_select = self.db.get_ime_property('auto_select').lower() == u'true'
|
||||
+ else:
|
||||
+ self._auto_select = False
|
||||
|
||||
# the commit phrases length
|
||||
self._len_list = [0]
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,66 +0,0 @@
|
||||
From 3b7a3530c42766b801cded26b3bc269222c3fb0a Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Thu, 14 Feb 2013 18:21:57 +0100
|
||||
Subject: [PATCH 5/5] Preedit needs to be updated on page-up and page-down
|
||||
|
||||
When paging through the lookup table, the preedit needs to be updated
|
||||
to show the phrase selected by the cursor in the lookup table. Before
|
||||
this patch, the preedit was not updated and when commiting the
|
||||
character selected in the lookup table suddenly replaced the character
|
||||
in the preedit. This differed from the behaviour when moving through
|
||||
the lookup table with the arrow-up and arrow-down keys.
|
||||
Using page-up and page-down or the arrow icons at the bottom
|
||||
of the lookup table should also update the preedit just like it
|
||||
is done when the arrow-up and arrow-down keys are used.
|
||||
---
|
||||
engine/table.py | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/engine/table.py b/engine/table.py
|
||||
index 3999c35..58a8d4d 100644
|
||||
--- a/engine/table.py
|
||||
+++ b/engine/table.py
|
||||
@@ -1751,7 +1751,7 @@ class tabengine (IBus.Engine):
|
||||
# on lookup page
|
||||
if IBus.KEY_space in self._page_down_keys:
|
||||
res = self._editor.page_down()
|
||||
- self._update_lookup_table ()
|
||||
+ self._update_ui ()
|
||||
return res
|
||||
else:
|
||||
o_py = self._editor._py_mode
|
||||
@@ -1826,13 +1826,13 @@ class tabengine (IBus.Engine):
|
||||
elif key.code in self._page_down_keys \
|
||||
and self._editor._candidates[0]:
|
||||
res = self._editor.page_down()
|
||||
- self._update_lookup_table ()
|
||||
+ self._update_ui ()
|
||||
return res
|
||||
|
||||
elif key.code in self._page_up_keys \
|
||||
and self._editor._candidates[0]:
|
||||
res = self._editor.page_up ()
|
||||
- self._update_lookup_table ()
|
||||
+ self._update_ui ()
|
||||
return res
|
||||
|
||||
elif keychar in self._editor.get_select_keys() and self._editor._candidates[0]:
|
||||
@@ -1909,13 +1909,13 @@ class tabengine (IBus.Engine):
|
||||
|
||||
def do_page_up (self):
|
||||
if self._editor.page_up ():
|
||||
- self._update_lookup_table ()
|
||||
+ self._update_ui ()
|
||||
return True
|
||||
return False
|
||||
|
||||
def do_page_down (self):
|
||||
if self._editor.page_down ():
|
||||
- self._update_lookup_table ()
|
||||
+ self._update_ui ()
|
||||
return True
|
||||
return False
|
||||
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -ru ibus-table-1.5.0/engine/Makefile.in ibus-table-1.5.0/engine/Makefile.in
|
||||
--- ibus-table-1.5.0/engine/Makefile.in 2013-01-28 15:43:30.000000000 +0100
|
||||
+++ ibus-table-1.5.0/engine/Makefile.in 2013-01-28 17:10:33.749435024 +0100
|
||||
@@ -254,6 +254,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
engine_table_PYTHON = \
|
||||
+ chinese_variants.py \
|
||||
factory.py \
|
||||
main.py \
|
||||
table.py \
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -ru ibus-table-1.3.9.20120904.orig/engine/tabdict.py ibus-table-1.3.9.20120904/engine/tabdict.py
|
||||
--- ibus-table-1.3.9.20120904.orig/engine/tabdict.py 2012-09-03 16:51:59.000000000 +0200
|
||||
+++ ibus-table-1.3.9.20120904/engine/tabdict.py 2012-09-04 14:50:32.186626109 +0200
|
||||
@@ -54,7 +54,10 @@
|
||||
# for translit
|
||||
gen_uni('ä'):95,
|
||||
gen_uni('ö'):96,
|
||||
- gen_uni('ü'):97
|
||||
+ gen_uni('ü'):97,
|
||||
+ gen_uni('Ä'):98,
|
||||
+ gen_uni('Ö'):99,
|
||||
+ gen_uni('Ü'):100
|
||||
}
|
||||
|
||||
tab_key_list = tab_dict.keys()
|
||||
ibus-table-1.3.9.20120904/engineだけに発見: tabdict.py.~1~
|
@ -1,22 +1,11 @@
|
||||
Name: ibus-table
|
||||
Version: 1.5.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.5.0.20130419
|
||||
Release: 1%{?dist}
|
||||
Summary: The Table engine for IBus platform
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://code.google.com/p/ibus/
|
||||
Source0: http://mfabian.fedorapeople.org/ibus-table/%{name}-%{version}.tar.gz
|
||||
Patch1: ibus-table-1.3.9.20110827-uppercase-umlauts.patch
|
||||
Patch2: 0001-Changes-in-dconf-values-now-get-applied-immediately.patch
|
||||
Patch3: 0001-Make-comments-about-_chinese_mode-clearer.patch
|
||||
Patch4: 0002-Improve-detection-of-simplified-and-traditional-Chin.patch
|
||||
Patch5: 0003-add-engine-chinese_variants.py-to-engine-Makefile.am.patch
|
||||
Patch6: add-engine-chinese_variants.py-to-engine-Makefile.in.patch
|
||||
Patch7: 0001-Fix-typo-thanks-to-Mathieu-Bridon.patch
|
||||
Patch8: 0002-Add-auto_select-functionality-to-select-the-first-ph.patch
|
||||
Patch9: 0003-Update-cmode-pproperty-in-chinese-mode-only.patch
|
||||
Patch10: 0004-Fall-back-to-auto_select-False-if-neither-dconf-nor-.patch
|
||||
Patch11: 0005-Preedit-needs-to-be-updated-on-page-up-and-page-down.patch
|
||||
|
||||
Requires: ibus > 1.3.0
|
||||
BuildRequires: ibus-devel > 1.3.0
|
||||
@ -39,17 +28,6 @@ Development files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .uppercase-umlauts
|
||||
%patch2 -p1 -b .apply-dconf-changes
|
||||
%patch3 -p1 -b .make-comments-about-chinese-mode-clearer
|
||||
%patch4 -p1 -b .improve-detection-of-simplified-and-traditional-chinese
|
||||
%patch5 -p1 -b .fix-makefile-am
|
||||
%patch6 -p1 -b .fix-makefile-in
|
||||
%patch7 -p1 -b .fix-typo
|
||||
%patch8 -p1 -b .add-auto-select
|
||||
%patch9 -p1 -b .update-cmode-in-chinese-mode-only
|
||||
%patch10 -p1 -b .fall-back-to-auto-select-false-by-default
|
||||
%patch11 -p1 -b .preedit-needs-to-be-updated-when-paging
|
||||
|
||||
%build
|
||||
%configure --disable-static --disable-additional
|
||||
@ -117,12 +95,18 @@ Development files for %{name}.
|
||||
%{_datadir}/%{name}/tables/template.txt
|
||||
%{_bindir}/%{name}-createdb
|
||||
%{_libexecdir}/ibus-engine-table
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, -)
|
||||
%{_datadir}/pkgconfig/%{name}.pc
|
||||
|
||||
%changelog
|
||||
* Fri Apr 19 2013 Mike FABIAN <mfabian@redhat.com> - 1.5.0.20130419-1
|
||||
- update to latest upstream
|
||||
- remove patches which are included upstream
|
||||
- Resolves: #948454 - Man page scan results for ibus-table
|
||||
|
||||
* Thu Feb 14 2013 Mike FABIAN <mfabian@redhat.com> - 1.5.0-2
|
||||
- Resolves: #911487 - Non-Chinese tables from the ibus-table-other package do not work
|
||||
- Add auto_select functionality to select the first phrase when typing.
|
||||
|
Loading…
Reference in New Issue
Block a user