Update to 1.12.5
- Return False in _execute_command_commit_candidate_number(self, number) if number out of range - Resolves: https://github.com/moebiuscurve/ibus-table-others/issues/21 - remove Use-from-unittest-import-mock-instead-of-just-import.patch (included upstream) - Update translations from Weblate (New translation for Sinhala (si) started)
This commit is contained in:
parent
19dab3bce8
commit
3ffbe2d7b7
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@ ibus-table-1.3.0.20100621.tar.gz
|
||||
/ibus-table-1.12.2.tar.gz
|
||||
/ibus-table-1.12.3.tar.gz
|
||||
/ibus-table-1.12.4.tar.gz
|
||||
/ibus-table-1.12.5.tar.gz
|
||||
|
@ -1,36 +0,0 @@
|
||||
From f41791d752a7a398b57f88e07bb2871ae533ca1c Mon Sep 17 00:00:00 2001
|
||||
From: Mike FABIAN <mfabian@redhat.com>
|
||||
Date: Tue, 2 Feb 2021 11:42:49 +0100
|
||||
Subject: [PATCH] =?UTF-8?q?Use=20=E2=80=9Cfrom=20unittest=20import=20mock?=
|
||||
=?UTF-8?q?=E2=80=9D=20instead=20of=20just=20=E2=80=9Cimport=20mock?=
|
||||
=?UTF-8?q?=E2=80=9D.?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Since Python 3.3, mock is part of unittest in the standard
|
||||
library. The third-party `mock` library is a backport for older Python
|
||||
versions.
|
||||
|
||||
This makes it possible to remove the “BuildRequires: python3-mock”
|
||||
from the ibus-table.spec file.
|
||||
---
|
||||
tests/test_it.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/test_it.py b/tests/test_it.py
|
||||
index a4b6ba6..cad55c1 100755
|
||||
--- a/tests/test_it.py
|
||||
+++ b/tests/test_it.py
|
||||
@@ -29,7 +29,7 @@ import logging
|
||||
import time
|
||||
import unittest
|
||||
import importlib
|
||||
-import mock
|
||||
+from unittest import mock
|
||||
|
||||
from gi import require_version
|
||||
require_version('IBus', '1.0')
|
||||
--
|
||||
2.29.2
|
||||
|
@ -1,11 +1,10 @@
|
||||
Name: ibus-table
|
||||
Version: 1.12.4
|
||||
Release: 5%{?dist}
|
||||
Version: 1.12.5
|
||||
Release: 1%{?dist}
|
||||
Summary: The Table engine for IBus platform
|
||||
License: LGPLv2+
|
||||
URL: http://code.google.com/p/ibus/
|
||||
Source0: http://mfabian.fedorapeople.org/ibus-table/%{name}-%{version}.tar.gz
|
||||
Patch0: Use-from-unittest-import-mock-instead-of-just-import.patch
|
||||
Requires: ibus > 1.3.0
|
||||
%{?__python3:Requires: %{__python3}}
|
||||
BuildRequires: gcc
|
||||
@ -54,7 +53,6 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .use-standard-library-mock
|
||||
|
||||
%build
|
||||
export PYTHON=%{__python3}
|
||||
@ -150,6 +148,15 @@ fi
|
||||
%{_datadir}/installed-tests/%{name}
|
||||
|
||||
%changelog
|
||||
* Fri Mar 05 2021 Mike FABIAN <mfabian@redhat.com> - 1.12.5-1
|
||||
- Update to 1.12.5
|
||||
- Return False in _execute_command_commit_candidate_number(self, number)
|
||||
if number out of range
|
||||
- Resolves: https://github.com/moebiuscurve/ibus-table-others/issues/21
|
||||
- remove Use-from-unittest-import-mock-instead-of-just-import.patch
|
||||
(included upstream)
|
||||
- Update translations from Weblate (New translation for Sinhala (si) started)
|
||||
|
||||
* Wed Feb 17 2021 Mike FABIAN <mfabian@redhat.com> - 1.12.4-5
|
||||
- Use “BuildRequires: appstream” only on Fedora
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ibus-table-1.12.4.tar.gz) = 3e175dad8d9e12be91f6b6878b67301bbbf04c55e43d483162d3b10d2edbdcf1077d1f37beea2ef36323eb7de289a0c60cd3d055357a580e5d18bcc642bb907c
|
||||
SHA512 (ibus-table-1.12.5.tar.gz) = 1fbbf07c64b366c84ca463e0e5f21a6008cc488f75ac24466d94982f70c04b6b882f098bae210d4f32c381c24899c5c0da389a501c30ef5e3dd679828720ab5a
|
||||
|
Loading…
Reference in New Issue
Block a user