update to 1.5.0 and add patches for better simplified/traditional Chinese detection

- update to latest upstream 1.5.0  from Caius ‘kaio’ Chance’s repository
- add patches for better simplified/traditional Chinese detection
- Resolves: #857967 - simplified/traditional Chinese detection in ibus-table does not work well
This commit is contained in:
Mike FABIAN 2013-01-28 15:54:50 +01:00
parent ece062c31c
commit 17882b4e15
7 changed files with 20027 additions and 2 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@ ibus-table-1.3.0.20100621.tar.gz
/ibus-table-1.4.99.20130103.tar.gz
/ibus-table-1.4.99.20130108.tar.gz
/ibus-table-1.4.99.20130110.tar.gz
/ibus-table-1.5.0.tar.gz

View File

@ -0,0 +1,51 @@
From 1c316e066f88f9555de5407f00b4be0b076fd42c Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Thu, 24 Jan 2013 12:47:19 +0100
Subject: [PATCH 1/2] Make comments about _chinese_mode clearer
There was one obvious typo and the comments did not explain
the meaning of _chinese_mode clearly.
---
engine/table.py | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/engine/table.py b/engine/table.py
index e171949..c106a0a 100644
--- a/engine/table.py
+++ b/engine/table.py
@@ -217,11 +217,11 @@ class editor(object):
if self._onechar == None:
self_onechar = False
# self._chinese_mode: the candidate filter mode,
- # 0 is simplify Chinese
- # 1 is traditional Chinese
- # 2 is Big charset mode, but simplify Chinese first
- # 3 is Big charset mode, but traditional Chinese first
- # 4 is Big charset mode.
+ # 0 means to show simplified Chinese only
+ # 1 means to show traditional Chinese only
+ # 2 means to show all characters but show simplified Chinese first
+ # 3 means to show all characters but show traditional Chinese first
+ # 4 means to show all characters
# we use LC_CTYPE or LANG to determine which one to use
self._chinese_mode = variant_to_value(self._config.get_value(
self._config_section,
@@ -636,13 +636,13 @@ class editor(object):
return candidates[:]
bm_index = self._pt.index('category')
if self._chinese_mode == 2:
- # big charset with SC first
+ # All Chinese characters with simplified Chinese first
return filter (lambda x: x[bm_index] & 1, candidates)\
+filter (lambda x: x[bm_index] & (1 << 1) and \
(not x[bm_index] & 1), candidates)\
+ filter (lambda x: x[bm_index] & (1 << 2), candidates)
elif self._chinese_mode == 3:
- # big charset with SC first
+ # All Chinese characters with traditional Chinese first
return filter (lambda x: x[bm_index] & (1 << 1), candidates)\
+filter (lambda x: x[bm_index] & 1 and\
(not x[bm_index] & (1<<1)) , candidates)\
--
1.7.11.7

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,31 @@
From 5b434df882093a3def36585582c84950ce7e3b52 Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Mon, 28 Jan 2013 15:15:10 +0100
Subject: [PATCH 3/3] add engine/chinese_variants.py to engine/Makefile.am
Needed by
commit f17e9b3aecea7b6646da689a466341936bce1ee3
Author: Mike FABIAN <mfabian@redhat.com>
Date: Thu Jan 24 17:37:27 2013 +0100
Improve detection of simplified and traditional Chinese
---
engine/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/engine/Makefile.am b/engine/Makefile.am
index 082e177..f17afe3 100644
--- a/engine/Makefile.am
+++ b/engine/Makefile.am
@@ -20,6 +20,7 @@
#
engine_table_PYTHON = \
+ chinese_variants.py \
factory.py \
main.py \
table.py \
--
1.7.11.7

View File

@ -0,0 +1,12 @@
diff -ru ibus-table-1.5.0/engine/Makefile.in ibus-table-1.5.0/engine/Makefile.in
--- ibus-table-1.5.0/engine/Makefile.in 2013-01-28 15:43:30.000000000 +0100
+++ ibus-table-1.5.0/engine/Makefile.in 2013-01-28 17:10:33.749435024 +0100
@@ -254,6 +254,7 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
engine_table_PYTHON = \
+ chinese_variants.py \
factory.py \
main.py \
table.py \

View File

@ -1,5 +1,5 @@
Name: ibus-table
Version: 1.4.99.20130110
Version: 1.5.0
Release: 1%{?dist}
Summary: The Table engine for IBus platform
License: LGPLv2+
@ -8,6 +8,10 @@ URL: http://code.google.com/p/ibus/
Source0: http://mfabian.fedorapeople.org/ibus-table/%{name}-%{version}.tar.gz
Patch1: ibus-table-1.3.9.20110827-uppercase-umlauts.patch
Patch2: 0001-Changes-in-dconf-values-now-get-applied-immediately.patch
Patch3: 0001-Make-comments-about-_chinese_mode-clearer.patch
Patch4: 0002-Improve-detection-of-simplified-and-traditional-Chin.patch
Patch5: 0003-add-engine-chinese_variants.py-to-engine-Makefile.am.patch
Patch6: add-engine-chinese_variants.py-to-engine-Makefile.in.patch
Requires: ibus > 1.3.0
BuildRequires: ibus-devel > 1.3.0
@ -32,6 +36,10 @@ Development files for %{name}.
%setup -q
%patch1 -p1 -b .uppercase-umlauts
%patch2 -p1 -b .apply-dconf-changes
%patch3 -p1 -b .make-comments-about-chinese-mode-clearer
%patch4 -p1 -b .improve-detection-of-simplified-and-traditional-chinese
%patch5 -p1 -b .fix-makefile-am
%patch6 -p1 -b .fix-makefile-in
%build
%configure --disable-static --disable-additional
@ -75,6 +83,9 @@ Development files for %{name}.
%{_datadir}/%{name}/icons/tc-mode.svg
%{_datadir}/%{name}/icons/tcb-mode.svg
%{_datadir}/%{name}/data/pinyin_table.txt.bz2
%{_datadir}/%{name}/engine/chinese_variants.py
%{_datadir}/%{name}/engine/chinese_variants.pyc
%{_datadir}/%{name}/engine/chinese_variants.pyo
%{_datadir}/%{name}/engine/factory.py
%{_datadir}/%{name}/engine/factory.pyc
%{_datadir}/%{name}/engine/factory.pyo
@ -102,6 +113,11 @@ Development files for %{name}.
%{_datadir}/pkgconfig/%{name}.pc
%changelog
* Mon Jan 28 2013 Mike FABIAN <mfabian@redhat.com> - 1.5.0-1
- update to latest upstream 1.5.0 from Caius kaio Chances repository
- add patches for better simplified/traditional Chinese detection
- Resolves: #857967 - simplified/traditional Chinese detection in ibus-table does not work well
* Thu Jan 10 2013 Mike FABIAN <mfabian@redhat.com> - 1.4.99.20130110-1
- Resolves: #513901 ibus-table setup does not store config settings
- update to latest upstream 1.4.99.20130110 from Caius kaio Chances repository, 1.5.0 branch

View File

@ -1 +1 @@
50745b4b20215012127577df9c73f7f1 ibus-table-1.4.99.20130110.tar.gz
fa9914e5c4c28173d1cdf9c23e681188 ibus-table-1.5.0.tar.gz