84d8dfc468
- Make the status prompts for Ukrainian and Russian unique (from Daniil Ivanov <daniil.ivanov@gmail.com>) - Make icons for Ukrainian and Russian unique (from Daniil Ivanov <daniil.ivanov@gmail.com>)
478 lines
21 KiB
Diff
478 lines
21 KiB
Diff
From 0c9d7f4bcb870a8a1af9b26fffd026e75c38c8c1 Mon Sep 17 00:00:00 2001
|
|
From: Daniil Ivanov <daniil.ivanov@gmail.com>
|
|
Date: Sat, 8 Sep 2012 13:27:31 +0300
|
|
Subject: [PATCH 2/2] PNG icons for Russian and Ukrainian replaced with
|
|
updated SVG versions
|
|
|
|
---
|
|
ibus-table-others.spec | 4 +--
|
|
ibus-table-others.spec.in | 4 +--
|
|
icons/Makefile | 8 ++---
|
|
icons/Makefile.am | 8 ++---
|
|
icons/Makefile.in | 8 ++---
|
|
icons/translit-ua.png | Bin 2658 -> 0 bytes
|
|
icons/translit-ua.svg | 90 ++++++++++++++++++++++++++++++++++++++++++++++
|
|
icons/translit.png | Bin 2658 -> 0 bytes
|
|
icons/translit.svg | 89 +++++++++++++++++++++++++++++++++++++++++++++
|
|
tables/translit-ua.txt | 2 +-
|
|
tables/translit.txt | 2 +-
|
|
11 files changed, 197 insertions(+), 18 deletions(-)
|
|
delete mode 100644 icons/translit-ua.png
|
|
create mode 100644 icons/translit-ua.svg
|
|
delete mode 100644 icons/translit.png
|
|
create mode 100644 icons/translit.svg
|
|
|
|
diff --git a/ibus-table-others.spec b/ibus-table-others.spec
|
|
index 849796c..4984c1c 100644
|
|
--- a/ibus-table-others.spec
|
|
+++ b/ibus-table-others.spec
|
|
@@ -49,8 +49,8 @@ rm -rf $RPM_BUILD_ROOT
|
|
%files
|
|
%defattr(-,root,root,-)
|
|
%doc AUTHORS COPYING README
|
|
-%{_datadir}/ibus-table/icons/translit.png
|
|
-%{_datadir}/ibus-table/icons/translit-ua.png
|
|
+%{_datadir}/ibus-table/icons/translit.svg
|
|
+%{_datadir}/ibus-table/icons/translit-ua.svg
|
|
%{_datadir}/ibus-table/icons/rustrad.png
|
|
%{_datadir}/ibus-table/icons/yawerty.png
|
|
%{_datadir}/ibus-table/tables/translit.db
|
|
diff --git a/ibus-table-others.spec.in b/ibus-table-others.spec.in
|
|
index 87ca595..1c653cf 100644
|
|
--- a/ibus-table-others.spec.in
|
|
+++ b/ibus-table-others.spec.in
|
|
@@ -49,8 +49,8 @@ rm -rf $RPM_BUILD_ROOT
|
|
%files
|
|
%defattr(-,root,root,-)
|
|
%doc AUTHORS COPYING README
|
|
-%{_datadir}/ibus-table/icons/translit.png
|
|
-%{_datadir}/ibus-table/icons/translit-ua.png
|
|
+%{_datadir}/ibus-table/icons/translit.svg
|
|
+%{_datadir}/ibus-table/icons/translit-ua.svg
|
|
%{_datadir}/ibus-table/icons/rustrad.png
|
|
%{_datadir}/ibus-table/icons/yawerty.png
|
|
%{_datadir}/ibus-table/tables/translit.db
|
|
diff --git a/icons/Makefile b/icons/Makefile
|
|
index ed1ef0c..db4cc99 100644
|
|
--- a/icons/Makefile
|
|
+++ b/icons/Makefile
|
|
@@ -54,8 +54,8 @@ PRE_UNINSTALL = :
|
|
POST_UNINSTALL = :
|
|
am__append_1 = compose.svg
|
|
am__append_2 = ipa-x-sampa.svg
|
|
-am__append_3 = translit.png
|
|
-am__append_4 = translit-ua.png
|
|
+am__append_3 = translit.svg
|
|
+am__append_4 = translit-ua.svg
|
|
am__append_5 = rustrad.png
|
|
am__append_6 = yawerty.png
|
|
am__append_7 = thai.png
|
|
@@ -193,8 +193,8 @@ iconsdir = $(datadir)/ibus-table/icons
|
|
EXTRA_DIST = \
|
|
compose.svg \
|
|
ipa-x-sampa.svg \
|
|
- translit.png \
|
|
- translit-ua.png \
|
|
+ translit.svg \
|
|
+ translit-ua.svg \
|
|
rustrad.png \
|
|
yawerty.png \
|
|
thai.png \
|
|
diff --git a/icons/Makefile.am b/icons/Makefile.am
|
|
index e52599b..e8658b7 100644
|
|
--- a/icons/Makefile.am
|
|
+++ b/icons/Makefile.am
|
|
@@ -29,11 +29,11 @@ icons_DATA += ipa-x-sampa.svg
|
|
endif
|
|
|
|
if IBUS_TABLE_BUILD_TRANSLIT
|
|
-icons_DATA += translit.png
|
|
+icons_DATA += translit.svg
|
|
endif
|
|
|
|
if IBUS_TABLE_BUILD_TRANSLITUA
|
|
-icons_DATA += translit-ua.png
|
|
+icons_DATA += translit-ua.svg
|
|
endif
|
|
|
|
if IBUS_TABLE_BUILD_RUSTRAD
|
|
@@ -75,8 +75,8 @@ iconsdir = $(datadir)/ibus-table/icons
|
|
EXTRA_DIST = \
|
|
compose.svg \
|
|
ipa-x-sampa.svg \
|
|
- translit.png \
|
|
- translit-ua.png \
|
|
+ translit.svg \
|
|
+ translit-ua.svg \
|
|
rustrad.png \
|
|
yawerty.png \
|
|
thai.png \
|
|
diff --git a/icons/Makefile.in b/icons/Makefile.in
|
|
index eb40290..f22e8da 100644
|
|
--- a/icons/Makefile.in
|
|
+++ b/icons/Makefile.in
|
|
@@ -54,8 +54,8 @@ PRE_UNINSTALL = :
|
|
POST_UNINSTALL = :
|
|
@IBUS_TABLE_BUILD_COMPOSE_TRUE@am__append_1 = compose.svg
|
|
@IBUS_TABLE_BUILD_IPAXSAMPA_TRUE@am__append_2 = ipa-x-sampa.svg
|
|
-@IBUS_TABLE_BUILD_TRANSLIT_TRUE@am__append_3 = translit.png
|
|
-@IBUS_TABLE_BUILD_TRANSLITUA_TRUE@am__append_4 = translit-ua.png
|
|
+@IBUS_TABLE_BUILD_TRANSLIT_TRUE@am__append_3 = translit.svg
|
|
+@IBUS_TABLE_BUILD_TRANSLITUA_TRUE@am__append_4 = translit-ua.svg
|
|
@IBUS_TABLE_BUILD_RUSTRAD_TRUE@am__append_5 = rustrad.png
|
|
@IBUS_TABLE_BUILD_YAWERTY_TRUE@am__append_6 = yawerty.png
|
|
@IBUS_TABLE_BUILD_THAI_TRUE@am__append_7 = thai.png
|
|
@@ -193,8 +193,8 @@ iconsdir = $(datadir)/ibus-table/icons
|
|
EXTRA_DIST = \
|
|
compose.svg \
|
|
ipa-x-sampa.svg \
|
|
- translit.png \
|
|
- translit-ua.png \
|
|
+ translit.svg \
|
|
+ translit-ua.svg \
|
|
rustrad.png \
|
|
yawerty.png \
|
|
thai.png \
|
|
diff --git a/icons/translit-ua.png b/icons/translit-ua.png
|
|
deleted file mode 100644
|
|
index aeb56285fa68535606788d3ce40010901089b085..0000000000000000000000000000000000000000
|
|
GIT binary patch
|
|
literal 0
|
|
HcmV?d00001
|
|
|
|
literal 2658
|
|
zcmV-o3Z3<dP)<h;3K|Lk000e1NJLTq001xm001xu1^@s6R|5Hm00006VoOIv0RI60
|
|
z0RN!9r;`8x010qNS#tmY3ljhU3ljkVnw%H_000McNliru)(Z##1v_@DQ4Ih93GYcn
|
|
zK~!ko?U`L{TxVLxfA5)@W6#(g$CHi6$#(0g>1LtnQlM=}N_H!8u@$QYRcNJNExkhm
|
|
zRYHObF3=*7QqV5qq8D5&S2TM8H<h*}?Un>6EG?vQ6VasG#!ktHJ@$CU^Zj+socH75
|
|
zV$K-Hial<NkU@Q<qp|1AIp_Jm&-4F3&-)zs+&;I@?f<XI4))PUH{_L9UU_)m1Gsqc
|
|
zqO@8qsnu(;va%xAuU(fHUwl!fr>7;K&+iKW-fkzI6GQ~(1m_%99L~9YwaB{z5R0=8
|
|
zaSm%O)|&rg0Ib7UgS7)7*4Rw|BC;<4BzGtAaOLeiKtzOkz5W7F2Ly<K0&oE+@0$n=
|
|
zowvqfObkHmzDl9ws1&kRqfHzIW3YC24n*-Seau!lo&dfKJOCUKk;z`KmyV)H1^u8G
|
|
zhS5gQ?cNfR_rLPhU+8SV{!;_6&SCVxaXpN{9!Q)Loe=n4;56_AFb}A$zfmeN0A~dq
|
|
z_35^|^mX68^VWq+^;+YvU+%PDe*XFAqtBi~Lj}?XW6UN8cC%t}Eq&|Ot-k=i4ICXh
|
|
z-|O|LR4S~juCTgRpj0Z+Y_^DWL~7i}_kAx2qNi&0+Fw;`)$3=^o_*}IMPM^+4A$A0
|
|
z1EV8w`_>)mjXKF>lC`xpKK$@QmY0{QR5s}KdKhC#cpjOF31$w=Fq4}hH#5V;!~}^{
|
|
zlF7+Qs@3Z8VsZVSfAc%vIeqSjKfLj&0cfMqk;NFjN$OFyu~Fvc#~*Y4{CWQM?YCLJ
|
|
zdlzHO_BI88nVA`m9XrPH<HtEVf0XG1)1*?VIK||^`g-YQ;Fmrf0An!5Vyqr~8naoQ
|
|
zcT1y2v%#fHmw4liH;AS7DsU^7+Aa_P<0A4vtyVi;tJO{y3WeM=&pd;d@JRV7tTy;5
|
|
zpRw_=lTSYR<gY9&Ed0}_BC$0l2BOi%;N0j4EG{kS%a<>IS1I));HQmVBtAv~k1M5S
|
|
zMI-|xlu~68xd!~5QtJ6?wR-xYhaSSls+aOp<nwv1UcLJJKnwT}xL2M=r;r{vZek#N
|
|
zNufXa(?9S38RqP^$N0b@;ETY7QYs}P9-x#`Dxc3^e)idCPxrb#s<j%{Ig+U)x!gh8
|
|
z?e?QesS_gdMc_SPb&nCSm|-!q4(IGAZXrbEh=}}JrBXRlER{|<=Vp~sX&`B>Rwi;J
|
|
z{3PRJV{|$le)_=&gATws6pHcjF@hlYf{5gSOw5OW1J*|Z7_Pd}8e<Jw4<fJ^5F&C^
|
|
zM84PW_rI-_^3oF%9L^u68?*_6K9PxV8bk?U5KygbP%dxKXtmH<<Kmi=NF)Hp;=_wu
|
|
zmy^J2qbsp-XstJaxIGp!!roIs5WJp9Bn~*^s5hGwi>oXxEpqMJb#C6gNu^RD3<6M!
|
|
zY&Og6>@2ghvt%-vxRoE&8)FP=AW0sOQc6t$(<1USz>Sd+7#=!4Mggd;7jpel@kiNg
|
|
z_COeh6bc0v7Z>^WOP9EC;qO^lUfHpmee|o3^7XGh&DfZ~WlwU?^OT6BfN7=F&x**6
|
|
z(Hs~OIBqH22of(XF1?VS%OC3Z`xMvKxP9ji*REgZ_4DUhUtbsCFM)GPsgJ@i><q6v
|
|
zcI?>0bNRWOekzGlYNy+)SiRCpsl14cQlU5k+F;yZ^{v~zmALuw(yu3y35+%rR#&Oj
|
|
zYLwR3SzliVINJ)%ANiOAz#~8oNCU}3hYlS(b?Ov}M1n93(OT~aB96k;XcAkuB?5a(
|
|
zp=!1Em2$a^F_uoJjn*2aRJ=8H|KMYOHGcSHOiUk0%+JrCnwy&=3`3$Q+HKRMfP{#s
|
|
z(aoGOXdPj!8Ej~_)PbF%&<lc0qh6=kY|!ubQ7Ce`94AknWMX3Cmw_+E$1E@dOk}g!
|
|
zsi(jG^w%aPChj5dh$b|#r*71kK|eHTtM$kTgh5a*S1PpIZK8gJ@&*7-JbHpNXU;t5
|
|
zdEUWT&wap~ot;g5|NGy2Ztn10E{Y<0z22UR<*>uuT}GW7@IY%K9ig=ySqEyh+LcPB
|
|
z@{PH}bEL=9c%DZ(ljchgJjlUZ?y)DHcrxE=H9yo^hlh_G$)0%Rk)KPYQrTj$NV#05
|
|
z)9LIL!01YhfC&HH$k|~-w{sNM*VoV0>-BF~YnjeYGnJjh_s2;2KKc9{nM`Iblm7DD
|
|
z<m4oYWP(bi!nt$j2*a>EH8nMR{P=Ok#>O^zbFVk3Jp*{@rI#|zRukeVIOi}{qa!_x
|
|
zj=evLtAEpIG=AsOyO*Ate{h~$E=M+-C7n()K0Z!5ohFq^(d+eCT3X_@*IvU~+Xa66
|
|
z#EBEH<Z?ND-`_E1_6)%Hlk<nZa0oA%L~BD7MFc@ex7Qt#IJn<+Z@u%bd-%a4zfmfc
|
|
z-dw)B{PQz2IVLA3NT<^z5(%uev|25y)hfMS4-x4qrJkLdn!1z8WLQ{Opxf>4xn<cA
|
|
zfafK?H9dWRFzm-_q-nR?^twGn#KfZ%wI#fpw!FMtnx39M9R$I5%jMDw<uchFMz0@O
|
|
zYk%OJ`$ymRk1Z@L{Lf4!-gxuP`A)0#2MN!k88!&QkZyOdpDk~c0oF!MCj4eI1pd(X
|
|
z{j=8E-vb_tWz&gB-8pv`sC%C0fai+EVi`CS*N7RVR2G;Lk+E1ZcTb^<7cV9}&pTqR
|
|
z{ifFXk29If!Fs(;quC?~0^02+tE;P&N+q0gx9?B+`+$j}0C-&~wG7OO$aw6G0#eSo
|
|
zX<$6A$}V;`8AnLRQt#~w;MG@OeXrZ?KJNQI$z+m5B0;@grxNRVr_*6=t;p)?>R=LL
|
|
z?Ufw>>@>`IUql{IN{z=+@V7XXiv36{rH1ziM5GNY0lyfZS38bXu3Wi7GMU5}L!;4P
|
|
zb#;}Ml@&HNHa7piapMN%av2f1Dk2;Aao)xI-FpUH@!tacL_|u!2G9ZeN+}&XYym4G
|
|
z5zvZ%cNw_jd0rFfDWw7++;$9}QmfUtbLS4jO4#jo>2|v`n@tLZ0!vFvlu9K;q-2cw
|
|
z+js@H64=I$^zS!Oi@$3DKUPXTB_aovQkgivJ*CtzU3wzYjkk?u;E;1}HI7Jf$2u@v
|
|
z`A(-pqtO_2kfjnUD=QQVg`s5pr?vJ6A~MX=&DB>*=~$UYnHG_M0a7AzG|qcpM66P(
|
|
zB_el$_SOjv@YYBba?TM&QJm{*EG{l``}Xaj<89z|t@VX1UF7!F4}j(;P(Kaayx*MY
|
|
zlbQm^X0z{wVfc8Qn+;&yIad{to6fmwfEN#F$F~v60lj$M^An)>zdfB+yPW&2c(XAU
|
|
zJH1uTWcXe{DOD4Z0`TK~HC~VBHe*{PZ@c2?IBzS!+xzbQK)mBo+w$GTIp2@vt_r-n
|
|
zjd=U#1;-Yrol?q(NEqjQ3#bC`#9;R48=6?3ZLAvISk?-_`@=%=xqU|aF9Afs2OGhh
|
|
QasU7T07*qoM6N<$f^3f=WB>pF
|
|
|
|
diff --git a/icons/translit-ua.svg b/icons/translit-ua.svg
|
|
new file mode 100644
|
|
index 0000000..78edf16
|
|
--- /dev/null
|
|
+++ b/icons/translit-ua.svg
|
|
@@ -0,0 +1,90 @@
|
|
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
|
|
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
|
|
+
|
|
+<svg
|
|
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
|
|
+ xmlns:cc="http://creativecommons.org/ns#"
|
|
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
|
|
+ xmlns:svg="http://www.w3.org/2000/svg"
|
|
+ xmlns="http://www.w3.org/2000/svg"
|
|
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
|
|
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
|
|
+ width="48"
|
|
+ height="48"
|
|
+ id="svg2"
|
|
+ version="1.1"
|
|
+ inkscape:version="0.48.2 r9819"
|
|
+ sodipodi:docname="ua.svg">
|
|
+ <defs
|
|
+ id="defs4" />
|
|
+ <sodipodi:namedview
|
|
+ id="base"
|
|
+ pagecolor="#ffffff"
|
|
+ bordercolor="#666666"
|
|
+ borderopacity="1.0"
|
|
+ inkscape:pageopacity="0"
|
|
+ inkscape:pageshadow="2"
|
|
+ inkscape:zoom="2.49"
|
|
+ inkscape:cx="-55.012279"
|
|
+ inkscape:cy="38.199551"
|
|
+ inkscape:document-units="px"
|
|
+ inkscape:current-layer="layer1"
|
|
+ showgrid="false"
|
|
+ inkscape:window-width="1366"
|
|
+ inkscape:window-height="719"
|
|
+ inkscape:window-x="0"
|
|
+ inkscape:window-y="0"
|
|
+ inkscape:window-maximized="1" />
|
|
+ <metadata
|
|
+ id="metadata7">
|
|
+ <rdf:RDF>
|
|
+ <cc:Work
|
|
+ rdf:about="">
|
|
+ <dc:format>image/svg+xml</dc:format>
|
|
+ <dc:type
|
|
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
|
|
+ <dc:title />
|
|
+ </cc:Work>
|
|
+ </rdf:RDF>
|
|
+ </metadata>
|
|
+ <g
|
|
+ inkscape:label="Layer 1"
|
|
+ inkscape:groupmode="layer"
|
|
+ id="layer1"
|
|
+ transform="translate(0,-1004.3622)">
|
|
+ <g
|
|
+ id="g3809"
|
|
+ transform="matrix(0.1425,0,0,0.1425,-5.6400002,905.76059)">
|
|
+ <g
|
|
+ transform="matrix(2.3098684,0,0,2.3098684,-152.54903,259.82192)"
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T"
|
|
+ id="g3803">
|
|
+ <path
|
|
+ d="m 164.08,217.58835 -17.28,32.688 -19.584,-32.688 -32.976,0 35.424,58.896 0,37.152 29.808,0 0,-38.448 34.992,-57.6 -30.384,0"
|
|
+ id="path3805"
|
|
+ inkscape:connector-curvature="0"
|
|
+ style="fill:#000000;fill-opacity:1" />
|
|
+ <path
|
|
+ d="m 224.14825,246.38835 -27.792,0 0,67.248 27.792,0 0,-67.248 m -14.256,-33.12 c -8.63999,0 -14.832,5.90401 -14.832,14.256 0,8.35199 6.19201,14.256 14.832,14.256 8.78399,0 14.976,-5.90401 14.976,-14.256 0,-8.35199 -6.19201,-14.256 -14.976,-14.256"
|
|
+ id="path3807"
|
|
+ inkscape:connector-curvature="0"
|
|
+ style="fill:#000000;fill-opacity:1" />
|
|
+ </g>
|
|
+ <g
|
|
+ id="text3026"
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#005aff;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T"
|
|
+ transform="matrix(2.3098684,0,0,2.3098684,-168.54903,243.82192)">
|
|
+ <path
|
|
+ style="fill:#005aff;fill-opacity:1"
|
|
+ inkscape:connector-curvature="0"
|
|
+ id="path3031"
|
|
+ d="m 164.08,217.58835 -17.28,32.688 -19.584,-32.688 -32.976,0 35.424,58.896 0,37.152 29.808,0 0,-38.448 34.992,-57.6 -30.384,0" />
|
|
+ <path
|
|
+ style="fill:#005aff;fill-opacity:1"
|
|
+ inkscape:connector-curvature="0"
|
|
+ id="path3033"
|
|
+ d="m 224.14825,246.38835 -27.792,0 0,67.248 27.792,0 0,-67.248 m -14.256,-33.12 c -8.63999,0 -14.832,5.90401 -14.832,14.256 0,8.35199 6.19201,14.256 14.832,14.256 8.78399,0 14.976,-5.90401 14.976,-14.256 0,-8.35199 -6.19201,-14.256 -14.976,-14.256" />
|
|
+ </g>
|
|
+ </g>
|
|
+ </g>
|
|
+</svg>
|
|
diff --git a/icons/translit.png b/icons/translit.png
|
|
deleted file mode 100644
|
|
index aeb56285fa68535606788d3ce40010901089b085..0000000000000000000000000000000000000000
|
|
GIT binary patch
|
|
literal 0
|
|
HcmV?d00001
|
|
|
|
literal 2658
|
|
zcmV-o3Z3<dP)<h;3K|Lk000e1NJLTq001xm001xu1^@s6R|5Hm00006VoOIv0RI60
|
|
z0RN!9r;`8x010qNS#tmY3ljhU3ljkVnw%H_000McNliru)(Z##1v_@DQ4Ih93GYcn
|
|
zK~!ko?U`L{TxVLxfA5)@W6#(g$CHi6$#(0g>1LtnQlM=}N_H!8u@$QYRcNJNExkhm
|
|
zRYHObF3=*7QqV5qq8D5&S2TM8H<h*}?Un>6EG?vQ6VasG#!ktHJ@$CU^Zj+socH75
|
|
zV$K-Hial<NkU@Q<qp|1AIp_Jm&-4F3&-)zs+&;I@?f<XI4))PUH{_L9UU_)m1Gsqc
|
|
zqO@8qsnu(;va%xAuU(fHUwl!fr>7;K&+iKW-fkzI6GQ~(1m_%99L~9YwaB{z5R0=8
|
|
zaSm%O)|&rg0Ib7UgS7)7*4Rw|BC;<4BzGtAaOLeiKtzOkz5W7F2Ly<K0&oE+@0$n=
|
|
zowvqfObkHmzDl9ws1&kRqfHzIW3YC24n*-Seau!lo&dfKJOCUKk;z`KmyV)H1^u8G
|
|
zhS5gQ?cNfR_rLPhU+8SV{!;_6&SCVxaXpN{9!Q)Loe=n4;56_AFb}A$zfmeN0A~dq
|
|
z_35^|^mX68^VWq+^;+YvU+%PDe*XFAqtBi~Lj}?XW6UN8cC%t}Eq&|Ot-k=i4ICXh
|
|
z-|O|LR4S~juCTgRpj0Z+Y_^DWL~7i}_kAx2qNi&0+Fw;`)$3=^o_*}IMPM^+4A$A0
|
|
z1EV8w`_>)mjXKF>lC`xpKK$@QmY0{QR5s}KdKhC#cpjOF31$w=Fq4}hH#5V;!~}^{
|
|
zlF7+Qs@3Z8VsZVSfAc%vIeqSjKfLj&0cfMqk;NFjN$OFyu~Fvc#~*Y4{CWQM?YCLJ
|
|
zdlzHO_BI88nVA`m9XrPH<HtEVf0XG1)1*?VIK||^`g-YQ;Fmrf0An!5Vyqr~8naoQ
|
|
zcT1y2v%#fHmw4liH;AS7DsU^7+Aa_P<0A4vtyVi;tJO{y3WeM=&pd;d@JRV7tTy;5
|
|
zpRw_=lTSYR<gY9&Ed0}_BC$0l2BOi%;N0j4EG{kS%a<>IS1I));HQmVBtAv~k1M5S
|
|
zMI-|xlu~68xd!~5QtJ6?wR-xYhaSSls+aOp<nwv1UcLJJKnwT}xL2M=r;r{vZek#N
|
|
zNufXa(?9S38RqP^$N0b@;ETY7QYs}P9-x#`Dxc3^e)idCPxrb#s<j%{Ig+U)x!gh8
|
|
z?e?QesS_gdMc_SPb&nCSm|-!q4(IGAZXrbEh=}}JrBXRlER{|<=Vp~sX&`B>Rwi;J
|
|
z{3PRJV{|$le)_=&gATws6pHcjF@hlYf{5gSOw5OW1J*|Z7_Pd}8e<Jw4<fJ^5F&C^
|
|
zM84PW_rI-_^3oF%9L^u68?*_6K9PxV8bk?U5KygbP%dxKXtmH<<Kmi=NF)Hp;=_wu
|
|
zmy^J2qbsp-XstJaxIGp!!roIs5WJp9Bn~*^s5hGwi>oXxEpqMJb#C6gNu^RD3<6M!
|
|
zY&Og6>@2ghvt%-vxRoE&8)FP=AW0sOQc6t$(<1USz>Sd+7#=!4Mggd;7jpel@kiNg
|
|
z_COeh6bc0v7Z>^WOP9EC;qO^lUfHpmee|o3^7XGh&DfZ~WlwU?^OT6BfN7=F&x**6
|
|
z(Hs~OIBqH22of(XF1?VS%OC3Z`xMvKxP9ji*REgZ_4DUhUtbsCFM)GPsgJ@i><q6v
|
|
zcI?>0bNRWOekzGlYNy+)SiRCpsl14cQlU5k+F;yZ^{v~zmALuw(yu3y35+%rR#&Oj
|
|
zYLwR3SzliVINJ)%ANiOAz#~8oNCU}3hYlS(b?Ov}M1n93(OT~aB96k;XcAkuB?5a(
|
|
zp=!1Em2$a^F_uoJjn*2aRJ=8H|KMYOHGcSHOiUk0%+JrCnwy&=3`3$Q+HKRMfP{#s
|
|
z(aoGOXdPj!8Ej~_)PbF%&<lc0qh6=kY|!ubQ7Ce`94AknWMX3Cmw_+E$1E@dOk}g!
|
|
zsi(jG^w%aPChj5dh$b|#r*71kK|eHTtM$kTgh5a*S1PpIZK8gJ@&*7-JbHpNXU;t5
|
|
zdEUWT&wap~ot;g5|NGy2Ztn10E{Y<0z22UR<*>uuT}GW7@IY%K9ig=ySqEyh+LcPB
|
|
z@{PH}bEL=9c%DZ(ljchgJjlUZ?y)DHcrxE=H9yo^hlh_G$)0%Rk)KPYQrTj$NV#05
|
|
z)9LIL!01YhfC&HH$k|~-w{sNM*VoV0>-BF~YnjeYGnJjh_s2;2KKc9{nM`Iblm7DD
|
|
z<m4oYWP(bi!nt$j2*a>EH8nMR{P=Ok#>O^zbFVk3Jp*{@rI#|zRukeVIOi}{qa!_x
|
|
zj=evLtAEpIG=AsOyO*Ate{h~$E=M+-C7n()K0Z!5ohFq^(d+eCT3X_@*IvU~+Xa66
|
|
z#EBEH<Z?ND-`_E1_6)%Hlk<nZa0oA%L~BD7MFc@ex7Qt#IJn<+Z@u%bd-%a4zfmfc
|
|
z-dw)B{PQz2IVLA3NT<^z5(%uev|25y)hfMS4-x4qrJkLdn!1z8WLQ{Opxf>4xn<cA
|
|
zfafK?H9dWRFzm-_q-nR?^twGn#KfZ%wI#fpw!FMtnx39M9R$I5%jMDw<uchFMz0@O
|
|
zYk%OJ`$ymRk1Z@L{Lf4!-gxuP`A)0#2MN!k88!&QkZyOdpDk~c0oF!MCj4eI1pd(X
|
|
z{j=8E-vb_tWz&gB-8pv`sC%C0fai+EVi`CS*N7RVR2G;Lk+E1ZcTb^<7cV9}&pTqR
|
|
z{ifFXk29If!Fs(;quC?~0^02+tE;P&N+q0gx9?B+`+$j}0C-&~wG7OO$aw6G0#eSo
|
|
zX<$6A$}V;`8AnLRQt#~w;MG@OeXrZ?KJNQI$z+m5B0;@grxNRVr_*6=t;p)?>R=LL
|
|
z?Ufw>>@>`IUql{IN{z=+@V7XXiv36{rH1ziM5GNY0lyfZS38bXu3Wi7GMU5}L!;4P
|
|
zb#;}Ml@&HNHa7piapMN%av2f1Dk2;Aao)xI-FpUH@!tacL_|u!2G9ZeN+}&XYym4G
|
|
z5zvZ%cNw_jd0rFfDWw7++;$9}QmfUtbLS4jO4#jo>2|v`n@tLZ0!vFvlu9K;q-2cw
|
|
z+js@H64=I$^zS!Oi@$3DKUPXTB_aovQkgivJ*CtzU3wzYjkk?u;E;1}HI7Jf$2u@v
|
|
z`A(-pqtO_2kfjnUD=QQVg`s5pr?vJ6A~MX=&DB>*=~$UYnHG_M0a7AzG|qcpM66P(
|
|
zB_el$_SOjv@YYBba?TM&QJm{*EG{l``}Xaj<89z|t@VX1UF7!F4}j(;P(Kaayx*MY
|
|
zlbQm^X0z{wVfc8Qn+;&yIad{to6fmwfEN#F$F~v60lj$M^An)>zdfB+yPW&2c(XAU
|
|
zJH1uTWcXe{DOD4Z0`TK~HC~VBHe*{PZ@c2?IBzS!+xzbQK)mBo+w$GTIp2@vt_r-n
|
|
zjd=U#1;-Yrol?q(NEqjQ3#bC`#9;R48=6?3ZLAvISk?-_`@=%=xqU|aF9Afs2OGhh
|
|
QasU7T07*qoM6N<$f^3f=WB>pF
|
|
|
|
diff --git a/icons/translit.svg b/icons/translit.svg
|
|
new file mode 100644
|
|
index 0000000..c034b87
|
|
--- /dev/null
|
|
+++ b/icons/translit.svg
|
|
@@ -0,0 +1,89 @@
|
|
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
|
|
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
|
|
+
|
|
+<svg
|
|
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
|
|
+ xmlns:cc="http://creativecommons.org/ns#"
|
|
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
|
|
+ xmlns:svg="http://www.w3.org/2000/svg"
|
|
+ xmlns="http://www.w3.org/2000/svg"
|
|
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
|
|
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
|
|
+ width="48"
|
|
+ height="48"
|
|
+ id="svg2"
|
|
+ version="1.1"
|
|
+ inkscape:version="0.48.2 r9819"
|
|
+ sodipodi:docname="ru.svg">
|
|
+ <defs
|
|
+ id="defs4" />
|
|
+ <sodipodi:namedview
|
|
+ id="base"
|
|
+ pagecolor="#ffffff"
|
|
+ bordercolor="#666666"
|
|
+ borderopacity="1.0"
|
|
+ inkscape:pageopacity="0"
|
|
+ inkscape:pageshadow="2"
|
|
+ inkscape:zoom="4.3299648"
|
|
+ inkscape:cx="35.026079"
|
|
+ inkscape:cy="38.546185"
|
|
+ inkscape:document-units="px"
|
|
+ inkscape:current-layer="layer1"
|
|
+ showgrid="false"
|
|
+ inkscape:window-width="1366"
|
|
+ inkscape:window-height="719"
|
|
+ inkscape:window-x="0"
|
|
+ inkscape:window-y="0"
|
|
+ inkscape:window-maximized="1" />
|
|
+ <metadata
|
|
+ id="metadata7">
|
|
+ <rdf:RDF>
|
|
+ <cc:Work
|
|
+ rdf:about="">
|
|
+ <dc:format>image/svg+xml</dc:format>
|
|
+ <dc:type
|
|
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
|
|
+ <dc:title></dc:title>
|
|
+ </cc:Work>
|
|
+ </rdf:RDF>
|
|
+ </metadata>
|
|
+ <g
|
|
+ inkscape:label="Layer 1"
|
|
+ inkscape:groupmode="layer"
|
|
+ id="layer1"
|
|
+ transform="translate(0,-1004.3622)">
|
|
+ <g
|
|
+ id="g3884"
|
|
+ transform="matrix(0.12,0,0,0.12,-0.67771668,923.49618)">
|
|
+ <g
|
|
+ transform="translate(16,16)"
|
|
+ id="g3870"
|
|
+ style="fill:#000000;fill-opacity:1">
|
|
+ <path
|
|
+ d="m 181.05217,754.04143 -39.47366,74.67101 -44.736818,-74.67101 -75.328904,0 80.921002,134.53939 0,84.86838 68.09207,0 0,-87.8289 79.93416,-131.57887 -69.40785,0"
|
|
+ id="path3872"
|
|
+ inkscape:connector-curvature="0"
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T" />
|
|
+ <path
|
|
+ d="m 373.78249,819.83086 -63.4868,0 0,17.76315 c -10.19736,-16.77628 -20.39475,-22.03946 -42.76313,-22.03946 -48.02625,0 -74.34207,28.9474 -74.34207,82.56574 0,50.32887 25.00003,79.60522 68.09207,79.60522 23.35523,0 35.85524,-4.93423 49.01313,-19.40788 l 0,15.13157 63.4868,0 0,-153.61834 m -87.82889,40.78945 c 15.13154,0 24.34209,13.15791 24.34209,35.5263 0,24.99996 -8.2237,36.84208 -25.65788,36.84208 -15.46052,0 -24.01315,-12.82896 -24.01315,-36.18419 0,-23.68417 8.88158,-36.18419 25.32894,-36.18419"
|
|
+ id="path3874"
|
|
+ inkscape:connector-curvature="0"
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T" />
|
|
+ </g>
|
|
+ <g
|
|
+ style="fill:#1b17ca;fill-opacity:1"
|
|
+ id="g3866">
|
|
+ <path
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#1b17ca;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T"
|
|
+ inkscape:connector-curvature="0"
|
|
+ id="path3841"
|
|
+ d="m 181.05217,754.04143 -39.47366,74.67101 -44.736818,-74.67101 -75.328904,0 80.921002,134.53939 0,84.86838 68.09207,0 0,-87.8289 79.93416,-131.57887 -69.40785,0" />
|
|
+ <path
|
|
+ style="font-size:144px;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#1b17ca;fill-opacity:1;stroke:none;font-family:URW Grotesk T;-inkscape-font-specification:URW Grotesk T"
|
|
+ inkscape:connector-curvature="0"
|
|
+ id="path3843"
|
|
+ d="m 373.78249,819.83086 -63.4868,0 0,17.76315 c -10.19736,-16.77628 -20.39475,-22.03946 -42.76313,-22.03946 -48.02625,0 -74.34207,28.9474 -74.34207,82.56574 0,50.32887 25.00003,79.60522 68.09207,79.60522 23.35523,0 35.85524,-4.93423 49.01313,-19.40788 l 0,15.13157 63.4868,0 0,-153.61834 m -87.82889,40.78945 c 15.13154,0 24.34209,13.15791 24.34209,35.5263 0,24.99996 -8.2237,36.84208 -25.65788,36.84208 -15.46052,0 -24.01315,-12.82896 -24.01315,-36.18419 0,-23.68417 8.88158,-36.18419 25.32894,-36.18419" />
|
|
+ </g>
|
|
+ </g>
|
|
+ </g>
|
|
+</svg>
|
|
diff --git a/tables/translit-ua.txt b/tables/translit-ua.txt
|
|
index 5af3917..e533dd4 100644
|
|
--- a/tables/translit-ua.txt
|
|
+++ b/tables/translit-ua.txt
|
|
@@ -23,7 +23,7 @@ UUID = 9068f86e-02b5-400b-9732-4f9433ac9968
|
|
### This number must be less than 2^32.
|
|
SERIAL_NUMBER = 20120906
|
|
|
|
-ICON = translit-ua.png
|
|
+ICON = translit-ua.svg
|
|
|
|
### The default name of this table
|
|
NAME = Ua-Translit
|
|
diff --git a/tables/translit.txt b/tables/translit.txt
|
|
index 11d6425..da3ec62 100644
|
|
--- a/tables/translit.txt
|
|
+++ b/tables/translit.txt
|
|
@@ -21,7 +21,7 @@ UUID = e39c975a-262b-4ad3-b9b8-15c5ff211e4e
|
|
### This number must be less than 2^32.
|
|
SERIAL_NUMBER = 20120906
|
|
|
|
-ICON = translit.png
|
|
+ICON = translit.svg
|
|
|
|
### The default name of this table
|
|
NAME = Translit
|
|
--
|
|
1.7.11.4
|
|
|