Remove BuildRequirement of cmake-fedora
This commit is contained in:
parent
077814afc8
commit
2a46aea612
@ -4,16 +4,16 @@
|
|||||||
%global createdb ibus-table-createdb
|
%global createdb ibus-table-createdb
|
||||||
Name: ibus-table-chinese
|
Name: ibus-table-chinese
|
||||||
Version: 1.8.3
|
Version: 1.8.3
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Chinese input tables for IBus
|
Summary: Chinese input tables for IBus
|
||||||
Summary(zh_CN): 中文码表输入法
|
Summary(zh_CN): 中文码表输入法
|
||||||
Summary(zh_TW): 中文碼表輸入法
|
Summary(zh_TW): 中文碼表輸入法
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: https://github.com/definite/ibus-table-chinese
|
URL: https://github.com/definite/ibus-table-chinese
|
||||||
Source0: https://github.com/definite/ibus-table-chinese/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/definite/ibus-table-chinese/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: no-cmake-fedora.patch
|
||||||
|
|
||||||
BuildRequires: cmake >= 2.6.2
|
BuildRequires: cmake >= 2.6.2
|
||||||
BuildRequires: cmake-fedora
|
|
||||||
BuildRequires: ibus-table-devel >= 1.10.0
|
BuildRequires: ibus-table-devel >= 1.10.0
|
||||||
Requires: ibus-table >= 1.10.0
|
Requires: ibus-table >= 1.10.0
|
||||||
Obsoletes: ibus-table-yinma < 1.3
|
Obsoletes: ibus-table-yinma < 1.3
|
||||||
@ -305,11 +305,12 @@ Cantonese input method based on yale romanization
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p1 -b .no-cmake-fedora
|
||||||
%{__sed} -i 's/\r//' tables/wubi-haifeng/COPYING
|
%{__sed} -i 's/\r//' tables/wubi-haifeng/COPYING
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# $RPM_OPT_FLAGS should be loaded from cmake macro.
|
# $RPM_OPT_FLAGS should be loaded from cmake macro.
|
||||||
%cmake -B . -DMANAGE_MESSAGE_LEVEL=%{message_level} -DCMAKE_FEDORA_ENABLE_FEDORA_BUILD=1 .
|
%cmake -B .
|
||||||
%__make VERBOSE=1 %{?_smp_mflags}
|
%__make VERBOSE=1 %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -496,7 +497,7 @@ rm -fr %{buildroot}%{_docdir}/*
|
|||||||
%{createdb} -i -n %{ibus_tables_dir}/cantonyale.db
|
%{createdb} -i -n %{ibus_tables_dir}/cantonyale.db
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc
|
%doc AUTHORS README ChangeLog COPYING
|
||||||
|
|
||||||
%files array
|
%files array
|
||||||
%{ibus_icons_dir}/array30.*
|
%{ibus_icons_dir}/array30.*
|
||||||
@ -572,6 +573,9 @@ rm -fr %{buildroot}%{_docdir}/*
|
|||||||
%verify(not size md5 mtime) %{ibus_tables_dir}/cantonyale.db
|
%verify(not size md5 mtime) %{ibus_tables_dir}/cantonyale.db
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 03 2020 Mike FABIAN <mfabian@redhat.com> - 1.8.3-6
|
||||||
|
- Remove BuildRequirement of cmake-fedora
|
||||||
|
|
||||||
* Thu Jul 30 2020 Mike FABIAN <mfabian@redhat.com> - 1.8.3-5
|
* Thu Jul 30 2020 Mike FABIAN <mfabian@redhat.com> - 1.8.3-5
|
||||||
- Fix build on rawhide
|
- Fix build on rawhide
|
||||||
|
|
||||||
|
199
no-cmake-fedora.patch
Normal file
199
no-cmake-fedora.patch
Normal file
@ -0,0 +1,199 @@
|
|||||||
|
From 11f6bb926b5039c99869c3056449560524029e8d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mike FABIAN <mfabian@redhat.com>
|
||||||
|
Date: Mon, 2 Nov 2020 19:50:01 +0100
|
||||||
|
Subject: [PATCH] Simplify CMakeLists.txt to avoid requiring cmake-fedora
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 143 +++---------------------------------------
|
||||||
|
tables/CMakeLists.txt | 2 +-
|
||||||
|
2 files changed, 9 insertions(+), 136 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index bc10507..9113fba 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -1,104 +1,26 @@
|
||||||
|
cmake_minimum_required(VERSION 2.6.2)
|
||||||
|
|
||||||
|
-# Included scripts do automatic cmake_policy PUSH and POP.
|
||||||
|
-# OLD: CMake policy in included script will affect the invoker.
|
||||||
|
-CMAKE_POLICY(SET CMP0011 OLD)
|
||||||
|
-
|
||||||
|
# Default CMAKE_INSTALL_PREFIX should be set before PROJECT()
|
||||||
|
SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "Install dir prefix")
|
||||||
|
|
||||||
|
-# Whether to build on fedora
|
||||||
|
-SET(CMAKE_FEDORA_ENABLE_FEDORA_BUILD "1" CACHE STRING "Enable fedora build")
|
||||||
|
-
|
||||||
|
-# Message level INFO1 (5)
|
||||||
|
-SET(MANAGE_MESSAGE_LEVEL 5 CACHE STRING "Message (Verbose) Level")
|
||||||
|
-
|
||||||
|
####################################################################
|
||||||
|
# Project specific information
|
||||||
|
#
|
||||||
|
PROJECT(ibus-table-chinese NONE)
|
||||||
|
SET(PRJ_SUMMARY "Chinese input tables for IBus")
|
||||||
|
|
||||||
|
-SET(SUMMARY_TRANSLATIONS
|
||||||
|
- "zh_CN" "中文码表输入法"
|
||||||
|
- "zh_TW" "中文碼表輸入法"
|
||||||
|
- )
|
||||||
|
-
|
||||||
|
SET(PRJ_DESCRIPTION
|
||||||
|
"ibus-table-chinese is provides the infrastructure for Chinese input methods.
|
||||||
|
Input tables themselves are in subpackages."
|
||||||
|
)
|
||||||
|
|
||||||
|
-SET(DESCRIPTION_TRANSLATIONS
|
||||||
|
- "zh_TW" "ibus-table-chinese 提供了中文碼表輸入法的基礎架構。
|
||||||
|
- 輸入法本身則在子套件裡。"
|
||||||
|
- )
|
||||||
|
-
|
||||||
|
-SET(AUTHORS "Yuwei Yu, Caius 'kaio' Chance, Ding-Yi Chen")
|
||||||
|
-SET(MAINTAINER "Ding-Yi Chen <dchen@redhat.com>")
|
||||||
|
-SET(VENDOR "Red Hat, Inc")
|
||||||
|
-SET(LICENSE "GPLv3+")
|
||||||
|
-SET(PRJ_GROUP "System Environment/Libraries")
|
||||||
|
-SET(BUILD_ARCH "noarch")
|
||||||
|
-SET(RPM_SPEC_URL "http://code.google.com/p/ibus/")
|
||||||
|
-SET(RPM_SPEC_SOURCES "https://fedorahosted.org/releases/c/m/%{name}/%{name}-%{version}-Source.tar.gz")
|
||||||
|
-
|
||||||
|
-####################################################################
|
||||||
|
-# Includes
|
||||||
|
-#
|
||||||
|
-LIST(INSERT CMAKE_MODULE_PATH 0 ${CMAKE_SOURCE_DIR}/Modules)
|
||||||
|
-
|
||||||
|
-# Create a link if Modules/ does not exists
|
||||||
|
-IF(EXISTS ${CMAKE_SOURCE_DIR}/cmake-fedora/Modules)
|
||||||
|
- IF(NOT EXISTS ${CMAKE_SOURCE_DIR}/Modules)
|
||||||
|
- EXECUTE_PROCESS(COMMAND ln -s ${CMAKE_SOURCE_DIR}/cmake-fedora/Modules .)
|
||||||
|
- ENDIF(NOT EXISTS ${CMAKE_SOURCE_DIR}/Modules)
|
||||||
|
-ENDIF(EXISTS ${CMAKE_SOURCE_DIR}/cmake-fedora/Modules)
|
||||||
|
-
|
||||||
|
-# Use standard FHS if Fedora build is not enabled
|
||||||
|
-IF(NOT CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
- IF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
- SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib64" CACHE PATH "Library dir")
|
||||||
|
- ELSE(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
- SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib" CACHE PATH "Library dir")
|
||||||
|
- ENDIF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
- SET(LIBEXEC_DIR "${LIB_DIR}" CACHE PATH "LIBEXEC dir")
|
||||||
|
-ENDIF(NOT CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
-
|
||||||
|
-INCLUDE(ManageEnvironmentCommon RESULT_VARIABLE MANAGE_ENVIRONMENT_PATH)
|
||||||
|
-IF(MANAGE_ENVIRONMENT_PATH STREQUAL "NOTFOUND")
|
||||||
|
-MESSAGE(FATAL_ERROR "ManageEnvironmentCommon is not found in CMAKE_MODULE_PATH,
|
||||||
|
- please do the either:
|
||||||
|
- 1) git submodule init; git submodule update
|
||||||
|
- 2) or install cmake-fedora
|
||||||
|
- 3) or wget -P SOURCES https://fedorahosted.org/releases/c/m/cmake-fedora/cmake-fedora-modules-only-latest.tar.gz
|
||||||
|
- tar zxvf SOURCES/cmake-fedora-modules-only-latest.tar.gz")
|
||||||
|
-ENDIF(MANAGE_ENVIRONMENT_PATH STREQUAL "NOTFOUND")
|
||||||
|
-
|
||||||
|
-INCLUDE(ManageEnvironment)
|
||||||
|
-INCLUDE(ManageVersion)
|
||||||
|
-RELEASE_NOTES_READ_FILE()
|
||||||
|
-INCLUDE(ManageArchive)
|
||||||
|
-INCLUDE(ManageFile)
|
||||||
|
-INCLUDE(ManageSourceVersionControl)
|
||||||
|
-INCLUDE(ManageTarget)
|
||||||
|
-INCLUDE(ManageTranslation)
|
||||||
|
-INCLUDE(ManageUninstall)
|
||||||
|
-ENABLE_TESTING()
|
||||||
|
-
|
||||||
|
-####################################################################
|
||||||
|
-# Dependencies
|
||||||
|
-#
|
||||||
|
-
|
||||||
|
-INCLUDE(ManageDependency)
|
||||||
|
-## Requires
|
||||||
|
-MANAGE_DEPENDENCY(REQUIRES IBUS-TABLE VER "1.2.0" REQUIRED)
|
||||||
|
-
|
||||||
|
-## Build Requires
|
||||||
|
-MANAGE_DEPENDENCY(BUILD_REQUIRES CMAKE VER "2.6.2" REQUIRED)
|
||||||
|
-MANAGE_DEPENDENCY(BUILD_REQUIRES IBUS-TABLE VER "1.5.0" REQUIRED)
|
||||||
|
-PRJ_INFO_CMAKE_APPEND(${PRJ_INFO_CMAKE} REQUIRES)
|
||||||
|
-PRJ_INFO_CMAKE_APPEND(${PRJ_INFO_CMAKE} BUILD_REQUIRES)
|
||||||
|
+IF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
+ SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib64" CACHE PATH "Library dir")
|
||||||
|
+ELSE(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
+ SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib" CACHE PATH "Library dir")
|
||||||
|
+ENDIF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||||
|
+SET(LIBEXEC_DIR "${LIB_DIR}" CACHE PATH "LIBEXEC dir")
|
||||||
|
+SET(DATA_DIR "/usr/share")
|
||||||
|
|
||||||
|
####################################################################
|
||||||
|
# Building
|
||||||
|
@@ -108,55 +30,6 @@ ADD_SUBDIRECTORY(tables)
|
||||||
|
####################################################################
|
||||||
|
# Installing
|
||||||
|
#
|
||||||
|
-
|
||||||
|
-MANAGE_SOURCE_VERSION_CONTROL_GIT()
|
||||||
|
-
|
||||||
|
+SET(PRJ_DOC_DIR "${DATA_DIR}/doc/ibus-table-chinese")
|
||||||
|
INSTALL(FILES AUTHORS README ChangeLog COPYING DESTINATION ${PRJ_DOC_DIR})
|
||||||
|
|
||||||
|
-####################################################################
|
||||||
|
-# Packing
|
||||||
|
-#
|
||||||
|
-
|
||||||
|
-## Pack Source
|
||||||
|
-SET(SOURCE_ARCHIVE_DIR ${CMAKE_BINARY_DIR}/SOURCES CACHE PATH "Source Archive Dir")
|
||||||
|
-PACK_SOURCE_ARCHIVE("${SOURCE_ARCHIVE_DIR}"
|
||||||
|
- GITIGNORE ${CMAKE_SOURCE_DIR}/.gitignore
|
||||||
|
- )
|
||||||
|
-
|
||||||
|
-## Pack RPM
|
||||||
|
-IF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
- SET(RPM_BUILD_SOURCES ${SOURCE_ARCHIVE_DIR})
|
||||||
|
- INCLUDE(ManageRPM)
|
||||||
|
- PACK_RPM(SPEC_IN "SPECS/project.spec.in")
|
||||||
|
-ENDIF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
-
|
||||||
|
-####################################################################
|
||||||
|
-# Hosting and Release
|
||||||
|
-#
|
||||||
|
-# Set to "True" to build against updates-candidate if possible.
|
||||||
|
-
|
||||||
|
-#INCLUDE(ManageUpload)
|
||||||
|
-#ADD_CUSTOM_TARGET(upload
|
||||||
|
-# COMMENT "Uploading all files"
|
||||||
|
-# )
|
||||||
|
-
|
||||||
|
-#MANAGE_UPLOAD_CMD(scp src UPLOAD_FILES ${SOURCE_ARCHIVE_FILE})
|
||||||
|
-#ADD_DEPENDENCIES(upload upload_src)
|
||||||
|
-
|
||||||
|
-INCLUDE(ManageRelease)
|
||||||
|
-IF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
- INCLUDE(ManageReleaseFedora)
|
||||||
|
- RELEASE_FEDORA(fedora el6)
|
||||||
|
- # "Off" Warning is displayed if mock is not installed.
|
||||||
|
- MANAGE_RELEASE(tag_push release_fedora)
|
||||||
|
-ELSE(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
- MANAGE_RELEASE(tag_push)
|
||||||
|
-ENDIF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-####################################################################
|
||||||
|
-# Test Suites.
|
||||||
|
-#
|
||||||
|
-#ADD_TEST("Test" test_cmd1)
|
||||||
|
-
|
||||||
|
-
|
||||||
|
diff --git a/tables/CMakeLists.txt b/tables/CMakeLists.txt
|
||||||
|
index 9f04605..6a5c8c1 100644
|
||||||
|
--- a/tables/CMakeLists.txt
|
||||||
|
+++ b/tables/CMakeLists.txt
|
||||||
|
@@ -98,7 +98,7 @@ MACRO(CONVERT_DB targetName)
|
||||||
|
LIST(APPEND _dependIcon "${CMAKE_SOURCE_DIR}/icons/${_tabName}.jpg")
|
||||||
|
ENDIF(EXISTS "${CMAKE_SOURCE_DIR}/icons/${_tabName}.png")
|
||||||
|
ENDFOREACH(_tabFile ${ARGN})
|
||||||
|
- M_MSG(${M_INFO1} "[${targetName}] db files=${_dependDb}")
|
||||||
|
+ MESSAGE("[${targetName}] db files=${_dependDb}")
|
||||||
|
|
||||||
|
ADD_CUSTOM_TARGET(convert_${targetName}
|
||||||
|
COMMENT "Building ${targetName} table(s)..."
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
Loading…
Reference in New Issue
Block a user