Update to 1.3.4-1.
This commit is contained in:
parent
8612a7d0b5
commit
a692a4ee70
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ ibus-m17n-1.3.0.tar.gz
|
|||||||
/ibus-m17n-1.3.1.tar.gz
|
/ibus-m17n-1.3.1.tar.gz
|
||||||
/ibus-m17n-1.3.2.tar.gz
|
/ibus-m17n-1.3.2.tar.gz
|
||||||
/ibus-m17n-1.3.3.tar.gz
|
/ibus-m17n-1.3.3.tar.gz
|
||||||
|
/ibus-m17n-1.3.4.tar.gz
|
||||||
|
2860
ibus-m17n-HEAD.patch
2860
ibus-m17n-HEAD.patch
File diff suppressed because it is too large
Load Diff
@ -7,19 +7,19 @@ Subject: [PATCH 2/4] Hide status from the panel if status == title.
|
|||||||
src/engine.c | 8 +++++++-
|
src/engine.c | 8 +++++++-
|
||||||
1 files changed, 7 insertions(+), 1 deletions(-)
|
1 files changed, 7 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/engine.c b/src/engine.c
|
Index: ibus-m17n-1.3.4/src/engine.c
|
||||||
index 4c7411c..efbce66 100644
|
===================================================================
|
||||||
--- a/src/engine.c
|
--- ibus-m17n-1.3.4.orig/src/engine.c
|
||||||
+++ b/src/engine.c
|
+++ ibus-m17n-1.3.4/src/engine.c
|
||||||
@@ -35,6 +35,7 @@ struct _IBusM17NEngineClass {
|
@@ -36,6 +36,7 @@ struct _IBusM17NEngineClass {
|
||||||
gint preedit_underline;
|
IBusPreeditFocusMode preedit_focus_mode;
|
||||||
gint lookup_table_orientation;
|
gint lookup_table_orientation;
|
||||||
|
|
||||||
+ gchar *title;
|
+ gchar *title;
|
||||||
MInputMethod *im;
|
MInputMethod *im;
|
||||||
};
|
};
|
||||||
|
|
||||||
@@ -244,6 +245,10 @@ ibus_m17n_engine_class_init (IBusM17NEngineClass *klass)
|
@@ -245,6 +246,10 @@ ibus_m17n_engine_class_init (IBusM17NEng
|
||||||
}
|
}
|
||||||
engine_name = g_strdup_printf ("m17n:%s:%s", lang, name);
|
engine_name = g_strdup_printf ("m17n:%s:%s", lang, name);
|
||||||
klass->config_section = g_strdup_printf ("engine/M17N/%s/%s", lang, name);
|
klass->config_section = g_strdup_printf ("engine/M17N/%s/%s", lang, name);
|
||||||
@ -30,7 +30,7 @@ index 4c7411c..efbce66 100644
|
|||||||
g_free (lang);
|
g_free (lang);
|
||||||
g_free (name);
|
g_free (name);
|
||||||
|
|
||||||
@@ -895,8 +900,9 @@ ibus_m17n_engine_callback (MInputContext *context,
|
@@ -903,8 +908,9 @@ ibus_m17n_engine_callback (MInputContext
|
||||||
else if (command == Minput_status_draw) {
|
else if (command == Minput_status_draw) {
|
||||||
gchar *status;
|
gchar *status;
|
||||||
status = ibus_m17n_mtext_to_utf8 (m17n->context->status);
|
status = ibus_m17n_mtext_to_utf8 (m17n->context->status);
|
||||||
@ -41,6 +41,3 @@ index 4c7411c..efbce66 100644
|
|||||||
IBusText *text;
|
IBusText *text;
|
||||||
text = ibus_text_new_from_string (status);
|
text = ibus_text_new_from_string (status);
|
||||||
ibus_property_set_label (m17n->status_prop, text);
|
ibus_property_set_label (m17n->status_prop, text);
|
||||||
--
|
|
||||||
1.7.7.6
|
|
||||||
|
|
||||||
|
@ -12,10 +12,10 @@ Subject: [PATCH 4/4] Add virtual keyboard support.
|
|||||||
src/m17nutil.h | 3 +
|
src/m17nutil.h | 3 +
|
||||||
6 files changed, 434 insertions(+), 1 deletions(-)
|
6 files changed, 434 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
Index: ibus-m17n-1.3.4/configure.ac
|
||||||
index be9728d..3daf917 100644
|
===================================================================
|
||||||
--- a/configure.ac
|
--- ibus-m17n-1.3.4.orig/configure.ac
|
||||||
+++ b/configure.ac
|
+++ ibus-m17n-1.3.4/configure.ac
|
||||||
@@ -88,6 +88,23 @@ fi
|
@@ -88,6 +88,23 @@ fi
|
||||||
|
|
||||||
AM_CONDITIONAL([HAVE_GTK],[test x$with_gtk != xno])
|
AM_CONDITIONAL([HAVE_GTK],[test x$with_gtk != xno])
|
||||||
@ -40,10 +40,10 @@ index be9728d..3daf917 100644
|
|||||||
# check if minput_list, which is available in m17n-lib 1.6.2+ (CVS)
|
# check if minput_list, which is available in m17n-lib 1.6.2+ (CVS)
|
||||||
save_CFLAGS="$CFLAGS"
|
save_CFLAGS="$CFLAGS"
|
||||||
save_LIBS="$LIBS"
|
save_LIBS="$LIBS"
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
Index: ibus-m17n-1.3.4/src/Makefile.am
|
||||||
index 39d6523..93e7dfd 100644
|
===================================================================
|
||||||
--- a/src/Makefile.am
|
--- ibus-m17n-1.3.4.orig/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ ibus-m17n-1.3.4/src/Makefile.am
|
||||||
@@ -65,10 +65,15 @@ ibus_engine_m17n_SOURCES = \
|
@@ -65,10 +65,15 @@ ibus_engine_m17n_SOURCES = \
|
||||||
engine.c \
|
engine.c \
|
||||||
engine.h \
|
engine.h \
|
||||||
@ -60,10 +60,10 @@ index 39d6523..93e7dfd 100644
|
|||||||
$(NULL)
|
$(NULL)
|
||||||
|
|
||||||
if HAVE_GTK
|
if HAVE_GTK
|
||||||
diff --git a/src/default.xml.in.in b/src/default.xml.in.in
|
Index: ibus-m17n-1.3.4/src/default.xml.in.in
|
||||||
index fda4f30..cbc29af 100644
|
===================================================================
|
||||||
--- a/src/default.xml.in.in
|
--- ibus-m17n-1.3.4.orig/src/default.xml.in.in
|
||||||
+++ b/src/default.xml.in.in
|
+++ ibus-m17n-1.3.4/src/default.xml.in.in
|
||||||
@@ -11,6 +11,7 @@
|
@@ -11,6 +11,7 @@
|
||||||
<rank>0</rank>
|
<rank>0</rank>
|
||||||
<preedit-highlight>FALSE</preedit-highlight>
|
<preedit-highlight>FALSE</preedit-highlight>
|
||||||
@ -187,10 +187,10 @@ index fda4f30..cbc29af 100644
|
|||||||
+ <virtual-keyboard>te-inscript,us</virtual-keyboard>
|
+ <virtual-keyboard>te-inscript,us</virtual-keyboard>
|
||||||
+ </engine>
|
+ </engine>
|
||||||
</engines>
|
</engines>
|
||||||
diff --git a/src/engine.c b/src/engine.c
|
Index: ibus-m17n-1.3.4/src/engine.c
|
||||||
index efbce66..cd18e76 100644
|
===================================================================
|
||||||
--- a/src/engine.c
|
--- ibus-m17n-1.3.4.orig/src/engine.c
|
||||||
+++ b/src/engine.c
|
+++ ibus-m17n-1.3.4/src/engine.c
|
||||||
@@ -7,6 +7,9 @@
|
@@ -7,6 +7,9 @@
|
||||||
#include <m17n.h>
|
#include <m17n.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
@ -214,9 +214,9 @@ index efbce66..cd18e76 100644
|
|||||||
IBusPropList *prop_list;
|
IBusPropList *prop_list;
|
||||||
};
|
};
|
||||||
|
|
||||||
@@ -34,9 +39,16 @@ struct _IBusM17NEngineClass {
|
@@ -35,9 +40,16 @@ struct _IBusM17NEngineClass {
|
||||||
guint preedit_background;
|
|
||||||
gint preedit_underline;
|
gint preedit_underline;
|
||||||
|
IBusPreeditFocusMode preedit_focus_mode;
|
||||||
gint lookup_table_orientation;
|
gint lookup_table_orientation;
|
||||||
+ gchar *virtual_keyboard;
|
+ gchar *virtual_keyboard;
|
||||||
|
|
||||||
@ -231,7 +231,7 @@ index efbce66..cd18e76 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
/* functions prototype */
|
/* functions prototype */
|
||||||
@@ -100,13 +112,184 @@ static IBusEngineClass *parent_class = NULL;
|
@@ -101,13 +113,184 @@ static IBusEngineClass *parent_class = N
|
||||||
|
|
||||||
static IBusConfig *config = NULL;
|
static IBusConfig *config = NULL;
|
||||||
|
|
||||||
@ -416,15 +416,15 @@ index efbce66..cd18e76 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static gboolean
|
static gboolean
|
||||||
@@ -264,6 +447,7 @@ ibus_m17n_engine_class_init (IBusM17NEngineClass *klass)
|
@@ -268,6 +451,7 @@ ibus_m17n_engine_class_init (IBusM17NEng
|
||||||
INVALID_COLOR;
|
IBUS_ENGINE_PREEDIT_COMMIT :
|
||||||
klass->preedit_underline = IBUS_ATTR_UNDERLINE_NONE;
|
IBUS_ENGINE_PREEDIT_CLEAR;
|
||||||
klass->lookup_table_orientation = IBUS_ORIENTATION_SYSTEM;
|
klass->lookup_table_orientation = IBUS_ORIENTATION_SYSTEM;
|
||||||
+ klass->virtual_keyboard = engine_config->virtual_keyboard;
|
+ klass->virtual_keyboard = engine_config->virtual_keyboard;
|
||||||
|
|
||||||
ibus_m17n_engine_config_free (engine_config);
|
ibus_m17n_engine_config_free (engine_config);
|
||||||
|
|
||||||
@@ -313,6 +497,11 @@ ibus_m17n_engine_class_init (IBusM17NEngineClass *klass)
|
@@ -317,6 +501,11 @@ ibus_m17n_engine_class_init (IBusM17NEng
|
||||||
klass);
|
klass);
|
||||||
|
|
||||||
klass->im = NULL;
|
klass->im = NULL;
|
||||||
@ -436,7 +436,7 @@ index efbce66..cd18e76 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@@ -350,6 +539,7 @@ ibus_m17n_engine_init (IBusM17NEngine *m17n)
|
@@ -354,6 +543,7 @@ ibus_m17n_engine_init (IBusM17NEngine *m
|
||||||
{
|
{
|
||||||
IBusText* label;
|
IBusText* label;
|
||||||
IBusText* tooltip;
|
IBusText* tooltip;
|
||||||
@ -444,7 +444,7 @@ index efbce66..cd18e76 100644
|
|||||||
|
|
||||||
m17n->prop_list = ibus_prop_list_new ();
|
m17n->prop_list = ibus_prop_list_new ();
|
||||||
g_object_ref_sink (m17n->prop_list);
|
g_object_ref_sink (m17n->prop_list);
|
||||||
@@ -382,6 +572,36 @@ ibus_m17n_engine_init (IBusM17NEngine *m17n)
|
@@ -386,6 +576,36 @@ ibus_m17n_engine_init (IBusM17NEngine *m
|
||||||
ibus_prop_list_append (m17n->prop_list, m17n->setup_prop);
|
ibus_prop_list_append (m17n->prop_list, m17n->setup_prop);
|
||||||
#endif /* HAVE_SETUP */
|
#endif /* HAVE_SETUP */
|
||||||
|
|
||||||
@ -481,7 +481,7 @@ index efbce66..cd18e76 100644
|
|||||||
m17n->table = ibus_lookup_table_new (9, 0, TRUE, TRUE);
|
m17n->table = ibus_lookup_table_new (9, 0, TRUE, TRUE);
|
||||||
g_object_ref_sink (m17n->table);
|
g_object_ref_sink (m17n->table);
|
||||||
m17n->context = NULL;
|
m17n->context = NULL;
|
||||||
@@ -467,6 +687,11 @@ ibus_m17n_engine_destroy (IBusM17NEngine *m17n)
|
@@ -471,6 +691,11 @@ ibus_m17n_engine_destroy (IBusM17NEngine
|
||||||
}
|
}
|
||||||
#endif /* HAVE_SETUP */
|
#endif /* HAVE_SETUP */
|
||||||
|
|
||||||
@ -493,7 +493,7 @@ index efbce66..cd18e76 100644
|
|||||||
if (m17n->table) {
|
if (m17n->table) {
|
||||||
g_object_unref (m17n->table);
|
g_object_unref (m17n->table);
|
||||||
m17n->table = NULL;
|
m17n->table = NULL;
|
||||||
@@ -708,6 +933,14 @@ ibus_m17n_engine_enable (IBusEngine *engine)
|
@@ -716,6 +941,14 @@ ibus_m17n_engine_enable (IBusEngine *eng
|
||||||
/* Issue a dummy ibus_engine_get_surrounding_text() call to tell
|
/* Issue a dummy ibus_engine_get_surrounding_text() call to tell
|
||||||
input context that we will use surrounding-text. */
|
input context that we will use surrounding-text. */
|
||||||
ibus_engine_get_surrounding_text (engine, NULL, NULL, NULL);
|
ibus_engine_get_surrounding_text (engine, NULL, NULL, NULL);
|
||||||
@ -508,7 +508,7 @@ index efbce66..cd18e76 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@@ -717,6 +950,14 @@ ibus_m17n_engine_disable (IBusEngine *engine)
|
@@ -725,6 +958,14 @@ ibus_m17n_engine_disable (IBusEngine *en
|
||||||
|
|
||||||
ibus_m17n_engine_focus_out (engine);
|
ibus_m17n_engine_focus_out (engine);
|
||||||
parent_class->disable (engine);
|
parent_class->disable (engine);
|
||||||
@ -523,7 +523,7 @@ index efbce66..cd18e76 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@@ -764,6 +1005,7 @@ ibus_m17n_engine_property_activate (IBusEngine *engine,
|
@@ -772,6 +1013,7 @@ ibus_m17n_engine_property_activate (IBus
|
||||||
guint prop_state)
|
guint prop_state)
|
||||||
{
|
{
|
||||||
IBusM17NEngine *m17n = (IBusM17NEngine *) engine;
|
IBusM17NEngine *m17n = (IBusM17NEngine *) engine;
|
||||||
@ -531,7 +531,7 @@ index efbce66..cd18e76 100644
|
|||||||
|
|
||||||
#ifdef HAVE_SETUP
|
#ifdef HAVE_SETUP
|
||||||
if (g_strcmp0 (prop_name, "setup") == 0) {
|
if (g_strcmp0 (prop_name, "setup") == 0) {
|
||||||
@@ -779,6 +1021,53 @@ ibus_m17n_engine_property_activate (IBusEngine *engine,
|
@@ -787,6 +1029,53 @@ ibus_m17n_engine_property_activate (IBus
|
||||||
}
|
}
|
||||||
#endif /* HAVE_SETUP */
|
#endif /* HAVE_SETUP */
|
||||||
|
|
||||||
@ -585,10 +585,10 @@ index efbce66..cd18e76 100644
|
|||||||
parent_class->property_activate (engine, prop_name, prop_state);
|
parent_class->property_activate (engine, prop_name, prop_state);
|
||||||
}
|
}
|
||||||
|
|
||||||
diff --git a/src/m17nutil.c b/src/m17nutil.c
|
Index: ibus-m17n-1.3.4/src/m17nutil.c
|
||||||
index 0b46531..adf7044 100644
|
===================================================================
|
||||||
--- a/src/m17nutil.c
|
--- ibus-m17n-1.3.4.orig/src/m17nutil.c
|
||||||
+++ b/src/m17nutil.c
|
+++ ibus-m17n-1.3.4/src/m17nutil.c
|
||||||
@@ -18,7 +18,8 @@ typedef enum {
|
@@ -18,7 +18,8 @@ typedef enum {
|
||||||
ENGINE_CONFIG_SYMBOL_MASK = 1 << 1,
|
ENGINE_CONFIG_SYMBOL_MASK = 1 << 1,
|
||||||
ENGINE_CONFIG_LONGNAME_MASK = 1 << 2,
|
ENGINE_CONFIG_LONGNAME_MASK = 1 << 2,
|
||||||
@ -599,7 +599,7 @@ index 0b46531..adf7044 100644
|
|||||||
} EngineConfigMask;
|
} EngineConfigMask;
|
||||||
|
|
||||||
struct _EngineConfigNode {
|
struct _EngineConfigNode {
|
||||||
@@ -276,6 +277,8 @@ ibus_m17n_get_engine_config (const gchar *engine_name)
|
@@ -276,6 +277,8 @@ ibus_m17n_get_engine_config (const gchar
|
||||||
config->longname = cnode->config.longname;
|
config->longname = cnode->config.longname;
|
||||||
if (cnode->mask & ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK)
|
if (cnode->mask & ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK)
|
||||||
config->preedit_highlight = cnode->config.preedit_highlight;
|
config->preedit_highlight = cnode->config.preedit_highlight;
|
||||||
@ -608,7 +608,7 @@ index 0b46531..adf7044 100644
|
|||||||
if (cnode->mask & ENGINE_CONFIG_LAYOUT_MASK)
|
if (cnode->mask & ENGINE_CONFIG_LAYOUT_MASK)
|
||||||
config->layout = cnode->config.layout;
|
config->layout = cnode->config.layout;
|
||||||
}
|
}
|
||||||
@@ -333,6 +336,11 @@ ibus_m17n_engine_config_parse_xml_node (EngineConfigNode *cnode,
|
@@ -333,6 +336,11 @@ ibus_m17n_engine_config_parse_xml_node (
|
||||||
cnode->mask |= ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK;
|
cnode->mask |= ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK;
|
||||||
continue;
|
continue;
|
||||||
}
|
}
|
||||||
@ -620,10 +620,10 @@ index 0b46531..adf7044 100644
|
|||||||
g_warning ("<engine> element contains invalid element <%s>",
|
g_warning ("<engine> element contains invalid element <%s>",
|
||||||
sub_node->name);
|
sub_node->name);
|
||||||
}
|
}
|
||||||
diff --git a/src/m17nutil.h b/src/m17nutil.h
|
Index: ibus-m17n-1.3.4/src/m17nutil.h
|
||||||
index 93faad4..3c2944a 100644
|
===================================================================
|
||||||
--- a/src/m17nutil.h
|
--- ibus-m17n-1.3.4.orig/src/m17nutil.h
|
||||||
+++ b/src/m17nutil.h
|
+++ ibus-m17n-1.3.4/src/m17nutil.h
|
||||||
@@ -25,6 +25,9 @@ struct _IBusM17NEngineConfig {
|
@@ -25,6 +25,9 @@ struct _IBusM17NEngineConfig {
|
||||||
|
|
||||||
/* whether to highlight preedit */
|
/* whether to highlight preedit */
|
||||||
@ -634,6 +634,3 @@ index 93faad4..3c2944a 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
typedef struct _IBusM17NEngineConfig IBusM17NEngineConfig;
|
typedef struct _IBusM17NEngineConfig IBusM17NEngineConfig;
|
||||||
--
|
|
||||||
1.7.7.6
|
|
||||||
|
|
||||||
|
@ -18,15 +18,15 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: ibus-m17n
|
Name: ibus-m17n
|
||||||
Version: 1.3.3
|
Version: 1.3.4
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The M17N engine for IBus platform
|
Summary: The M17N engine for IBus platform
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://code.google.com/p/ibus/
|
URL: http://code.google.com/p/ibus/
|
||||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: ibus-m17n-HEAD.patch
|
# Patch0: ibus-m17n-HEAD.patch
|
||||||
Patch1: ibus-m17n-xkb-options.patch
|
Patch1: ibus-m17n-xkb-options.patch
|
||||||
Patch2: ibus-m17n-hide-title-status.patch
|
Patch2: ibus-m17n-hide-title-status.patch
|
||||||
Patch3: ibus-m17n-blacklist-engines.patch
|
Patch3: ibus-m17n-blacklist-engines.patch
|
||||||
@ -59,7 +59,7 @@ the input table maps from m17n-db.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1 -b .HEAD
|
#patch0 -p1 -b .HEAD
|
||||||
%patch1 -p1 -b .xkb-options
|
%patch1 -p1 -b .xkb-options
|
||||||
%patch2 -p1 -b .hide-title-status
|
%patch2 -p1 -b .hide-title-status
|
||||||
%patch3 -p1 -b .blacklist-engines
|
%patch3 -p1 -b .blacklist-engines
|
||||||
@ -85,6 +85,9 @@ make DESTDIR=${RPM_BUILD_ROOT} install
|
|||||||
%{_datadir}/ibus/component/*
|
%{_datadir}/ibus/component/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 11 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-1
|
||||||
|
- New upstream release.
|
||||||
|
|
||||||
* Tue Apr 3 2012 Daiki Ueno <dueno@redhat.com> - 1.3.3-12
|
* Tue Apr 3 2012 Daiki Ueno <dueno@redhat.com> - 1.3.3-12
|
||||||
- Check %%{rhel} version in addition to %%{fedora}
|
- Check %%{rhel} version in addition to %%{fedora}
|
||||||
- Remove unnecessary %%defattr(-,root,root,-) from %%files
|
- Remove unnecessary %%defattr(-,root,root,-) from %%files
|
||||||
|
Loading…
Reference in New Issue
Block a user