import RHEL 10 Beta ibus-m17n-1.4.29-4.el10

This commit is contained in:
eabdullin 2024-11-20 13:19:21 +00:00
parent b1be741796
commit 65fd986974
15 changed files with 251 additions and 2460 deletions

7
.gitignore vendored
View File

@ -1,6 +1 @@
ibus-m17n-1.3.0.tar.gz
/ibus-m17n-1.3.0.tar.gz
/ibus-m17n-1.3.1.tar.gz
/ibus-m17n-1.3.2.tar.gz
/ibus-m17n-1.3.3.tar.gz
/ibus-m17n-1.3.4.tar.gz
ibus-m17n-1.4.29.tar.gz

View File

@ -1,6 +0,0 @@
--- !Policy
product_versions:
- rhel-8
decision_context: osci_compose_gate
rules:
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}

File diff suppressed because it is too large Load Diff

View File

@ -1,97 +0,0 @@
From e995acb046c9e6bd3ee48cb0cf1ccf9d754546e7 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 6 Nov 2014 16:05:52 +0900
Subject: [PATCH] engine: Disable key processing on password input
---
src/engine.c | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Index: ibus-m17n-1.3.4/src/engine.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/engine.c
+++ ibus-m17n-1.3.4/src/engine.c
@@ -24,6 +24,7 @@ struct _IBusM17NEngine {
#endif /* HAVE_SETUP */
IBusPropList *prop_list;
IBusKeymap *us_keymap;
+ gboolean has_focus;
};
struct _IBusM17NEngineClass {
@@ -75,6 +76,10 @@ static void ibus_m17n_engine_property_ac
(IBusEngine *engine,
const gchar *prop_name,
guint prop_state);
+static void ibus_m17n_engine_set_content_type
+ (IBusEngine *engine,
+ IBusInputPurpose purpose,
+ IBusInputHints hints);
static void ibus_m17n_engine_commit_string
(IBusM17NEngine *m17n,
@@ -226,6 +231,8 @@ ibus_m17n_engine_class_init (IBusM17NEng
engine_class->property_activate = ibus_m17n_engine_property_activate;
+ engine_class->set_content_type = ibus_m17n_engine_set_content_type;
+
if (!ibus_m17n_scan_class_name (G_OBJECT_CLASS_NAME (klass),
&lang, &name)) {
g_free (lang);
@@ -667,6 +674,9 @@ ibus_m17n_engine_process_key_event (IBus
(IBusM17NEngineClass *) G_OBJECT_GET_CLASS (m17n);
guint original_keyval = keyval;
+ if (!m17n->has_focus)
+ return FALSE;
+
if (modifiers & IBUS_RELEASE_MASK)
return FALSE;
@@ -704,6 +714,7 @@ ibus_m17n_engine_focus_in (IBusEngine *e
ibus_engine_register_properties (engine, m17n->prop_list);
ibus_m17n_engine_process_key (m17n, Minput_focus_in);
+ m17n->has_focus = TRUE;
parent_class->focus_in (engine);
}
@@ -717,6 +728,7 @@ ibus_m17n_engine_focus_out (IBusEngine *
properly, we just reset the IC instead of passing Mfocus_out to
m17n-lib. */
minput_reset_ic (m17n->context);
+ m17n->has_focus = FALSE;
parent_class->focus_out (engine);
}
@@ -812,6 +824,29 @@ ibus_m17n_engine_property_activate (IBus
}
static void
+ibus_m17n_engine_set_content_type (IBusEngine *engine,
+ IBusInputPurpose purpose,
+ IBusInputHints hints)
+{
+ IBusM17NEngine *m17n = (IBusM17NEngine *) engine;
+
+ /* For password and PIN input, disable key processing by emulating
+ 'focus-out'. */
+ switch (purpose) {
+ case IBUS_INPUT_PURPOSE_PASSWORD:
+ case IBUS_INPUT_PURPOSE_PIN:
+ ibus_m17n_engine_process_key (m17n, Minput_focus_out);
+ m17n->has_focus = FALSE;
+ break;
+
+ default:
+ ibus_m17n_engine_process_key (m17n, Minput_focus_in);
+ m17n->has_focus = TRUE;
+ break;
+ }
+}
+
+static void
ibus_m17n_engine_update_lookup_table (IBusM17NEngine *m17n)
{
ibus_lookup_table_clear (m17n->table);

View File

@ -1,16 +0,0 @@
--- ibus-m17n-1.3.4/src/default.xml.old 2016-12-20 11:07:26.242523223 +0530
+++ ibus-m17n-1.3.4/src/default.xml 2016-12-20 11:11:42.392527990 +0530
@@ -18,6 +18,13 @@
<name>m17n:*:kbd</name>
<rank>-1</rank>
</engine>
+ <!-- Arabic kbd engine should be selected by default:
+ https://bugzilla.redhat.com/show_bug.cgi?id=1076945 -->
+ <engine>
+ <name>m17n:ar:kbd</name>
+ <rank>1</rank>
+ </engine>
+
<!-- zh:py is superseded by ibus-pinyin etc -->
<engine>
<name>m17n:zh:py</name>

View File

@ -1,25 +0,0 @@
From b0e03bac1f3b420ac1b7ac76d6008dd4ed942cbf Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Mon, 13 May 2013 15:45:33 +0900
Subject: [PATCH] Fix ibus-m17n-preferences.ui location
---
src/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/setup.c b/src/setup.c
index 513fabf..4de8fb1 100644
--- a/src/setup.c
+++ b/src/setup.c
@@ -570,7 +570,7 @@ setup_dialog_new (IBusConfig *config,
error = NULL;
if (gtk_builder_add_from_file (builder,
- PKGDATADIR "setup/ibus-m17n-preferences.ui",
+ PKGDATADIR "/setup/ibus-m17n-preferences.ui",
&error) == 0) {
g_warning ("can't read ibus-m17n-preferences.ui: %s",
error->message);
--
1.8.1.4

View File

@ -1,29 +0,0 @@
From e5c742c56abaadaa5d5a018c0d9004bf2d0a100c Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Mon, 12 Aug 2013 18:51:59 +0200
Subject: [PATCH] engine: fix preedit background colour and underlining
BUG=rhbz#995842
Review URL: https://codereview.appspot.com/12688049
Patch from Mike FABIAN <mfabian@redhat.com>.
---
src/engine.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/engine.c b/src/engine.c
index bcc1a71..ca70464 100644
--- a/src/engine.c
+++ b/src/engine.c
@@ -282,7 +282,7 @@ ibus_m17n_engine_class_init (IBusM17NEngineClass *klass)
"preedit_underline",
G_VARIANT_TYPE_INT32);
if (value != NULL) {
- klass->preedit_background = g_variant_get_int32 (value);
+ klass->preedit_underline = g_variant_get_int32 (value);
g_variant_unref (value);
}
--
1.8.3.1

View File

@ -1,24 +0,0 @@
From 1a497768dfb15c18865154183296087ec07d6a95 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Tue, 16 Sep 2014 11:28:04 +0900
Subject: [PATCH] setup: Don't use removed "tab_vborder" property
---
src/ibus-m17n-preferences.ui | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/ibus-m17n-preferences.ui b/src/ibus-m17n-preferences.ui
index e85fb15..19d3b47 100644
--- a/src/ibus-m17n-preferences.ui
+++ b/src/ibus-m17n-preferences.ui
@@ -98,7 +98,6 @@
<object class="GtkNotebook" id="pages">
<property name="visible">True</property>
<property name="can_focus">True</property>
- <property name="tab_vborder">3</property>
<child>
<object class="GtkAlignment" id="pageGeneral">
<property name="visible">True</property>
--
1.9.3

View File

@ -1,90 +0,0 @@
From 109acb63611f5fbd994aa56cd0b4a9b1b2eb178e Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 5 Jun 2014 12:17:36 +0900
Subject: [PATCH] build: Switch from intltool to gettext-0.19
---
configure.ac | 3 +--
po/POTFILES.in | 2 +-
src/Makefile.am | 19 ++++++++++++++-----
src/ibus-setup-m17n.desktop.in.in | 4 ++--
4 files changed, 18 insertions(+), 10 deletions(-)
diff --git a/configure.ac b/configure.ac
index 30d44ff..dab9354 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,7 +48,6 @@ AM_PROG_CC_C_O
AC_PROG_CXX
AC_ISC_POSIX
AC_HEADER_STDC
-IT_PROG_INTLTOOL([0.35.0])
AM_PROG_LIBTOOL
# check ibus
@@ -104,7 +103,7 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION(0.16.1)
+AM_GNU_GETTEXT_VERSION([0.19])
# OUTPUT files
diff --git a/po/POTFILES.in b/po/POTFILES.in
index bb3bd6e..4f81b75 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,5 +1,5 @@
src/engine.c
src/m17nutil.c
src/main.c
-[type: gettext/glade]src/ibus-m17n-preferences.ui
+src/ibus-m17n-preferences.ui
src/ibus-setup-m17n.desktop.in.in
diff --git a/src/Makefile.am b/src/Makefile.am
index 68ec953..c23e680 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -131,11 +131,20 @@ m17n.xml: m17n.xml.in
desktop_in_in_files = ibus-setup-m17n.desktop.in.in
desktop_in_files = $(desktop_in_in_files:.in.in=.in)
+desktop_files = $(desktop_in_files:.desktop.in=.desktop)
-$(desktop_in_files): %.desktop.in: %.desktop.in.in Makefile
- $(AM_V_GEN) $(edit) $< > $@.tmp && mv $@.tmp $@
+$(desktop_in_files):
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $@.in -o $@-t \
+ -d $(top_srcdir)/po && mv $@-t $@
-desktopdir=$(datadir)/applications
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+$(desktop_files):
+ @rm -f $@
+ $(AM_V_GEN) srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit) $${srcdir}$@.in >$@-t && mv $@-t $@
-@INTLTOOL_DESKTOP_RULE@
+ibus-setup-m17n.desktop.in: ibus-setup-m17n.desktop.in.in
+ibus-setup-m17n.desktop: ibus-setup-m17n.desktop.in
+
+desktopdir=$(datadir)/applications
+desktop_DATA = $(desktop_files)
diff --git a/src/ibus-setup-m17n.desktop.in.in b/src/ibus-setup-m17n.desktop.in.in
index a380cb3..110fcfb 100644
--- a/src/ibus-setup-m17n.desktop.in.in
+++ b/src/ibus-setup-m17n.desktop.in.in
@@ -1,6 +1,6 @@
[Desktop Entry]
-_Name=IBus M17N Setup
-_Comment=Set up IBus M17N engine
+Name=IBus M17N Setup
+Comment=Set up IBus M17N engine
Exec=@libexecdir@/ibus-setup-m17n
NoDisplay=true
Type=Application
--
1.9.0

View File

@ -1,43 +0,0 @@
From 02022c17212357afb5cec727edd8f095aa40d98d Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 29 Sep 2011 10:17:28 +0900
Subject: [PATCH 2/4] Hide status from the panel if status == title.
---
src/engine.c | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
Index: ibus-m17n-1.3.4/src/engine.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/engine.c
+++ ibus-m17n-1.3.4/src/engine.c
@@ -38,6 +38,7 @@ struct _IBusM17NEngineClass {
gint lookup_table_orientation;
gboolean use_us_layout;
+ gchar *title;
MInputMethod *im;
};
@@ -233,6 +234,10 @@ ibus_m17n_engine_class_init (IBusM17NEng
}
engine_name = g_strdup_printf ("m17n:%s:%s", lang, name);
klass->config_section = g_strdup_printf ("engine/M17N/%s/%s", lang, name);
+ MPlist *l = minput_get_title_icon (msymbol (lang), msymbol (name));
+ if (l && mplist_key (l) == Mtext) {
+ klass->title = ibus_m17n_mtext_to_utf8 (mplist_value (l));
+ }
g_free (lang);
g_free (name);
@@ -924,8 +929,9 @@ ibus_m17n_engine_callback (MInputContext
else if (command == Minput_status_draw) {
gchar *status;
status = ibus_m17n_mtext_to_utf8 (m17n->context->status);
+ IBusM17NEngineClass *klass = (IBusM17NEngineClass *) G_OBJECT_GET_CLASS (m17n);
- if (status && strlen (status)) {
+ if (status && strlen (status) && g_strcmp0 (status, klass->title)) {
IBusText *text;
text = ibus_text_new_from_string (status);
ibus_property_set_label (m17n->status_prop, text);

View File

@ -1,79 +0,0 @@
Index: ibus-m17n-1.3.4/src/default.xml
===================================================================
--- ibus-m17n-1.3.4.orig/src/default.xml
+++ ibus-m17n-1.3.4/src/default.xml
@@ -184,6 +184,15 @@
<name>m17n:si:samanala</name>
<rank>0</rank>
</engine>
+ <!-- Some Indic engines expect AltGr is automatically mapped -->
+ <engine>
+ <name>m17n:*:inscript*</name>
+ <layout>default[lv3:ralt_switch]</layout>
+ </engine>
+ <engine>
+ <name>m17n:si:*</name>
+ <layout>default[lv3:ralt_switch]</layout>
+ </engine>
<!-- Some CJK engines use preedit. -->
<engine>
<name>m17n:zh:cangjie</name>
Index: ibus-m17n-1.3.4/src/m17nutil.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/m17nutil.c
+++ ibus-m17n-1.3.4/src/m17nutil.c
@@ -17,7 +17,8 @@ typedef enum {
ENGINE_CONFIG_RANK_MASK = 1 << 0,
ENGINE_CONFIG_SYMBOL_MASK = 1 << 1,
ENGINE_CONFIG_LONGNAME_MASK = 1 << 2,
- ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK = 1 << 3
+ ENGINE_CONFIG_LAYOUT_MASK = 1 << 3,
+ ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK = 1 << 4
} EngineConfigMask;
struct _EngineConfigNode {
@@ -137,7 +138,7 @@ ibus_m17n_engine_new (MSymbol lang,
"language", msymbol_name (lang),
"license", "GPL",
"icon", engine_icon ? engine_icon : "",
- "layout", "default",
+ "layout", config->layout ? config->layout : "default",
"rank", config->rank,
"symbol", config->symbol ? config->symbol : "",
"setup", engine_setup,
@@ -272,6 +273,8 @@ ibus_m17n_get_engine_config (const gchar
config->symbol = cnode->config.symbol;
if (cnode->mask & ENGINE_CONFIG_LONGNAME_MASK)
config->longname = cnode->config.longname;
+ if (cnode->mask & ENGINE_CONFIG_LAYOUT_MASK)
+ config->layout = cnode->config.layout;
if (cnode->mask & ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK)
config->preedit_highlight = cnode->config.preedit_highlight;
}
@@ -314,6 +317,12 @@ ibus_m17n_engine_config_parse_xml_node (
cnode->mask |= ENGINE_CONFIG_LONGNAME_MASK;
continue;
}
+ if (g_strcmp0 (sub_node->name , "layout") == 0) {
+ g_free (cnode->config.layout);
+ cnode->config.layout = g_strdup (sub_node->text);
+ cnode->mask |= ENGINE_CONFIG_LAYOUT_MASK;
+ continue;
+ }
if (g_strcmp0 (sub_node->name , "preedit-highlight") == 0) {
if (g_ascii_strcasecmp ("TRUE", sub_node->text) == 0)
cnode->config.preedit_highlight = TRUE;
Index: ibus-m17n-1.3.4/src/m17nutil.h
===================================================================
--- ibus-m17n-1.3.4.orig/src/m17nutil.h
+++ ibus-m17n-1.3.4/src/m17nutil.h
@@ -20,6 +20,9 @@ struct _IBusM17NEngineConfig {
/* overridding longname shown on panel */
gchar *longname;
+ /* keyboard layout */
+ gchar *layout;
+
/* whether to highlight preedit */
gboolean preedit_highlight;
};

View File

@ -1,42 +1,31 @@
## START: Set by rpmautospec
## (rpmautospec version 0.6.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
%global require_ibus_version 1.4.0
Name: ibus-m17n
Version: 1.3.4
Release: 26%{?dist}
Version: 1.4.29
Release: %autorelease
Summary: The M17N engine for IBus platform
License: GPLv2+
License: GPL-2.0-or-later
URL: https://github.com/ibus/ibus-m17n
Source0: https://github.com/ibus/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
# Upstreamed patches:
Patch0: ibus-m17n-HEAD.patch
Patch1: ibus-m17n-fix-data-location.patch
Patch2: ibus-m17n-fix-preedit-color.patch
Patch3: ibus-m17n-fix-preferences-ui.patch
Patch4: ibus-m17n-content-type.patch
# Fedora specific patches:
# Enable lv3:ralt_switch option for some Indic engines in default.xml.
Patch100: ibus-m17n-xkb-options.patch
# Don't make the status button clickable (maybe obsolete).
Patch101: ibus-m17n-hide-title-status.patch
# Use gettext-0.19 instead of intltool
Patch102: ibus-m17n-gettext-0.19.patch
# Use ar-kbd as default keymap for Arabic
# https://bugzilla.redhat.com/show_bug.cgi?id=1076945
Patch103: ibus-m17n-enable-ar-kbd.patch
# The following BR is for autogen and not necessary when packging
# released tarballs.
BuildRequires: gettext-devel >= 0.19
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: gnome-common
BuildRequires: m17n-lib-devel
BuildRequires: gtk3-devel
BuildRequires: ibus-devel >= %{require_ibus_version}
BuildRequires: desktop-file-utils
BuildRequires: libappstream-glib
BuildRequires: make
Requires: ibus >= %{require_ibus_version}
Requires: m17n-lib
@ -48,78 +37,256 @@ the input table maps from m17n-db.
%prep
%setup -q
%patch0 -p1 -b .HEAD
%patch1 -p1 -b .fix-data-location
%patch2 -p1 -b .fix-preedit-color
%patch3 -p1 -b .fix-preferences-ui
%patch4 -p1 -b .content-type
%patch100 -p1 -b .xkb-options
%patch101 -p1 -b .hide-title-status
%patch102 -p1 -b .gettext-0.19
%patch103 -p1 -b .enable-ar-kbd
%build
NOCONFIGURE=1 ./autogen.sh
%configure --disable-static --with-gtk=3.0
# make -C po update-gmo
make %{?_smp_mflags}
%{make_build}
%install
make DESTDIR=${RPM_BUILD_ROOT} install
# Register as an AppStream component to be visible in the software center
#
# NOTE: It would be *awesome* if this file was maintained by the upstream
# project, translated and installed into the right place during `make install`.
#
# See http://www.freedesktop.org/software/appstream/docs/ for more details.
#
mkdir -p $RPM_BUILD_ROOT%{_datadir}/appdata
cat > $RPM_BUILD_ROOT%{_datadir}/appdata/m17n.appdata.xml <<EOF
<?xml version="1.0" encoding="UTF-8"?>
<component type="inputmethod">
<id>m17n.xml</id>
<metadata_license>CC0-1.0</metadata_license>
<name>Multilingualization</name>
<summary>Multilingualization input method</summary>
<description>
<p>
The multilingualization input method allows entering many languages using the
tables from the m17n library.
</p>
<p>
Input methods are typing systems allowing users to input complex languages.
They are necessary because these contain too many characters to simply be laid
out on a traditional keyboard.
</p>
</description>
<url type="homepage">https://github.com/ibus/ibus-m17n</url>
<compulsory_for_desktop>GNOME</compulsory_for_desktop>
<project_group>GNOME</project_group>
<developer_name>The GNOME Project</developer_name>
<url type="bugtracker">https://code.google.com/p/ibus/issues/list</url>
<url type="donation">http://www.gnome.org/friends/</url>
<url type="help">https://code.google.com/p/ibus/wiki/FAQ</url>
<update_contact><!-- upstream-contact_at_email.com --></update_contact>
</component>
EOF
desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/ibus-setup-m17n.desktop
%{make_install}
%find_lang %{name}
%check
appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*.appdata.xml
desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/ibus-setup-m17n.desktop
make check
%files -f %{name}.lang
%doc AUTHORS README
%license COPYING
%{_datadir}/appdata/*.appdata.xml
%{_datadir}/metainfo/m17n.appdata.xml
%{_datadir}/ibus-m17n
%{_datadir}/icons/hicolor/16x16/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/22x22/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/24x24/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/32x32/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/48x48/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/64x64/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/128x128/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/256x256/apps/ibus-m17n.png
%{_datadir}/icons/hicolor/scalable/apps/ibus-m17n.svg
%{_libexecdir}/ibus-engine-m17n
%{_libexecdir}/ibus-setup-m17n
%{_datadir}/ibus/component/*
%{_datadir}/applications/ibus-setup-m17n.desktop
%{_datadir}/glib-2.0/schemas/org.freedesktop.ibus.engine.m17n.gschema.xml
%changelog
## START: Generated by rpmautospec
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.4.29-4
- Bump release for June 2024 mass rebuild
* Tue Jun 11 2024 Mike FABIAN <mfabian@redhat.com> - 1.4.29-3
- Fix CI tests
* Tue Jun 04 2024 Twinkle Pardeshi <tpardesh@tpardesh-thinkpadp1gen4i.pnq.csb> - 1.4.29-2
- Resolves:RHELMISC-3924 - adding gating configuration
* Fri Apr 26 2024 Mike FABIAN <mfabian@redhat.com> - 1.4.29-1
- Update to 1.4.29
- Translation update from Weblate (Malayalam (ml), new, 100%%, Swedish (sv)
100%%)
* Thu Feb 15 2024 Mike FABIAN <mfabian@redhat.com> - 1.4.28-1
- Update to 1.4.28
- Translation update from Weblate (Russian (ru), new, 100%%)
- Build against gtk3 by default (Resolves:
https://github.com/ibus/ibus-m17n/issues/73)
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.27-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Jan 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.27-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Dec 02 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.27-1
- Update to 1.4.27
- Prefer commit to "return FALSE;" for space, and other keys
where the msymbol name is exactly one character, add a
sleep for Return. This is to avoid ordering problems in
mutter.
(Resolves: https://github.com/ibus/ibus-m17n/issues/72)
* Fri Nov 10 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.24-1
- Update to 1.4.24
- Make IBusEngineSimple read ~/.XCompose
(Resolves: https://github.com/ibus/ibus-m17n/issues/70)
- Do not hide empty preedit text before committing text.
(Resolves: https://github.com/ibus/ibus-m17n/pull/64).
Together with ibus >= 1.5.29 this solves the preedit flicker problem perfectly.
- Use “<developer><name>…</name></developer>” in m17n.appdata.xml instead of “<developer_name>…</developer_name>”
Because </developer_name> is deprecated and it makes the build fail on Fedora rawhide.
* Fri Oct 27 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.23-1
- Update to 1.4.23
- Do not translate the Multi_key when using the option “☑️ Use US keyboard layout”
- Fix option “☑️ Use US keyboard layout”
(Resolves: https://github.com/ibus/ibus-m17n/issues/66)
- Translation update from Weblate: new language Hindi, hi 100%
* Mon Aug 21 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.22-1
- Update to 1.4.22
- Translation update from Weblate (Lithuanian, lt 100%)
* Mon Aug 07 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.21-1
- Update to 1.4.21
- Translation update from Weblate (Swedish, sv 100%)
* Sun Jul 30 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.20-1
- Update to 1.4.20
- Reduce preedit flicker (Resolves: https://github.com/ibus/ibus/issues/2536)
- Remove `xml:lang="en"` from the screenshot in appdata.xml
See: https://github.com/ximion/appstream/issues/494
There must be one image in the default locale, and there can be some
translated ones, but having only translated images is not okay.
- Use ibus_text_new_from_string (string) instead of
ibus_text_new_from_static_string (string) in ibus_m17n_engine_commit_string()
- Add missing g_free (buf) in ibus_m17n_mtext_to_utf8()
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sun Feb 19 2023 Mike FABIAN <mfabian@redhat.com> - 1.4.19-1
- Update to 1.4.19
- Translation update from Weblate (Sinhala, si 100%)
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Dec 07 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.18-1
- Update to 1.4.18
- Add new icon
* Sat Nov 26 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.17-2
- Migrate license tag to SPDX
* Sat Sep 17 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.17-1
- Update to 1.4.17
- Fix problem that sa-IAST input method cannot be activated and make settings of sa-IAST work
(Resolves: https://github.com/ibus/ibus-m17n/issues/52)
- Let IBusM17nEngine inherit from IBusEngineSimple to enable compose support
(Resolves: https://github.com/ibus/ibus-m17n/pull/51)
* Thu Sep 08 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.13-1
- Update to 1.4.13
- Translation update from Weblate (ar updated 100%, ka added 100%)
* Sat Sep 03 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.11-1
- Update to 1.4.11
- Added translation using Weblate (Arabic, 100%)
- Add 256x256 icon to m17n.appdata.xml
* Wed Aug 03 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.10-1
- Update to 1.4.10
- Add language to longname in --xml output to make engines which have exactly
the same icon distinguishable in the engine switcher
- Make the icon of the current engine appear at the left of floating panel of ibus.
And also show the full engine name as a tooltip on that icon
Before only a generic gear wheel ⚙️ was shown, the same for
all engines, so one could not distinguish which engine was
selected in the floating panel.
- Show also the engine name in the title of the setup tool window.
I.e. instead of just “Preferences” show something like
“Preferences m17n:t:latn-post”.
- Better icon and a screenshot which can be shown in gnome-software
- Improvements in m17n.appdata.xml
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Jan 18 2022 Mike FABIAN <mfabian@redhat.com> - 1.4.9-1
- Update to 1.4.9
- Free lang and name after engine_name is built
(Resolves: https://github.com/ibus/ibus-m17n/issues/39)
- Just return from ibus_m17n_engine_callback with nullable m17n
- Accept virtual engine names for CI
- Hide status from the panel if status == title (by Daiki Ueno)
* Tue Oct 19 2021 Mike FABIAN <mfabian@redhat.com> - 1.4.8-1
- Update to 1.4.8
- Remove gnome-common requirement and re-write autogen.sh (by Parag Nemade)
(Resolves: https://github.com/ibus/ibus-m17n/pull/37)
- Translation update from Weblate for Sinhala
* Tue Oct 19 2021 Parag Nemade <pnemade AT redhat DOT com> - 1.4.7-2
- Remove BR: gnome-common and pkgconfig as it is not needed for released tarball
* Fri Aug 13 2021 Mike FABIAN <mfabian@redhat.com> - 1.4.7-1
- Update to 1.4.7
- Assign symbols to all the new inscript2 engines (and add some other missing symbols)
(Resolves: https://github.com/ibus/ibus-m17n/issues/34)
- Allow to use kbd engines (#32)
(Resolves: https://github.com/ibus/ibus-m17n/issues/32)
- ibus-m17n-xkb-options.patch from Fedora included upstream
- ibus-m17n-enable-ar-kbd.patch from Fedora included upstream
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Thu Jul 15 2021 Mike FABIAN <mfabian@redhat.com> - 1.4.6-1
- Update to 1.4.6
- Make inscript2 engines rank higher than inscript engines
- Resolves: rhbz#1982546
* Fri Mar 12 2021 Mike FABIAN <mfabian@redhat.com> - 1.4.5-1
- Update to 1.4.5
- Use ibus_engine_update_preedit_with_mode() *always* with IBUS_ENGINE_PREEDIT_COMMIT mode
- Translation update from Weblate, bn new and 100% complete, pt_BR now 100% complete
- Remove redundant target for desktop.in file
* Thu Jan 28 2021 Mike FABIAN <mfabian@redhat.com> - 1.4.4-1
- Update to 1.4.4
- Translation update from Weblate, zh_CN now 100% complete.
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sat Jun 20 2020 Mike FABIAN <mfabian@redhat.com> - 1.4.3-1
- Update to 1.4.3
- New translation: es (Spanish) 100%.
* Sat Apr 18 2020 Parag Nemade <pnemade AT redhat DOT com> - 1.4.2-4
- No need to call autogen.sh in %%prep section
* Wed Mar 18 2020 Parag Nemade <pnemade AT redhat DOT com> - 1.4.2-3
- Use make_build and make_install macros
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Mon Jan 20 2020 Mike FABIAN <mfabian@redhat.com> - 1.4.2-1
- Update to 1.4.2
- New translations: tr (Turkish) 100%, uk (Ukrainian) 100%,
id (Indonesian) 100%, ja_JP (Japanese) 100%.
- Translation updates: zh_CN, pt_BR
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Oct 25 2018 Mike FABIAN <mfabian@redhat.com> - 1.4.1-1
- Update to 1.4.1
- Fix for google code issue 1781 in ibus-m17n for kk (Correct symbols for kk input methods)
- Add German translations
- Add m17n.appdata.xml
* Tue Oct 23 2018 Mike FABIAN <mfabian@redhat.com> - 1.4.0-1
- Update to 1.4.0
- Migration from IBusConfig to GSettings
- Remove patches which are included upstream now
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Jun 22 2018 Parag Nemade <pnemade AT fedoraproject DOT org> - 1.3.4-26
- Fix the upstream URL and Source0 tags
@ -466,3 +633,5 @@ desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/ibus-setup-m17n.
* Thu Aug 07 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.0.20080810-1
- The first version.
## END: Generated by rpmautospec

View File

@ -1 +1 @@
SHA512 (ibus-m17n-1.3.4.tar.gz) = 9dbb5224fea377293a583e68598b36be4637698af0718c5117434d60b6a398bf94dc8cc2dbeef59c2d43bdab6f50e831bc60dd97112eed02105a3f2b9d55f026
SHA512 (ibus-m17n-1.4.29.tar.gz) = bb3b3f44fa5a79e7e15c71b30760f7b29454a47b167f12cc4bde52ee03151f794795fd0d9bb6a2a7877a0afc909f81342d50461da3d49a905255c76288023edb

View File

@ -1,10 +0,0 @@
#!/bin/bash
cd ../source
echo "---Start autogen.sh---"
NOCONFIGURE=1 ./autogen.sh
echo "---End autogen.sh---"
echo "--------------------"
./configure --disable-static --with-gtk=3.0
make check

View File

@ -1,26 +0,0 @@
---
- hosts: localhost
tags:
- classic
roles:
- role: standard-test-source
- hosts: localhost
tags:
- classic
roles:
- role: standard-test-basic
tests:
- smoke
required_packages:
- gcc
- make
- gnome-common
- autoconf
- automake
- gettext-devel
- ibus-devel
- gtk3-devel
- pkgconfig
- libtool
- m17n-lib-devel