Auto sync2gitlab import of ibus-m17n-1.3.4-26.el8.src.rpm

This commit is contained in:
James Antill 2022-05-26 09:47:32 -04:00
parent 915f2ffa2a
commit 3d18fa1ff5
13 changed files with 2801 additions and 1 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/ibus-m17n-1.3.4.tar.gz

1
EMPTY
View File

@ -1 +0,0 @@

1928
ibus-m17n-HEAD.patch Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,97 @@
From e995acb046c9e6bd3ee48cb0cf1ccf9d754546e7 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 6 Nov 2014 16:05:52 +0900
Subject: [PATCH] engine: Disable key processing on password input
---
src/engine.c | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Index: ibus-m17n-1.3.4/src/engine.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/engine.c
+++ ibus-m17n-1.3.4/src/engine.c
@@ -24,6 +24,7 @@ struct _IBusM17NEngine {
#endif /* HAVE_SETUP */
IBusPropList *prop_list;
IBusKeymap *us_keymap;
+ gboolean has_focus;
};
struct _IBusM17NEngineClass {
@@ -75,6 +76,10 @@ static void ibus_m17n_engine_property_ac
(IBusEngine *engine,
const gchar *prop_name,
guint prop_state);
+static void ibus_m17n_engine_set_content_type
+ (IBusEngine *engine,
+ IBusInputPurpose purpose,
+ IBusInputHints hints);
static void ibus_m17n_engine_commit_string
(IBusM17NEngine *m17n,
@@ -226,6 +231,8 @@ ibus_m17n_engine_class_init (IBusM17NEng
engine_class->property_activate = ibus_m17n_engine_property_activate;
+ engine_class->set_content_type = ibus_m17n_engine_set_content_type;
+
if (!ibus_m17n_scan_class_name (G_OBJECT_CLASS_NAME (klass),
&lang, &name)) {
g_free (lang);
@@ -667,6 +674,9 @@ ibus_m17n_engine_process_key_event (IBus
(IBusM17NEngineClass *) G_OBJECT_GET_CLASS (m17n);
guint original_keyval = keyval;
+ if (!m17n->has_focus)
+ return FALSE;
+
if (modifiers & IBUS_RELEASE_MASK)
return FALSE;
@@ -704,6 +714,7 @@ ibus_m17n_engine_focus_in (IBusEngine *e
ibus_engine_register_properties (engine, m17n->prop_list);
ibus_m17n_engine_process_key (m17n, Minput_focus_in);
+ m17n->has_focus = TRUE;
parent_class->focus_in (engine);
}
@@ -717,6 +728,7 @@ ibus_m17n_engine_focus_out (IBusEngine *
properly, we just reset the IC instead of passing Mfocus_out to
m17n-lib. */
minput_reset_ic (m17n->context);
+ m17n->has_focus = FALSE;
parent_class->focus_out (engine);
}
@@ -812,6 +824,29 @@ ibus_m17n_engine_property_activate (IBus
}
static void
+ibus_m17n_engine_set_content_type (IBusEngine *engine,
+ IBusInputPurpose purpose,
+ IBusInputHints hints)
+{
+ IBusM17NEngine *m17n = (IBusM17NEngine *) engine;
+
+ /* For password and PIN input, disable key processing by emulating
+ 'focus-out'. */
+ switch (purpose) {
+ case IBUS_INPUT_PURPOSE_PASSWORD:
+ case IBUS_INPUT_PURPOSE_PIN:
+ ibus_m17n_engine_process_key (m17n, Minput_focus_out);
+ m17n->has_focus = FALSE;
+ break;
+
+ default:
+ ibus_m17n_engine_process_key (m17n, Minput_focus_in);
+ m17n->has_focus = TRUE;
+ break;
+ }
+}
+
+static void
ibus_m17n_engine_update_lookup_table (IBusM17NEngine *m17n)
{
ibus_lookup_table_clear (m17n->table);

View File

@ -0,0 +1,16 @@
--- ibus-m17n-1.3.4/src/default.xml.old 2016-12-20 11:07:26.242523223 +0530
+++ ibus-m17n-1.3.4/src/default.xml 2016-12-20 11:11:42.392527990 +0530
@@ -18,6 +18,13 @@
<name>m17n:*:kbd</name>
<rank>-1</rank>
</engine>
+ <!-- Arabic kbd engine should be selected by default:
+ https://bugzilla.redhat.com/show_bug.cgi?id=1076945 -->
+ <engine>
+ <name>m17n:ar:kbd</name>
+ <rank>1</rank>
+ </engine>
+
<!-- zh:py is superseded by ibus-pinyin etc -->
<engine>
<name>m17n:zh:py</name>

View File

@ -0,0 +1,25 @@
From b0e03bac1f3b420ac1b7ac76d6008dd4ed942cbf Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Mon, 13 May 2013 15:45:33 +0900
Subject: [PATCH] Fix ibus-m17n-preferences.ui location
---
src/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/setup.c b/src/setup.c
index 513fabf..4de8fb1 100644
--- a/src/setup.c
+++ b/src/setup.c
@@ -570,7 +570,7 @@ setup_dialog_new (IBusConfig *config,
error = NULL;
if (gtk_builder_add_from_file (builder,
- PKGDATADIR "setup/ibus-m17n-preferences.ui",
+ PKGDATADIR "/setup/ibus-m17n-preferences.ui",
&error) == 0) {
g_warning ("can't read ibus-m17n-preferences.ui: %s",
error->message);
--
1.8.1.4

View File

@ -0,0 +1,29 @@
From e5c742c56abaadaa5d5a018c0d9004bf2d0a100c Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Mon, 12 Aug 2013 18:51:59 +0200
Subject: [PATCH] engine: fix preedit background colour and underlining
BUG=rhbz#995842
Review URL: https://codereview.appspot.com/12688049
Patch from Mike FABIAN <mfabian@redhat.com>.
---
src/engine.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/engine.c b/src/engine.c
index bcc1a71..ca70464 100644
--- a/src/engine.c
+++ b/src/engine.c
@@ -282,7 +282,7 @@ ibus_m17n_engine_class_init (IBusM17NEngineClass *klass)
"preedit_underline",
G_VARIANT_TYPE_INT32);
if (value != NULL) {
- klass->preedit_background = g_variant_get_int32 (value);
+ klass->preedit_underline = g_variant_get_int32 (value);
g_variant_unref (value);
}
--
1.8.3.1

View File

@ -0,0 +1,24 @@
From 1a497768dfb15c18865154183296087ec07d6a95 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Tue, 16 Sep 2014 11:28:04 +0900
Subject: [PATCH] setup: Don't use removed "tab_vborder" property
---
src/ibus-m17n-preferences.ui | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/ibus-m17n-preferences.ui b/src/ibus-m17n-preferences.ui
index e85fb15..19d3b47 100644
--- a/src/ibus-m17n-preferences.ui
+++ b/src/ibus-m17n-preferences.ui
@@ -98,7 +98,6 @@
<object class="GtkNotebook" id="pages">
<property name="visible">True</property>
<property name="can_focus">True</property>
- <property name="tab_vborder">3</property>
<child>
<object class="GtkAlignment" id="pageGeneral">
<property name="visible">True</property>
--
1.9.3

View File

@ -0,0 +1,90 @@
From 109acb63611f5fbd994aa56cd0b4a9b1b2eb178e Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 5 Jun 2014 12:17:36 +0900
Subject: [PATCH] build: Switch from intltool to gettext-0.19
---
configure.ac | 3 +--
po/POTFILES.in | 2 +-
src/Makefile.am | 19 ++++++++++++++-----
src/ibus-setup-m17n.desktop.in.in | 4 ++--
4 files changed, 18 insertions(+), 10 deletions(-)
diff --git a/configure.ac b/configure.ac
index 30d44ff..dab9354 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,7 +48,6 @@ AM_PROG_CC_C_O
AC_PROG_CXX
AC_ISC_POSIX
AC_HEADER_STDC
-IT_PROG_INTLTOOL([0.35.0])
AM_PROG_LIBTOOL
# check ibus
@@ -104,7 +103,7 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION(0.16.1)
+AM_GNU_GETTEXT_VERSION([0.19])
# OUTPUT files
diff --git a/po/POTFILES.in b/po/POTFILES.in
index bb3bd6e..4f81b75 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,5 +1,5 @@
src/engine.c
src/m17nutil.c
src/main.c
-[type: gettext/glade]src/ibus-m17n-preferences.ui
+src/ibus-m17n-preferences.ui
src/ibus-setup-m17n.desktop.in.in
diff --git a/src/Makefile.am b/src/Makefile.am
index 68ec953..c23e680 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -131,11 +131,20 @@ m17n.xml: m17n.xml.in
desktop_in_in_files = ibus-setup-m17n.desktop.in.in
desktop_in_files = $(desktop_in_in_files:.in.in=.in)
+desktop_files = $(desktop_in_files:.desktop.in=.desktop)
-$(desktop_in_files): %.desktop.in: %.desktop.in.in Makefile
- $(AM_V_GEN) $(edit) $< > $@.tmp && mv $@.tmp $@
+$(desktop_in_files):
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $@.in -o $@-t \
+ -d $(top_srcdir)/po && mv $@-t $@
-desktopdir=$(datadir)/applications
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+$(desktop_files):
+ @rm -f $@
+ $(AM_V_GEN) srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit) $${srcdir}$@.in >$@-t && mv $@-t $@
-@INTLTOOL_DESKTOP_RULE@
+ibus-setup-m17n.desktop.in: ibus-setup-m17n.desktop.in.in
+ibus-setup-m17n.desktop: ibus-setup-m17n.desktop.in
+
+desktopdir=$(datadir)/applications
+desktop_DATA = $(desktop_files)
diff --git a/src/ibus-setup-m17n.desktop.in.in b/src/ibus-setup-m17n.desktop.in.in
index a380cb3..110fcfb 100644
--- a/src/ibus-setup-m17n.desktop.in.in
+++ b/src/ibus-setup-m17n.desktop.in.in
@@ -1,6 +1,6 @@
[Desktop Entry]
-_Name=IBus M17N Setup
-_Comment=Set up IBus M17N engine
+Name=IBus M17N Setup
+Comment=Set up IBus M17N engine
Exec=@libexecdir@/ibus-setup-m17n
NoDisplay=true
Type=Application
--
1.9.0

View File

@ -0,0 +1,43 @@
From 02022c17212357afb5cec727edd8f095aa40d98d Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 29 Sep 2011 10:17:28 +0900
Subject: [PATCH 2/4] Hide status from the panel if status == title.
---
src/engine.c | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
Index: ibus-m17n-1.3.4/src/engine.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/engine.c
+++ ibus-m17n-1.3.4/src/engine.c
@@ -38,6 +38,7 @@ struct _IBusM17NEngineClass {
gint lookup_table_orientation;
gboolean use_us_layout;
+ gchar *title;
MInputMethod *im;
};
@@ -233,6 +234,10 @@ ibus_m17n_engine_class_init (IBusM17NEng
}
engine_name = g_strdup_printf ("m17n:%s:%s", lang, name);
klass->config_section = g_strdup_printf ("engine/M17N/%s/%s", lang, name);
+ MPlist *l = minput_get_title_icon (msymbol (lang), msymbol (name));
+ if (l && mplist_key (l) == Mtext) {
+ klass->title = ibus_m17n_mtext_to_utf8 (mplist_value (l));
+ }
g_free (lang);
g_free (name);
@@ -924,8 +929,9 @@ ibus_m17n_engine_callback (MInputContext
else if (command == Minput_status_draw) {
gchar *status;
status = ibus_m17n_mtext_to_utf8 (m17n->context->status);
+ IBusM17NEngineClass *klass = (IBusM17NEngineClass *) G_OBJECT_GET_CLASS (m17n);
- if (status && strlen (status)) {
+ if (status && strlen (status) && g_strcmp0 (status, klass->title)) {
IBusText *text;
text = ibus_text_new_from_string (status);
ibus_property_set_label (m17n->status_prop, text);

View File

@ -0,0 +1,79 @@
Index: ibus-m17n-1.3.4/src/default.xml
===================================================================
--- ibus-m17n-1.3.4.orig/src/default.xml
+++ ibus-m17n-1.3.4/src/default.xml
@@ -184,6 +184,15 @@
<name>m17n:si:samanala</name>
<rank>0</rank>
</engine>
+ <!-- Some Indic engines expect AltGr is automatically mapped -->
+ <engine>
+ <name>m17n:*:inscript*</name>
+ <layout>default[lv3:ralt_switch]</layout>
+ </engine>
+ <engine>
+ <name>m17n:si:*</name>
+ <layout>default[lv3:ralt_switch]</layout>
+ </engine>
<!-- Some CJK engines use preedit. -->
<engine>
<name>m17n:zh:cangjie</name>
Index: ibus-m17n-1.3.4/src/m17nutil.c
===================================================================
--- ibus-m17n-1.3.4.orig/src/m17nutil.c
+++ ibus-m17n-1.3.4/src/m17nutil.c
@@ -17,7 +17,8 @@ typedef enum {
ENGINE_CONFIG_RANK_MASK = 1 << 0,
ENGINE_CONFIG_SYMBOL_MASK = 1 << 1,
ENGINE_CONFIG_LONGNAME_MASK = 1 << 2,
- ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK = 1 << 3
+ ENGINE_CONFIG_LAYOUT_MASK = 1 << 3,
+ ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK = 1 << 4
} EngineConfigMask;
struct _EngineConfigNode {
@@ -137,7 +138,7 @@ ibus_m17n_engine_new (MSymbol lang,
"language", msymbol_name (lang),
"license", "GPL",
"icon", engine_icon ? engine_icon : "",
- "layout", "default",
+ "layout", config->layout ? config->layout : "default",
"rank", config->rank,
"symbol", config->symbol ? config->symbol : "",
"setup", engine_setup,
@@ -272,6 +273,8 @@ ibus_m17n_get_engine_config (const gchar
config->symbol = cnode->config.symbol;
if (cnode->mask & ENGINE_CONFIG_LONGNAME_MASK)
config->longname = cnode->config.longname;
+ if (cnode->mask & ENGINE_CONFIG_LAYOUT_MASK)
+ config->layout = cnode->config.layout;
if (cnode->mask & ENGINE_CONFIG_PREEDIT_HIGHLIGHT_MASK)
config->preedit_highlight = cnode->config.preedit_highlight;
}
@@ -314,6 +317,12 @@ ibus_m17n_engine_config_parse_xml_node (
cnode->mask |= ENGINE_CONFIG_LONGNAME_MASK;
continue;
}
+ if (g_strcmp0 (sub_node->name , "layout") == 0) {
+ g_free (cnode->config.layout);
+ cnode->config.layout = g_strdup (sub_node->text);
+ cnode->mask |= ENGINE_CONFIG_LAYOUT_MASK;
+ continue;
+ }
if (g_strcmp0 (sub_node->name , "preedit-highlight") == 0) {
if (g_ascii_strcasecmp ("TRUE", sub_node->text) == 0)
cnode->config.preedit_highlight = TRUE;
Index: ibus-m17n-1.3.4/src/m17nutil.h
===================================================================
--- ibus-m17n-1.3.4.orig/src/m17nutil.h
+++ ibus-m17n-1.3.4/src/m17nutil.h
@@ -20,6 +20,9 @@ struct _IBusM17NEngineConfig {
/* overridding longname shown on panel */
gchar *longname;
+ /* keyboard layout */
+ gchar *layout;
+
/* whether to highlight preedit */
gboolean preedit_highlight;
};

468
ibus-m17n.spec Normal file
View File

@ -0,0 +1,468 @@
%global require_ibus_version 1.4.0
Name: ibus-m17n
Version: 1.3.4
Release: 26%{?dist}
Summary: The M17N engine for IBus platform
License: GPLv2+
URL: https://github.com/ibus/ibus-m17n
Source0: https://github.com/ibus/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
# Upstreamed patches:
Patch0: ibus-m17n-HEAD.patch
Patch1: ibus-m17n-fix-data-location.patch
Patch2: ibus-m17n-fix-preedit-color.patch
Patch3: ibus-m17n-fix-preferences-ui.patch
Patch4: ibus-m17n-content-type.patch
# Fedora specific patches:
# Enable lv3:ralt_switch option for some Indic engines in default.xml.
Patch100: ibus-m17n-xkb-options.patch
# Don't make the status button clickable (maybe obsolete).
Patch101: ibus-m17n-hide-title-status.patch
# Use gettext-0.19 instead of intltool
Patch102: ibus-m17n-gettext-0.19.patch
# Use ar-kbd as default keymap for Arabic
# https://bugzilla.redhat.com/show_bug.cgi?id=1076945
Patch103: ibus-m17n-enable-ar-kbd.patch
# The following BR is for autogen and not necessary when packging
# released tarballs.
BuildRequires: gettext-devel >= 0.19
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: gnome-common
BuildRequires: m17n-lib-devel
BuildRequires: gtk3-devel
BuildRequires: ibus-devel >= %{require_ibus_version}
BuildRequires: desktop-file-utils
Requires: ibus >= %{require_ibus_version}
Requires: m17n-lib
%description
M17N engine for IBus input platform. It allows input of many languages using
the input table maps from m17n-db.
%prep
%setup -q
%patch0 -p1 -b .HEAD
%patch1 -p1 -b .fix-data-location
%patch2 -p1 -b .fix-preedit-color
%patch3 -p1 -b .fix-preferences-ui
%patch4 -p1 -b .content-type
%patch100 -p1 -b .xkb-options
%patch101 -p1 -b .hide-title-status
%patch102 -p1 -b .gettext-0.19
%patch103 -p1 -b .enable-ar-kbd
NOCONFIGURE=1 ./autogen.sh
%build
%configure --disable-static --with-gtk=3.0
# make -C po update-gmo
make %{?_smp_mflags}
%install
make DESTDIR=${RPM_BUILD_ROOT} install
# Register as an AppStream component to be visible in the software center
#
# NOTE: It would be *awesome* if this file was maintained by the upstream
# project, translated and installed into the right place during `make install`.
#
# See http://www.freedesktop.org/software/appstream/docs/ for more details.
#
mkdir -p $RPM_BUILD_ROOT%{_datadir}/appdata
cat > $RPM_BUILD_ROOT%{_datadir}/appdata/m17n.appdata.xml <<EOF
<?xml version="1.0" encoding="UTF-8"?>
<component type="inputmethod">
<id>m17n.xml</id>
<metadata_license>CC0-1.0</metadata_license>
<name>Multilingualization</name>
<summary>Multilingualization input method</summary>
<description>
<p>
The multilingualization input method allows entering many languages using the
tables from the m17n library.
</p>
<p>
Input methods are typing systems allowing users to input complex languages.
They are necessary because these contain too many characters to simply be laid
out on a traditional keyboard.
</p>
</description>
<url type="homepage">https://github.com/ibus/ibus-m17n</url>
<compulsory_for_desktop>GNOME</compulsory_for_desktop>
<project_group>GNOME</project_group>
<developer_name>The GNOME Project</developer_name>
<url type="bugtracker">https://code.google.com/p/ibus/issues/list</url>
<url type="donation">http://www.gnome.org/friends/</url>
<url type="help">https://code.google.com/p/ibus/wiki/FAQ</url>
<update_contact><!-- upstream-contact_at_email.com --></update_contact>
</component>
EOF
desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/ibus-setup-m17n.desktop
%find_lang %{name}
%files -f %{name}.lang
%doc AUTHORS README
%license COPYING
%{_datadir}/appdata/*.appdata.xml
%{_datadir}/ibus-m17n
%{_libexecdir}/ibus-engine-m17n
%{_libexecdir}/ibus-setup-m17n
%{_datadir}/ibus/component/*
%{_datadir}/applications/ibus-setup-m17n.desktop
%changelog
* Fri Jun 22 2018 Parag Nemade <pnemade AT fedoraproject DOT org> - 1.3.4-26
- Fix the upstream URL and Source0 tags
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Dec 20 2016 Parag Nemade <pnemade AT redhat DOT com> - 1.3.4-21
- Resolves:rhbz#1076945 - Enable default ar-kbd.mim for Arabic language
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.4-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Mar 25 2015 Richard Hughes <rhughes@redhat.com> - 1.3.4-18
- Register as an AppStream component.
* Thu Nov 6 2014 Daiki Ueno <dueno@redhat.com> - 1.3.4-17
- Add ibus-m17n-content-type.patch
- Fix bug 1024071 - ibus-m17n is enabled in the password entry field
of the lock screen
* Tue Sep 16 2014 Daiki Ueno <dueno@redhat.com> - 1.3.4-16
- Add ibus-m17n-fix-preferences-ui.patch
- Fix bug 1117720 - ibus-m17n input method's setup option does not work
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Thu Jun 5 2014 Daiki Ueno <dueno@redhat.com> - 1.3.4-13
- Use gettext-0.19 instead of intltool (#1078169)
* Wed Sep 4 2013 Daiki Ueno <dueno@redhat.com> - 1.3.4-12
- Add ibus-m17n-fix-preedit-color.patch
- Fix bug 995842 - Preedit background colour in ibus-m17n is always
black and preedit underlining is always off
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon May 13 2013 Daiki Ueno <dueno@redhat.com> - 1.3.4-10
- Add ibus-m17n-fix-data-location.patch
- Fix bug 962144 [abrt] ibus-m17n-1.3.4-9.fc19:
setup_dialog_load_config: Process /usr/libexec/ibus-setup-m17n was
killed by signal 11 (SIGSEGV)
* Wed May 1 2013 Daiki Ueno <dueno@redhat.com> - 1.3.4-9
- Update ibus-m17n-xkb-options.patch to set XKB option for Inscript2
- Fix bug 957993 - ibus-m17n doesn't automatically map Alt_R to AltGr
when Inscript2 maps are used
* Fri Apr 26 2013 Daiki Ueno <deno@redhat.com> - 1.3.4-8
- Update ibus-m17n-HEAD.patch to the latest upstream master
- Remove unnecessary and not upstreamable patches
- Use gtk3 always
- Fix bug 912592 - ibus-m17n should use default keyboard in most cases
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Oct 8 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-6
- Add ibus-m17n-desktop-file.patch
Fix bug 860955 - ibus-m17n setup is not enabled in
gnome-control-center region, .desktop file is missing
* Wed Sep 26 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-5
- Add ibus-m17n-honor-user-cflags.patch
* Wed Aug 15 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-4
- Add ibus-m17n-translit-layout.patch
- Fix bug 847495 - For non-US keyboard layout Ibus-m17n adds English
(US) to the list of input methods and other input methods use US
layout
- Require eekboard-service instead of eekboard
- Fix bug 847500 - Don't install Eekboard by default in the desktop spin
* Thu Aug 2 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-3
- Add ibus-m17n-fix-mtext-config.patch
- Fix bug 836397 - [abrt] ibus-m17n-1.3.3-11.fc17: mtext_data: Process
/usr/libexec/ibus-setup-m17n was killed by signal 11 (SIGSEGV)
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri May 11 2012 Daiki Ueno <dueno@redhat.com> - 1.3.4-1
- New upstream release.
* Tue Apr 3 2012 Daiki Ueno <dueno@redhat.com> - 1.3.3-12
- Check %%{rhel} version in addition to %%{fedora}
- Remove unnecessary %%defattr(-,root,root,-) from %%files
- Drop libxklavier-devel from BR
* Fri Mar 30 2012 Daiki Ueno <dueno@redhat.com> - 1.3.3-11
- Revive m17n:zh:pinyin with a different label ("hanyu pinyin (m17n)")
- Rebase ibus-m17n-virtkbd.patch
* Tue Mar 6 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.3-9
- Rebuild for ibus 1.4.99.20120304
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Dec 6 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-7
- Add ibus-m17n-custom-setup-element.patch
- Fix bug 760427 - engine preferences button in ibus-setup doesn't
work for ibus-m17n
* Fri Nov 18 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-6
- Add ibus-m17n-blacklist-engines.patch
https://lists.fedoraproject.org/pipermail/i18n/2011-October/001194.html
* Thu Sep 29 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-5
- Add ibus-m17n-hide-title-status.patch.
- Fix bug 741157 - ibus-m17n: m17n "title" variable appears as a
dormant button on the language panel
* Fri Sep 16 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-4
- Fix Indic IME symbols (thanks to pravins).
* Fri Sep 9 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.3-3
- Rebuild with the latest ibus 1.3.99.20110817-4 and eekboard 1.0.3
* Fri Sep 2 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-2
- Revive iok patch.
* Thu Sep 1 2011 Daiki Ueno <dueno@redhat.com> - 1.3.3-1
- New upstream release.
- Add ibus-m17n-default-xml-override.patch.
- Add ibus-m17n-virtkbd.patch, instead of ibus-m17n-iok.patch.
* Tue Aug 9 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-10
- Set symbol for m17n:ne:rom.
* Mon Aug 8 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-9
- Update ibus-m17n-xkb-options.patch.
- Don't set XKB options directly from engine but via ibus-xkb
* Fri Aug 5 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-8
- Update ibus-m17n-xx-icon-symbol.patch.
- Fix bug 727024 - ibus compose file needs a symbol tag for gnome-shell
- Update ibus-m17n-xkb-options.patch.
* Thu Jul 7 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-7
- don't specify --with-hotkey.
* Mon Jul 4 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-6
- Add ibus-m17n-xkb-options.patch.
- Add ibus-m17n-xx-icon-symbol.patch.
- Drop surrounding-text patches since they are included in the HEAD patch.
* Wed Jun 15 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-5
- Add ibus-m17n-stsreq.patch.
- Fix bug 711126 - ibus: surrounding text support fails for the first
syllable upon activation
* Tue Jun 7 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-4
- Add ibus-m17n-stscap.patch.
- Fix bug 711126 - ibus: surrounding text support fails for the first
syllable upon activation
* Mon May 23 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-3
- Update ibus-m17n-HEAD.patch.
* Mon May 23 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-2
- Bump the release to fix upgrade path.
- Fix bug 706602 - ibus-m17n-1.3.2-2.fc14 > ibus-m17n-1.3.2-1.fc15
- Drop preparing/cleaning buildroot.
* Mon Mar 7 2011 Daiki Ueno <dueno@redhat.com> - 1.3.2-1
- New upstream release.
* Fri Feb 11 2011 Matthias Clasen <mclasen@redhat.com> - 1.3.1-18
- Rebuild against newer gtk
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Feb 2 2011 Matthias Clasen <mclasen@redhat.com> - 1.3.1-16
- Rebuild against newer gtk
* Fri Jan 14 2011 Daiki Ueno <dueno@redhat.com> - 1.3.1-15
- Update iok patch.
- Fix bug 669128 - [abrt] ibus-m17n-1.3.1-14.fc15:
Process /usr/libexec/ibus-engine-m17n was killed by signal 6 (SIGABRT)
* Sun Jan 9 2011 Matthias Clasen <mclasen@redhat.com> - 1.3.1-14
- Rebuild against newer gtk3
* Mon Dec 27 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-13
- Update iok patch.
* Wed Dec 22 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-12
- Update surrounding-text patch.
* Fri Dec 10 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-11
- Update ibus-m17n-HEAD.patch.
- Lower si-samanala.mim rank per request from a Sinhala user.
* Wed Dec 8 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-10
- Update ibus-m17n-HEAD.patch.
- Fix bug 658336 - ibus-m17n: define the IM ranks in a config file and
not in a compiled binary
* Fri Dec 3 2010 Matthias Clasen <mclasen@redhat.com> - 1.3.1-9
- Rebuild against newer gtk3
* Tue Nov 9 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-8
- Apply ibus-m17n-ibus-1.4.patch for ibus-1.3.99.
- Specify backup filename for each patch.
* Fri Nov 5 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-7
- Rename ibus-m17n-fedora.patch to ibus-m17n-HEAD.patch since the
changes are merged into upstream.
- Update ibus-m17n-HEAD.patch with upstream fix 08e06310
- Fix bug 649230 - [si] last input character is committed late in
wijesekara input method
* Fri Oct 22 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-6
- Link ibus-setup-m17n with GTK+ 3.0.
* Tue Oct 12 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-5
- put several Fedora patches into one.
- Fix bug 640896 - Ibus does not load all the keymaps for a language
that is used for logging in.
* Tue Oct 5 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-4
- Remove Shift+AltGr patch; apply a simplified AltGr patch.
- Fix bug 639963 - SHIFT switch is not working in layouts as expected.
* Fri Oct 1 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-3
- Apply a patch to handle Shift+AltGr.
- Update surrounding-text patch.
- Fix bug 634829 - [abrt] ibus-m17n-1.3.1-1.fc14: shift_state: Process
/usr/libexec/ibus-engine-m17n was killed by signal 11 (SIGSEGV).
* Thu Sep 16 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-2
- Apply surrounding text patch. Bug 435880.
* Fri Sep 3 2010 Daiki Ueno <dueno@redhat.com> - 1.3.1-1
- Update to 1.3.1.
- Fix bug 615158 - Do not change the background colour of the pre-edit buffer
- Add gtk2-devel to BR
- Install ibus-setup-m17n in %%{_libexecdir}
* Thu Aug 26 2010 Daiki Ueno <dueno@redhat.com> - 1.3.0-4
- Rebuild with ibus 1.3.7 to avoid ABI incompatibility. Bug 627256.
* Tue Jul 27 2010 Daiki Ueno <dueno@redhat.com> - 1.3.0-3
- Update ibus-m17n-HEAD.patch.
- Fix regression with the previous update. See comment 7 of bug 614867.
* Fri Jul 16 2010 Daiki Ueno <dueno@redhat.com> - 1.3.0-2
- Update ibus-m17n-HEAD.patch.
- Fix bug 614867 - Invisible pre-edit buffer when using m17n Wijesekera keyboard layout
- Update iok patch.
* Mon Mar 29 2010 Peng Huang <shawn.p.huang@gmail.com> - 1.3.0-1
- Update to 1.3.0.
- Update iok patch.
- Fix bug 577148 - IOK screen appears with all keyboard layouts on ibus language panel
* Tue Feb 02 2010 Peng Huang <shawn.p.huang@gmail.com> - 1.2.99.20100202-1
- Update to 1.2.99.20100202.
- Update iok patch.
* Thu Dec 17 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.2.0.20091217-1
- Update to 1.2.0.20091217.
- Update iok patch.
* Fri Nov 20 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.2.0.20091120-1
- Update to 1.2.0.20091120.
- Fix bug 530976
* Fri Oct 23 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.2.0.20090617-5
- Update iok patch to fix bug 530493.
* Wed Oct 14 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.2.0.20090617-4
- Update iok patch to fix build error.
* Tue Oct 13 2009 Parag <pnemade@redhat.com> - 1.2.0.20090617-3
- Re-enable iok support to ibus-m17n.
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.20090617-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Mon Jun 22 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.2.0.20090617-1
- Update to 1.2.0.20090617.
* Thu Mar 05 2009 Parag <pnemade@redhat.com> - 1.1.0.20090211-4
- Add iok support to ibus-m17n.
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0.20090211-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Wed Feb 18 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.1.0.20090211-2
- Add patch ibus-m17n-HEAD.patch from upstream git tree.
- Make Control + Alt + ... available. (#482789)
* Wed Feb 11 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.1.0.20090211-1
- Update to 1.1.0.20090211.
* Thu Feb 05 2009 Peng Huang <shawn.p.huang@gmail.com> - 1.1.0.20090205-1
- Update to 1.1.0.20090205.
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.1.20081013-4
- Rebuild for Python 2.6
* Thu Oct 16 2008 Jens Petersen <petersen@redhat.com> - 0.1.1.20081013-3
- move the .engine files to m17n-db and m17n-contrib (#466410)
* Wed Oct 15 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20081013-2
- Move unicode, rfc1345 to generic package, and syrc-phonetic to syriac package.
* Mon Oct 13 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20081013-1
- Update to 0.1.1.20081013.
* Thu Oct 09 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20081009-1
- Update to 0.1.1.20081009.
* Mon Sep 01 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080901-1
- Update to 0.1.1.20080901.
* Sat Aug 23 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080823-1
- Update to 0.1.1.20080823.
* Fri Aug 15 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080815-1
- Update to 0.1.1.20080815.
* Tue Aug 12 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080812-1
- Update to 0.1.1.20080812.
* Thu Aug 07 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.0.20080810-1
- The first version.

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (ibus-m17n-1.3.4.tar.gz) = 9dbb5224fea377293a583e68598b36be4637698af0718c5117434d60b6a398bf94dc8cc2dbeef59c2d43bdab6f50e831bc60dd97112eed02105a3f2b9d55f026