Auto sync2gitlab import of ibus-libpinyin-1.10.0-2.el8.src.rpm
This commit is contained in:
parent
fcd9cee1ff
commit
26c506e897
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/ibus-libpinyin-1.10.0.tar.gz
|
158
ibus-libpinyin-fixes-period-and-comma-handling.patch
Normal file
158
ibus-libpinyin-fixes-period-and-comma-handling.patch
Normal file
@ -0,0 +1,158 @@
|
||||
From 1eb70ce12bed9d6b53c02ac8693ec52abe1d0216 Mon Sep 17 00:00:00 2001
|
||||
From: Peng Wu <pwu@redhat.com>
|
||||
Date: Wed, 20 Nov 2019 19:12:47 +0800
|
||||
Subject: [PATCH 1/3] fixes period handling
|
||||
|
||||
---
|
||||
src/PYFallbackEditor.cc | 1 +
|
||||
src/PYPPinyinEditor.cc | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/PYFallbackEditor.cc b/src/PYFallbackEditor.cc
|
||||
index e3dcfba..12985f4 100644
|
||||
--- a/src/PYFallbackEditor.cc
|
||||
+++ b/src/PYFallbackEditor.cc
|
||||
@@ -219,6 +219,7 @@ FallbackEditor::processKeyEvent (guint keyval, guint keycode, guint modifiers)
|
||||
case IBUS_A ... IBUS_Z:
|
||||
if (modifiers == 0) {
|
||||
if (!m_props.modeFull ())
|
||||
+ m_prev_committed_char = keyval;
|
||||
return FALSE;
|
||||
|
||||
commit (HalfFullConverter::toFull (keyval));
|
||||
diff --git a/src/PYPPinyinEditor.cc b/src/PYPPinyinEditor.cc
|
||||
index d2741b0..55bbb63 100644
|
||||
--- a/src/PYPPinyinEditor.cc
|
||||
+++ b/src/PYPPinyinEditor.cc
|
||||
@@ -130,7 +130,7 @@ PinyinEditor::processPunct (guint keyval, guint keycode,
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
- return TRUE;
|
||||
+ return FALSE;
|
||||
}
|
||||
|
||||
inline gboolean
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
||||
From 592b628000d9b58bb714ff9232d7d2ddf814cacf Mon Sep 17 00:00:00 2001
|
||||
From: Peng Wu <pwu@redhat.com>
|
||||
Date: Thu, 21 Nov 2019 14:45:28 +0800
|
||||
Subject: [PATCH 2/3] fixes period handling again
|
||||
|
||||
---
|
||||
src/PYFallbackEditor.cc | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/PYFallbackEditor.cc b/src/PYFallbackEditor.cc
|
||||
index 12985f4..3d03b49 100644
|
||||
--- a/src/PYFallbackEditor.cc
|
||||
+++ b/src/PYFallbackEditor.cc
|
||||
@@ -218,9 +218,10 @@ FallbackEditor::processKeyEvent (guint keyval, guint keycode, guint modifiers)
|
||||
case IBUS_a ... IBUS_z:
|
||||
case IBUS_A ... IBUS_Z:
|
||||
if (modifiers == 0) {
|
||||
- if (!m_props.modeFull ())
|
||||
+ if (!m_props.modeFull ()) {
|
||||
m_prev_committed_char = keyval;
|
||||
return FALSE;
|
||||
+ }
|
||||
|
||||
commit (HalfFullConverter::toFull (keyval));
|
||||
retval = TRUE;
|
||||
@@ -261,8 +262,10 @@ FallbackEditor::processKeyEvent (guint keyval, guint keycode, guint modifiers)
|
||||
keyval = IBUS_space;
|
||||
case IBUS_space:
|
||||
if (modifiers == 0) {
|
||||
- if (!m_props.modeFull ())
|
||||
+ if (!m_props.modeFull ()) {
|
||||
+ m_prev_committed_char = keyval;
|
||||
return FALSE;
|
||||
+ }
|
||||
|
||||
commit (" ");
|
||||
retval = TRUE;
|
||||
@@ -272,6 +275,9 @@ FallbackEditor::processKeyEvent (guint keyval, guint keycode, guint modifiers)
|
||||
default:
|
||||
break;
|
||||
}
|
||||
+
|
||||
+ if (!retval)
|
||||
+ m_prev_committed_char = keyval;
|
||||
return retval;
|
||||
}
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
||||
From 17121ad1dbc8c9be44d449c2d79179cdd90f6d7c Mon Sep 17 00:00:00 2001
|
||||
From: Peng Wu <pwu@redhat.com>
|
||||
Date: Fri, 29 Nov 2019 13:23:16 +0800
|
||||
Subject: [PATCH 3/3] fixes comma handling
|
||||
|
||||
---
|
||||
src/PYFallbackEditor.cc | 32 ++++++++++++++++++++++++--------
|
||||
1 file changed, 24 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/PYFallbackEditor.cc b/src/PYFallbackEditor.cc
|
||||
index 3d03b49..6020591 100644
|
||||
--- a/src/PYFallbackEditor.cc
|
||||
+++ b/src/PYFallbackEditor.cc
|
||||
@@ -76,13 +76,21 @@ FallbackEditor::processPunctForSimplifiedChinese (guint keyval, guint keycode, g
|
||||
m_double_quote = !m_double_quote;
|
||||
return TRUE;
|
||||
case ',':
|
||||
- commit (","); return TRUE;
|
||||
+ if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9') {
|
||||
+ m_prev_committed_char = keyval;
|
||||
+ return FALSE;
|
||||
+ } else {
|
||||
+ commit (",");
|
||||
+ return TRUE;
|
||||
+ }
|
||||
case '.':
|
||||
- if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9')
|
||||
+ if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9') {
|
||||
+ m_prev_committed_char = keyval;
|
||||
return FALSE;
|
||||
- else
|
||||
+ } else {
|
||||
commit ("。");
|
||||
- return TRUE;
|
||||
+ return TRUE;
|
||||
+ }
|
||||
case '<':
|
||||
commit ("《"); return TRUE;
|
||||
case '>':
|
||||
@@ -144,13 +152,21 @@ FallbackEditor::processPunctForTraditionalChinese (guint keyval, guint keycode,
|
||||
m_double_quote = !m_double_quote;
|
||||
return TRUE;
|
||||
case ',':
|
||||
- commit (","); return TRUE;
|
||||
+ if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9') {
|
||||
+ m_prev_committed_char = keyval;
|
||||
+ return FALSE;
|
||||
+ } else {
|
||||
+ commit (",");
|
||||
+ return TRUE;
|
||||
+ }
|
||||
case '.':
|
||||
- if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9')
|
||||
+ if (m_prev_committed_char >= '0' && m_prev_committed_char <= '9') {
|
||||
+ m_prev_committed_char = keyval;
|
||||
return FALSE;
|
||||
- else
|
||||
+ } else {
|
||||
commit ("。");
|
||||
- return TRUE;
|
||||
+ return TRUE;
|
||||
+ }
|
||||
case '<':
|
||||
commit ("《"); return TRUE;
|
||||
case '>':
|
||||
--
|
||||
2.26.2
|
||||
|
289
ibus-libpinyin.spec
Normal file
289
ibus-libpinyin.spec
Normal file
@ -0,0 +1,289 @@
|
||||
%global snapshot 0
|
||||
|
||||
Name: ibus-libpinyin
|
||||
Version: 1.10.0
|
||||
Release: 2%{?dist}
|
||||
Summary: Intelligent Pinyin engine based on libpinyin for IBus
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://github.com/libpinyin/ibus-libpinyin
|
||||
Source0: http://downloads.sourceforge.net/libpinyin/ibus-libpinyin/%{name}-%{version}.tar.gz
|
||||
%if %snapshot
|
||||
Patch0: ibus-libpinyin-1.10.x-head.patch
|
||||
%endif
|
||||
Patch1: ibus-libpinyin-fixes-period-and-comma-handling.patch
|
||||
|
||||
Requires: python3-gobject
|
||||
Requires: ibus >= 1.5.11
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: intltool
|
||||
BuildRequires: libtool
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: lua-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: ibus-devel >= 1.5.11
|
||||
BuildRequires: libpinyin-devel >= 2.1.0
|
||||
|
||||
# Requires(post): sqlite
|
||||
|
||||
Requires: libpinyin-data%{?_isa} >= 1.5.91
|
||||
|
||||
Obsoletes: ibus-pinyin < 1.4.0-17
|
||||
|
||||
%description
|
||||
It includes a Chinese Pinyin input method and a Chinese ZhuYin (Bopomofo)
|
||||
input method based on libpinyin for IBus.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%if %snapshot
|
||||
%patch0 -p1 -b .head
|
||||
%endif
|
||||
%patch1 -p1 -b .period
|
||||
|
||||
%build
|
||||
%configure --disable-static \
|
||||
--with-python=python3 \
|
||||
--disable-boost
|
||||
|
||||
# make -C po update-gmo
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%check
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup-libpinyin.desktop
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup-libbopomofo.desktop
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%post
|
||||
[ -x %{_bindir}/ibus ] && \
|
||||
%{_bindir}/ibus write-cache --system &>/dev/null || :
|
||||
|
||||
%postun
|
||||
[ -x %{_bindir}/ibus ] && \
|
||||
%{_bindir}/ibus write-cache --system &>/dev/null || :
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc AUTHORS COPYING README
|
||||
%{_datadir}/appdata/*.appdata.xml
|
||||
%{_datadir}/glib-2.0/schemas/*.gschema.xml
|
||||
%{_datadir}/applications/ibus-setup-libpinyin.desktop
|
||||
%{_datadir}/applications/ibus-setup-libbopomofo.desktop
|
||||
%{_libexecdir}/ibus-engine-libpinyin
|
||||
%{_libexecdir}/ibus-setup-libpinyin
|
||||
%{_datadir}/ibus-libpinyin/icons
|
||||
%{_datadir}/ibus-libpinyin/setup
|
||||
%{_datadir}/ibus-libpinyin/base.lua
|
||||
%{_datadir}/ibus-libpinyin/user.lua
|
||||
%{_datadir}/ibus-libpinyin/db/english.db
|
||||
%{_datadir}/ibus-libpinyin/db/strokes.db
|
||||
%dir %{_datadir}/ibus-libpinyin
|
||||
%dir %{_datadir}/ibus-libpinyin/db
|
||||
%{_datadir}/ibus/component/*
|
||||
|
||||
%changelog
|
||||
* Tue Oct 27 2020 Peng Wu <pwu@redhat.com> - 1.10.0-2
|
||||
- Fixes period and comma handling
|
||||
- Resolves: #1857750
|
||||
|
||||
* Tue Apr 17 2018 Peng Wu <pwu@redhat.com> - 1.10.0-1
|
||||
- Update to 1.10.0
|
||||
- bug fixes
|
||||
|
||||
* Thu Mar 22 2018 Peng Wu <pwu@redhat.com> - 1.9.91-1
|
||||
- Update to 1.9.91
|
||||
- migrate to use GSettings
|
||||
|
||||
* Thu Feb 8 2018 Peng Wu <pwu@redhat.com> - 1.9.3-1
|
||||
- Update to 1.9.3
|
||||
- translate input method name in ibus menu
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Sep 4 2017 Peng Wu <pwu@redhat.com> - 1.9.2-1
|
||||
- Update to 1.9.2
|
||||
|
||||
* Mon Aug 28 2017 Peng Wu <pwu@redhat.com> - 1.9.1-2
|
||||
- Fixes pinyin and bopomofo config
|
||||
|
||||
* Thu Aug 24 2017 Peng Wu <pwu@redhat.com> - 1.9.1-1
|
||||
- Update to 1.9.1
|
||||
- add sort candidate option to setup dialog
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Jun 9 2017 Peng Wu <pwu@redhat.com> - 1.9.0-2
|
||||
- Rebuilt for libpinyin 2.0.91
|
||||
|
||||
* Thu Apr 20 2017 Peng Wu <pwu@redhat.com> - 1.9.0-1
|
||||
- Update to 1.9.0
|
||||
|
||||
* Tue Mar 7 2017 Peng Wu <pwu@redhat.com> - 1.8.92-1
|
||||
- Update to 1.8.92
|
||||
- fixes config
|
||||
|
||||
* Tue Feb 28 2017 Peng Wu <pwu@redhat.com> - 1.8.91-2
|
||||
- Fixes config in setup dialog
|
||||
|
||||
* Wed Feb 15 2017 Peng Wu <pwu@redhat.com> - 1.8.91-1
|
||||
- Update to 1.8.91
|
||||
- use libpinyin 1.9.91
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Nov 30 2016 Peng Wu <pwu@redhat.com> - 1.8.1-1
|
||||
- Update to 1.8.1
|
||||
- change dconf key name to lower case
|
||||
|
||||
* Tue Nov 1 2016 Peng Wu <pwu@redhat.com> - 1.8.0-2
|
||||
- Rebuilt for libpinyin 1.6.91
|
||||
|
||||
* Wed Sep 7 2016 Peng Wu <pwu@redhat.com> - 1.8.0-1
|
||||
- Update to 1.8.0
|
||||
|
||||
* Tue Aug 9 2016 Peng Wu <pwu@redhat.com> - 1.7.92-2
|
||||
- Fixes crashes for Full Pinyin and Bopomofo
|
||||
|
||||
* Tue Aug 2 2016 Peng Wu <pwu@redhat.com> - 1.7.92-1
|
||||
- Update to 1.7.92
|
||||
|
||||
* Mon Jul 18 2016 Peng Wu <pwu@redhat.com> - 1.7.91-1
|
||||
- Update to 1.7.91
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Dec 17 2015 Peng Wu <pwu@redhat.com> - 1.7.4-1
|
||||
- Update to 1.7.4
|
||||
|
||||
* Mon Dec 14 2015 Peng Wu <pwu@redhat.com> - 1.7.3-3
|
||||
- Update patch
|
||||
|
||||
* Mon Dec 14 2015 Peng Wu <pwu@redhat.com> - 1.7.3-2
|
||||
- Fixes crash when use "Bopomofo" engine for first time
|
||||
|
||||
* Tue Nov 17 2015 Peng Wu <pwu@redhat.com> - 1.7.3-1
|
||||
- Update to 1.7.3
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Wed Jul 8 2015 Peng Wu <pwu@redhat.com> - 1.7.2-1
|
||||
- Update to 1.7.2
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.7.1-3
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Wed Mar 25 2015 Richard Hughes <rhughes@redhat.com> - 1.7.1-2
|
||||
- Register as an AppStream component.
|
||||
|
||||
* Wed Mar 25 2015 Peng Wu <pwu@redhat.com> - 1.7.1-1
|
||||
- Update 1.7.1
|
||||
|
||||
* Mon Mar 9 2015 Peng Wu <pwu@redhat.com> - 1.7.0-2
|
||||
- Fixes ibus-libpinyin upstream issue #33
|
||||
|
||||
* Wed Mar 4 2015 Peng Wu <pwu@redhat.com> - 1.7.0-1
|
||||
- Update to 1.7.0
|
||||
|
||||
* Thu Feb 12 2015 Peng Wu <pwu@redhat.com> - 1.6.99.20150203-2
|
||||
- Disable opencc according to upstream issue #26
|
||||
|
||||
* Tue Feb 3 2015 Peng Wu <pwu@redhat.com> - 1.6.99.20150203-1
|
||||
- Update to 1.6.99.20150203
|
||||
|
||||
* Wed Jan 7 2015 Peng Wu <pwu@redhat.com> - 1.6.92-5
|
||||
- Use opencc 1.0.2
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.92-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.92-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Nov 13 2013 Peng Wu <pwu@redhat.com> - 1.6.92-2
|
||||
- Fixes click of ibus-libpinyin indicator menu. (rhbz#1028905)
|
||||
|
||||
* Thu Oct 24 2013 Peng Wu <pwu@redhat.com> - 1.6.92-1
|
||||
- Update to 1.6.92
|
||||
|
||||
* Mon Oct 14 2013 Peng Wu <pwu@redhat.com> - 1.6.91-5
|
||||
- Update ibus-libpinyin-1.7.x-head.patch
|
||||
- Support ibus input purpose feature, fixes bug 1016438.
|
||||
- Remove pyxdg depends, fixes bug 1016941.
|
||||
|
||||
* Tue Oct 8 2013 Peng Wu <pwu@redhat.com> - 1.6.91-4
|
||||
- Write ibus system cache when install or uninstall
|
||||
|
||||
* Wed Jul 31 2013 Peng Wu <pwu@redhat.com> - 1.6.91-3
|
||||
- Fixes lua 5.2 compile
|
||||
|
||||
* Tue Jul 30 2013 Peng Wu <pwu@redhat.com> - 1.6.91-2
|
||||
- Update the symbol of the ibus indicator
|
||||
|
||||
* Sun Apr 28 2013 Peng Wu <pwu@redhat.com> - 1.6.91-1
|
||||
- Update to 1.6.91
|
||||
|
||||
* Tue Mar 19 2013 Peng Wu <pwu@redhat.com> - 1.5.92-1
|
||||
- Update to 1.5.92
|
||||
|
||||
* Mon Mar 4 2013 Peng Wu <pwu@redhat.com> - 1.5.91-1
|
||||
- Update to 1.5.91
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.93-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Nov 27 2012 Peng Wu <pwu@redhat.com> - 1.4.93-4
|
||||
- Fixes symbol icons
|
||||
|
||||
* Tue Nov 20 2012 Peng Wu <pwu@redhat.com> - 1.4.93-3
|
||||
- Fixes spec file
|
||||
|
||||
* Mon Oct 29 2012 Peng Wu <pwu@redhat.com> - 1.4.93-2
|
||||
- Fixes libpinyin Requires
|
||||
|
||||
* Mon Oct 15 2012 Peng Wu <pwu@redhat.com> - 1.4.93-1
|
||||
- Update to 1.4.93
|
||||
|
||||
* Mon Sep 17 2012 Peng Wu <pwu@redhat.com> - 1.4.92-1
|
||||
- Update to 1.4.92
|
||||
|
||||
* Thu Aug 16 2012 Peng Wu <pwu@redhat.com> - 1.4.91-1
|
||||
- Update to 1.4.91
|
||||
|
||||
* Mon Aug 06 2012 Peng Wu <pwu@redhat.com> - 1.4.2-1
|
||||
- Update to 1.4.2
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jul 16 2012 Peng Wu <pwu@redhat.com> - 1.4.1-4
|
||||
- Fixes obsoletes
|
||||
|
||||
* Wed Jul 11 2012 Peng Wu <pwu@redhat.com> - 1.4.1-3
|
||||
- Update ibus-libpinyin-1.4.x-head.patch
|
||||
|
||||
* Tue Jul 10 2012 Peng Wu <pwu@redhat.com> - 1.4.1-2
|
||||
- Update ibus-libpinyin-1.4.x-head.patch
|
||||
|
||||
* Wed Jul 04 2012 Peng Wu <pwu@redhat.com> - 1.4.1-1
|
||||
- Update to 1.4.1
|
||||
|
||||
* Fri Jun 01 2012 Peng Wu <pwu@redhat.com> - 1.4.0-1
|
||||
- The first version.
|
Loading…
Reference in New Issue
Block a user