ibus-hangul/ibus-hangul-HEAD.patch
2012-03-05 11:50:23 +09:00

519 lines
24 KiB
Diff

From 5ed10c1319f994536be4bbce2cf891be5a72d50a Mon Sep 17 00:00:00 2001
From: Choe Hwanjin <choe.hwanjin@gmail.com>
Date: Wed, 11 Jan 2012 23:00:14 +0900
Subject: [PATCH 1/7] Fix typo in README
---
README | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/README b/README
index 32481ef..3d64330 100644
--- a/README
+++ b/README
@@ -1,7 +1,7 @@
ibus-hangul
-----------
-ibus-hangul is a Korean input method engine for IBus. It is
+ibus-hangul is a Korean input method engine for IBus.
The official web site is:
--
1.7.7.6
From 64d68d37f61be45b187ef9de7855b423052cec96 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Thu, 26 Jan 2012 11:24:13 +0900
Subject: [PATCH 2/7] Don't abort ibus-setup-hangul with exception when
ibus-daemon is not running.
Fixes https://bugzilla.redhat.com/show_bug.cgi?id=784377
---
setup/main.py | 15 ++++++++++++---
1 files changed, 12 insertions(+), 3 deletions(-)
diff --git a/setup/main.py b/setup/main.py
index 9dd0238..068c048 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -32,8 +32,8 @@ from keycapturedialog import KeyCaptureDialog
_ = lambda a : gettext.dgettext(config.gettext_package, a)
class Setup ():
- def __init__ (self):
- self.__bus = ibus.Bus()
+ def __init__ (self, bus):
+ self.__bus = bus
self.__config = self.__bus.get_config()
self.__config.connect("value-changed", self.on_value_changed, None)
@@ -194,4 +194,13 @@ if __name__ == "__main__":
locale.bindtextdomain(config.gettext_package, config.localedir)
locale.bind_textdomain_codeset(config.gettext_package, "UTF-8")
- Setup().run()
+ try:
+ bus = ibus.Bus()
+ except:
+ message = _("IBus daemon is not started")
+ dialog = gtk.MessageDialog(type = gtk.MESSAGE_ERROR,
+ buttons = gtk.BUTTONS_CLOSE,
+ message_format = message)
+ dialog.run()
+ sys.exit(1)
+ Setup(bus).run()
--
1.7.7.6
From c29819ff8c435bfc26ce51da8b48bb39ba500850 Mon Sep 17 00:00:00 2001
From: Choe Hwanjin <choe.hwanjin@gmail.com>
Date: Mon, 6 Feb 2012 22:22:47 +0900
Subject: [PATCH 3/7] Update icon files
---
icons/ibus-hangul.png | Bin 4044 -> 3602 bytes
icons/ibus-hangul.svg | 74 ++++++++++++++++++++++++++++++++++++------------
2 files changed, 55 insertions(+), 19 deletions(-)
diff --git a/icons/ibus-hangul.png b/icons/ibus-hangul.png
index 81071c6..5383120 100644
Binary files a/icons/ibus-hangul.png and b/icons/ibus-hangul.png differ
diff --git a/icons/ibus-hangul.svg b/icons/ibus-hangul.svg
index bed691d..a882f73 100644
--- a/icons/ibus-hangul.svg
+++ b/icons/ibus-hangul.svg
@@ -1,5 +1,6 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
<svg
xmlns:dc="http://purl.org/dc/elements/1.1/"
xmlns:cc="http://creativecommons.org/ns#"
@@ -13,9 +14,10 @@
height="64px"
id="svg2383"
sodipodi:version="0.32"
- inkscape:version="0.46"
+ inkscape:version="0.48.1 r9760"
sodipodi:docname="ibus-hangul.svg"
- inkscape:output_extension="org.inkscape.output.svg.inkscape">
+ inkscape:output_extension="org.inkscape.output.svg.inkscape"
+ version="1.1">
<defs
id="defs2385">
<linearGradient
@@ -177,6 +179,36 @@
y2="-54.920265"
gradientUnits="userSpaceOnUse"
gradientTransform="translate(31.25,109.5)" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4023"
+ id="linearGradient3014"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="translate(31.25,109.5)"
+ x1="9.9628201"
+ y1="-81.170265"
+ x2="-11.264362"
+ y2="-54.920265" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4009"
+ id="linearGradient3017"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="translate(31.25,109.5)"
+ x1="-6.7380753"
+ y1="-65.728729"
+ x2="-9.4620743"
+ y2="-104.31674" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4031"
+ id="linearGradient3020"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="translate(31.25,109.5)"
+ x1="-8.8764257"
+ y1="-83.973495"
+ x2="25.90625"
+ y2="-79.973495" />
</defs>
<sodipodi:namedview
id="base"
@@ -186,18 +218,19 @@
inkscape:pageopacity="0.0"
inkscape:pageshadow="2"
inkscape:zoom="5.6568542"
- inkscape:cx="25.501144"
- inkscape:cy="32.124297"
+ inkscape:cx="26.119862"
+ inkscape:cy="32.265549"
inkscape:current-layer="layer1"
showgrid="false"
inkscape:document-units="px"
inkscape:grid-bbox="true"
- inkscape:window-width="679"
- inkscape:window-height="658"
+ inkscape:window-width="961"
+ inkscape:window-height="736"
inkscape:window-x="0"
- inkscape:window-y="25"
+ inkscape:window-y="30"
showguides="false"
- inkscape:snap-global="true">
+ inkscape:snap-global="true"
+ inkscape:window-maximized="0">
<inkscape:grid
type="xygrid"
id="grid3182" />
@@ -218,41 +251,44 @@
inkscape:label="Layer 1"
inkscape:groupmode="layer">
<g
- id="g2418">
+ id="g3792">
<path
transform="matrix(0.8249579,0,0,0.9513028,4.4592444,1.1376405)"
- d="M 69.119686,33.859573 A 33.941124,29.433319 0 1 1 1.2374382,33.859573 A 33.941124,29.433319 0 1 1 69.119686,33.859573 z"
+ d="m 69.119686,33.859573 a 33.941124,29.433319 0 1 1 -67.8822478,0 33.941124,29.433319 0 1 1 67.8822478,0 z"
sodipodi:ry="29.433319"
sodipodi:rx="33.941124"
sodipodi:cy="33.859573"
sodipodi:cx="35.178562"
id="path4041"
- style="fill:#b3b3b3;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0.1;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;filter:url(#filter4051)"
+ style="fill:#000000;fill-opacity:0.29803923;fill-rule:nonzero;stroke:none;filter:url(#filter4051)"
sodipodi:type="arc" />
<path
transform="matrix(0.9807549,0,0,0.9747195,-3.7227321,-2.4475105)"
- d="M 64.523493,34.389904 A 28.549437,28.726213 0 1 1 7.4246197,34.389904 A 28.549437,28.726213 0 1 1 64.523493,34.389904 z"
+ d="m 64.523493,34.389904 a 28.549437,28.726213 0 1 1 -57.0988733,0 28.549437,28.726213 0 1 1 57.0988733,0 z"
sodipodi:ry="28.726213"
sodipodi:rx="28.549437"
sodipodi:cy="34.389904"
sodipodi:cx="35.974056"
id="path4039"
- style="fill:#000000;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0.1;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
+ style="fill:#000000;fill-opacity:1;fill-rule:nonzero;stroke:none"
sodipodi:type="arc" />
<path
sodipodi:nodetypes="cscsscscc"
id="path3914"
- d="M 36.3125,7.75 C 31.002688,7.95047 25.216173,11.767047 23.0625,16.84375 C 20.630655,22.576172 24.923799,32.135987 31.4375,30.90625 C 34.83708,25.059985 43.720249,26.246499 47.46875,31.21875 C 50.788469,35.622239 50.60629,41.613832 48.125,46.3125 C 46.051511,50.238941 42.555817,54.140479 37.875,55.8125 C 48.966004,52.95672 57.15625,42.884758 57.15625,30.90625 C 57.15625,23.936894 54.381788,17.602212 49.875,12.96875 C 46.076648,9.682735 40.789748,7.58096 36.3125,7.75 z"
- style="fill:url(#linearGradient4482);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:0.01000000000000000;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ d="m 36.3125,7.75 c -5.309812,0.20047 -11.096327,4.017047 -13.25,9.09375 -2.431845,5.732422 1.861299,15.292237 8.375,14.0625 3.39958,-5.846265 12.282749,-4.659751 16.03125,0.3125 3.319719,4.403489 3.13754,10.395082 0.65625,15.09375 -2.073489,3.926441 -5.569183,7.827979 -10.25,9.5 11.091004,-2.85578 19.28125,-12.927742 19.28125,-24.90625 0,-6.969356 -2.774462,-13.304038 -7.28125,-17.9375 C 46.076648,9.682735 40.789748,7.58096 36.3125,7.75 z"
+ style="fill:url(#linearGradient3020);fill-opacity:1;fill-rule:evenodd;stroke:none"
+ inkscape:connector-curvature="0" />
<path
sodipodi:nodetypes="cscsscscc"
id="path4455"
- d="M 8.749353,38.529535 C 11.577871,43.027732 18.410358,46.447698 23.883746,45.774484 C 30.064093,45.014312 35.301532,36.149204 31.43723,30.906536 C 24.674426,30.885546 21.260393,22.599239 23.692238,16.866816 C 25.845912,11.79011 31.125873,8.95209 36.435684,8.75161 C 40.872826,8.58409 45.999504,9.66068 49.787925,12.878372 C 41.769245,4.70117 28.951547,2.64419 18.577855,8.63345 C 12.542216,12.11812 8.443448,17.688221 6.684148,23.907944 C 5.737555,28.840418 6.364336,34.736644 8.749353,38.529535 z"
- style="fill:url(#linearGradient4490);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:0.01000000000000000;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ d="m 8.749353,38.529535 c 2.828518,4.498197 9.661005,7.918163 15.134393,7.244949 6.180347,-0.760172 11.417786,-9.62528 7.553484,-14.867948 C 24.674426,30.885546 21.260393,22.599239 23.692238,16.866816 25.845912,11.79011 31.125873,8.95209 36.435684,8.75161 40.872826,8.58409 45.999504,9.66068 49.787925,12.878372 41.769245,4.70117 28.951547,2.64419 18.577855,8.63345 12.542216,12.11812 8.443448,17.688221 6.684148,23.907944 5.737555,28.840418 6.364336,34.736644 8.749353,38.529535 z"
+ style="fill:url(#linearGradient3017);fill-opacity:1;fill-rule:evenodd;stroke:none"
+ inkscape:connector-curvature="0" />
<path
id="path4457"
- d="M 48.124455,46.314422 C 50.605749,41.615755 50.809776,35.629209 47.490062,31.225723 C 43.74156,26.253472 34.835976,25.058764 31.436578,30.906169 C 34.799802,36.773424 29.330666,43.873217 23.15032,44.633389 C 17.676926,45.306606 12.579148,42.153035 9.750622,37.654844 C 7.386974,33.895926 5.75599,28.917798 6.648382,24.028083 C 3.576058,35.061065 8.20351,47.190007 18.577207,53.179258 C 24.612839,56.663939 31.486072,57.428526 37.75216,55.842263 C 42.497104,54.1958 46.032223,50.276353 48.124455,46.314422 z"
- style="fill:url(#linearGradient4498);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:0.01000000000000000;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ d="M 48.124455,46.314422 C 50.605749,41.615755 50.809776,35.629209 47.490062,31.225723 43.74156,26.253472 34.835976,25.058764 31.436578,30.906169 34.799802,36.773424 29.330666,43.873217 23.15032,44.633389 17.676926,45.306606 12.579148,42.153035 9.750622,37.654844 7.386974,33.895926 5.75599,28.917798 6.648382,24.028083 3.576058,35.061065 8.20351,47.190007 18.577207,53.179258 c 6.035632,3.484681 12.908865,4.249268 19.174953,2.663005 4.744944,-1.646463 8.280063,-5.56591 10.372295,-9.527841 z"
+ style="fill:url(#linearGradient3014);fill-opacity:1;fill-rule:evenodd;stroke:none"
+ inkscape:connector-curvature="0" />
</g>
</g>
</svg>
--
1.7.7.6
From 050c84ea5a7ba1dc19de34ee28ef02d00b7d0ad0 Mon Sep 17 00:00:00 2001
From: Choe Hwanjin <choe.hwanjin@gmail.com>
Date: Fri, 10 Feb 2012 23:02:49 +0900
Subject: [PATCH 4/7] Install icons to hicolor icon theme directory
This makes ibus-hangul's icons themable.
---
icons/Makefile.am | 10 +++++++---
setup/Makefile.am | 6 ++++++
src/hangul.xml.in.in | 2 +-
3 files changed, 14 insertions(+), 4 deletions(-)
diff --git a/icons/Makefile.am b/icons/Makefile.am
index 638af49..2414f13 100644
--- a/icons/Makefile.am
+++ b/icons/Makefile.am
@@ -23,10 +23,14 @@ icons_DATA = \
ibus-hangul.png \
ibus-hangul.svg \
$(NULL)
-
iconsdir = $(pkgdatadir)/icons
+hicolor_icon_64_DATA = ibus-hangul.png
+hicolor_icon_64dir = $(datadir)/icons/hicolor/64x64/apps
+
+hicolor_icon_scalable_DATA = ibus-hangul.svg
+hicolor_icon_scalabledir = $(datadir)/icons/hicolor/scalable/apps
+
EXTRA_DIST = \
- ibus-hangul.png \
- ibus-hangul.svg \
+ $(icon_DATA) \
$(NULL)
diff --git a/setup/Makefile.am b/setup/Makefile.am
index eedb507..f0fd9b3 100644
--- a/setup/Makefile.am
+++ b/setup/Makefile.am
@@ -43,6 +43,12 @@ desktop_DATA = ibus-setup-hangul.desktop
desktopdir = $(datadir)/applications
@INTLTOOL_DESKTOP_RULE@
+hicolor_icon_64_DATA = ibus-setup-hangul.png
+hicolor_icon_64dir = $(datadir)/icons/hicolor/64x64/apps
+
+hicolor_icon_scalable_DATA = ibus-setup-hangul.svg
+hicolor_icon_scalabledir = $(datadir)/icons/hicolor/scalable/apps
+
CLEANFILES = \
ibus-setup-hangul \
config.py \
diff --git a/src/hangul.xml.in.in b/src/hangul.xml.in.in
index a87df59..c634d62 100644
--- a/src/hangul.xml.in.in
+++ b/src/hangul.xml.in.in
@@ -16,7 +16,7 @@
<language>ko</language>
<license>GPL</license>
<author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
- <icon>${pkgdatadir}/icons/ibus-hangul.png</icon>
+ <icon>ibus-hangul</icon>
<layout>us</layout>
<longname>Korean</longname>
<description>Korean Input Method</description>
--
1.7.7.6
From 5b2fbc34ea17cfa71efaca42bcfdf1aedafd3587 Mon Sep 17 00:00:00 2001
From: Choe Hwanjin <choe.hwanjin@gmail.com>
Date: Sun, 12 Feb 2012 21:11:05 +0900
Subject: [PATCH 5/7] Install symbolic link to ibus-setup-hangul in bindir
ibus-setup scan $(libexecdir) to find setup executables.
So it is better to install ibus-setup-hangul into $(libexecdir).
---
configure.ac | 2 ++
setup/Makefile.am | 18 +++++++++++++++++-
2 files changed, 19 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
index 03e2496..a7a42d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,9 +45,11 @@ AM_DISABLE_STATIC
AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_CXX
+AC_PROG_LN_S
AC_ISC_POSIX
AC_HEADER_STDC
AM_PROG_LIBTOOL
+
IT_PROG_INTLTOOL([0.35.0])
# check ibus
diff --git a/setup/Makefile.am b/setup/Makefile.am
index f0fd9b3..b3b48af 100644
--- a/setup/Makefile.am
+++ b/setup/Makefile.am
@@ -29,7 +29,7 @@ nodist_setup_hangul_PYTHON = config.py
setup_hanguldir = $(pkgdatadir)/setup
-bin_SCRIPTS = ibus-setup-hangul
+libexec_SCRIPTS = ibus-setup-hangul
setuplibdir = $(pkglibdir)/setup
setuplib_PROGRAMS = hangul_keyboard_list
@@ -75,3 +75,19 @@ config.py: config.py.in Makefile
ibus-setup-hangul: ibus-setup-hangul.in config.py Makefile
sed -e 's&@SETUP_PKGDATADIR@&$(pkgdatadir)&g' $< > $@
+
+install-exec-hook:
+ $(mkdir_p) $(DESTDIR)$(bindir)
+ cd $(DESTDIR)$(bindir) && \
+ rm -f ibus-setup-hangul && \
+ a="$(bindir)"; b="$(libexecdir)"; updir=""; downdir=""; \
+ while test "$$a" != "$$b"; do \
+ bbase=`basename $$b`; \
+ updir="../$$updir"; \
+ downdir="$$bbase/$$downdir"; \
+ a=`dirname $$a`; b=`dirname $$b`; \
+ done; \
+ $(LN_S) $$updir$${downdir}ibus-setup-hangul ibus-setup-hangul
+
+uninstall-hook:
+ cd "$(DESTDIR)$(bindir)" && rm -f ibus-setup-hangul
--
1.7.7.6
From d3ca4607f87c5244f3ebddb99c2f8310da767eb7 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Tue, 14 Feb 2012 15:42:32 +0900
Subject: [PATCH 6/7] Define <symbol> in the component file.
---
src/hangul.xml.in.in | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/hangul.xml.in.in b/src/hangul.xml.in.in
index a87df59..0496f7f 100644
--- a/src/hangul.xml.in.in
+++ b/src/hangul.xml.in.in
@@ -21,6 +21,7 @@
<longname>Korean</longname>
<description>Korean Input Method</description>
<rank>99</rank>
+ <symbol>&#xD55C;</symbol>
</engine>
</engines>
--
1.7.7.6
From 86a2b75ac2c0f999bf987b99d4b4920342a2cbd1 Mon Sep 17 00:00:00 2001
From: Choe Hwanjin <choe.hwanjin@gmail.com>
Date: Sat, 18 Feb 2012 21:39:48 +0900
Subject: [PATCH 7/7] Update ibus-setup-hangul icon
Use alpha for shade instead of gray color.
This looks better on black background.
---
setup/ibus-setup-hangul.png | Bin 6979 -> 6771 bytes
setup/ibus-setup-hangul.svg | 59 ++++++++++++++++++++++++++++++++-----------
2 files changed, 44 insertions(+), 15 deletions(-)
diff --git a/setup/ibus-setup-hangul.png b/setup/ibus-setup-hangul.png
index b515dbe..e79bd4a 100644
Binary files a/setup/ibus-setup-hangul.png and b/setup/ibus-setup-hangul.png differ
diff --git a/setup/ibus-setup-hangul.svg b/setup/ibus-setup-hangul.svg
index 47beb5a..2195456 100644
--- a/setup/ibus-setup-hangul.svg
+++ b/setup/ibus-setup-hangul.svg
@@ -350,6 +350,36 @@
id="linearGradient3294"
xlink:href="#linearGradient4023"
inkscape:collect="always" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4023"
+ id="linearGradient3049"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.4704029,0,0,0.4704029,33.457768,70.288002)"
+ x1="9.9628201"
+ y1="-81.170265"
+ x2="-11.264362"
+ y2="-54.920265" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4009"
+ id="linearGradient3052"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.4704029,0,0,0.4704029,33.457768,70.288002)"
+ x1="-6.7380753"
+ y1="-65.728729"
+ x2="-9.4620743"
+ y2="-104.31674" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4031"
+ id="linearGradient3055"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.4704029,0,0,0.4704029,33.457768,70.288002)"
+ x1="-8.8764257"
+ y1="-83.973495"
+ x2="25.90625"
+ y2="-79.973495" />
</defs>
<sodipodi:namedview
inkscape:showpageshadow="false"
@@ -360,13 +390,13 @@
inkscape:pageopacity="0.0"
inkscape:pageshadow="2"
inkscape:zoom="5.6568542"
- inkscape:cx="38.205399"
+ inkscape:cx="11.246953"
inkscape:cy="20.457681"
inkscape:current-layer="layer1"
showgrid="false"
inkscape:grid-bbox="true"
inkscape:document-units="px"
- inkscape:window-width="808"
+ inkscape:window-width="942"
inkscape:window-height="655"
inkscape:window-x="362"
inkscape:window-y="25"
@@ -475,21 +505,20 @@
inkscape:r_cx="true"
inkscape:r_cy="true" />
<g
- transform="matrix(0.4704029,0,0,0.4704029,18.757677,18.778884)"
- id="g2418">
+ id="g3827">
<path
- transform="matrix(0.8249579,0,0,0.9513028,4.4592444,1.1376405)"
- d="m 69.119686,33.859573 c 0,16.255574 -15.195959,29.433319 -33.941124,29.433319 -18.745165,0 -33.9411238,-13.177745 -33.9411238,-29.433319 0,-16.255573 15.1959588,-29.4333187 33.9411238,-29.4333187 18.745165,0 33.941124,13.1777457 33.941124,29.4333187 z"
+ transform="matrix(0.38806259,0,0,0.4474956,20.855318,19.314033)"
+ d="m 69.119686,33.859573 a 33.941124,29.433319 0 1 1 -67.8822478,0 33.941124,29.433319 0 1 1 67.8822478,0 z"
sodipodi:ry="29.433319"
sodipodi:rx="33.941124"
sodipodi:cy="33.859573"
sodipodi:cx="35.178562"
id="path4041"
- style="fill:#b3b3b3;fill-opacity:1;fill-rule:nonzero;stroke:none;filter:url(#filter4051)"
+ style="fill:#000000;fill-opacity:0.3019608;fill-rule:nonzero;stroke:none;filter:url(#filter4051)"
sodipodi:type="arc" />
<path
- transform="matrix(0.9807549,0,0,0.9747195,-3.7227321,-2.4475105)"
- d="m 64.523493,34.389904 c 0,15.86505 -12.782018,28.726213 -28.549437,28.726213 -15.767418,0 -28.5494363,-12.861163 -28.5494363,-28.726213 0,-15.86505 12.7820183,-28.7262134 28.5494363,-28.7262134 15.767419,0 28.549437,12.8611634 28.549437,28.7262134 z"
+ transform="matrix(0.46134995,0,0,0.45851088,17.006493,17.627568)"
+ d="m 64.523493,34.389904 a 28.549437,28.726213 0 1 1 -57.0988733,0 28.549437,28.726213 0 1 1 57.0988733,0 z"
sodipodi:ry="28.726213"
sodipodi:rx="28.549437"
sodipodi:cy="34.389904"
@@ -501,19 +530,19 @@
inkscape:connector-curvature="0"
sodipodi:nodetypes="cscsscscc"
id="path3914"
- d="m 36.3125,7.75 c -5.309812,0.20047 -11.096327,4.017047 -13.25,9.09375 -2.431845,5.732422 1.861299,15.292237 8.375,14.0625 3.39958,-5.846265 12.282749,-4.659751 16.03125,0.3125 3.319719,4.403489 3.13754,10.395082 0.65625,15.09375 -2.073489,3.926441 -5.569183,7.827979 -10.25,9.5 11.091004,-2.85578 19.28125,-12.927742 19.28125,-24.90625 0,-6.969356 -2.774462,-13.304038 -7.28125,-17.9375 C 46.076648,9.682735 40.789748,7.58096 36.3125,7.75 z"
- style="fill:url(#linearGradient4482);fill-opacity:1;fill-rule:evenodd;stroke:none" />
+ d="m 35.839182,22.424506 c -2.497751,0.0943 -5.219744,1.889631 -6.232838,4.277727 -1.143947,2.696548 0.87556,7.193512 3.939624,6.615041 1.599172,-2.7501 5.777841,-2.191961 7.541147,0.147001 1.561605,2.071414 1.475908,4.889876 0.308702,7.100143 -0.975376,1.84701 -2.61976,3.682304 -4.82163,4.468828 5.21724,-1.343367 9.069956,-6.081247 9.069956,-11.715972 0,-3.278406 -1.305115,-6.258258 -3.425121,-8.437852 -1.786756,-1.545751 -4.273729,-2.534432 -6.37984,-2.454916 z"
+ style="fill:url(#linearGradient3055);fill-opacity:1;fill-rule:evenodd;stroke:none" />
<path
inkscape:connector-curvature="0"
sodipodi:nodetypes="cscsscscc"
id="path4455"
- d="m 8.749353,38.529535 c 2.828518,4.498197 9.661005,7.918163 15.134393,7.244949 6.180347,-0.760172 11.417786,-9.62528 7.553484,-14.867948 C 24.674426,30.885546 21.260393,22.599239 23.692238,16.866816 25.845912,11.79011 31.125873,8.95209 36.435684,8.75161 40.872826,8.58409 45.999504,9.66068 49.787925,12.878372 41.769245,4.70117 28.951547,2.64419 18.577855,8.63345 12.542216,12.11812 8.443448,17.688221 6.684148,23.907944 5.737555,28.840418 6.364336,34.736644 8.749353,38.529535 z"
- style="fill:url(#linearGradient4490);fill-opacity:1;fill-rule:evenodd;stroke:none" />
+ d="m 22.873398,36.903289 c 1.330543,2.115965 4.544565,3.724727 7.119262,3.408045 2.907254,-0.357587 5.37096,-4.52776 3.553181,-6.993926 -3.181242,-0.0099 -4.787213,-3.907776 -3.643267,-6.604325 1.013095,-2.388097 3.496804,-3.72311 5.994554,-3.817416 2.087245,-0.0788 4.498849,0.427629 6.280933,1.941241 -3.77201,-3.84658 -9.801492,-4.814189 -14.681307,-1.996824 -2.839182,1.639199 -4.767255,4.25939 -5.594834,7.185166 -0.44528,2.32025 -0.150441,5.093852 0.971478,6.878039 z"
+ style="fill:url(#linearGradient3052);fill-opacity:1;fill-rule:evenodd;stroke:none" />
<path
inkscape:connector-curvature="0"
id="path4457"
- d="M 48.124455,46.314422 C 50.605749,41.615755 50.809776,35.629209 47.490062,31.225723 43.74156,26.253472 34.835976,25.058764 31.436578,30.906169 34.799802,36.773424 29.330666,43.873217 23.15032,44.633389 17.676926,45.306606 12.579148,42.153035 9.750622,37.654844 7.386974,33.895926 5.75599,28.917798 6.648382,24.028083 3.576058,35.061065 8.20351,47.190007 18.577207,53.179258 c 6.035632,3.484681 12.908865,4.249268 19.174953,2.663005 4.744944,-1.646463 8.280063,-5.56591 10.372295,-9.527841 z"
- style="fill:url(#linearGradient3294);fill-opacity:1;fill-rule:evenodd;stroke:none" />
+ d="m 41.39556,40.565322 c 1.167208,-2.210266 1.263183,-5.026355 -0.29842,-7.097767 -1.763306,-2.338962 -5.952519,-2.900956 -7.551606,-0.150319 1.582071,2.759973 -0.990627,6.099737 -3.897879,6.457324 -2.574701,0.316683 -4.97271,-1.166766 -6.303257,-3.282728 -1.111867,-1.768206 -1.879087,-4.109932 -1.459303,-6.410068 -1.44523,5.189947 0.731537,10.895436 5.611354,13.712797 2.839179,1.639204 6.072368,1.998868 9.019954,1.252685 2.232035,-0.774501 3.894965,-2.61822 4.879157,-4.481924 z"
+ style="fill:url(#linearGradient3049);fill-opacity:1;fill-rule:evenodd;stroke:none" />
</g>
</g>
</svg>
--
1.7.7.6