ibus-hangul/ibus-hangul-python3.patch
2015-07-02 17:04:01 +09:00

27 lines
663 B
Diff

commit 1b4247fc0675450564c733e5caa40768cd413162
Author: Changwoo Ryu <cwryu@debian.org>
Date: Mon Oct 13 03:44:26 2014 +0900
Add configure --with-python option
It could be used to select python2 or python3
diff --git a/configure.ac b/configure.ac
index 57e4b20..a3e016c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,7 +67,12 @@ PKG_CHECK_MODULES(HANGUL, [
AC_PATH_PROG(ENV_PROG, env)
AC_SUBST(ENV_PROG)
-#check python
+# Define python version
+AC_ARG_WITH(python,
+ AS_HELP_STRING([--with-python[=PATH]],
+ [Select python2 or python3]),
+ [PYTHON=$with_python], []
+)
AM_PATH_PYTHON([2.5])
# define GETTEXT_* variables