Use Python 3 for install scripts
This commit is contained in:
parent
ff0d1c8146
commit
fbbe536b5b
27
ibus-hangul-autogen-remove-gettext.patch
Normal file
27
ibus-hangul-autogen-remove-gettext.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
commit fd0e3c8d0fd9f90dd3519be61e8d8916e9742c72
|
||||||
|
Author: Petr Viktorin <pviktori@redhat.com>
|
||||||
|
Date: Fri Jan 30 18:03:55 2015 +0100
|
||||||
|
|
||||||
|
Don't use both AM_GNU_GETTEXT and IT_PROG_INTLTOOL
|
||||||
|
|
||||||
|
When using IT_PROG_INTLTOOL using the gettect automake macros isn't
|
||||||
|
necessary. To make matters worse, when mixing the marcos both try to
|
||||||
|
generate po/Makefile.in.in. Recent versions of intltool detect when
|
||||||
|
gettext won and bails when building.
|
||||||
|
|
||||||
|
See e.g. similar bug in gdm: https://bugzilla.gnome.org/show_bug.cgi?id=711818
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index a3e016c..fb04bfd 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -80,9 +80,6 @@ GETTEXT_PACKAGE=ibus-hangul
|
||||||
|
AC_SUBST(GETTEXT_PACKAGE)
|
||||||
|
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
|
||||||
|
|
||||||
|
-AM_GNU_GETTEXT([external])
|
||||||
|
-AM_GNU_GETTEXT_VERSION([0.17])
|
||||||
|
-
|
||||||
|
|
||||||
|
# OUTPUT files
|
||||||
|
AC_CONFIG_FILES([ po/Makefile.in
|
26
ibus-hangul-python3.patch
Normal file
26
ibus-hangul-python3.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
commit 1b4247fc0675450564c733e5caa40768cd413162
|
||||||
|
Author: Changwoo Ryu <cwryu@debian.org>
|
||||||
|
Date: Mon Oct 13 03:44:26 2014 +0900
|
||||||
|
|
||||||
|
Add configure --with-python option
|
||||||
|
|
||||||
|
It could be used to select python2 or python3
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 57e4b20..a3e016c 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -67,7 +67,12 @@ PKG_CHECK_MODULES(HANGUL, [
|
||||||
|
AC_PATH_PROG(ENV_PROG, env)
|
||||||
|
AC_SUBST(ENV_PROG)
|
||||||
|
|
||||||
|
-#check python
|
||||||
|
+# Define python version
|
||||||
|
+AC_ARG_WITH(python,
|
||||||
|
+ AS_HELP_STRING([--with-python[=PATH]],
|
||||||
|
+ [Select python2 or python3]),
|
||||||
|
+ [PYTHON=$with_python], []
|
||||||
|
+)
|
||||||
|
AM_PATH_PYTHON([2.5])
|
||||||
|
|
||||||
|
# define GETTEXT_* variables
|
@ -3,17 +3,22 @@
|
|||||||
|
|
||||||
Name: ibus-hangul
|
Name: ibus-hangul
|
||||||
Version: 1.5.0
|
Version: 1.5.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: The Hangul engine for IBus input platform
|
Summary: The Hangul engine for IBus input platform
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://code.google.com/p/ibus/
|
URL: http://code.google.com/p/ibus/
|
||||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
# upstreamed patches
|
|
||||||
#Patch0: ibus-hangul-HEAD.patch
|
|
||||||
# not upstreamed patches
|
# not upstreamed patches
|
||||||
Patch1: ibus-hangul-setup-abspath.patch
|
Patch1: ibus-hangul-setup-abspath.patch
|
||||||
|
|
||||||
|
# Upstreamed: https://github.com/choehwanjin/ibus-hangul/pull/28
|
||||||
|
Patch2: ibus-hangul-python3.patch
|
||||||
|
|
||||||
|
# Upstreamed: https://github.com/choehwanjin/ibus-hangul/pull/34
|
||||||
|
Patch3: ibus-hangul-autogen-remove-gettext.patch
|
||||||
|
|
||||||
BuildRequires: gettext-devel, automake, libtool
|
BuildRequires: gettext-devel, automake, libtool
|
||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
@ -21,11 +26,13 @@ BuildRequires: libhangul-devel >= %{require_libhangul_version}
|
|||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: ibus-devel >= %{require_ibus_version}
|
BuildRequires: ibus-devel >= %{require_ibus_version}
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python3
|
||||||
|
BuildRequires: gnome-common
|
||||||
|
|
||||||
Requires: ibus >= %{require_ibus_version}
|
Requires: ibus >= %{require_ibus_version}
|
||||||
Requires: libhangul >= %{require_libhangul_version}
|
Requires: libhangul >= %{require_libhangul_version}
|
||||||
Requires: pygobject3
|
Requires: pygobject3
|
||||||
|
Requires: python3
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Hangul engine for IBus platform. It provides Korean input method from
|
The Hangul engine for IBus platform. It provides Korean input method from
|
||||||
@ -34,12 +41,15 @@ libhangul.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .setup-abspath
|
%patch1 -p1 -b .setup-abspath
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
# autopoint -f
|
# autopoint -f
|
||||||
# AUTOPOINT='intltoolize --automake --copy' autoreconf -fi
|
# AUTOPOINT='intltoolize --automake --copy' autoreconf -fi
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static %{?_with_hotkeys}
|
./autogen.sh
|
||||||
|
%configure --disable-static --with-python=python3 %{?_with_hotkeys}
|
||||||
# make -C po update-gmo
|
# make -C po update-gmo
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -116,6 +126,10 @@ fi
|
|||||||
%{_datadir}/icons/hicolor/*/apps/*
|
%{_datadir}/icons/hicolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 02 2015 Petr Viktorin <pviktori@redhat.com> - 1.5.0-4
|
||||||
|
- Use autogen in RPM build
|
||||||
|
- Use Python 3 for setup scripts
|
||||||
|
|
||||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-3
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user