diff --git a/ibus-hangul-gtk4-sync.patch b/ibus-hangul-gtk4-sync.patch
new file mode 100644
index 0000000..e95c8ca
--- /dev/null
+++ b/ibus-hangul-gtk4-sync.patch
@@ -0,0 +1,24 @@
+From c3cc3e08c3fe19b62fc4bdb2381ce3f3092c303b Mon Sep 17 00:00:00 2001
+From: Peng Wu <alexepico@gmail.com>
+Date: Thu, 4 Aug 2022 16:10:24 +0800
+Subject: [PATCH] Use synchornized process key event API for gtk4
+
+For gtk4 immodule, use synchornized process key event API for gtk4,
+and avoid to use forward key event API.
+---
+ src/engine.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+Index: ibus-hangul-1.5.4/src/engine.c
+===================================================================
+--- ibus-hangul-1.5.4.orig/src/engine.c
++++ ibus-hangul-1.5.4/src/engine.c
+@@ -1577,7 +1577,7 @@ ibus_hangul_engine_process_key_event (IB
+      *
+      * See: https://github.com/choehwanjin/ibus-hangul/issues/40
+      */
+-    if (use_event_forwarding) {
++    if (use_event_forwarding && !(hangul->caps & IBUS_CAP_SYNC_PROCESS_KEY)) {
+         if (!retval) {
+             ibus_engine_forward_key_event (engine, orig_keyval, keycode, modifiers);
+         }
diff --git a/ibus-hangul.spec b/ibus-hangul.spec
index 6faec45..34a250d 100644
--- a/ibus-hangul.spec
+++ b/ibus-hangul.spec
@@ -3,7 +3,7 @@
 
 Name:       ibus-hangul
 Version:    1.5.4
-Release:    11%{?dist}
+Release:    12%{?dist}
 Summary:    The Hangul engine for IBus input platform
 License:    GPLv2+
 URL:        https://github.com/libhangul/ibus-hangul
@@ -11,6 +11,7 @@ Source0:    https://github.com/libhangul/ibus-hangul/releases/download/%{version
 
 # not upstreamed patches
 Patch1:     ibus-hangul-setup-abspath.patch
+Patch2:     ibus-hangul-gtk4-sync.patch
 
 BuildRequires:  gettext-devel, automake, libtool
 BuildRequires:  libhangul-devel >= %{require_libhangul_version}
@@ -41,6 +42,7 @@ the functionality of the installed %{name} package.
 %prep
 %setup -q
 %patch1 -p1 -b .setup-abspath
+%patch2 -p1 -b .gtk4-sync
 
 %build
 ./autogen.sh
@@ -88,6 +90,10 @@ make check \
 %{_datadir}/installed-tests/ibus-hangul
 
 %changelog
+* Fri Aug 19 2022 Peng Wu <pwu@redhat.com> - 1.5.4-12
+- Fix forward key event issue with ibus-gtk4
+- Add ibus-hangul-gtk4-sync.patch
+
 * Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.4-11
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild