Update to 1.5.1
This commit is contained in:
parent
93135064b8
commit
81af824811
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ ibus-hangul-1.3.0.20100329.tar.gz
|
||||
/ibus-hangul-1.4.1.tar.gz
|
||||
/ibus-hangul-1.4.2.tar.gz
|
||||
/ibus-hangul-1.5.0.tar.gz
|
||||
/ibus-hangul-1.5.1.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
commit fd0e3c8d0fd9f90dd3519be61e8d8916e9742c72
|
||||
Author: Petr Viktorin <pviktori@redhat.com>
|
||||
Date: Fri Jan 30 18:03:55 2015 +0100
|
||||
|
||||
Don't use both AM_GNU_GETTEXT and IT_PROG_INTLTOOL
|
||||
|
||||
When using IT_PROG_INTLTOOL using the gettect automake macros isn't
|
||||
necessary. To make matters worse, when mixing the marcos both try to
|
||||
generate po/Makefile.in.in. Recent versions of intltool detect when
|
||||
gettext won and bails when building.
|
||||
|
||||
See e.g. similar bug in gdm: https://bugzilla.gnome.org/show_bug.cgi?id=711818
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a3e016c..fb04bfd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -80,9 +80,6 @@ GETTEXT_PACKAGE=ibus-hangul
|
||||
AC_SUBST(GETTEXT_PACKAGE)
|
||||
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
|
||||
|
||||
-AM_GNU_GETTEXT([external])
|
||||
-AM_GNU_GETTEXT_VERSION([0.17])
|
||||
-
|
||||
|
||||
# OUTPUT files
|
||||
AC_CONFIG_FILES([ po/Makefile.in
|
@ -1,80 +0,0 @@
|
||||
commit 1ddfdc1219586ed7ca11bed38827b38dacd88aef
|
||||
Author: Choe Hwanjin <choe.hwanjin@gmail.com>
|
||||
Date: Sat Dec 31 01:04:22 2016 +0900
|
||||
|
||||
Fix wrong space order problem
|
||||
|
||||
With IBUS_ENABLE_SYNC_MODE=1 option,
|
||||
'rksk ' is translated '가 나'.
|
||||
It's caused by limitations of IBus implementation.
|
||||
IBus can not send a result of other function inside a function
|
||||
in sync mode. The results of other functions will be delayed until
|
||||
the current function ends.
|
||||
This makes ibus-hangul do wrong.
|
||||
|
||||
We solve this problem by forwarding key event.
|
||||
It may be a hack, but we can not help it.
|
||||
That's the limitation of the framework.
|
||||
|
||||
https://github.com/choehwanjin/ibus-hangul/issues/42
|
||||
|
||||
diff --git a/src/engine.c b/src/engine.c
|
||||
index bd009cb..960bedc 100644
|
||||
--- a/src/engine.c
|
||||
+++ b/src/engine.c
|
||||
@@ -1190,7 +1190,54 @@ ibus_hangul_engine_process_key_event (IBusEngine *engine,
|
||||
ibus_hangul_engine_flush (hangul);
|
||||
}
|
||||
|
||||
- return retval;
|
||||
+ /* We always return TRUE here even if we didn't use this event.
|
||||
+ * Instead, we forward the event to clients.
|
||||
+ *
|
||||
+ * Because IBus has a problem with sync mode.
|
||||
+ * I think it's limitations of IBus implementation.
|
||||
+ * We call several engine functions(updating preedit text and committing
|
||||
+ * text) inside this function.
|
||||
+ * But clients cannot receive the results of other calls until this
|
||||
+ * function ends. Clients only get one result from a remote call at a time
|
||||
+ * because clients may run on event loop.
|
||||
+ * Clients may process this event first and then get the results which
|
||||
+ * may change the preedit text or commit text.
|
||||
+ * So the event order is broken.
|
||||
+ * Call order:
|
||||
+ * engine client
|
||||
+ * call process_key_event
|
||||
+ * begin process_key_event
|
||||
+ * call commit_text
|
||||
+ * call update_preedit_text
|
||||
+ * return the event as unused
|
||||
+ * receive the result of process_key_event
|
||||
+ * receive the result of commit_text
|
||||
+ * receive the result of update_preedit_text
|
||||
+ *
|
||||
+ * To solve this problem, we return TRUE as if we consumed this event.
|
||||
+ * After that, we forward this event to clients.
|
||||
+ * Then clients may get the events in correct order.
|
||||
+ * This approach is a kind of async processing.
|
||||
+ * Call order:
|
||||
+ * engine client
|
||||
+ * call process_key_event
|
||||
+ * begin process_key_event
|
||||
+ * call commit_text
|
||||
+ * call update_preedit_text
|
||||
+ * call forward_key_event
|
||||
+ * return the event as used
|
||||
+ * receive the result of process_key_event
|
||||
+ * receive the result of commit_text
|
||||
+ * receive the result of update_preedit_text
|
||||
+ * receive the forwarded key event
|
||||
+ *
|
||||
+ * See: https://github.com/choehwanjin/ibus-hangul/issues/40
|
||||
+ */
|
||||
+ if (!retval) {
|
||||
+ ibus_engine_forward_key_event (engine, keyval, keycode, modifiers);
|
||||
+ }
|
||||
+
|
||||
+ return TRUE;
|
||||
}
|
||||
|
||||
static void
|
@ -1,26 +0,0 @@
|
||||
commit 1b4247fc0675450564c733e5caa40768cd413162
|
||||
Author: Changwoo Ryu <cwryu@debian.org>
|
||||
Date: Mon Oct 13 03:44:26 2014 +0900
|
||||
|
||||
Add configure --with-python option
|
||||
|
||||
It could be used to select python2 or python3
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 57e4b20..a3e016c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -67,7 +67,12 @@ PKG_CHECK_MODULES(HANGUL, [
|
||||
AC_PATH_PROG(ENV_PROG, env)
|
||||
AC_SUBST(ENV_PROG)
|
||||
|
||||
-#check python
|
||||
+# Define python version
|
||||
+AC_ARG_WITH(python,
|
||||
+ AS_HELP_STRING([--with-python[=PATH]],
|
||||
+ [Select python2 or python3]),
|
||||
+ [PYTHON=$with_python], []
|
||||
+)
|
||||
AM_PATH_PYTHON([2.5])
|
||||
|
||||
# define GETTEXT_* variables
|
@ -2,8 +2,8 @@
|
||||
%global require_libhangul_version 0.1.0
|
||||
|
||||
Name: ibus-hangul
|
||||
Version: 1.5.0
|
||||
Release: 14%{?dist}
|
||||
Version: 1.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: The Hangul engine for IBus input platform
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -13,15 +13,6 @@ Source0: https://github.com/libhangul/ibus-hangul/releases/download/%{version
|
||||
# not upstreamed patches
|
||||
Patch1: ibus-hangul-setup-abspath.patch
|
||||
|
||||
# Upstreamed: https://github.com/choehwanjin/ibus-hangul/pull/28
|
||||
Patch2: ibus-hangul-python3.patch
|
||||
|
||||
# Upstreamed: https://github.com/choehwanjin/ibus-hangul/pull/34
|
||||
Patch3: ibus-hangul-autogen-remove-gettext.patch
|
||||
|
||||
# Pulled from upstream
|
||||
Patch4: ibus-hangul-fixes-order-problem.patch
|
||||
|
||||
BuildRequires: gettext-devel, automake, libtool
|
||||
BuildRequires: intltool
|
||||
BuildRequires: libtool
|
||||
@ -44,9 +35,6 @@ libhangul.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .setup-abspath
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# autopoint -f
|
||||
# AUTOPOINT='intltoolize --automake --copy' autoreconf -fi
|
||||
@ -116,12 +104,16 @@ desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/ibus-setup-hangu
|
||||
%{_libexecdir}/ibus-engine-hangul
|
||||
%{_libexecdir}/ibus-setup-hangul
|
||||
%{_datadir}/appdata/*.appdata.xml
|
||||
%{_datadir}/glib-2.0/schemas/*.gschema.xml
|
||||
%{_datadir}/ibus-hangul
|
||||
%{_datadir}/ibus/component/*
|
||||
%{_datadir}/applications/ibus-setup-hangul.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 30 2018 Peng Wu <pwu@redhat.com> - 1.5.1-1
|
||||
- Update to 1.5.1
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user