Update to 1.3.1-5; migrate to quilt.

This commit is contained in:
Daiki Ueno 2011-07-07 16:28:52 +09:00
parent 50f367e7d7
commit 571f9c094e
4 changed files with 65 additions and 90 deletions

View File

@ -1,19 +1,9 @@
From 6ce58d1d79e5b175865ee26794e9fc7ce576ce56 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Mon, 8 Nov 2010 14:12:35 +0900
Subject: [PATCH] Fix build with ibus-1.4.
This patch adds compatibility code for the API changes of IBusConfig and
IBusEngineDesc in ibus-1.3 -> ibus-1.4.
---
src/engine.c | 75 ++++++++++++++++++++++++++++++++++++++++++++++++---------
1 files changed, 63 insertions(+), 12 deletions(-)
diff --git a/src/engine.c b/src/engine.c
index 79db70f..a297e4d 100644
--- a/src/engine.c
+++ b/src/engine.c
@@ -111,7 +111,11 @@ static void ibus_hangul_engine_update_lookup_table
Patch to follow ibus 1.4 config API change.
Index: ibus-hangul-1.3.1/src/engine.c
===================================================================
--- ibus-hangul-1.3.1.orig/src/engine.c
+++ ibus-hangul-1.3.1/src/engine.c
@@ -111,7 +111,11 @@ static void ibus_hangul_engine_update_lo
static void ibus_config_value_changed (IBusConfig *config,
const gchar *section,
const gchar *name,
@ -25,7 +15,7 @@ index 79db70f..a297e4d 100644
gpointer user_data);
static void lookup_table_set_visible (IBusLookupTable *table,
@@ -136,6 +140,11 @@ static gboolean hanja_key_list_match (HanjaKeyList *list,
@@ -136,6 +140,11 @@ static gboolean hanja_key_list_match
static gboolean hanja_key_list_has_modifier (HanjaKeyList *list,
guint keyval);
@ -75,7 +65,7 @@ index 79db70f..a297e4d 100644
} else {
hanja_key_list_append(&hanja_keys, IBUS_Hangul_Hanja, 0);
hanja_key_list_append(&hanja_keys, IBUS_F9, 0);
@@ -963,27 +970,71 @@ ibus_hangul_engine_property_activate (IBusEngine *engine,
@@ -963,27 +970,71 @@ ibus_hangul_engine_property_activate (IB
}
}
@ -150,6 +140,3 @@ index 79db70f..a297e4d 100644
}
}
}
--
1.7.5.1

View File

@ -1,101 +1,86 @@
From e0463ae479a2d40b8f036ac81133585d2edd6e89 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@unixuser.org>
Date: Mon, 4 Jul 2011 18:42:43 +0900
Subject: [PATCH] Supply hotkeys and icon_symbol in engine desc.
---
configure.ac | 4 +++
m4/.gitignore | 1 +
m4/ibus.m4 | 51 ++++++++++++++++++++++++++++++++++++++++++++++++++
src/hangul.xml.in.in | 2 +
4 files changed, 58 insertions(+), 0 deletions(-)
create mode 100644 m4/ibus.m4
diff --git a/configure.ac b/configure.ac
index 043e150..edf19d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,10 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only
Patch to embed hotkeys and symbol property in component XML.
Index: ibus-hangul-1.3.1/configure.ac
===================================================================
--- ibus-hangul-1.3.1.orig/configure.ac
+++ ibus-hangul-1.3.1/configure.ac
@@ -75,6 +75,10 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GET
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.17])
+# hotkeys and icon-symbol properties in component xml
+# hotkeys and symbol properties in component xml
+IBUS_WITH_HOTKEYS([Control+space,Hangul])
+IBUS_ICON_SYMBOL([&xD55C;])
+IBUS_SET_SYMBOL([&xD55C;])
+
# OUTPUT files
AC_CONFIG_FILES([ po/Makefile.in
diff --git a/m4/ibus.m4 b/m4/ibus.m4
new file mode 100644
index 0000000..b92d000
Index: ibus-hangul-1.3.1/m4/ibus.m4
===================================================================
--- /dev/null
+++ b/m4/ibus.m4
@@ -0,0 +1,51 @@
+++ ibus-hangul-1.3.1/m4/ibus.m4
@@ -0,0 +1,52 @@
+# IBUS_WITH_HOTKEYS([DEFAULT])
+AC_DEFUN([IBUS_WITH_HOTKEYS], [
+ HOTKEYS_DEFAULT=m4_default([$1], [Control+space,Zenkaku_Hankaku])
+ IBUS_HOTKEYS_DEFAULT=m4_default([$1], [Control+space,Zenkaku_Hankaku])
+ AC_ARG_WITH(hotkeys,
+ [AC_HELP_STRING([--with-hotkeys=HOTKEYS],
+ [Use hotkeys for ibus bridge mode. (available value: yes/no/keys)])],
+ [with_hotkeys="$withval"],
+ [with_hotkeys="no"])
+ if test x$with_hotkeys = xno; then
+ HOTKEYS_XML="<!-- <hotkeys>${HOTKEYS_DEFAULT}</hotkeys> -->"
+ IBUS_HOTKEYS_XML="<!-- <hotkeys>${IBUS_HOTKEYS_DEFAULT}</hotkeys> -->"
+ elif test x$with_hotkeys = xyes -o x$with_hotkeys = x; then
+ HOTKEYS="$HOTKEYS_DEFAULT"
+ HOTKEYS_XML="<hotkeys>${HOTKEYS}</hotkeys>"
+ IBUS_HOTKEYS="$IBUS_HOTKEYS_DEFAULT"
+ IBUS_HOTKEYS_XML="<hotkeys>${IBUS_HOTKEYS}</hotkeys>"
+ else
+ HOTKEYS="$with_hotkeys"
+ HOTKEYS_XML="<hotkeys>${HOTKEYS}</hotkeys>"
+ IBUS_HOTKEYS="$with_hotkeys"
+ IBUS_HOTKEYS_XML="<hotkeys>${IBUS_HOTKEYS}</hotkeys>"
+ fi
+ if test x$HOTKEYS != x; then
+ AC_DEFINE_UNQUOTED(IBUS_HOTKEYS, ["$HOTKEYS"],
+ if test x$IBUS_HOTKEYS != x; then
+ AC_DEFINE_UNQUOTED(IBUS_IBUS_HOTKEYS, ["$IBUS_HOTKEYS"],
+ [IME specific hotkeys for IBus])
+ AC_SUBST(HOTKEYS)
+ AC_SUBST(IBUS_HOTKEYS)
+ fi
+ AC_SUBST(HOTKEYS_XML)
+ AC_SUBST(IBUS_HOTKEYS_XML)
+])
+
+# IBUS_ICON_SYMBOL(SYMBOL)
+AC_DEFUN([IBUS_ICON_SYMBOL], [
+ ICON_SYMBOL="$1"
+# IBUS_SET_SYMBOL(SYMBOL)
+AC_DEFUN([IBUS_SET_SYMBOL], [
+ IBUS_SYMBOL="$1"
+ if test x$PYTHON = x; then
+ AM_PATH_PYTHON([2.5])
+ fi
+ AC_MSG_CHECKING([if ibus supports icon symbol])
+ $PYTHON <<_ICON_SYMBOL_TEST
+ $PYTHON <<_IBUS_SYMBOL_TEST
+import ibus
+engine = ibus.EngineDesc('test')
+exit(not hasattr(engine, 'icon_symbol'))
+_ICON_SYMBOL_TEST
+exit(not hasattr(engine, 'symbol'))
+_IBUS_SYMBOL_TEST
+ if test $? -eq 0; then
+ ICON_SYMBOL_XML="<icon_symbol>${icon_symbol}</icon_symbol>"
+ IBUS_SYMBOL_XML="<symbol>${IBUS_SYMBOL}</symbol>"
+ AC_MSG_RESULT([yes])
+ else
+ ICON_SYMBOL_XML="<!-- <icon_symbol>${icon_symbol}</icon_symbol> -->"
+ ICON_SYMBOL=
+ IBUS_SYMBOL_XML="<!-- <symbol>${IBUS_SYMBOL}</symbol> -->"
+ IBUS_SYMBOL=
+ AC_MSG_RESULT([no])
+ fi
+ if test x$ICON_SYMBOL != x; then
+ AC_DEFINE_UNQUOTED([IBUS[]_ICON_SYMBOL], ["$ICON_SYMBOL"],
+ if test x$IBUS_SYMBOL != x; then
+ AC_DEFINE_UNQUOTED([IBUS_SYMBOL], ["$IBUS_SYMBOL"],
+ [Icon symbol string for IBus])
+ AC_SUBST(IBUS_SYMBOL)
+ fi
+ AC_SUBST(ICON_SYMBOL_XML)
+ AC_SUBST(IBUS_SYMBOL_XML)
+])
diff --git a/src/hangul.xml.in.in b/src/hangul.xml.in.in
index a87df59..00ba331 100644
--- a/src/hangul.xml.in.in
+++ b/src/hangul.xml.in.in
Index: ibus-hangul-1.3.1/src/hangul.xml.in.in
===================================================================
--- ibus-hangul-1.3.1.orig/src/hangul.xml.in.in
+++ ibus-hangul-1.3.1/src/hangul.xml.in.in
@@ -21,6 +21,8 @@
<longname>Korean</longname>
<description>Korean Input Method</description>
<rank>99</rank>
+ @HOTKEYS_XML@
+ @ICON_SYMBOL_XML@
+ @IBUS_HOTKEYS_XML@
+ @IBUS_SYMBOL_XML@
</engine>
</engines>
--
1.7.6

View File

@ -1,19 +1,23 @@
%define require_ibus_version 1.2.99
%define require_libhangul_version 0.0.10
%define have_bridge_hotkey 1
%global require_ibus_version 1.2.99
%global require_libhangul_version 0.0.10
%global have_bridge_hotkey 0
%if %have_bridge_hotkey
%global _with_hotkeys --with-hotkeys
%endif
Name: ibus-hangul
Version: 1.3.1
Release: 4%{?dist}
Release: 5%{?dist}
Summary: The Hangul engine for IBus input platform
License: GPLv2+
Group: System Environment/Libraries
URL: http://code.google.com/p/ibus/
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
# dummy source to keep quilt series file
Source1: series
Patch0: ibus-hangul-ibus-1.4.patch
%if %have_bridge_hotkey
Patch1: ibus-hangul-xx-icon-symbol.patch
%endif
BuildRequires: gettext-devel
BuildRequires: intltool
@ -35,17 +39,11 @@ libhangul.
%prep
%setup -q
%patch0 -p1 -b .ibus-1.4
%if %have_bridge_hotkey
%patch1 -p1 -b .icon-symbol
%endif
%build
%if %have_bridge_hotkey
autoreconf
%configure --disable-static --with-hotkeys
%else
%configure --disable-static
%endif
%configure --disable-static %{?_with_hotkeys}
# make -C po update-gmo
make %{?_smp_mflags}
@ -63,6 +61,9 @@ make DESTDIR=${RPM_BUILD_ROOT} install
%{_datadir}/ibus/component/*
%changelog
* Thu Jul 7 2011 Daiki Ueno <dueno@redhat.com> - 1.3.1-5
- don't specify --with-hotkeys.
* Mon Jul 4 2011 Daiki Ueno <dueno@redhat.com> - 1.3.1-4
- Added ibus-hangul-xx-icon-symbol.patch to enable the engine symbol & hotkeys.

2
series Normal file
View File

@ -0,0 +1,2 @@
ibus-hangul-ibus-1.4.patch
ibus-hangul-xx-icon-symbol.patch