Bug 1779129- Fix to install zipcode dict with anthy-unicode
This commit is contained in:
parent
1d2a83b9a2
commit
dd352ed511
@ -368,3 +368,79 @@ index 0000000..ae2b299
|
|||||||
--
|
--
|
||||||
2.21.0
|
2.21.0
|
||||||
|
|
||||||
|
From a2e418003b3733c5792fbab62a2e364a343a6e49 Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Wed, 4 Dec 2019 16:58:52 +0900
|
||||||
|
Subject: [PATCH] configure: Fix to install zipcode dict with anthy-unicode
|
||||||
|
(#1779129)
|
||||||
|
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
setup/python2/main.py | 6 +++---
|
||||||
|
setup/python3/main.py | 6 +++---
|
||||||
|
3 files changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 64afcc6..3fecd12 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -236,7 +236,7 @@ AC_ARG_WITH(anthy-zipcode,
|
||||||
|
[AC_HELP_STRING([--with-anthy-zipcode=FILE],
|
||||||
|
[file path of Anty zipcode.t])],
|
||||||
|
[ANTHY_ZIPCODE_FILE="$withval"],
|
||||||
|
- [ANTHY_ZIPCODE_FILE="$datadir/anthy/zipcode.t"])
|
||||||
|
+ [ANTHY_ZIPCODE_FILE="$datadir/$ANTHY_PC/zipcode.t"])
|
||||||
|
test "x$prefix" = xNONE && prefix=$ac_default_prefix
|
||||||
|
eval ANTHY_ZIPCODE_FILE=$ANTHY_ZIPCODE_FILE
|
||||||
|
eval ANTHY_ZIPCODE_FILE=$ANTHY_ZIPCODE_FILE
|
||||||
|
diff --git a/setup/python2/main.py b/setup/python2/main.py
|
||||||
|
index 1fb5a67..4e6b15b 100644
|
||||||
|
--- a/setup/python2/main.py
|
||||||
|
+++ b/setup/python2/main.py
|
||||||
|
@@ -4,8 +4,8 @@
|
||||||
|
#
|
||||||
|
# Copyright (c) 2007-2008 Peng Huang <shawn.p.huang@gmail.com>
|
||||||
|
# Copyright (c) 2009 Hideaki ABE <abe.sendai@gmail.com>
|
||||||
|
-# Copyright (c) 2010-2017 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||||
|
-# Copyright (c) 2007-2017 Red Hat, Inc.
|
||||||
|
+# Copyright (c) 2010-2019 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||||
|
+# Copyright (c) 2007-2019 Red Hat, Inc.
|
||||||
|
#
|
||||||
|
# This program is free software; you can redistribute it and/or modify
|
||||||
|
# it under the terms of the GNU General Public License as published by
|
||||||
|
@@ -1460,7 +1460,7 @@ class AnthySetup(object):
|
||||||
|
Gtk.MessageType.ERROR)
|
||||||
|
return
|
||||||
|
if not path.exists(dict_file[0]):
|
||||||
|
- self.__run_message_dialog(_("Your file does not exist: ") + dict_file,
|
||||||
|
+ self.__run_message_dialog(_("Your file does not exist: ") + dict_file[0],
|
||||||
|
Gtk.MessageType.ERROR)
|
||||||
|
return
|
||||||
|
|
||||||
|
diff --git a/setup/python3/main.py b/setup/python3/main.py
|
||||||
|
index 5fd3040..340e8ef 100644
|
||||||
|
--- a/setup/python3/main.py
|
||||||
|
+++ b/setup/python3/main.py
|
||||||
|
@@ -4,8 +4,8 @@
|
||||||
|
#
|
||||||
|
# Copyright (c) 2007-2008 Peng Huang <shawn.p.huang@gmail.com>
|
||||||
|
# Copyright (c) 2009 Hideaki ABE <abe.sendai@gmail.com>
|
||||||
|
-# Copyright (c) 2010-2017 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||||
|
-# Copyright (c) 2007-2017 Red Hat, Inc.
|
||||||
|
+# Copyright (c) 2010-2019 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||||
|
+# Copyright (c) 2007-2019 Red Hat, Inc.
|
||||||
|
#
|
||||||
|
# This program is free software; you can redistribute it and/or modify
|
||||||
|
# it under the terms of the GNU General Public License as published by
|
||||||
|
@@ -1454,7 +1454,7 @@ class AnthySetup(object):
|
||||||
|
Gtk.MessageType.ERROR)
|
||||||
|
return
|
||||||
|
if not path.exists(dict_file[0]):
|
||||||
|
- self.__run_message_dialog(_("Your file does not exist: ") + dict_file,
|
||||||
|
+ self.__run_message_dialog(_("Your file does not exist: ") + dict_file[0],
|
||||||
|
Gtk.MessageType.ERROR)
|
||||||
|
return
|
||||||
|
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
||||||
|
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
Name: ibus-anthy
|
Name: ibus-anthy
|
||||||
Version: 1.5.11
|
Version: 1.5.11
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: The Anthy engine for IBus input platform
|
Summary: The Anthy engine for IBus input platform
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/ibus/ibus/wiki
|
URL: https://github.com/ibus/ibus/wiki
|
||||||
@ -205,6 +205,9 @@ touch --no-create %{_datadir}/icons/hicolor || :
|
|||||||
%{_datadir}/installed-tests/%{name}
|
%{_datadir}/installed-tests/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 04 2019 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.11-5
|
||||||
|
- Bug 1779129- Fix to install zipcode dict with anthy-unicode
|
||||||
|
|
||||||
* Thu Oct 17 2019 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.11-4
|
* Thu Oct 17 2019 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.11-4
|
||||||
- Add CI
|
- Add CI
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user