Updated ibus-anthy-xx-icon-symbol.patch to replace icon_symbol with symbol.
This commit is contained in:
parent
1b976a9524
commit
9e2d96f8b3
@ -1,27 +1,6 @@
|
|||||||
--- ibus-anthy-1.2.4/engine/anthy.xml.in.in.orig 2011-06-21 18:24:39.000000000 +0900
|
|
||||||
+++ ibus-anthy-1.2.4/engine/anthy.xml.in.in 2011-06-22 12:56:29.000000000 +0900
|
|
||||||
@@ -22,6 +22,8 @@
|
|
||||||
<longname>Anthy</longname>
|
|
||||||
<description>Anthy Input Method</description>
|
|
||||||
<rank>99</rank>
|
|
||||||
+ @HOTKEYS@
|
|
||||||
+ @ICON_SYMBOL@
|
|
||||||
</engine>
|
|
||||||
</engines>
|
|
||||||
</component>
|
|
||||||
--- ibus-anthy-1.2.4/engine/engine.py.orig 2011-06-22 13:16:30.000000000 +0900
|
|
||||||
+++ ibus-anthy-1.2.4/engine/engine.py 2011-06-22 13:16:35.000000000 +0900
|
|
||||||
@@ -626,6 +626,7 @@ class Engine(ibus.EngineBase):
|
|
||||||
self.__input_mode = mode
|
|
||||||
prop = self.__prop_dict[u"InputMode"]
|
|
||||||
prop.label = label
|
|
||||||
+ self.set_icon_symbol(label)
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
self.__reset()
|
|
||||||
--- ibus-anthy-1.2.4/configure.ac.orig 2011-06-21 18:25:58.000000000 +0900
|
--- ibus-anthy-1.2.4/configure.ac.orig 2011-06-21 18:25:58.000000000 +0900
|
||||||
+++ ibus-anthy-1.2.4/configure.ac 2011-06-22 13:14:26.000000000 +0900
|
+++ ibus-anthy-1.2.4/configure.ac 2011-06-30 18:10:50.000000000 +0900
|
||||||
@@ -122,6 +122,36 @@ AC_ARG_WITH(kasumi-icon,
|
@@ -122,6 +122,37 @@ AC_ARG_WITH(kasumi-icon,
|
||||||
[KASUMI_ICON_FILE="$datadir/pixmaps/kasumi.png"])
|
[KASUMI_ICON_FILE="$datadir/pixmaps/kasumi.png"])
|
||||||
AC_SUBST(KASUMI_ICON_FILE)
|
AC_SUBST(KASUMI_ICON_FILE)
|
||||||
|
|
||||||
@ -43,22 +22,23 @@
|
|||||||
+fi
|
+fi
|
||||||
+AC_SUBST(HOTKEYS)
|
+AC_SUBST(HOTKEYS)
|
||||||
+
|
+
|
||||||
+ICON_SYMBOL_TEST="import ibus
|
+SYMBOL_TEST="import ibus
|
||||||
+engine = ibus.EngineDesc('test')
|
+engine = ibus.EngineDesc('test')
|
||||||
+print hasattr(engine, 'icon_symbol')
|
+exit(not hasattr(engine, 'symbol'))
|
||||||
+"
|
+"
|
||||||
+HAS_ICON_SYMBOL=`$PYTHON -c "$ICON_SYMBOL_TEST"`
|
+$PYTHON -c "$SYMBOL_TEST"
|
||||||
+if test x"$HAS_ICON_SYMBOL" = x"True"; then
|
+if test $? -eq 0; then
|
||||||
+ ICON_SYMBOL="<icon_symbol>あ</icon_symbol>"
|
+ SYMBOL="<symbol>\xe3\x81\x82</symbol>"
|
||||||
+else
|
+else
|
||||||
+ ICON_SYMBOL="<!-- <icon_symbol>あ</icon_symbol> -->"
|
+ SYMBOL="<!-- <symbol>\xe3\x81\x82</symbol> -->"
|
||||||
+fi
|
+fi
|
||||||
+AC_SUBST(ICON_SYMBOL)
|
+SYMBOL=`printf "$SYMBOL"`
|
||||||
|
+AC_SUBST(SYMBOL)
|
||||||
+
|
+
|
||||||
dnl - define GETTEXT_* variables
|
dnl - define GETTEXT_* variables
|
||||||
GETTEXT_PACKAGE=ibus-anthy
|
GETTEXT_PACKAGE=ibus-anthy
|
||||||
AC_SUBST(GETTEXT_PACKAGE)
|
AC_SUBST(GETTEXT_PACKAGE)
|
||||||
@@ -146,3 +176,15 @@ m4/Makefile
|
@@ -146,3 +177,15 @@ m4/Makefile
|
||||||
])
|
])
|
||||||
|
|
||||||
AC_OUTPUT
|
AC_OUTPUT
|
||||||
@ -72,5 +52,16 @@
|
|||||||
+KASUMI_EXEC_FILE $KASUMI_EXEC_FILE
|
+KASUMI_EXEC_FILE $KASUMI_EXEC_FILE
|
||||||
+KASUMI_ICON_FILE $KASUMI_ICON_FILE
|
+KASUMI_ICON_FILE $KASUMI_ICON_FILE
|
||||||
+HOTKEYS $HOTKEYS
|
+HOTKEYS $HOTKEYS
|
||||||
+ICON_SYMBOL $ICON_SYMBOL
|
+SYMBOL $SYMBOL
|
||||||
+"
|
+"
|
||||||
|
--- ibus-anthy-1.2.4/engine/anthy.xml.in.in.orig 2011-06-21 18:24:39.000000000 +0900
|
||||||
|
+++ ibus-anthy-1.2.4/engine/anthy.xml.in.in 2011-06-30 17:37:45.000000000 +0900
|
||||||
|
@@ -22,6 +22,8 @@
|
||||||
|
<longname>Anthy</longname>
|
||||||
|
<description>Anthy Input Method</description>
|
||||||
|
<rank>99</rank>
|
||||||
|
+ @HOTKEYS@
|
||||||
|
+ @SYMBOL@
|
||||||
|
</engine>
|
||||||
|
</engines>
|
||||||
|
</component>
|
||||||
|
Loading…
Reference in New Issue
Block a user