Bumped to 1.5.4
This commit is contained in:
parent
d628c8fb36
commit
880fbf693a
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ ibus-anthy.png
|
|||||||
/ibus-anthy-1.5.1.tar.gz
|
/ibus-anthy-1.5.1.tar.gz
|
||||||
/ibus-anthy-1.5.2.tar.gz
|
/ibus-anthy-1.5.2.tar.gz
|
||||||
/ibus-anthy-1.5.3.tar.gz
|
/ibus-anthy-1.5.3.tar.gz
|
||||||
|
/ibus-anthy-1.5.4.tar.gz
|
||||||
|
@ -1,83 +0,0 @@
|
|||||||
--- ibus-anthy/engine/engine.py.orig 2012-12-31 00:46:13.000000000 +0900
|
|
||||||
+++ ibus-anthy/engine/engine.py 2013-01-16 17:53:40.922164419 +0900
|
|
||||||
@@ -233,7 +233,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
{ 'description' : _("Input mode"), 'symbol' : symbol }
|
|
||||||
input_mode_prop = IBus.Property(key=u'InputMode',
|
|
||||||
prop_type=IBus.PropType.MENU,
|
|
||||||
- label=IBus.Text.new_from_string(label),
|
|
||||||
+ label=IBus.Text.new_from_string(symbol),
|
|
||||||
symbol=IBus.Text.new_from_string(symbol),
|
|
||||||
icon='',
|
|
||||||
tooltip=IBus.Text.new_from_string(_("Switch input mode")),
|
|
||||||
@@ -321,7 +321,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
{ 'description' : _("Typing method"), 'symbol' : symbol }
|
|
||||||
typing_mode_prop = IBus.Property(key=u'TypingMode',
|
|
||||||
prop_type=IBus.PropType.MENU,
|
|
||||||
- label=IBus.Text.new_from_string(label),
|
|
||||||
+ label=IBus.Text.new_from_string(symbol),
|
|
||||||
symbol=IBus.Text.new_from_string(symbol),
|
|
||||||
icon='',
|
|
||||||
tooltip=IBus.Text.new_from_string(_("Switch typing method")),
|
|
||||||
@@ -388,7 +388,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
{ 'description' : _("Segment mode"), 'symbol' : symbol }
|
|
||||||
segment_mode_prop = IBus.Property(key=u'SegmentMode',
|
|
||||||
prop_type=IBus.PropType.MENU,
|
|
||||||
- label=IBus.Text.new_from_string(label),
|
|
||||||
+ label=IBus.Text.new_from_string(symbol),
|
|
||||||
symbol=IBus.Text.new_from_string(symbol),
|
|
||||||
icon=None,
|
|
||||||
tooltip=IBus.Text.new_from_string(_("Switch conversion mode")),
|
|
||||||
@@ -464,7 +464,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
{ 'description' : _("Dictionary mode"), 'symbol' : short_label }
|
|
||||||
dict_mode_prop = IBus.Property(key=u'DictMode',
|
|
||||||
prop_type=IBus.PropType.MENU,
|
|
||||||
- label=IBus.Text.new_from_string(label),
|
|
||||||
+ label=IBus.Text.new_from_string(short_label),
|
|
||||||
symbol=IBus.Text.new_from_string(short_label),
|
|
||||||
icon=None,
|
|
||||||
tooltip=IBus.Text.new_from_string(_("Switch dictionary")),
|
|
||||||
@@ -793,7 +793,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
Engine.__input_mode = mode
|
|
||||||
prop = self.__prop_dict[u'InputMode']
|
|
||||||
prop.set_symbol(IBus.Text.new_from_string(symbol))
|
|
||||||
- prop.set_label(IBus.Text.new_from_string(label))
|
|
||||||
+ prop.set_label(IBus.Text.new_from_string(symbol))
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
self.__reset()
|
|
||||||
@@ -821,7 +821,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
Engine.__typing_mode = mode
|
|
||||||
prop = self.__prop_dict[u'TypingMode']
|
|
||||||
prop.set_symbol(IBus.Text.new_from_string(symbol))
|
|
||||||
- prop.set_label(IBus.Text.new_from_string(label))
|
|
||||||
+ prop.set_label(IBus.Text.new_from_string(symbol))
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
self.__reset()
|
|
||||||
@@ -846,7 +846,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
_prop.set_state(IBus.PropState.CHECKED)
|
|
||||||
self.update_property(_prop)
|
|
||||||
prop.set_symbol(IBus.Text.new_from_string(symbol))
|
|
||||||
- prop.set_label(IBus.Text.new_from_string(label))
|
|
||||||
+ prop.set_label(IBus.Text.new_from_string(symbol))
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
def __segment_mode_activate(self, prop_name, state):
|
|
||||||
@@ -871,7 +871,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
Engine.__segment_mode = mode
|
|
||||||
prop = self.__prop_dict[u'SegmentMode']
|
|
||||||
prop.set_symbol(IBus.Text.new_from_string(symbol))
|
|
||||||
- prop.set_label(IBus.Text.new_from_string(label))
|
|
||||||
+ prop.set_label(IBus.Text.new_from_string(symbol))
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
self.__reset()
|
|
||||||
@@ -936,7 +936,7 @@ class Engine(IBus.EngineSimple):
|
|
||||||
label = _("%(description)s (%(symbol)s)") % \
|
|
||||||
{ 'description' : _("Dictionary mode"), 'symbol' : symbol }
|
|
||||||
prop.set_symbol(IBus.Text.new_from_string(symbol))
|
|
||||||
- prop.set_label(IBus.Text.new_from_string(label))
|
|
||||||
+ prop.set_label(IBus.Text.new_from_string(symbol))
|
|
||||||
self.update_property(prop)
|
|
||||||
|
|
||||||
def __argb(self, a, r, g, b):
|
|
103
ibus-anthy.spec
103
ibus-anthy.spec
@ -1,5 +1,5 @@
|
|||||||
%global sub_version 1.0
|
%global sub_version 1.0
|
||||||
%global require_ibus_version 1.5.1
|
%global require_ibus_version 1.5.3
|
||||||
%global have_default_layout 1
|
%global have_default_layout 1
|
||||||
%global have_bridge_hotkey 1
|
%global have_bridge_hotkey 1
|
||||||
|
|
||||||
@ -9,22 +9,23 @@
|
|||||||
%global with_ctrl_space 0
|
%global with_ctrl_space 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: ibus-anthy
|
%if (0%{?fedora} > 19 || 0%{?rhel} > 6)
|
||||||
Version: 1.5.3
|
%global with_python_pkg 1
|
||||||
Release: 2%{?dist}
|
%else
|
||||||
Summary: The Anthy engine for IBus input platform
|
%global with_python_pkg 0
|
||||||
License: GPLv2+
|
%endif
|
||||||
Group: System Environment/Libraries
|
|
||||||
URL: http://code.google.com/p/ibus/
|
Name: ibus-anthy
|
||||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
Version: 1.5.4
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: The Anthy engine for IBus input platform
|
||||||
|
License: GPLv2+
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
URL: http://code.google.com/p/ibus/
|
||||||
|
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# Upstreamed patches.
|
# Upstreamed patches.
|
||||||
# Patch0: %%{name}-HEAD.patch
|
# Patch0: %%{name}-HEAD.patch
|
||||||
|
|
||||||
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
|
|
||||||
# IBusProperty.symbol is not used by ibus-gjs
|
|
||||||
Patch91: %{name}-xx-disable-prop-symbol.patch
|
|
||||||
%endif
|
|
||||||
|
|
||||||
BuildRequires: anthy-devel
|
BuildRequires: anthy-devel
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
@ -37,21 +38,34 @@ BuildRequires: libtool
|
|||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
|
|
||||||
Requires: ibus >= %{require_ibus_version}
|
Requires: ibus >= %{require_ibus_version}
|
||||||
Requires: anthy
|
Requires: kasumi
|
||||||
Requires: kasumi
|
Requires: anthy
|
||||||
Requires: pygobject3
|
Requires: pygobject3
|
||||||
|
%if %with_python_pkg
|
||||||
|
Requires: %{name}-python = %{version}-%{release}
|
||||||
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Anthy engine for IBus platform. It provides Japanese input method from
|
The Anthy engine for IBus platform. It provides Japanese input method from
|
||||||
a library of the Anthy.
|
a library of the Anthy.
|
||||||
|
|
||||||
|
%if %with_python_pkg
|
||||||
|
%package python
|
||||||
|
Summary: Anthy Python files for IBus
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description python
|
||||||
|
This package contains the Anthy Python files for IBus
|
||||||
|
%endif
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development tools for ibus
|
Summary: Development tools for IBus
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: glib2-devel
|
Requires: glib2-devel
|
||||||
Requires: anthy-devel
|
Requires: anthy-devel
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The ibus-anthy-devel package contains .so file and .gir files
|
The ibus-anthy-devel package contains .so file and .gir files
|
||||||
@ -61,10 +75,6 @@ for developers.
|
|||||||
%setup -q
|
%setup -q
|
||||||
# %%patch0 -p1
|
# %%patch0 -p1
|
||||||
|
|
||||||
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
|
|
||||||
%patch91 -p1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
%if %have_default_layout
|
%if %have_default_layout
|
||||||
@ -82,17 +92,6 @@ for developers.
|
|||||||
# make -C po update-gmo
|
# make -C po update-gmo
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
# home [dot] corp [dot] redhat [dot] com/wiki/rpmdiff-multilib
|
|
||||||
if test -f engine/_config.py.in -a -f engine/_config.py ; then
|
|
||||||
touch -r engine/_config.py.in engine/_config.py
|
|
||||||
fi
|
|
||||||
if test -f setup/_config.py.in -a -f setup/_config.py ; then
|
|
||||||
touch -r setup/_config.py.in setup/_config.py
|
|
||||||
fi
|
|
||||||
if test -f setup/anthyprefs.py.in -a -f setup/anthyprefs.py ; then
|
|
||||||
touch -r setup/anthyprefs.py.in setup/anthyprefs.py
|
|
||||||
fi
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libanthygobject-%{sub_version}.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/libanthygobject-%{sub_version}.la
|
||||||
@ -109,6 +108,8 @@ desktop-file-validate \
|
|||||||
touch --no-create %{_datadir}/icons/hicolor || :
|
touch --no-create %{_datadir}/icons/hicolor || :
|
||||||
[ -x %{_bindir}/gtk-update-icon-cache ] && \
|
[ -x %{_bindir}/gtk-update-icon-cache ] && \
|
||||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||||
|
[ -x %{_bindir}/ibus ] && \
|
||||||
|
%{_bindir}/ibus write-cache --system &>/dev/null || :
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
@ -116,25 +117,45 @@ touch --no-create %{_datadir}/icons/hicolor || :
|
|||||||
touch --no-create %{_datadir}/icons/hicolor || :
|
touch --no-create %{_datadir}/icons/hicolor || :
|
||||||
[ -x %{_bindir}/gtk-update-icon-cache ] && \
|
[ -x %{_bindir}/gtk-update-icon-cache ] && \
|
||||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||||
|
[ -x %{_bindir}/ibus ] && \
|
||||||
|
%{_bindir}/ibus write-cache --system &>/dev/null || :
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc AUTHORS COPYING README
|
%doc AUTHORS COPYING README
|
||||||
# dir {python2_sitearch}/ibus
|
# dir {python2_sitearch}/ibus
|
||||||
%{_libdir}/libanthygobject-%{sub_version}.so.*
|
%{_libdir}/libanthygobject-%{sub_version}.so.*
|
||||||
%{_libdir}/girepository-1.0/Anthy*.typelib
|
%{_libdir}/girepository-1.0/Anthy*.typelib
|
||||||
|
%if %with_python_pkg
|
||||||
|
%dir %{_datadir}/ibus-anthy
|
||||||
|
%{_datadir}/ibus-anthy/dicts
|
||||||
|
%else
|
||||||
%{_libexecdir}/ibus-*-anthy
|
%{_libexecdir}/ibus-*-anthy
|
||||||
%{_datadir}/applications/ibus-setup-anthy.desktop
|
%{_datadir}/applications/ibus-setup-anthy.desktop
|
||||||
%{_datadir}/ibus-anthy
|
%{_datadir}/ibus-anthy
|
||||||
%{_datadir}/ibus/component/*
|
%{_datadir}/ibus/component/*
|
||||||
|
%endif
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/ibus-anthy.svg
|
%{_datadir}/icons/hicolor/scalable/apps/ibus-anthy.svg
|
||||||
|
|
||||||
|
%if %with_python_pkg
|
||||||
|
%files python
|
||||||
|
%{_libexecdir}/ibus-*-anthy
|
||||||
|
%{_datadir}/applications/ibus-setup-anthy.desktop
|
||||||
|
%{_datadir}/ibus-anthy/engine
|
||||||
|
%{_datadir}/ibus-anthy/setup
|
||||||
|
%{_datadir}/ibus/component/*
|
||||||
|
%endif
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_datadir}/gir-1.0/Anthy*.gir
|
%{_datadir}/gir-1.0/Anthy*.gir
|
||||||
%{_includedir}/ibus-anthy-%{sub_version}
|
%{_includedir}/ibus-anthy-%{sub_version}
|
||||||
%{_libdir}/libanthygobject-%{sub_version}.so
|
%{_libdir}/libanthygobject-%{sub_version}.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 09 2013 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.4-1
|
||||||
|
- Bumped to 1.5.4
|
||||||
|
- Added ibus-anthy-python subpackage for noarch.
|
||||||
|
- Deleted ibus-anthy-xx-disable-prop-symbol.patch
|
||||||
|
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.3-2
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
@ -327,7 +348,7 @@ touch --no-create %{_datadir}/icons/hicolor || :
|
|||||||
* Fri Aug 15 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080815-1
|
* Fri Aug 15 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080815-1
|
||||||
- Update to 0.1.1.20080815.
|
- Update to 0.1.1.20080815.
|
||||||
|
|
||||||
* Thu Aug 12 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080812-1
|
* Tue Aug 12 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.1.20080812-1
|
||||||
- Update to 0.1.1.20080812.
|
- Update to 0.1.1.20080812.
|
||||||
|
|
||||||
* Fri Aug 08 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.0.20080810-1
|
* Fri Aug 08 2008 Peng Huang <shawn.p.huang@gmail.com> - 0.1.0.20080810-1
|
||||||
|
Loading…
Reference in New Issue
Block a user