Bumped to 1.4.99.20121006

This commit is contained in:
Takao Fujiwara 2012-10-06 22:14:13 +09:00
parent e66e469c3b
commit 50a115b4f6
6 changed files with 119 additions and 116 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@ ibus-anthy.png
/ibus-anthy-1.2.7.tar.gz
/ibus-anthy-1.3.99.20120304.tar.gz
/ibus-anthy-1.4.99.20120327.tar.gz
/ibus-anthy-1.4.99.20121006.tar.gz

View File

@ -0,0 +1,83 @@
--- ibus-anthy/engine/engine.py.orig 2012-10-06 21:14:45.250978091 +0900
+++ ibus-anthy/engine/engine.py 2012-10-06 21:20:31.325649562 +0900
@@ -204,7 +204,7 @@ class Engine(IBus.EngineSimple):
{ 'description' : _("Input mode"), 'symbol' : symbol }
input_mode_prop = IBus.Property(key=u'InputMode',
prop_type=IBus.PropType.MENU,
- label=IBus.Text.new_from_string(label),
+ label=IBus.Text.new_from_string(symbol),
symbol=IBus.Text.new_from_string(symbol),
icon='',
tooltip=IBus.Text.new_from_string(_("Switch input mode")),
@@ -278,7 +278,7 @@ class Engine(IBus.EngineSimple):
{ 'description' : _("Typing method"), 'symbol' : symbol }
typing_mode_prop = IBus.Property(key=u'TypingMode',
prop_type=IBus.PropType.MENU,
- label=IBus.Text.new_from_string(label),
+ label=IBus.Text.new_from_string(symbol),
symbol=IBus.Text.new_from_string(symbol),
icon='',
tooltip=IBus.Text.new_from_string(_("Switch typing method")),
@@ -355,7 +355,7 @@ class Engine(IBus.EngineSimple):
{ 'description' : _("Segment mode"), 'symbol' : symbol }
segment_mode_prop = IBus.Property(key=u'SegmentMode',
prop_type=IBus.PropType.MENU,
- label=IBus.Text.new_from_string(label),
+ label=IBus.Text.new_from_string(symbol),
symbol=IBus.Text.new_from_string(symbol),
icon=None,
tooltip=IBus.Text.new_from_string(_("Switch conversion mode")),
@@ -420,7 +420,7 @@ class Engine(IBus.EngineSimple):
{ 'description' : _("Dictionary mode"), 'symbol' : short_label }
dict_mode_prop = IBus.Property(key=u'DictMode',
prop_type=IBus.PropType.MENU,
- label=IBus.Text.new_from_string(label),
+ label=IBus.Text.new_from_string(short_label),
symbol=IBus.Text.new_from_string(short_label),
icon=None,
tooltip=IBus.Text.new_from_string(_("Switch dictionary")),
@@ -743,7 +743,7 @@ class Engine(IBus.EngineSimple):
self.__input_mode = mode
prop = self.__prop_dict[u'InputMode']
prop.set_symbol(IBus.Text.new_from_string(symbol))
- prop.set_label(IBus.Text.new_from_string(label))
+ prop.set_label(IBus.Text.new_from_string(symbol))
self.update_property(prop)
self.__reset()
@@ -771,7 +771,7 @@ class Engine(IBus.EngineSimple):
Engine.__typing_mode = mode
prop = self.__prop_dict[u'TypingMode']
prop.set_symbol(IBus.Text.new_from_string(symbol))
- prop.set_label(IBus.Text.new_from_string(label))
+ prop.set_label(IBus.Text.new_from_string(symbol))
self.update_property(prop)
self.__reset()
@@ -793,7 +793,7 @@ class Engine(IBus.EngineSimple):
_prop.set_state(IBus.PropState.CHECKED)
self.update_property(_prop)
prop.set_symbol(IBus.Text.new_from_string(symbol))
- prop.set_label(IBus.Text.new_from_string(label))
+ prop.set_label(IBus.Text.new_from_string(symbol))
self.update_property(prop)
def __segment_mode_activate(self, prop_name, state):
@@ -818,7 +818,7 @@ class Engine(IBus.EngineSimple):
self.__segment_mode = mode
prop = self.__prop_dict[u'SegmentMode']
prop.set_symbol(IBus.Text.new_from_string(symbol))
- prop.set_label(IBus.Text.new_from_string(label))
+ prop.set_label(IBus.Text.new_from_string(symbol))
self.update_property(prop)
self.__reset()
@@ -883,7 +883,7 @@ class Engine(IBus.EngineSimple):
label = _("%(description)s (%(symbol)s)") % \
{ 'description' : _("Dictionary mode"), 'symbol' : symbol }
prop.set_symbol(IBus.Text.new_from_string(symbol))
- prop.set_label(IBus.Text.new_from_string(label))
+ prop.set_label(IBus.Text.new_from_string(symbol))
self.update_property(prop)
def __argb(self, a, r, g, b):

View File

@ -1,69 +0,0 @@
--- ibus-anthy-1.2.4/configure.ac.orig 2011-06-21 18:25:58.000000000 +0900
+++ ibus-anthy-1.2.4/configure.ac 2011-07-29 23:37:19.000000000 +0900
@@ -122,6 +122,39 @@ AC_ARG_WITH(kasumi-icon,
[KASUMI_ICON_FILE="$datadir/pixmaps/kasumi.png"])
AC_SUBST(KASUMI_ICON_FILE)
+dnl - check hotkeys for ibus-anthy which is used for ibus bridge mode.
+dnl - Normally you don't need this so could be HOTKEYS="no"
+AC_ARG_WITH(hotkeys,
+ [AC_HELP_STRING([--with-hotkeys=HOTKEYS],
+ [Use hotkeys for ibus bridge mode. (available value: yes/no/keys)])],
+ [HOTKEYS="$withval"],
+ [HOTKEYS="no"])
+if test x"$HOTKEYS" = x"no"; then
+ HOTKEYS_XML="<!-- <hotkeys>Control+space,Zenkaku_Hankaku</hotkeys> -->"
+elif test x"$HOTKEYS" = x"yes"; then
+ HOTKEYS_XML="<hotkeys>Control+space,Zenkaku_Hankaku</hotkeys>"
+elif test x"$HOTKEYS" = x; then
+ HOTKEYS_XML="<hotkeys>Control+space,Zenkaku_Hankaku</hotkeys>"
+elif test x"$HOTKEYS" = xnull; then
+ HOTKEYS_XML="<hotkeys></hotkeys>"
+else
+ HOTKEYS_XML="<hotkeys>${HOTKEYS}</hotkeys>"
+fi
+AC_SUBST(HOTKEYS_XML)
+
+SYMBOL_CHAR='&#x3042;'
+SYMBOL_TEST="import ibus
+engine = ibus.EngineDesc('test')
+exit(not hasattr(engine, 'symbol'))
+"
+$PYTHON -c "$SYMBOL_TEST"
+if test $? -eq 0; then
+ SYMBOL_XML="<symbol>${SYMBOL_CHAR}</symbol>"
+else
+ SYMBOL_XML="<!-- <symbol>${SYMBOL_CHAR}</symbol> -->"
+fi
+AC_SUBST(SYMBOL_XML)
+
dnl - define GETTEXT_* variables
GETTEXT_PACKAGE=ibus-anthy
AC_SUBST(GETTEXT_PACKAGE)
@@ -146,3 +179,15 @@ m4/Makefile
])
AC_OUTPUT
+echo "
+ IBus-Anthy version ibus_version
+
+python-config: $PYTHON_CONFIG
+PYTHON_CFLAGS $PYTHON_CFLAGS
+PYTHON_LIBS $PYTHON_LIBS
+ANTHY_ZIPCODE_FILE $ANTHY_ZIPCODE_FILE
+KASUMI_EXEC_FILE $KASUMI_EXEC_FILE
+KASUMI_ICON_FILE $KASUMI_ICON_FILE
+HOTKEYS_XML $HOTKEYS_XML
+SYMBOL_XML $SYMBOL_XML
+"
--- ibus-anthy-1.2.4/engine/anthy.xml.in.in.orig 2011-06-21 18:24:39.000000000 +0900
+++ ibus-anthy-1.2.4/engine/anthy.xml.in.in 2011-07-29 23:36:19.000000000 +0900
@@ -22,6 +22,8 @@
<longname>Anthy</longname>
<description>Anthy Input Method</description>
<rank>99</rank>
+ @HOTKEYS_XML@
+ @SYMBOL_XML@
</engine>
</engines>
</component>

View File

@ -1,40 +0,0 @@
--- ibus-anthy-1.2.6/configure.ac.orig 2012-02-06 11:08:11.937122266 +0900
+++ ibus-anthy-1.2.6/configure.ac 2012-02-06 11:16:23.738872390 +0900
@@ -155,6 +155,20 @@ else
fi
AC_SUBST(SYMBOL_XML)
+dnl - set ibus-anthy layout
+AC_ARG_WITH(layout,
+ [AC_HELP_STRING([--with-layout=LAYOUT],
+ [Define the laoyut. the default is 'jp'.
+ Probably You could set 'default'.])],
+ [LAYOUT="$withval"],
+ [LAYOUT="jp"])
+if test x"$LAYOUT" = x; then
+ LAYOUT_XML="<layout>jp</layout>"
+else
+ LAYOUT_XML="<layout>${LAYOUT}</layout>"
+fi
+AC_SUBST(LAYOUT_XML)
+
dnl - define GETTEXT_* variables
GETTEXT_PACKAGE=ibus-anthy
AC_SUBST(GETTEXT_PACKAGE)
@@ -190,4 +204,5 @@ KASUMI_EXEC_FILE $KASUMI_EXEC_FI
KASUMI_ICON_FILE $KASUMI_ICON_FILE
HOTKEYS_XML $HOTKEYS_XML
SYMBOL_XML $SYMBOL_XML
+LAYOUT_XML $LAYOUT_XML
"
--- ibus-anthy-1.2.6/engine/anthy.xml.in.in.orig 2012-02-06 11:08:40.405570889 +0900
+++ ibus-anthy-1.2.6/engine/anthy.xml.in.in 2012-02-06 11:15:21.085885067 +0900
@@ -18,7 +18,7 @@
<license>GPL</license>
<author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
<icon>${pkgdatadir}/icons/ibus-anthy.png</icon>
- <layout>jp</layout>
+ @LAYOUT_XML@
<longname>Anthy</longname>
<description>Anthy Input Method</description>
<rank>99</rank>

View File

@ -1,20 +1,26 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define require_ibus_version 1.4.99.20120203
%define sub_version 1.0
%define have_default_layout 1
%define have_bridge_hotkey 1
%define sub_version 1.0
%define require_ibus_version 1.4.99.20120203
%define have_default_layout 1
%define have_bridge_hotkey 1
Name: ibus-anthy
Version: 1.4.99.20120327
Release: 2%{?dist}
Version: 1.4.99.20121006
Release: 1%{?dist}
Summary: The Anthy engine for IBus input platform
License: GPLv2+
Group: System Environment/Libraries
URL: http://code.google.com/p/ibus/
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
# Patch0: ibus-anthy-HEAD.patch
%if 0%{?fedora} <= 17
# IBusProperty.symbol is not used by ibus-gjs
Patch91: ibus-anthy-xx-disable-prop-symbol.patch
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: anthy-devel
@ -50,6 +56,10 @@ for developers.
%setup -q
# patch0 -p1
%if 0%{?fedora} <= 17
%patch91 -p1
%endif
%build
%configure \
%if %have_default_layout
@ -72,6 +82,18 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libanthygobject-%{sub_version}.la
%clean
rm -rf $RPM_BUILD_ROOT
%post
# recreate icon cache
touch --no-create %{_datadir}/icons/hicolor || :
[ -x %{_bindir}/gtk-update-icon-cache ] && \
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
%postun
# recreate icon cache
touch --no-create %{_datadir}/icons/hicolor || :
[ -x %{_bindir}/gtk-update-icon-cache ] && \
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
%files -f %{name}.lang
%defattr(-,root,root,-)
%doc AUTHORS COPYING README
@ -79,8 +101,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libanthygobject-%{sub_version}.so.*
%{_libdir}/girepository-1.0/Anthy*.typelib
%{_libexecdir}/ibus-*-anthy
%{_datadir}/applications/ibus-setup-anthy.desktop
%{_datadir}/ibus-anthy
%{_datadir}/ibus/component/*
%{_datadir}/icons/hicolor/scalable/apps/ibus-anthy.svg
%files devel
%{_datadir}/gir-1.0/Anthy*.gir
@ -88,6 +112,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libanthygobject-%{sub_version}.so
%changelog
* Sat Oct 06 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121006-1
- Bumped to 1.4.99.20121006
- Added ibus-anthy-xx-disable-prop-symbol.patch for Fedora 17
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.99.20120327-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

View File

@ -1 +1 @@
c426152e1aaf6782443e114b78425501 ibus-anthy-1.4.99.20120327.tar.gz
518aa503ce40054e0027f2a79c9df640 ibus-anthy-1.4.99.20121006.tar.gz