diff --git a/ibus-anthy-xx-layout.patch b/ibus-anthy-xx-layout.patch
new file mode 100644
index 0000000..20718c6
--- /dev/null
+++ b/ibus-anthy-xx-layout.patch
@@ -0,0 +1,40 @@
+--- ibus-anthy-1.2.6/configure.ac.orig 2012-02-06 11:08:11.937122266 +0900
++++ ibus-anthy-1.2.6/configure.ac 2012-02-06 11:16:23.738872390 +0900
+@@ -155,6 +155,20 @@ else
+ fi
+ AC_SUBST(SYMBOL_XML)
+
++dnl - set ibus-anthy layout
++AC_ARG_WITH(layout,
++ [AC_HELP_STRING([--with-layout=LAYOUT],
++ [Define the laoyut. the default is 'jp'.
++ Probably You could set 'default'.])],
++ [LAYOUT="$withval"],
++ [LAYOUT="jp"])
++if test x"$LAYOUT" = x; then
++ LAYOUT_XML="jp"
++else
++ LAYOUT_XML="${LAYOUT}"
++fi
++AC_SUBST(LAYOUT_XML)
++
+ dnl - define GETTEXT_* variables
+ GETTEXT_PACKAGE=ibus-anthy
+ AC_SUBST(GETTEXT_PACKAGE)
+@@ -190,4 +204,5 @@ KASUMI_EXEC_FILE $KASUMI_EXEC_FI
+ KASUMI_ICON_FILE $KASUMI_ICON_FILE
+ HOTKEYS_XML $HOTKEYS_XML
+ SYMBOL_XML $SYMBOL_XML
++LAYOUT_XML $LAYOUT_XML
+ "
+--- ibus-anthy-1.2.6/engine/anthy.xml.in.in.orig 2012-02-06 11:08:40.405570889 +0900
++++ ibus-anthy-1.2.6/engine/anthy.xml.in.in 2012-02-06 11:15:21.085885067 +0900
+@@ -18,7 +18,7 @@
+ GPL
+ Peng Huang <shawn.p.huang@gmail.com>
+ ${pkgdatadir}/icons/ibus-anthy.png
+- jp
++ @LAYOUT_XML@
+ Anthy
+ Anthy Input Method
+ 99
diff --git a/ibus-anthy.spec b/ibus-anthy.spec
index 4e979e6..daef1bf 100644
--- a/ibus-anthy.spec
+++ b/ibus-anthy.spec
@@ -1,7 +1,14 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-%define require_ibus_version 1.2.0.20100111
+# %define require_ibus_version 1.2.0.20100111
%define require_pygtk2_version 2.15.2
+%if 0%{?fedora} > 16
+%define have_default_layout 1
+%define require_ibus_version 1.4.99.20120203
+%else
+%define have_default_layout 0
+%define require_ibus_version 1.2.0.20100111
+%endif
%if 0%{?fedora} > 15
%define have_bridge_hotkey 1
%else
@@ -10,7 +17,7 @@
Name: ibus-anthy
Version: 1.2.6
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: The Anthy engine for IBus input platform
License: GPLv2+
Group: System Environment/Libraries
@@ -18,6 +25,7 @@ URL: http://code.google.com/p/ibus/
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
# Patch0: ibus-anthy-HEAD.patch
Patch1: ibus-anthy-xx-icon-symbol.patch
+Patch2: ibus-anthy-xx-layout.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -43,11 +51,15 @@ libanthy.
%setup -q
# %patch0 -p1
%patch1 -p1 -b .icon-symbol
+%patch2 -p1 -b .layout
%build
# for .icon-symbol patch
autoreconf
%configure \
+%if %have_default_layout
+ --with-layout='default' \
+%endif
%if %have_bridge_hotkey
--with-hotkeys \
%endif
@@ -76,6 +88,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/ibus/component/*
%changelog
+* Mon Feb 06 2012 Takao Fujiwara - 1.2.6-5
+- Added ibus-anthy-xx-layout.patch to set 'default' layout in f17.
+
* Fri Jan 13 2012 Fedora Release Engineering - 1.2.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild