Add upstream patch fixing libi2c license headers
This commit is contained in:
parent
8e0a475228
commit
d3fc66ffde
104
0001-libi2c-Mention-the-correct-license-in-source-files.patch
Normal file
104
0001-libi2c-Mention-the-correct-license-in-source-files.patch
Normal file
@ -0,0 +1,104 @@
|
||||
From fbd988b4fa3d008c5fd210a66834d1305de41f6c Mon Sep 17 00:00:00 2001
|
||||
From: Jean Delvare <jdelvare@suse.de>
|
||||
Date: Fri, 3 Aug 2018 13:54:26 +0200
|
||||
Subject: [PATCH] libi2c: Mention the correct license in source files
|
||||
|
||||
The libi2c library is released under the LGPL, not GPL, as explained
|
||||
in the README file and documented in lib/Module.mk. Thanks to
|
||||
Aurelien Jarno for pointing out the inconsistency.
|
||||
|
||||
A little bit of history:
|
||||
|
||||
The code started its life two decades ago as part of the lm-sensors
|
||||
project, which was released as a whole under the GPL originally,
|
||||
including the library part (libsensors).
|
||||
|
||||
In 2007, I decided to split the i2c tools, which are not specific
|
||||
to sensor devices, to a separate package.
|
||||
|
||||
In 2009, as I was working on lm-sensors v3, I contacted all the
|
||||
original authors to get their approval to release the upcoming and all
|
||||
future versions of libsensors as LGPL instead, to allow wider
|
||||
adoption. The proposal was accepted by all original authors.
|
||||
|
||||
In 2012, I decided to turn the inlined i2c_smbus_* helper functions
|
||||
into a proper library, with the intent to release it under the LGPL,
|
||||
as is the common practice for libraries. As the authors of this code
|
||||
is a subset of the authors of libsensors, I assumed their agreement
|
||||
for libsensors could be extended to libi2c as well. This is the
|
||||
reason why LGPL is mentioned in README and lib/Module.mk.
|
||||
|
||||
Unfortunately, when working on the library code itself, I forgot to
|
||||
update the comments in the source files. Let's fix them now.
|
||||
|
||||
Signed-off-by: Jean Delvare <jdelvare@suse.de>
|
||||
---
|
||||
include/i2c/smbus.h | 21 ++++++---------------
|
||||
lib/smbus.c | 16 +++-------------
|
||||
2 files changed, 9 insertions(+), 28 deletions(-)
|
||||
|
||||
diff --git a/include/i2c/smbus.h b/include/i2c/smbus.h
|
||||
index 18a5305..3003ed7 100644
|
||||
--- a/include/i2c/smbus.h
|
||||
+++ b/include/i2c/smbus.h
|
||||
@@ -1,23 +1,14 @@
|
||||
/*
|
||||
smbus.h - SMBus level access helper functions
|
||||
|
||||
- Copyright (C) 1995-97 Simon G. Vogl
|
||||
- Copyright (C) 1998-99 Frodo Looijaard <frodol@dds.nl>
|
||||
+ Copyright (C) 1995-1997 Simon G. Vogl
|
||||
+ Copyright (C) 1998-1999 Frodo Looijaard <frodol@dds.nl>
|
||||
+ Copyright (C) 2012-2017 Jean Delvare <jdelvare@suse.de>
|
||||
|
||||
- This program is free software; you can redistribute it and/or modify
|
||||
- it under the terms of the GNU General Public License as published by
|
||||
- the Free Software Foundation; either version 2 of the License, or
|
||||
+ This library is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU Lesser General Public License as published
|
||||
+ by the Free Software Foundation; either version 2.1 of the License, or
|
||||
(at your option) any later version.
|
||||
-
|
||||
- This program is distributed in the hope that it will be useful,
|
||||
- but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
- GNU General Public License for more details.
|
||||
-
|
||||
- You should have received a copy of the GNU General Public License
|
||||
- along with this program; if not, write to the Free Software
|
||||
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
|
||||
- MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
#ifndef LIB_I2C_SMBUS_H
|
||||
diff --git a/lib/smbus.c b/lib/smbus.c
|
||||
index 3a2c45a..df5a5ad 100644
|
||||
--- a/lib/smbus.c
|
||||
+++ b/lib/smbus.c
|
||||
@@ -5,20 +5,10 @@
|
||||
Copyright (C) 1998-1999 Frodo Looijaard <frodol@dds.nl>
|
||||
Copyright (C) 2012-2013 Jean Delvare <jdelvare@suse.de>
|
||||
|
||||
- This program is free software; you can redistribute it and/or modify
|
||||
- it under the terms of the GNU General Public License as published by
|
||||
- the Free Software Foundation; either version 2 of the License, or
|
||||
+ This library is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU Lesser General Public License as published
|
||||
+ by the Free Software Foundation; either version 2.1 of the License, or
|
||||
(at your option) any later version.
|
||||
-
|
||||
- This program is distributed in the hope that it will be useful,
|
||||
- but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
- GNU General Public License for more details.
|
||||
-
|
||||
- You should have received a copy of the GNU General Public License
|
||||
- along with this program; if not, write to the Free Software
|
||||
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
|
||||
- MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
#include <errno.h>
|
||||
--
|
||||
2.14.4
|
||||
|
@ -12,7 +12,7 @@
|
||||
|
||||
Name: i2c-tools
|
||||
Version: 4.0
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
Summary: A heterogeneous set of I2C tools for Linux
|
||||
License: GPLv2+
|
||||
URL: https://i2c.wiki.kernel.org/index.php/I2C_Tools
|
||||
@ -23,6 +23,8 @@ Patch0: 0001-i2c-tools-i2cbusses-Avoid-buffer-overflows-in-sysfs-.patch
|
||||
Patch1: 0002-tools-i2cbusses-Check-the-return-value-of-snprintf.patch
|
||||
# Upstream patch
|
||||
Patch2: 0003-py-smbus-Fix-FSF-address-in-smbusmodule.c.patch
|
||||
# Upstream patch fixing license headers of libi2c
|
||||
Patch3: 0001-libi2c-Mention-the-correct-license-in-source-files.patch
|
||||
|
||||
# for /etc/udev/makedev.d resp /etc/modprobe.d ownership
|
||||
Requires: udev module-init-tools
|
||||
@ -90,9 +92,6 @@ A collection of tools written in perl for use with i2c devices.
|
||||
|
||||
%package -n libi2c
|
||||
Summary: I2C/SMBus bus access library
|
||||
# This is indeed (meant to be) LGPLv2+, even if the sources don't say so
|
||||
# at the moment. That will be corrected in the near future.
|
||||
# https://marc.info/?l=linux-i2c&m=153258984521108&w=2
|
||||
License: LGPLv2+
|
||||
|
||||
%description -n libi2c
|
||||
@ -101,9 +100,6 @@ connected to the I2C or SMBus buses of the system.
|
||||
|
||||
%package -n libi2c-devel
|
||||
Summary: Development files for the I2C library
|
||||
# This is indeed (meant to be) LGPLv2+, even if the sources don't say so
|
||||
# at the moment. That will be corrected in the near future.
|
||||
# https://marc.info/?l=linux-i2c&m=153258984521108&w=2
|
||||
License: LGPLv2+
|
||||
Requires: libi2c%{?_isa} = %{version}-%{release}
|
||||
# Remove in F30
|
||||
@ -117,6 +113,7 @@ Obsoletes: i2c-tools-devel < 4.0-1
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" BUILD_STATIC_LIB=0 EXTRA=eeprog
|
||||
@ -223,6 +220,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 03 2018 Ondřej Lysoněk <olysonek@redhat.com> - 4.0-10
|
||||
- Add upstream patch fixing libi2c license headers
|
||||
|
||||
* Tue Jul 31 2018 Ondřej Lysoněk <olysonek@redhat.com> - 4.0-9
|
||||
- Corrected the License tags
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user