- Making the decode-* man pages installable with Makefile
This commit is contained in:
parent
02d81a9785
commit
bbd91c6797
@ -120,3 +120,38 @@ diff -Naur i2c-tools-3.1.0.orig/eeprom/decode-vaio.1 i2c-tools-3.1.0/eeprom/deco
|
||||
+.UR khali@linux-fr.org
|
||||
+Jean Delvare
|
||||
+.UE
|
||||
diff -Naur i2c-tools-3.1.0.orig/eeprom/Module.mk i2c-tools-3.1.0/eeprom/Module.mk
|
||||
--- i2c-tools-3.1.0.orig/eeprom/Module.mk 2009-01-13 18:32:03.000000000 +0100
|
||||
+++ i2c-tools-3.1.0/eeprom/Module.mk 2013-10-04 11:58:45.000000000 +0200
|
||||
@@ -7,9 +7,10 @@
|
||||
# the Free Software Foundation; either version 2 of the License, or
|
||||
# (at your option) any later version.
|
||||
|
||||
-EEPROM_DIR := eeprom
|
||||
+EEPROM_DIR := eeprom
|
||||
|
||||
-EEPROM_TARGETS := decode-dimms decode-vaio ddcmon decode-edid
|
||||
+EEPROM_TARGETS := decode-dimms decode-vaio ddcmon decode-edid
|
||||
+EEPROM_MAN_TARGETS := decode-dimms.1 decode-vaio.1
|
||||
|
||||
#
|
||||
# Commands
|
||||
@@ -24,6 +25,16 @@
|
||||
for program in $(EEPROM_TARGETS) ; do \
|
||||
$(RM) $(DESTDIR)$(bindir)/$$program ; done
|
||||
|
||||
-install: install-eeprom
|
||||
+install-eeprom-man: $(addprefix $(EEPROM_DIR)/,$(EEPROM_MAN_TARGETS))
|
||||
+ $(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
|
||||
+ for manual in $(EEPROM_MAN_TARGETS) ; do \
|
||||
+ $(INSTALL_DATA) $(EEPROM_DIR)/$$manual $(DESTDIR)$(mandir)/man1 ; done
|
||||
|
||||
-uninstall: uninstall-eeprom
|
||||
+uninstall-eeprom-man:
|
||||
+ for manual in $(EEPROM_MAN_TARGETS) ; do \
|
||||
+ $(RM) $(DESTDIR)$(mandir)/$$manual ; done
|
||||
+
|
||||
+
|
||||
+install: install-eeprom install-eeprom-man
|
||||
+
|
||||
+uninstall: uninstall-eeprom uninstall-eeprom-man
|
||||
|
@ -6,7 +6,7 @@
|
||||
|
||||
Name: i2c-tools
|
||||
Version: 3.1.0
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
Summary: A heterogeneous set of I2C tools for Linux
|
||||
Group: Applications/System
|
||||
License: GPLv2+
|
||||
@ -70,9 +70,6 @@ install -m 755 eepromer/{eepromer,eeprom,eeprog} \
|
||||
$RPM_BUILD_ROOT%{_sbindir}
|
||||
install -m 644 eepromer/{eepromer,eeprom,eeprog}.8 \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man8
|
||||
install -d 755 $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
install -m 644 eeprom/{decode-dimms,decode-vaio}.1 \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man1
|
||||
pushd py-smbus
|
||||
%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
|
||||
popd
|
||||
@ -119,6 +116,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Oct 04 2013 Jaromir Capik <jcapik@redhat.com> - 3.1.0-10
|
||||
- Making the decode-* man pages installable with Makefile
|
||||
|
||||
* Thu Oct 03 2013 Jaromir Capik <jcapik@redhat.com> - 3.1.0-9
|
||||
- Introducing man pages for decode-* binaries
|
||||
- Cleaning the spec
|
||||
|
Loading…
Reference in New Issue
Block a user