Properly check valgrind arches
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
d4e05166b8
commit
325a3471cc
@ -1,17 +0,0 @@
|
|||||||
--- tests/test.sh 2012-04-12 15:29:53.576994298 +0100
|
|
||||||
+++ tests/test.sh 2012-04-12 15:30:06.447143498 +0100
|
|
||||||
@@ -7,12 +7,14 @@
|
|
||||||
if ! grep -q 'ERROR SUMMARY: 0 error' $log; then
|
|
||||||
echo "Fail in $NAME $1 checking detected by Valgrind"
|
|
||||||
echo "$log Valgrind log file moved to $TEMPDIR/badlogs"
|
|
||||||
+ cat $log
|
|
||||||
mv $log $TEMPDIR/badlogs
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
if grep -q 'LEAK SUMMARY' $log; then
|
|
||||||
echo "Memory leak in $NAME $1 checking detected by Valgrind"
|
|
||||||
echo "$log Valgrind log file moved to $TEMPDIR/badlogs"
|
|
||||||
+ cat $log
|
|
||||||
mv $log $TEMPDIR/badlogs
|
|
||||||
exit 1
|
|
||||||
fi
|
|
13
hyphen.spec
13
hyphen.spec
@ -1,16 +1,12 @@
|
|||||||
Name: hyphen
|
Name: hyphen
|
||||||
Summary: A text hyphenation library
|
Summary: A text hyphenation library
|
||||||
Version: 2.8.8
|
Version: 2.8.8
|
||||||
Release: 23%{?dist}
|
Release: 24%{?dist}
|
||||||
Source: http://downloads.sourceforge.net/hunspell/hyphen-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/hunspell/hyphen-%{version}.tar.gz
|
||||||
URL: http://hunspell.sf.net
|
URL: http://hunspell.sf.net
|
||||||
License: GPL-2.0-only OR LGPL-2.1-or-later OR MPL-1.1
|
License: GPL-2.0-only OR LGPL-2.1-or-later OR MPL-1.1
|
||||||
BuildRequires: perl-interpreter, patch, autoconf, automake, libtool
|
BuildRequires: perl-interpreter, patch, autoconf, automake, libtool
|
||||||
# s390 lacks valgrind support
|
%ifarch %{valgrind_arches}
|
||||||
# no working valgrind built for MIPS yet
|
|
||||||
# tests with valgrind fail on arm
|
|
||||||
# tests with valgrind fail on ppc64le
|
|
||||||
%ifnarch s390 %{arm} %{mips} ppc64le
|
|
||||||
BuildRequires: valgrind
|
BuildRequires: valgrind
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -42,7 +38,7 @@ make %{?_smp_mflags}
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
make check
|
make check
|
||||||
%ifnarch s390 %{arm} %{mips} ppc64le
|
%ifarch %{valgrind_arches}
|
||||||
VALGRIND=memcheck make check
|
VALGRIND=memcheck make check
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -75,6 +71,9 @@ popd
|
|||||||
%{_bindir}/substrings.pl
|
%{_bindir}/substrings.pl
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 06 2024 David Abdurachmanov <davidlt@rivosinc.com> - 2.8.8-24
|
||||||
|
- Properly check valgrind arches
|
||||||
|
|
||||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.8-23
|
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.8-23
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user