Update to 1.11.8
This commit is contained in:
parent
477b741db1
commit
f8226c36e3
@ -0,0 +1,25 @@
|
|||||||
|
From 9d6e8bfe26c24df8272d6af782ebbde9ef62acb0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
||||||
|
Date: Wed, 6 Sep 2017 17:35:56 +0200
|
||||||
|
Subject: [PATCH] Avoid letting snprintf interpret process name as format
|
||||||
|
|
||||||
|
---
|
||||||
|
utils/lstopo/lstopo.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/utils/lstopo/lstopo.c b/utils/lstopo/lstopo.c
|
||||||
|
index a23980010d..e9d600d457 100644
|
||||||
|
--- a/utils/lstopo/lstopo.c
|
||||||
|
+++ b/utils/lstopo/lstopo.c
|
||||||
|
@@ -229,7 +229,7 @@ static void add_process_objects(hwloc_topology_t topology)
|
||||||
|
if (!parenl) {
|
||||||
|
snprintf(comm, sizeof(comm), "(unknown)");
|
||||||
|
} else {
|
||||||
|
- snprintf(comm, sizeof(comm), parenl+1);
|
||||||
|
+ snprintf(comm, sizeof(comm), "%s", parenl+1);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.13.6
|
||||||
|
|
11
hwloc.spec
11
hwloc.spec
@ -1,11 +1,13 @@
|
|||||||
Summary: Portable Hardware Locality - portable abstraction of hierarchical architectures
|
Summary: Portable Hardware Locality - portable abstraction of hierarchical architectures
|
||||||
Name: hwloc
|
Name: hwloc
|
||||||
Version: 1.11.5
|
Version: 1.11.8
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.open-mpi.org/projects/hwloc/
|
URL: http://www.open-mpi.org/projects/hwloc/
|
||||||
Source0: http://www.open-mpi.org/software/hwloc/v1.11/downloads/%{name}-%{version}.tar.bz2
|
Source0: http://www.open-mpi.org/software/hwloc/v1.11/downloads/%{name}-%{version}.tar.bz2
|
||||||
|
# fix build with -Werror=format-security
|
||||||
|
Patch0: 0001-Avoid-letting-snprintf-interpret-process-name-as-for.patch
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
BuildRequires: cairo-devel
|
BuildRequires: cairo-devel
|
||||||
@ -76,7 +78,7 @@ Requires: %{name}-plugins%{?_isa} = %{version}-%{release}
|
|||||||
- libxml support
|
- libxml support
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Remove rpaths
|
# Remove rpaths
|
||||||
@ -148,6 +150,9 @@ make check
|
|||||||
%{_libdir}/hwloc*
|
%{_libdir}/hwloc*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 27 2017 Michal Schmidt <mschmidt@redhat.com> - 1.11.8-1
|
||||||
|
- Update to 1.11.8.
|
||||||
|
|
||||||
* Wed Aug 23 2017 Adam Williamson <awilliam@redhat.com> - 1.11.5-6
|
* Wed Aug 23 2017 Adam Williamson <awilliam@redhat.com> - 1.11.5-6
|
||||||
- Use 'rdma-core-devel' not 'libibverbs-devel' for dependencies
|
- Use 'rdma-core-devel' not 'libibverbs-devel' for dependencies
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (hwloc-1.11.5.tar.bz2) = f32715d0b19400fa0cc02d4dd7b789d740f7bf16f16dbb247f6124adb41b452673139b12936d21259d6bc0dec4988260e6c3d00b3b145f410960e868ae96e1c6
|
SHA512 (hwloc-1.11.8.tar.bz2) = 6ade049b1de2204ba876fa49344a8389c8128a4082f8e1bc1196a659e862dd4222e954aac64bdb8560dd59412b629d5a41c161a4746199b8994c4e490fae89f7
|
||||||
|
Loading…
Reference in New Issue
Block a user