Update to 1.11.9
Remove remaining Group tags.
This commit is contained in:
parent
51d9297d37
commit
154c8f4cad
@ -1,25 +0,0 @@
|
||||
From 9d6e8bfe26c24df8272d6af782ebbde9ef62acb0 Mon Sep 17 00:00:00 2001
|
||||
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
||||
Date: Wed, 6 Sep 2017 17:35:56 +0200
|
||||
Subject: [PATCH] Avoid letting snprintf interpret process name as format
|
||||
|
||||
---
|
||||
utils/lstopo/lstopo.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/utils/lstopo/lstopo.c b/utils/lstopo/lstopo.c
|
||||
index a23980010d..e9d600d457 100644
|
||||
--- a/utils/lstopo/lstopo.c
|
||||
+++ b/utils/lstopo/lstopo.c
|
||||
@@ -229,7 +229,7 @@ static void add_process_objects(hwloc_topology_t topology)
|
||||
if (!parenl) {
|
||||
snprintf(comm, sizeof(comm), "(unknown)");
|
||||
} else {
|
||||
- snprintf(comm, sizeof(comm), parenl+1);
|
||||
+ snprintf(comm, sizeof(comm), "%s", parenl+1);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.13.6
|
||||
|
14
hwloc.spec
14
hwloc.spec
@ -1,12 +1,10 @@
|
||||
Summary: Portable Hardware Locality - portable abstraction of hierarchical architectures
|
||||
Name: hwloc
|
||||
Version: 1.11.8
|
||||
Release: 6%{?dist}
|
||||
Version: 1.11.9
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: http://www.open-mpi.org/projects/hwloc/
|
||||
Source0: http://www.open-mpi.org/software/hwloc/v1.11/downloads/%{name}-%{version}.tar.bz2
|
||||
# fix build with -Werror=format-security
|
||||
Patch0: 0001-Avoid-letting-snprintf-interpret-process-name-as-for.patch
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -49,7 +47,6 @@ about the hardware, bind processes, and much more.
|
||||
|
||||
%package devel
|
||||
Summary: Headers and shared development libraries for hwloc
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%ifnarch %{arm}
|
||||
Requires: rdma-core-devel%{?_isa}
|
||||
@ -60,14 +57,12 @@ Headers and shared object symbolic links for the hwloc.
|
||||
|
||||
%package libs
|
||||
Summary: Run time libraries for the hwloc
|
||||
Group: Development/Libraries
|
||||
|
||||
%description libs
|
||||
Run time libraries for the hwloc
|
||||
|
||||
%package gui
|
||||
Summary: The gui-based hwloc program(s)
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description gui
|
||||
@ -75,7 +70,6 @@ GUI-based tool for displaying system topology information.
|
||||
|
||||
%package plugins
|
||||
Summary: Plugins for hwloc
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-plugins%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description plugins
|
||||
@ -177,6 +171,10 @@ LD_LIBRARY_PATH=$PWD/src/.libs make check
|
||||
%{_libdir}/%{name}/hwloc*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 05 2018 Michal Schmidt <mschmidt@redhat.com> - 1.11.9-1
|
||||
- Update to 1.11.9.
|
||||
- BuildRequire gcc, gcc-c++. Drop Group tags.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.8-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hwloc-1.11.8.tar.bz2) = 6ade049b1de2204ba876fa49344a8389c8128a4082f8e1bc1196a659e862dd4222e954aac64bdb8560dd59412b629d5a41c161a4746199b8994c4e490fae89f7
|
||||
SHA512 (hwloc-1.11.9.tar.bz2) = 59198b460e2acb9ff0f8b06a86116a2ab67515e92035d3ecc1619ddbe42c7dd8991acab9cfe9c7130517238552aa570e3a51d135773ba34fbe343f2dfe48d956
|
||||
|
Loading…
Reference in New Issue
Block a user