auto-import changelog data from httpd-2.0.40-5.src.rpm
Sun Sep 01 2002 Joe Orton <jorton@redhat.com> 2.0.40-5 - fix SSL session cache (#69699) - revert addition of LDAP support to apr-util
This commit is contained in:
parent
b8eb6a9549
commit
f13b38c6d9
@ -1,3 +1,7 @@
|
|||||||
|
|
||||||
|
Set SIGXFSZ to be ignored, so a write() beyond 2gb will fail with
|
||||||
|
E2BIG rather than killing the process
|
||||||
|
|
||||||
--- ./server/mpm/prefork/prefork.c.xfsz Wed Jul 17 22:39:55 2002
|
--- ./server/mpm/prefork/prefork.c.xfsz Wed Jul 17 22:39:55 2002
|
||||||
+++ ./server/mpm/prefork/prefork.c Mon Aug 26 15:40:24 2002
|
+++ ./server/mpm/prefork/prefork.c Mon Aug 26 15:40:24 2002
|
||||||
@@ -461,7 +461,7 @@
|
@@ -461,7 +461,7 @@
|
||||||
|
18
httpd.spec
18
httpd.spec
@ -4,7 +4,7 @@
|
|||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.0.40
|
Version: 2.0.40
|
||||||
Release: 4
|
Release: 5
|
||||||
URL: http://httpd.apache.org/
|
URL: http://httpd.apache.org/
|
||||||
Vendor: Red Hat, Inc.
|
Vendor: Red Hat, Inc.
|
||||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
||||||
@ -30,7 +30,6 @@ License: Apache Software License
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: db4-devel, expat-devel, findutils, perl
|
BuildPrereq: db4-devel, expat-devel, findutils, perl
|
||||||
BuildPrereq: openldap-devel
|
|
||||||
Requires: /etc/mime.types, gawk, /usr/share/magic.mime, /usr/bin/find
|
Requires: /etc/mime.types, gawk, /usr/share/magic.mime, /usr/bin/find
|
||||||
Prereq: /sbin/chkconfig, /bin/mktemp, /bin/rm, /bin/mv
|
Prereq: /sbin/chkconfig, /bin/mktemp, /bin/rm, /bin/mv
|
||||||
Prereq: sh-utils, textutils, /usr/sbin/useradd
|
Prereq: sh-utils, textutils, /usr/sbin/useradd
|
||||||
@ -122,8 +121,7 @@ CFLAGS="$RPM_OPT_FLAGS" \
|
|||||||
--enable-ssl --with-ssl \
|
--enable-ssl --with-ssl \
|
||||||
--enable-deflate \
|
--enable-deflate \
|
||||||
--enable-proxy --enable-proxy-connect \
|
--enable-proxy --enable-proxy-connect \
|
||||||
--enable-proxy-http --enable-proxy-ftp \
|
--enable-proxy-http --enable-proxy-ftp
|
||||||
--with-ldap-include=%{_includedir}/openldap --with-ldap
|
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -159,6 +157,10 @@ done
|
|||||||
# for holding mod_dav lock database
|
# for holding mod_dav lock database
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
|
||||||
|
|
||||||
|
# create a prototype session cache
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
|
||||||
|
touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
|
||||||
|
|
||||||
# move utilities to /usr/bin
|
# move utilities to /usr/bin
|
||||||
mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
|
mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
|
||||||
$RPM_BUILD_ROOT%{_bindir}
|
$RPM_BUILD_ROOT%{_bindir}
|
||||||
@ -330,6 +332,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/httpd/modules/mod_ssl.so
|
%{_libdir}/httpd/modules/mod_ssl.so
|
||||||
%config(noreplace) %{_sysconfdir}/httpd/conf.d/ssl.conf
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/ssl.conf
|
||||||
%dir %{_sysconfdir}/httpd/conf/ssl.*
|
%dir %{_sysconfdir}/httpd/conf/ssl.*
|
||||||
|
%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
|
||||||
|
%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
|
||||||
|
%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
|
||||||
|
%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -344,6 +350,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/httpd/build/libtool
|
%{_libdir}/httpd/build/libtool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Sep 1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
|
||||||
|
- fix SSL session cache (#69699)
|
||||||
|
- revert addition of LDAP support to apr-util
|
||||||
|
|
||||||
* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
|
* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
|
||||||
- set SIGXFSZ disposition to "ignored" (#69520)
|
- set SIGXFSZ disposition to "ignored" (#69520)
|
||||||
- make dummy connections to the first listener in config (#72692)
|
- make dummy connections to the first listener in config (#72692)
|
||||||
|
6
ssl.conf
6
ssl.conf
@ -56,9 +56,9 @@ SSLPassPhraseDialog builtin
|
|||||||
# Configure the SSL Session Cache: First the mechanism
|
# Configure the SSL Session Cache: First the mechanism
|
||||||
# to use and second the expiring timeout (in seconds).
|
# to use and second the expiring timeout (in seconds).
|
||||||
#SSLSessionCache none
|
#SSLSessionCache none
|
||||||
#SSLSessionCache shmht:logs/ssl_scache(512000)
|
#SSLSessionCache shmht:/var/cache/mod_ssl/scache(512000)
|
||||||
#SSLSessionCache shmcb:logs/ssl_scache(512000)
|
#SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
|
||||||
SSLSessionCache dbm:logs/ssl_scache
|
SSLSessionCache dbm:/var/cache/mod_ssl/scache
|
||||||
SSLSessionCacheTimeout 300
|
SSLSessionCacheTimeout 300
|
||||||
|
|
||||||
# Semaphore:
|
# Semaphore:
|
||||||
|
Loading…
Reference in New Issue
Block a user