- require pkgconfig for -devel (#194152)

- fixes for installed support makefiles (special.mk et al)
This commit is contained in:
jorton 2006-06-07 10:40:34 +00:00
parent 48593e5892
commit c1d75190cf
2 changed files with 33 additions and 6 deletions

View File

@ -5,7 +5,7 @@
--- httpd-2.2.2/support/apxs.in.apxs
+++ httpd-2.2.2/support/apxs.in
@@ -25,7 +25,15 @@
@@ -25,7 +25,18 @@
my %config_vars = ();
@ -17,12 +17,15 @@
+ exit(1);
+}
+
+my $installbuilddir = `pkg-config --variable=libdir apr-1` . "httpd/build";
+my $libdir = `pkg-config --variable=libdir apr-1`;
+chomp $libdir;
+
+my $installbuilddir = $libdir . "/httpd/build";
+
get_config_vars("$installbuilddir/config_vars.mk",\%config_vars);
# read the configuration variables once
@@ -184,34 +192,6 @@
@@ -184,34 +195,6 @@
}
}
@ -57,7 +60,16 @@
sub get_config_vars{
my ($file, $rh_config) = @_;
@@ -433,9 +413,9 @@
@@ -291,7 +274,7 @@
$data =~ s|%NAME%|$name|sg;
$data =~ s|%TARGET%|$CFG_TARGET|sg;
$data =~ s|%PREFIX%|$prefix|sg;
- $data =~ s|%INSTALLBUILDDIR%|$installbuilddir|sg;
+ $data =~ s|%LIBDIR%|$libdir|sg;
my ($mkf, $mods, $src) = ($data =~ m|^(.+)-=#=-\n(.+)-=#=-\n(.+)|s);
@@ -433,9 +416,9 @@
if ($opt_p == 1) {
@ -69,3 +81,14 @@
chomp($apu_libs);
$opt .= " ".$apu_libs." ".$apr_libs;
@@ -646,8 +629,8 @@
builddir=.
top_srcdir=%PREFIX%
-top_builddir=%PREFIX%
-include %INSTALLBUILDDIR%/special.mk
+top_builddir=%LIBDIR%/httpd
+include %LIBDIR%/httpd/special.mk
# the used tools
APXS=apxs

View File

@ -7,7 +7,7 @@
Summary: Apache HTTP Server
Name: httpd
Version: 2.2.2
Release: 4
Release: 5
URL: http://httpd.apache.org/
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
Source1: index.html
@ -65,7 +65,7 @@ web server.
Group: Development/Libraries
Summary: Development tools for the Apache HTTP server.
Obsoletes: secureweb-devel, apache-devel, stronghold-apache-devel
Requires: apr-devel, apr-util-devel
Requires: apr-devel, apr-util-devel, pkgconfig
Requires: httpd = %{version}-%{release}
%description devel
@ -479,6 +479,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/httpd/build/*.sh
%changelog
* Wed Jun 7 2006 Joe Orton <jorton@redhat.com> 2.2.2-5
- require pkgconfig for -devel (#194152)
- fixes for installed support makefiles (special.mk et al)
* Fri Jun 2 2006 Joe Orton <jorton@redhat.com> 2.2.2-4
- make -devel package multilib-safe (#192686)