- update to 2.2.8
- drop mod_imagemap
This commit is contained in:
parent
e22b9a54a5
commit
abfe86f01d
@ -1 +1,3 @@
|
|||||||
httpd-2.2.6.tar.gz
|
httpd-2.2.8.tar.gz
|
||||||
|
x86_64
|
||||||
|
*.log
|
||||||
|
@ -1,104 +0,0 @@
|
|||||||
--- httpd-2.2.6/modules/ssl/mod_ssl.c.ssllibver
|
|
||||||
+++ httpd-2.2.6/modules/ssl/mod_ssl.c
|
|
||||||
@@ -500,7 +500,7 @@ static void ssl_register_hooks(apr_pool_
|
|
||||||
ap_hook_insert_filter (ssl_hook_Insert_Filter, NULL,NULL, APR_HOOK_MIDDLE);
|
|
||||||
/* ap_hook_handler (ssl_hook_Upgrade, NULL,NULL, APR_HOOK_MIDDLE); */
|
|
||||||
|
|
||||||
- ssl_var_register();
|
|
||||||
+ ssl_var_register(p);
|
|
||||||
|
|
||||||
APR_REGISTER_OPTIONAL_FN(ssl_proxy_enable);
|
|
||||||
APR_REGISTER_OPTIONAL_FN(ssl_engine_disable);
|
|
||||||
--- httpd-2.2.6/modules/ssl/ssl_engine_vars.c.ssllibver
|
|
||||||
+++ httpd-2.2.6/modules/ssl/ssl_engine_vars.c
|
|
||||||
@@ -58,12 +58,32 @@ static int ssl_is_https(conn_rec *c)
|
|
||||||
return sslconn && sslconn->ssl;
|
|
||||||
}
|
|
||||||
|
|
||||||
-void ssl_var_register(void)
|
|
||||||
+static const char var_interface[] = "mod_ssl/" MOD_SSL_VERSION;
|
|
||||||
+static char var_library_interface[] = SSL_LIBRARY_TEXT;
|
|
||||||
+static char *var_library = NULL;
|
|
||||||
+
|
|
||||||
+void ssl_var_register(apr_pool_t *p)
|
|
||||||
{
|
|
||||||
+ char *cp, *cp2;
|
|
||||||
+
|
|
||||||
APR_REGISTER_OPTIONAL_FN(ssl_is_https);
|
|
||||||
APR_REGISTER_OPTIONAL_FN(ssl_var_lookup);
|
|
||||||
APR_REGISTER_OPTIONAL_FN(ssl_ext_lookup);
|
|
||||||
- return;
|
|
||||||
+
|
|
||||||
+ /* Perform once-per-process library version determination: */
|
|
||||||
+ var_library = apr_pstrdup(p, SSL_LIBRARY_DYNTEXT);
|
|
||||||
+
|
|
||||||
+ if ((cp = strchr(var_library, ' ')) != NULL) {
|
|
||||||
+ *cp = '/';
|
|
||||||
+ if ((cp2 = strchr(cp, ' ')) != NULL)
|
|
||||||
+ *cp2 = NUL;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if ((cp = strchr(var_library_interface, ' ')) != NULL) {
|
|
||||||
+ *cp = '/';
|
|
||||||
+ if ((cp2 = strchr(cp, ' ')) != NULL)
|
|
||||||
+ *cp2 = NUL;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
/* This function must remain safe to use for a non-SSL connection. */
|
|
||||||
@@ -635,39 +655,17 @@ static void ssl_var_lookup_ssl_cipher_bi
|
|
||||||
|
|
||||||
static char *ssl_var_lookup_ssl_version(apr_pool_t *p, char *var)
|
|
||||||
{
|
|
||||||
- static char interface[] = "mod_ssl/" MOD_SSL_VERSION;
|
|
||||||
- static char library_interface[] = SSL_LIBRARY_TEXT;
|
|
||||||
- static char *library = NULL;
|
|
||||||
- char *result;
|
|
||||||
-
|
|
||||||
- if (!library) {
|
|
||||||
- char *cp, *cp2;
|
|
||||||
- library = apr_pstrdup(p, SSL_LIBRARY_DYNTEXT);
|
|
||||||
- if ((cp = strchr(library, ' ')) != NULL) {
|
|
||||||
- *cp = '/';
|
|
||||||
- if ((cp2 = strchr(cp, ' ')) != NULL)
|
|
||||||
- *cp2 = NUL;
|
|
||||||
- }
|
|
||||||
- if ((cp = strchr(library_interface, ' ')) != NULL) {
|
|
||||||
- *cp = '/';
|
|
||||||
- if ((cp2 = strchr(cp, ' ')) != NULL)
|
|
||||||
- *cp2 = NUL;
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
if (strEQ(var, "INTERFACE")) {
|
|
||||||
- result = apr_pstrdup(p, interface);
|
|
||||||
+ return apr_pstrdup(p, var_interface);
|
|
||||||
}
|
|
||||||
else if (strEQ(var, "LIBRARY_INTERFACE")) {
|
|
||||||
- result = apr_pstrdup(p, library_interface);
|
|
||||||
+ return apr_pstrdup(p, var_library_interface);
|
|
||||||
}
|
|
||||||
else if (strEQ(var, "LIBRARY")) {
|
|
||||||
- result = apr_pstrdup(p, library);
|
|
||||||
- }
|
|
||||||
- else {
|
|
||||||
- result = NULL;
|
|
||||||
+ return apr_pstrdup(p, var_library);
|
|
||||||
}
|
|
||||||
- return result;
|
|
||||||
+
|
|
||||||
+ return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
--- httpd-2.2.6/modules/ssl/ssl_private.h.ssllibver
|
|
||||||
+++ httpd-2.2.6/modules/ssl/ssl_private.h
|
|
||||||
@@ -648,7 +648,7 @@ void ssl_die(void);
|
|
||||||
void ssl_log_ssl_error(const char *, int, int, server_rec *);
|
|
||||||
|
|
||||||
/** Variables */
|
|
||||||
-void ssl_var_register(void);
|
|
||||||
+void ssl_var_register(apr_pool_t *p);
|
|
||||||
char *ssl_var_lookup(apr_pool_t *, server_rec *, conn_rec *, request_rec *, char *);
|
|
||||||
const char *ssl_ext_lookup(apr_pool_t *p, conn_rec *c, int peer, const char *oid);
|
|
||||||
|
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.7 (Darwin)
|
|
||||||
|
|
||||||
iD8DBQBG3buFizpgHwjJdeURAiQhAJ0UzwL/Sg4PZdw1USvc4CWytBg+kgCeKf83
|
|
||||||
vNBG4bcFy+gEuU0vVE/HCGM=
|
|
||||||
=dt4x
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
httpd-2.2.8.tar.gz.asc
Normal file
7
httpd-2.2.8.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.4.7 (Darwin)
|
||||||
|
|
||||||
|
iD8DBQBHhk3hizpgHwjJdeURAgacAKDeXrgaZB+lPqRrVSQMPUgpW3AN3ACg6JPW
|
||||||
|
My+xx7Jzj3rZ1RwIBwxA9Ls=
|
||||||
|
=NOQO
|
||||||
|
-----END PGP SIGNATURE-----
|
16
httpd.spec
16
httpd.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.2.6
|
Version: 2.2.8
|
||||||
Release: 4
|
Release: 2
|
||||||
URL: http://httpd.apache.org/
|
URL: http://httpd.apache.org/
|
||||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
||||||
Source1: index.html
|
Source1: index.html
|
||||||
@ -36,7 +36,6 @@ Patch25: httpd-2.0.54-selinux.patch
|
|||||||
# Bug fixes
|
# Bug fixes
|
||||||
Patch54: httpd-2.2.0-authnoprov.patch
|
Patch54: httpd-2.2.0-authnoprov.patch
|
||||||
Patch55: httpd-2.2.4-oldflush.patch
|
Patch55: httpd-2.2.4-oldflush.patch
|
||||||
Patch56: httpd-2.2.6-ssllibver.patch
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -124,7 +123,6 @@ Security (TLS) protocols.
|
|||||||
|
|
||||||
%patch54 -p1 -b .authnoprov
|
%patch54 -p1 -b .authnoprov
|
||||||
%patch55 -p1 -b .oldflush
|
%patch55 -p1 -b .oldflush
|
||||||
%patch56 -p1 -b .ssllibver
|
|
||||||
|
|
||||||
# Patch in vendor/release string
|
# Patch in vendor/release string
|
||||||
sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
|
sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
|
||||||
@ -146,9 +144,6 @@ rm -rf srclib/{apr,apr-util,pcre}
|
|||||||
# regenerate configure scripts
|
# regenerate configure scripts
|
||||||
autoheader && autoconf || exit 1
|
autoheader && autoconf || exit 1
|
||||||
|
|
||||||
# Limit size of CHANGES to recent history
|
|
||||||
echo '1,/Changes with Apache 2.0/wq' | ed CHANGES
|
|
||||||
|
|
||||||
# Before configure; fix location of build dir in generated apxs
|
# Before configure; fix location of build dir in generated apxs
|
||||||
%{__perl} -pi -e "s:\@exp_installbuilddir\@:%{_libdir}/httpd/build:g" \
|
%{__perl} -pi -e "s:\@exp_installbuilddir\@:%{_libdir}/httpd/build:g" \
|
||||||
support/apxs.in
|
support/apxs.in
|
||||||
@ -201,7 +196,8 @@ mpmbuild prefork \
|
|||||||
--enable-file-cache --enable-disk-cache \
|
--enable-file-cache --enable-disk-cache \
|
||||||
--enable-ldap --enable-authnz-ldap \
|
--enable-ldap --enable-authnz-ldap \
|
||||||
--enable-cgid \
|
--enable-cgid \
|
||||||
--enable-authn-anon --enable-authn-alias
|
--enable-authn-anon --enable-authn-alias \
|
||||||
|
--disable-imagemap
|
||||||
|
|
||||||
# For the other MPMs, just build httpd and no optional modules
|
# For the other MPMs, just build httpd and no optional modules
|
||||||
mpmbuild worker --enable-modules=none
|
mpmbuild worker --enable-modules=none
|
||||||
@ -479,6 +475,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/httpd/build/*.sh
|
%{_libdir}/httpd/build/*.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 22 2008 Joe Orton <jorton@redhat.com> 2.2.8-2
|
||||||
|
- update to 2.2.8
|
||||||
|
- drop mod_imagemap
|
||||||
|
|
||||||
* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.2.6-4
|
* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.2.6-4
|
||||||
- Rebuild for openssl bump
|
- Rebuild for openssl bump
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
d050a49bd7532ec21c6bb593b3473a5d httpd-2.2.6.tar.gz
|
39a755eb0f584c279336387b321e3dfc httpd-2.2.8.tar.gz
|
||||||
|
1620
upstream-key.gpg
1620
upstream-key.gpg
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user