- load mod_proxy_hcheck - recommend use of "systemctl edit" in httpd.service Resolves: rhbz#1353203 Resolves: rhbz#1325883
This commit is contained in:
parent
aaf7efcca6
commit
a67a8d7392
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@ x86_64
|
||||
/httpd-2.4.16.tar.bz2
|
||||
/httpd-2.4.17.tar.bz2
|
||||
/httpd-2.4.18.tar.bz2
|
||||
/httpd-2.4.23.tar.bz2
|
||||
|
@ -12,5 +12,6 @@ LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
|
||||
LoadModule proxy_fdpass_module modules/mod_proxy_fdpass.so
|
||||
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
|
||||
LoadModule proxy_http_module modules/mod_proxy_http.so
|
||||
LoadModule proxy_hcheck_module modules/mod_proxy_hcheck.so
|
||||
LoadModule proxy_scgi_module modules/mod_proxy_scgi.so
|
||||
LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
|
||||
|
@ -1,42 +0,0 @@
|
||||
diff --git a/server/mpm/event/event.c b/server/mpm/event/event.c
|
||||
index cd70b7d..94813af 100644
|
||||
--- a/server/mpm/event/event.c
|
||||
+++ b/server/mpm/event/event.c
|
||||
@@ -3042,8 +3042,7 @@ static int event_open_logs(apr_pool_t * p, apr_pool_t * plog,
|
||||
|
||||
all_buckets = apr_pcalloc(pconf, num_buckets * sizeof(*all_buckets));
|
||||
for (i = 0; i < num_buckets; i++) {
|
||||
- if (!one_process && /* no POD in one_process mode */
|
||||
- (rv = ap_mpm_podx_open(pconf, &all_buckets[i].pod))) {
|
||||
+ if (rv = ap_mpm_podx_open(pconf, &all_buckets[i].pod)) {
|
||||
ap_log_error(APLOG_MARK, APLOG_CRIT | level_flags, rv,
|
||||
(startup ? NULL : s),
|
||||
"could not open pipe-of-death");
|
||||
diff --git a/server/mpm/prefork/prefork.c b/server/mpm/prefork/prefork.c
|
||||
index 343e51d..f4c3dbe 100644
|
||||
--- a/server/mpm/prefork/prefork.c
|
||||
+++ b/server/mpm/prefork/prefork.c
|
||||
@@ -1326,8 +1326,7 @@ static int prefork_open_logs(apr_pool_t *p, apr_pool_t *plog, apr_pool_t *ptemp,
|
||||
all_buckets = apr_pcalloc(pconf, num_buckets *
|
||||
sizeof(prefork_child_bucket));
|
||||
for (i = 0; i < num_buckets; i++) {
|
||||
- if (!one_process && /* no POD in one_process mode */
|
||||
- (rv = ap_mpm_pod_open(pconf, &all_buckets[i].pod))) {
|
||||
+ if (rv = ap_mpm_pod_open(pconf, &all_buckets[i].pod)) {
|
||||
ap_log_error(APLOG_MARK, APLOG_CRIT | level_flags, rv,
|
||||
(startup ? NULL : s),
|
||||
"could not open pipe-of-death");
|
||||
diff --git a/server/mpm/worker/worker.c b/server/mpm/worker/worker.c
|
||||
index 4a729c0..8a59219 100644
|
||||
--- a/server/mpm/worker/worker.c
|
||||
+++ b/server/mpm/worker/worker.c
|
||||
@@ -2051,8 +2051,7 @@ static int worker_open_logs(apr_pool_t *p, apr_pool_t *plog, apr_pool_t *ptemp,
|
||||
|
||||
all_buckets = apr_pcalloc(pconf, num_buckets * sizeof(*all_buckets));
|
||||
for (i = 0; i < num_buckets; i++) {
|
||||
- if (!one_process && /* no POD in one_process mode */
|
||||
- (rv = ap_mpm_podx_open(pconf, &all_buckets[i].pod))) {
|
||||
+ if (rv = ap_mpm_podx_open(pconf, &all_buckets[i].pod)) {
|
||||
ap_log_error(APLOG_MARK, APLOG_CRIT | level_flags, rv,
|
||||
(startup ? NULL : s),
|
||||
"could not open pipe-of-death");
|
@ -1,16 +1,11 @@
|
||||
# It's not recommended to modify this file in-place, because it will be
|
||||
# It is not recommended to modify this file in-place, because it will be
|
||||
# overwritten during package upgrades. If you want to customize, the best
|
||||
# way is to create a file "/etc/systemd/system/httpd.service",
|
||||
# containing
|
||||
# .include /lib/systemd/system/httpd.service
|
||||
# ...make your changes here...
|
||||
# For more info about custom unit files, see
|
||||
# http://fedoraproject.org/wiki/Systemd#How_do_I_customize_a_unit_file.2F_add_a_custom_unit_file.3F
|
||||
# way is to use the "systemctl edit" command to create an override unit.
|
||||
|
||||
# For example, to pass additional options (for instance, -D
|
||||
# definitions) to the httpd binary at startup, create an override unit
|
||||
# (as is done by systemctl edit) and enter the following:
|
||||
|
||||
# For example, to pass additional options (for instance, -D definitions) to the
|
||||
# httpd binary at startup, you need to create a file named
|
||||
# "/etc/systemd/system/httpd.service" containing:
|
||||
# .include /lib/systemd/system/httpd.service
|
||||
# [Service]
|
||||
# Environment=OPTIONS=-DMY_DEFINE
|
||||
|
||||
|
11
httpd.spec
11
httpd.spec
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Apache HTTP Server
|
||||
Name: httpd
|
||||
Version: 2.4.18
|
||||
Release: 6%{?dist}
|
||||
Version: 2.4.23
|
||||
Release: 1%{?dist}
|
||||
URL: http://httpd.apache.org/
|
||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||
Source1: index.html
|
||||
@ -66,7 +66,6 @@ Patch35: httpd-2.4.17-sslciphdefault.patch
|
||||
Patch55: httpd-2.4.4-malformed-host.patch
|
||||
Patch56: httpd-2.4.4-mod_unique_id.patch
|
||||
Patch57: httpd-2.4.10-sigint.patch
|
||||
Patch58: httpd-2.4.17-debug-crash.patch
|
||||
# Security fixes
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Daemons
|
||||
@ -211,7 +210,6 @@ interface for storing and accessing per-user session data.
|
||||
%patch55 -p1 -b .malformedhost
|
||||
%patch56 -p1 -b .uniqueid
|
||||
%patch57 -p1 -b .sigint
|
||||
%patch58 -p1 -b .debugcrash
|
||||
|
||||
# Patch in the vendor string
|
||||
sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
|
||||
@ -672,6 +670,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_rpmconfigdir}/macros.d/macros.httpd
|
||||
|
||||
%changelog
|
||||
* Thu Jul 7 2016 Joe Orton <jorton@redhat.com> - 2.4.23-1
|
||||
- update to 2.4.23 (#1325883, #1353203)
|
||||
- load mod_proxy_hcheck
|
||||
- recommend use of "systemctl edit" in httpd.service
|
||||
|
||||
* Thu Apr 7 2016 Joe Orton <jorton@redhat.com> - 2.4.18-6
|
||||
- have "apachectl graceful" start httpd if not running, per man page
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user