- update to 2.2.9

- build event MPM too
This commit is contained in:
jorton 2008-07-08 15:54:57 +00:00
parent 91afecf7de
commit 9dd08ada42
7 changed files with 39 additions and 31 deletions

View File

@ -1,4 +1 @@
httpd-2.2.8.tar.gz httpd-2.2.9.tar.gz
x86_64
*.log
*.rpm

View File

@ -1,17 +0,0 @@
apr and apr-util are patched to correctly depend on their deps, so
it's sufficient to just link httpd against the .la file.
Upstream-Status: needed
--- httpd-2.0.45/configure.in.deplibs 2003-04-29 10:27:05.000000000 +0100
+++ httpd-2.0.45/configure.in 2003-04-29 10:26:45.000000000 +0100
@@ -455,7 +455,7 @@
AP_LIBS="$abs_builddir/srclib/pcre/libpcre.la $AP_LIBS"
dnl APR should go after the other libs, so the right symbols can be picked up
-AP_LIBS="$AP_LIBS `$apu_config --link-libtool --libs` `$apr_config --link-libtool --libs`"
+AP_LIBS="$AP_LIBS `$apu_config --link-libtool` `$apr_config --link-libtool`"
APACHE_SUBST(AP_LIBS)
APACHE_SUBST(AP_BUILD_SRCLIB_DIRS)
APACHE_SUBST(AP_CLEAN_SRCLIB_DIRS)

14
httpd-2.2.9-deplibs.patch Normal file
View File

@ -0,0 +1,14 @@
--- httpd-2.2.9/configure.in.deplibs
+++ httpd-2.2.9/configure.in
@@ -588,9 +588,8 @@ APACHE_HELP_STRING(--with-suexec-umask,u
AC_DEFINE_UNQUOTED(AP_SUEXEC_UMASK, 0$withval, [umask for suexec'd process] ) ] )
dnl APR should go after the other libs, so the right symbols can be picked up
-apulinklibs="`$apu_config --avoid-ldap --link-libtool --libs`" \
- || apulinklibs="`$apu_config --link-libtool --libs`"
-AP_LIBS="$AP_LIBS $apulinklibs `$apr_config --link-libtool --libs`"
+apulinklibs="`$apu_config --link-libtool`"
+AP_LIBS="$AP_LIBS $apulinklibs `$apr_config --link-libtool`"
APACHE_SUBST(AP_LIBS)
APACHE_SUBST(AP_BUILD_SRCLIB_DIRS)
APACHE_SUBST(AP_CLEAN_SRCLIB_DIRS)

7
httpd-2.2.9.tar.gz.asc Normal file
View File

@ -0,0 +1,7 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (Darwin)
iD8DBQBITtN1izpgHwjJdeURAkceAKC+pFgPKC9gcrkHTeBuI/rnKFIVQACdETFB
fZ866HrZqHalNYAPd1Yck1U=
=B7lp
-----END PGP SIGNATURE-----

View File

@ -2,11 +2,12 @@
%define suexec_caller apache %define suexec_caller apache
%define mmn 20051115 %define mmn 20051115
%define vstring Fedora %define vstring Fedora
%define mpms worker event
Summary: Apache HTTP Server Summary: Apache HTTP Server
Name: httpd Name: httpd
Version: 2.2.8 Version: 2.2.9
Release: 4 Release: 2
URL: http://httpd.apache.org/ URL: http://httpd.apache.org/
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
Source1: index.html Source1: index.html
@ -23,7 +24,7 @@ Source33: README.confd
# build/scripts patches # build/scripts patches
Patch1: httpd-2.1.10-apctl.patch Patch1: httpd-2.1.10-apctl.patch
Patch2: httpd-2.1.10-apxs.patch Patch2: httpd-2.1.10-apxs.patch
Patch3: httpd-2.0.45-deplibs.patch Patch3: httpd-2.2.9-deplibs.patch
Patch4: httpd-2.1.10-disablemods.patch Patch4: httpd-2.1.10-disablemods.patch
Patch5: httpd-2.1.10-layout.patch Patch5: httpd-2.1.10-layout.patch
# Features/functional changes # Features/functional changes
@ -200,8 +201,9 @@ mpmbuild prefork \
--disable-imagemap --disable-imagemap
# For the other MPMs, just build httpd and no optional modules # For the other MPMs, just build httpd and no optional modules
mpmbuild worker --enable-modules=none for f in %{mpms}; do
#mpmbuild event --enable-modules=none mpmbuild $f --enable-modules=none
done
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -215,8 +217,9 @@ make DESTDIR=$RPM_BUILD_ROOT install
popd popd
# install alternative MPMs # install alternative MPMs
install -m 755 worker/httpd $RPM_BUILD_ROOT%{_sbindir}/httpd.worker for f in %{mpms}; do
#install -m 755 event/httpd $RPM_BUILD_ROOT%{_sbindir}/httpd.event install -m 755 ${f}/httpd $RPM_BUILD_ROOT%{_sbindir}/httpd.${f}
done
# install conf file/directory # install conf file/directory
mkdir $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d mkdir $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
@ -382,7 +385,7 @@ fi
# Verify that the same modules were built into the httpd binaries # Verify that the same modules were built into the httpd binaries
./prefork/httpd -l | grep -v prefork > prefork.mods ./prefork/httpd -l | grep -v prefork > prefork.mods
for mpm in worker; do for mpm in %{mpms}; do
./${mpm}/httpd -l | grep -v ${mpm} > ${mpm}.mods ./${mpm}/httpd -l | grep -v ${mpm} > ${mpm}.mods
if ! diff -u prefork.mods ${mpm}.mods; then if ! diff -u prefork.mods ${mpm}.mods; then
: Different modules built into httpd binaries, will not proceed : Different modules built into httpd binaries, will not proceed
@ -475,6 +478,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/httpd/build/*.sh %{_libdir}/httpd/build/*.sh
%changelog %changelog
* Tue Jul 8 2008 Joe Orton <jorton@redhat.com> 2.2.9-2
- update to 2.2.9
- build event MPM too
* Wed Jun 4 2008 Joe Orton <jorton@redhat.com> 2.2.8-4 * Wed Jun 4 2008 Joe Orton <jorton@redhat.com> 2.2.8-4
- correct UserDir directive in default config (#449815) - correct UserDir directive in default config (#449815)

View File

@ -1 +1 @@
39a755eb0f584c279336387b321e3dfc httpd-2.2.8.tar.gz 80d3754fc278338033296f0d41ef2c04 httpd-2.2.9.tar.gz

View File

@ -1 +1 @@
httpd-2.2.8.tar.gz httpd-2.2.9.tar.gz