update to 2.4.10
This commit is contained in:
parent
572a5df9ee
commit
94c96741e2
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ x86_64
|
|||||||
/httpd-2.4.6.tar.bz2
|
/httpd-2.4.6.tar.bz2
|
||||||
/httpd-2.4.7.tar.bz2
|
/httpd-2.4.7.tar.bz2
|
||||||
/httpd-2.4.9.tar.bz2
|
/httpd-2.4.9.tar.bz2
|
||||||
|
/httpd-2.4.10.tar.bz2
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
# ./pullrev.sh 1537535
|
|
||||||
|
|
||||||
http://svn.apache.org/viewvc?view=revision&revision=1537535
|
|
||||||
|
|
||||||
--- httpd-2.4.7/modules/ssl/ssl_engine_config.c.r1537535
|
|
||||||
+++ httpd-2.4.7/modules/ssl/ssl_engine_config.c
|
|
||||||
@@ -196,7 +196,7 @@ static SSLSrvConfigRec *ssl_config_serve
|
|
||||||
SSLSrvConfigRec *sc = apr_palloc(p, sizeof(*sc));
|
|
||||||
|
|
||||||
sc->mc = NULL;
|
|
||||||
- sc->enabled = SSL_ENABLED_FALSE;
|
|
||||||
+ sc->enabled = SSL_ENABLED_UNSET;
|
|
||||||
sc->proxy_enabled = UNSET;
|
|
||||||
sc->vhost_id = NULL; /* set during module init */
|
|
||||||
sc->vhost_id_len = 0; /* set during module init */
|
|
||||||
--- httpd-2.4.7/modules/ssl/ssl_engine_init.c.r1537535
|
|
||||||
+++ httpd-2.4.7/modules/ssl/ssl_engine_init.c
|
|
||||||
@@ -115,13 +115,16 @@ int ssl_init_Module(apr_pool_t *p, apr_p
|
|
||||||
sc->vhost_id = ssl_util_vhostid(p, s);
|
|
||||||
sc->vhost_id_len = strlen(sc->vhost_id);
|
|
||||||
|
|
||||||
- if (ap_get_server_protocol(s) &&
|
|
||||||
- strcmp("https", ap_get_server_protocol(s)) == 0) {
|
|
||||||
+ /* Default to enabled if SSLEngine is not set explicitly, and
|
|
||||||
+ * the protocol is https. */
|
|
||||||
+ if (ap_get_server_protocol(s)
|
|
||||||
+ && strcmp("https", ap_get_server_protocol(s)) == 0
|
|
||||||
+ && sc->enabled == SSL_ENABLED_UNSET) {
|
|
||||||
sc->enabled = SSL_ENABLED_TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
- /* If sc->enabled is UNSET, then SSL is optional on this vhost */
|
|
||||||
- /* Fix up stuff that may not have been set */
|
|
||||||
+ /* Fix up stuff that may not have been set. If sc->enabled is
|
|
||||||
+ * UNSET, then SSL is disabled on this vhost. */
|
|
||||||
if (sc->enabled == SSL_ENABLED_UNSET) {
|
|
||||||
sc->enabled = SSL_ENABLED_FALSE;
|
|
||||||
}
|
|
@ -1,29 +0,0 @@
|
|||||||
--- a/modules/proxy/mod_proxy.c 2014/03/03 17:28:10 1573625
|
|
||||||
+++ b/modules/proxy/mod_proxy.c 2014/03/03 17:28:17 1573626
|
|
||||||
@@ -927,8 +927,25 @@
|
|
||||||
struct dirconn_entry *list = (struct dirconn_entry *)conf->dirconn->elts;
|
|
||||||
|
|
||||||
/* is this for us? */
|
|
||||||
- if (!r->proxyreq || !r->filename || strncmp(r->filename, "proxy:", 6) != 0)
|
|
||||||
+ if (!r->filename) {
|
|
||||||
return DECLINED;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (!r->proxyreq) {
|
|
||||||
+ /* We may have forced the proxy handler via config or .htaccess */
|
|
||||||
+ if (r->handler &&
|
|
||||||
+ strncmp(r->handler, "proxy:", 6) == 0 &&
|
|
||||||
+ strncmp(r->filename, "proxy:", 6) != 0) {
|
|
||||||
+ r->proxyreq = PROXYREQ_REVERSE;
|
|
||||||
+ r->filename = apr_pstrcat(r->pool, r->handler, r->filename, NULL);
|
|
||||||
+ apr_table_setn(r->notes, "rewrite-proxy", "1");
|
|
||||||
+ }
|
|
||||||
+ else {
|
|
||||||
+ return DECLINED;
|
|
||||||
+ }
|
|
||||||
+ } else if (strncmp(r->filename, "proxy:", 6) != 0) {
|
|
||||||
+ return DECLINED;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* handle max-forwards / OPTIONS / TRACE */
|
|
||||||
if ((str = apr_table_get(r->headers_in, "Max-Forwards"))) {
|
|
11
httpd.spec
11
httpd.spec
@ -13,8 +13,8 @@
|
|||||||
|
|
||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.4.9
|
Version: 2.4.10
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://httpd.apache.org/
|
URL: http://httpd.apache.org/
|
||||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||||
Source1: index.html
|
Source1: index.html
|
||||||
@ -63,8 +63,6 @@ Patch27: httpd-2.4.2-icons.patch
|
|||||||
Patch29: httpd-2.4.3-mod_systemd.patch
|
Patch29: httpd-2.4.3-mod_systemd.patch
|
||||||
Patch30: httpd-2.4.4-cachehardmax.patch
|
Patch30: httpd-2.4.4-cachehardmax.patch
|
||||||
Patch31: httpd-2.4.6-sslmultiproxy.patch
|
Patch31: httpd-2.4.6-sslmultiproxy.patch
|
||||||
Patch32: httpd-2.4.7-r1537535.patch
|
|
||||||
Patch33: httpd-2.4.9-r1573626.patch
|
|
||||||
Patch34: httpd-2.4.9-socket-activation.patch
|
Patch34: httpd-2.4.9-socket-activation.patch
|
||||||
# Bug fixes
|
# Bug fixes
|
||||||
Patch55: httpd-2.4.4-malformed-host.patch
|
Patch55: httpd-2.4.4-malformed-host.patch
|
||||||
@ -201,8 +199,6 @@ interface for storing and accessing per-user session data.
|
|||||||
%patch29 -p1 -b .systemd
|
%patch29 -p1 -b .systemd
|
||||||
%patch30 -p1 -b .cachehardmax
|
%patch30 -p1 -b .cachehardmax
|
||||||
%patch31 -p1 -b .sslmultiproxy
|
%patch31 -p1 -b .sslmultiproxy
|
||||||
%patch32 -p1 -b .r1537535
|
|
||||||
%patch33 -p1 -b .r1573626
|
|
||||||
%patch34 -p1 -b .socketactivation
|
%patch34 -p1 -b .socketactivation
|
||||||
|
|
||||||
%patch55 -p1 -b .malformedhost
|
%patch55 -p1 -b .malformedhost
|
||||||
@ -647,6 +643,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_rpmconfigdir}/macros.d/macros.httpd
|
%{_rpmconfigdir}/macros.d/macros.httpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 21 2014 Joe Orton <jorton@redhat.com> - 2.4.10-1
|
||||||
|
- update to 2.4.10
|
||||||
|
|
||||||
* Tue Jul 08 2014 Jan Kaluza <jkaluza@redhat.com> - 2.4.9-8
|
* Tue Jul 08 2014 Jan Kaluza <jkaluza@redhat.com> - 2.4.9-8
|
||||||
- add support for systemd socket activation (#1111648)
|
- add support for systemd socket activation (#1111648)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user