new version 2.4.55
This commit is contained in:
parent
a9ebcc1200
commit
85bd0d7cb0
1
.gitignore
vendored
1
.gitignore
vendored
@ -45,3 +45,4 @@ x86_64
|
|||||||
/httpd-2.4.52.tar.bz2.asc
|
/httpd-2.4.52.tar.bz2.asc
|
||||||
/httpd-2.4.53.tar.bz2.asc
|
/httpd-2.4.53.tar.bz2.asc
|
||||||
/httpd-2.4.54.tar.bz2.asc
|
/httpd-2.4.54.tar.bz2.asc
|
||||||
|
/httpd-2.4.55.tar.bz2.asc
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
diff --git a/modules/ssl/ssl_engine_config.c b/modules/ssl/ssl_engine_config.c
|
|
||||||
index b53f3f8..979489c 100644
|
|
||||||
--- a/modules/ssl/ssl_engine_config.c
|
|
||||||
+++ b/modules/ssl/ssl_engine_config.c
|
|
||||||
@@ -812,8 +812,14 @@ const char *ssl_cmd_SSLCipherSuite(cmd_parms *cmd,
|
|
||||||
static const char *ssl_cmd_check_file(cmd_parms *parms,
|
|
||||||
const char **file)
|
|
||||||
{
|
|
||||||
- const char *filepath = ap_server_root_relative(parms->pool, *file);
|
|
||||||
+ const char *filepath;
|
|
||||||
|
|
||||||
+ /* If only dumping the config, don't verify the paths */
|
|
||||||
+ if (ap_state_query(AP_SQ_RUN_MODE) == AP_SQ_RM_CONFIG_DUMP) {
|
|
||||||
+ return NULL;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ filepath = ap_server_root_relative(parms->pool, *file);
|
|
||||||
if (!filepath) {
|
|
||||||
return apr_pstrcat(parms->pool, parms->cmd->name,
|
|
||||||
": Invalid file path ", *file, NULL);
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/modules/proxy/proxy_util.c b/modules/proxy/proxy_util.c
|
|
||||||
index e488aa6..8267f1b 100644
|
|
||||||
--- a/modules/proxy/proxy_util.c
|
|
||||||
+++ b/modules/proxy/proxy_util.c
|
|
||||||
@@ -3121,7 +3121,7 @@ PROXY_DECLARE(apr_status_t) ap_proxy_check_connection(const char *scheme,
|
|
||||||
"%s: backend socket is disconnected.", scheme);
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
- ap_log_error(APLOG_MARK, APLOG_WARNING, 0, server, APLOGNO(03408)
|
|
||||||
+ ap_log_error(APLOG_MARK, APLOG_INFO, 0, server, APLOGNO(03408)
|
|
||||||
"%s: reusable backend connection is not empty: "
|
|
||||||
"forcibly closed", scheme);
|
|
||||||
}
|
|
11
httpd.spec
11
httpd.spec
@ -23,8 +23,8 @@
|
|||||||
|
|
||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.4.54
|
Version: 2.4.55
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: https://httpd.apache.org/
|
URL: https://httpd.apache.org/
|
||||||
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||||
Source1: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2.asc
|
Source1: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2.asc
|
||||||
@ -92,7 +92,6 @@ Patch30: httpd-2.4.43-cachehardmax.patch
|
|||||||
Patch34: httpd-2.4.43-socket-activation.patch
|
Patch34: httpd-2.4.43-socket-activation.patch
|
||||||
Patch38: httpd-2.4.43-sslciphdefault.patch
|
Patch38: httpd-2.4.43-sslciphdefault.patch
|
||||||
Patch39: httpd-2.4.43-sslprotdefault.patch
|
Patch39: httpd-2.4.43-sslprotdefault.patch
|
||||||
Patch40: httpd-2.4.43-r1861269.patch
|
|
||||||
Patch41: httpd-2.4.43-r1861793+.patch
|
Patch41: httpd-2.4.43-r1861793+.patch
|
||||||
Patch42: httpd-2.4.48-r1828172+.patch
|
Patch42: httpd-2.4.48-r1828172+.patch
|
||||||
Patch45: httpd-2.4.43-logjournal.patch
|
Patch45: httpd-2.4.43-logjournal.patch
|
||||||
@ -104,7 +103,6 @@ Patch60: httpd-2.4.43-enable-sslv3.patch
|
|||||||
Patch61: httpd-2.4.48-r1878890.patch
|
Patch61: httpd-2.4.48-r1878890.patch
|
||||||
Patch63: httpd-2.4.46-htcacheclean-dont-break.patch
|
Patch63: httpd-2.4.46-htcacheclean-dont-break.patch
|
||||||
Patch65: httpd-2.4.51-r1894152.patch
|
Patch65: httpd-2.4.51-r1894152.patch
|
||||||
Patch66: httpd-2.4.54-proxy-util-loglevel.patch
|
|
||||||
|
|
||||||
# Security fixes
|
# Security fixes
|
||||||
|
|
||||||
@ -260,7 +258,6 @@ written in the Lua programming language.
|
|||||||
%patch34 -p1 -b .socketactivation
|
%patch34 -p1 -b .socketactivation
|
||||||
%patch38 -p1 -b .sslciphdefault
|
%patch38 -p1 -b .sslciphdefault
|
||||||
%patch39 -p1 -b .sslprotdefault
|
%patch39 -p1 -b .sslprotdefault
|
||||||
%patch40 -p1 -b .r1861269
|
|
||||||
%patch41 -p1 -b .r1861793+
|
%patch41 -p1 -b .r1861793+
|
||||||
%patch42 -p1 -b .r1828172+
|
%patch42 -p1 -b .r1828172+
|
||||||
%patch45 -p1 -b .logjournal
|
%patch45 -p1 -b .logjournal
|
||||||
@ -271,7 +268,6 @@ written in the Lua programming language.
|
|||||||
%patch61 -p1 -b .r1878890
|
%patch61 -p1 -b .r1878890
|
||||||
%patch63 -p1 -b .htcacheclean-dont-break
|
%patch63 -p1 -b .htcacheclean-dont-break
|
||||||
%patch65 -p1 -b .r1894152
|
%patch65 -p1 -b .r1894152
|
||||||
%patch66 -p1 -b .proxyutil-loglevel
|
|
||||||
|
|
||||||
# Patch in the vendor string
|
# Patch in the vendor string
|
||||||
sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
|
sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
|
||||||
@ -854,6 +850,9 @@ exit $rv
|
|||||||
%{_rpmconfigdir}/macros.d/macros.httpd
|
%{_rpmconfigdir}/macros.d/macros.httpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 25 2023 Luboš Uhliarik <luhliari@redhat.com> - 2.4.55-1
|
||||||
|
- new version 2.4.55
|
||||||
|
|
||||||
* Tue Jan 24 2023 Luboš Uhliarik <luhliari@redhat.com> - 2.4.54-12
|
* Tue Jan 24 2023 Luboš Uhliarik <luhliari@redhat.com> - 2.4.54-12
|
||||||
- prevent sscg writing /dhparams.pem
|
- prevent sscg writing /dhparams.pem
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (httpd-2.4.54.tar.bz2) = 228493b2ff32c4142c6e484d304f2ea12e467498605fe12adce2b61388d8efe7b2e96ae2fd0abd1dc88a5f12d625e007d8da0ae5628cff2a5272806754f41e18
|
SHA512 (httpd-2.4.55.tar.bz2) = 94982f7a1fedac8961fc17b5a22cf763ac28cb27ee6facab2e6a15b249b927773667493fd3f7354fb13fcb34a6f1afc1bdd5cf4b7be030cba1dfb523e40d43fb
|
||||||
SHA512 (httpd-2.4.54.tar.bz2.asc) = 90a582b10bbcd054f62b6961194f7d97b1f0f56286cfd89e0a5c36248808365b4defade068340a1e9deeaee09dcd3e88810bee8951f9840fe666dab8861b757b
|
SHA512 (httpd-2.4.55.tar.bz2.asc) = 7e9f946a72a9106325ca1479123e9320e6749ba304d945ce48f4eb816710ad7fe6a2e0a9108c98d36a99eacd70c4984a1b5cb1b7e6690cdff77039c4a2732328
|
||||||
SHA512 (KEYS) = 88c848b7ab9e4915d6625dcad3e8328673b0448f2ce76f2c44eecc612cf6afbce3287a4ee7219a44c6fcc61d5ecb2a1a8545456a4a16b90400263d7249cbf192
|
SHA512 (KEYS) = 88c848b7ab9e4915d6625dcad3e8328673b0448f2ce76f2c44eecc612cf6afbce3287a4ee7219a44c6fcc61d5ecb2a1a8545456a4a16b90400263d7249cbf192
|
||||||
|
Loading…
Reference in New Issue
Block a user