drop backwards-compat authz module hack
minor updates to httpd.conf drop old patches
This commit is contained in:
parent
de1732661c
commit
718c836305
@ -1,30 +0,0 @@
|
||||
--- httpd-2.2.0/modules/aaa/mod_authn_file.c.authnoprov
|
||||
+++ httpd-2.2.0/modules/aaa/mod_authn_file.c
|
||||
@@ -70,6 +70,10 @@
|
||||
apr_status_t status;
|
||||
char *file_password = NULL;
|
||||
|
||||
+ if (!conf->pwfile) {
|
||||
+ return AUTH_GENERAL_ERROR;
|
||||
+ }
|
||||
+
|
||||
status = ap_pcfg_openfile(&f, r->pool, conf->pwfile);
|
||||
|
||||
if (status != APR_SUCCESS) {
|
||||
--- httpd-2.2.0/modules/aaa/mod_auth_basic.c.authnoprov
|
||||
+++ httpd-2.2.0/modules/aaa/mod_auth_basic.c
|
||||
@@ -252,6 +252,14 @@
|
||||
return DECLINED;
|
||||
}
|
||||
|
||||
+ /* If no providers were configured, and the default file
|
||||
+ * provider gave a general error (which will happen only if
|
||||
+ * has not been configured), presume that a non-provider-based
|
||||
+ * authn module is configured, and get out of the way. */
|
||||
+ if (!conf->providers && auth_result == AUTH_GENERAL_ERROR) {
|
||||
+ return DECLINED;
|
||||
+ }
|
||||
+
|
||||
switch (auth_result) {
|
||||
case AUTH_DENIED:
|
||||
ap_log_rerror(APLOG_MARK, APLOG_ERR, 0, r,
|
@ -2,8 +2,8 @@
|
||||
Bump up the core size limit if CoreDumpDirectory is
|
||||
configured.
|
||||
|
||||
Was discussed upstream but there are competing desires;
|
||||
there are portability oddities here too.
|
||||
Upstream-Status: Was discussed but there are competing desires;
|
||||
there are portability oddities here too.
|
||||
|
||||
--- httpd-2.2.11/server/core.c.corelimit
|
||||
+++ httpd-2.2.11/server/core.c
|
||||
|
@ -1,7 +1,7 @@
|
||||
|
||||
Log the SELinux context at startup.
|
||||
|
||||
Almost certainly undesired upstream.
|
||||
Upstream-Status: unlikely to be any interest in this upstream
|
||||
|
||||
--- httpd-2.2.11/configure.in.selinux
|
||||
+++ httpd-2.2.11/configure.in
|
||||
|
@ -1,3 +1,9 @@
|
||||
|
||||
Link only against the libtool libraries to avoid pulling in
|
||||
all dependencies if libapr/libaprutil.
|
||||
|
||||
Upstream-Status: probably breaks static builds, not desired
|
||||
|
||||
--- httpd-2.2.9/configure.in.deplibs
|
||||
+++ httpd-2.2.9/configure.in
|
||||
@@ -588,9 +588,8 @@ APACHE_HELP_STRING(--with-suexec-umask,u
|
||||
|
@ -1,3 +1,6 @@
|
||||
|
||||
Upstream-Status: in trunk, differently
|
||||
|
||||
--- httpd-2.2.9/os/unix/unixd.c.suenable
|
||||
+++ httpd-2.2.9/os/unix/unixd.c
|
||||
@@ -215,7 +215,7 @@ AP_DECLARE(void) unixd_pre_config(apr_po
|
||||
|
11
httpd.spec
11
httpd.spec
@ -8,7 +8,7 @@
|
||||
Summary: Apache HTTP Server
|
||||
Name: httpd
|
||||
Version: 2.2.17
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
URL: http://httpd.apache.org/
|
||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||
Source1: index.html
|
||||
@ -37,8 +37,6 @@ Patch23: httpd-2.0.45-export.patch
|
||||
Patch24: httpd-2.2.11-corelimit.patch
|
||||
Patch25: httpd-2.2.11-selinux.patch
|
||||
Patch26: httpd-2.2.9-suenable.patch
|
||||
# Bug fixes
|
||||
Patch54: httpd-2.2.0-authnoprov.patch
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Daemons
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
@ -124,8 +122,6 @@ Security (TLS) protocols.
|
||||
%patch25 -p1 -b .selinux
|
||||
%patch26 -p1 -b .suenable
|
||||
|
||||
%patch54 -p1 -b .authnoprov
|
||||
|
||||
# Patch in vendor/release string
|
||||
sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
|
||||
|
||||
@ -497,6 +493,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/httpd/build/*.sh
|
||||
|
||||
%changelog
|
||||
* Wed Mar 23 2011 Joe Orton <jorton@redhat.com> - 2.2.17-11
|
||||
- drop backwards-compat authz module hack
|
||||
- minor updates to httpd.conf
|
||||
- drop old patches
|
||||
|
||||
* Wed Mar 2 2011 Joe Orton <jorton@redhat.com> - 2.2.17-10
|
||||
- rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user