diff --git a/00-mpm.conf b/00-mpm.conf
index 75d90e9..b15f913 100644
--- a/00-mpm.conf
+++ b/00-mpm.conf
@@ -1,8 +1,13 @@
# Select the MPM module which should be used by uncommenting exactly
-# one of the following LoadModule lines:
+# one of the following LoadModule lines. See the httpd.service(8) man
+# page for more information on changing the MPM.
# prefork MPM: Implements a non-threaded, pre-forking web server
# See: http://httpd.apache.org/docs/2.4/mod/prefork.html
+#
+# NOTE: If enabling prefork, the httpd_graceful_shutdown SELinux
+# boolean should be enabled, to allow graceful stop/shutdown.
+#
#LoadModule mpm_prefork_module modules/mod_mpm_prefork.so
# worker MPM: Multi-Processing Module implementing a hybrid
@@ -16,4 +21,3 @@
# See: http://httpd.apache.org/docs/2.4/mod/event.html
#
#LoadModule mpm_event_module modules/mod_mpm_event.so
-
diff --git a/httpd.service.xml b/httpd.service.xml
index d851862..4402ed5 100644
--- a/httpd.service.xml
+++ b/httpd.service.xml
@@ -166,6 +166,24 @@ Wants=network-online.target
--kill-who=main --signal=HUP httpd.
+
+ Changing the default MPM (Multi-Processing Module)
+
+ httpd offers a choice of multi-processing modules (MPMs),
+ which can be configured in
+ /etc/httpd/conf.modules.d/00-mpm.conf. The
+ default is to use the @MPM@ MPM.
+
+ If using the prefork MPM, the
+ "httpd_graceful_shutdown" SELinux boolean should also be
+ enabled, since with this MPM, httpd needs to establish TCP
+ connections to local ports to successfully complete a graceful
+ restart or shutdown. This boolean can be enabled by running the
+ command: semanage boolean -m --on
+ httpd_graceful_shutdown
+
+
+
systemd integration and mod_systemd
diff --git a/httpd.spec b/httpd.spec
index 6f14798..e9e4319 100644
--- a/httpd.spec
+++ b/httpd.spec
@@ -13,7 +13,7 @@
Summary: Apache HTTP Server
Name: httpd
Version: 2.4.27
-Release: 13%{?dist}
+Release: 14%{?dist}
URL: https://httpd.apache.org/
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
Source1: index.html
@@ -239,7 +239,10 @@ if test "x${vmmn}" != "x%{mmn}"; then
exit 1
fi
-xmlto man $RPM_SOURCE_DIR/httpd.service.xml
+sed 's/@MPM@/%{mpm}/' < $RPM_SOURCE_DIR/httpd.service.xml \
+ > httpd.service.xml
+
+xmlto man ./httpd.service.xml
: Building with MMN %{mmn}, MMN-ISA %{mmnisa}
: Default MPM is %{mpm}, vendor string is '%{vstring}'
@@ -688,6 +691,9 @@ rm -rf $RPM_BUILD_ROOT
%{_rpmconfigdir}/macros.d/macros.httpd
%changelog
+* Tue Oct 3 2017 Joe Orton - 2.4.27-14
+- add notes on enabling httpd_graceful_shutdown boolean for prefork
+
* Fri Sep 22 2017 Joe Orton - 2.4.27-13
- drop Requires(post) for mod_ssl