new version 2.4.54
This commit is contained in:
parent
c2f1d6bf30
commit
589318da66
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ x86_64
|
|||||||
/httpd-2.4.51.tar.bz2.asc
|
/httpd-2.4.51.tar.bz2.asc
|
||||||
/httpd-2.4.52.tar.bz2.asc
|
/httpd-2.4.52.tar.bz2.asc
|
||||||
/httpd-2.4.53.tar.bz2.asc
|
/httpd-2.4.53.tar.bz2.asc
|
||||||
|
/httpd-2.4.54.tar.bz2.asc
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/configure.in b/configure.in
|
diff --git a/configure.in b/configure.in
|
||||||
index c8f9aa2..cb43246 100644
|
index 74015ca..8c0ee10 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -484,6 +484,11 @@ getloadavg
|
@@ -508,6 +508,11 @@ getloadavg
|
||||||
dnl confirm that a void pointer is large enough to store a long integer
|
dnl confirm that a void pointer is large enough to store a long integer
|
||||||
APACHE_CHECK_VOID_PTR_LEN
|
APACHE_CHECK_VOID_PTR_LEN
|
||||||
|
|
||||||
@ -15,10 +15,10 @@ index c8f9aa2..cb43246 100644
|
|||||||
[AC_TRY_RUN(#define _GNU_SOURCE
|
[AC_TRY_RUN(#define _GNU_SOURCE
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
diff --git a/server/core.c b/server/core.c
|
diff --git a/server/core.c b/server/core.c
|
||||||
index dc0f17a..7ed9527 100644
|
index a6fa2fb..cf4cba4 100644
|
||||||
--- a/server/core.c
|
--- a/server/core.c
|
||||||
+++ b/server/core.c
|
+++ b/server/core.c
|
||||||
@@ -59,6 +59,10 @@
|
@@ -65,6 +65,10 @@
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -28,8 +28,8 @@ index dc0f17a..7ed9527 100644
|
|||||||
+
|
+
|
||||||
/* LimitRequestBody handling */
|
/* LimitRequestBody handling */
|
||||||
#define AP_LIMIT_REQ_BODY_UNSET ((apr_off_t) -1)
|
#define AP_LIMIT_REQ_BODY_UNSET ((apr_off_t) -1)
|
||||||
#define AP_DEFAULT_LIMIT_REQ_BODY ((apr_off_t) 0)
|
#define AP_DEFAULT_LIMIT_REQ_BODY ((apr_off_t) 1<<30) /* 1GB */
|
||||||
@@ -5015,6 +5019,28 @@ static int core_post_config(apr_pool_t *pconf, apr_pool_t *plog, apr_pool_t *pte
|
@@ -5150,6 +5154,28 @@ static int core_post_config(apr_pool_t *pconf, apr_pool_t *plog, apr_pool_t *pte
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
@ -23,8 +23,8 @@
|
|||||||
|
|
||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.4.53
|
Version: 2.4.54
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: https://httpd.apache.org/
|
URL: https://httpd.apache.org/
|
||||||
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||||
Source1: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2.asc
|
Source1: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2.asc
|
||||||
@ -84,7 +84,7 @@ Patch21: httpd-2.4.48-r1842929+.patch
|
|||||||
Patch22: httpd-2.4.43-mod_systemd.patch
|
Patch22: httpd-2.4.43-mod_systemd.patch
|
||||||
Patch23: httpd-2.4.53-export.patch
|
Patch23: httpd-2.4.53-export.patch
|
||||||
Patch24: httpd-2.4.43-corelimit.patch
|
Patch24: httpd-2.4.43-corelimit.patch
|
||||||
Patch25: httpd-2.4.43-selinux.patch
|
Patch25: httpd-2.4.54-selinux.patch
|
||||||
Patch26: httpd-2.4.43-gettid.patch
|
Patch26: httpd-2.4.43-gettid.patch
|
||||||
Patch27: httpd-2.4.53-icons.patch
|
Patch27: httpd-2.4.53-icons.patch
|
||||||
Patch30: httpd-2.4.43-cachehardmax.patch
|
Patch30: httpd-2.4.43-cachehardmax.patch
|
||||||
@ -836,6 +836,9 @@ exit $rv
|
|||||||
%{_rpmconfigdir}/macros.d/macros.httpd
|
%{_rpmconfigdir}/macros.d/macros.httpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 09 2022 Luboš Uhliarik <luhliari@redhat.com> - 2.4.54-1
|
||||||
|
- new version 2.4.54
|
||||||
|
|
||||||
* Mon May 16 2022 Joe Orton <jorton@redhat.com> - 2.4.53-7
|
* Mon May 16 2022 Joe Orton <jorton@redhat.com> - 2.4.53-7
|
||||||
- disable package notes
|
- disable package notes
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (httpd-2.4.53.tar.bz2) = 07ef59594251a30a864cc9cc9a58ab788c2d006cef85b728f29533243927c63cb063e0867f2a306f37324c3adb9cf7dcb2402f3516b05c2c6f32469d475dd756
|
SHA512 (httpd-2.4.54.tar.bz2) = 228493b2ff32c4142c6e484d304f2ea12e467498605fe12adce2b61388d8efe7b2e96ae2fd0abd1dc88a5f12d625e007d8da0ae5628cff2a5272806754f41e18
|
||||||
SHA512 (httpd-2.4.53.tar.bz2.asc) = 553df571cf8edda9146c2aaadce7e5a204f9aa8bd05b165dd81e2339db830c06bdb2b546321d3ab1dcc3133a7d37bbbeb31944b725d8a5fc6b6dc389a5c25686
|
SHA512 (httpd-2.4.54.tar.bz2.asc) = 90a582b10bbcd054f62b6961194f7d97b1f0f56286cfd89e0a5c36248808365b4defade068340a1e9deeaee09dcd3e88810bee8951f9840fe666dab8861b757b
|
||||||
SHA512 (KEYS) = 88c848b7ab9e4915d6625dcad3e8328673b0448f2ce76f2c44eecc612cf6afbce3287a4ee7219a44c6fcc61d5ecb2a1a8545456a4a16b90400263d7249cbf192
|
SHA512 (KEYS) = 88c848b7ab9e4915d6625dcad3e8328673b0448f2ce76f2c44eecc612cf6afbce3287a4ee7219a44c6fcc61d5ecb2a1a8545456a4a16b90400263d7249cbf192
|
||||||
|
Loading…
Reference in New Issue
Block a user