- make -devel package multilib-safe (#192686)
This commit is contained in:
parent
21e359146b
commit
48593e5892
@ -1,10 +1,28 @@
|
|||||||
|
|
||||||
- remove unnecessary stuff which runs httpd during build
|
- remove unnecessary stuff which runs httpd during build
|
||||||
- drop unnecessary --libs output from ap?-?-config
|
- drop unnecessary --libs output from ap?-?-config
|
||||||
|
- make multilib-safe
|
||||||
|
|
||||||
--- httpd-2.1.10/support/apxs.in.apxs
|
--- httpd-2.2.2/support/apxs.in.apxs
|
||||||
+++ httpd-2.1.10/support/apxs.in
|
+++ httpd-2.2.2/support/apxs.in
|
||||||
@@ -184,34 +184,6 @@
|
@@ -25,7 +25,15 @@
|
||||||
|
|
||||||
|
my %config_vars = ();
|
||||||
|
|
||||||
|
-my $installbuilddir = "@exp_installbuilddir@";
|
||||||
|
+# Awful hack to make apxs libdir-agnostic:
|
||||||
|
+my $pkg_config = "/usr/bin/pkg-config";
|
||||||
|
+if (! -x "$pkg_config") {
|
||||||
|
+ error("$pkg_config not found!");
|
||||||
|
+ exit(1);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+my $installbuilddir = `pkg-config --variable=libdir apr-1` . "httpd/build";
|
||||||
|
+
|
||||||
|
get_config_vars("$installbuilddir/config_vars.mk",\%config_vars);
|
||||||
|
|
||||||
|
# read the configuration variables once
|
||||||
|
@@ -184,34 +192,6 @@
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -39,7 +57,7 @@
|
|||||||
sub get_config_vars{
|
sub get_config_vars{
|
||||||
my ($file, $rh_config) = @_;
|
my ($file, $rh_config) = @_;
|
||||||
|
|
||||||
@@ -433,9 +405,9 @@
|
@@ -433,9 +413,9 @@
|
||||||
|
|
||||||
if ($opt_p == 1) {
|
if ($opt_p == 1) {
|
||||||
|
|
||||||
|
14
httpd.spec
14
httpd.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.2.2
|
Version: 2.2.2
|
||||||
Release: 3
|
Release: 4
|
||||||
URL: http://httpd.apache.org/
|
URL: http://httpd.apache.org/
|
||||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
||||||
Source1: index.html
|
Source1: index.html
|
||||||
@ -251,9 +251,6 @@ mkdir $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_proxy
|
|||||||
mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
|
mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
|
||||||
$RPM_BUILD_ROOT%{_bindir}
|
$RPM_BUILD_ROOT%{_bindir}
|
||||||
|
|
||||||
# move builddir to the right place
|
|
||||||
#mv $RPM_BUILD_ROOT%{contentdir}/build $RPM_BUILD_ROOT%{_libdir}/httpd/build
|
|
||||||
|
|
||||||
# Make the MMN accessible to module packages
|
# Make the MMN accessible to module packages
|
||||||
echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/httpd/.mmn
|
echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/httpd/.mmn
|
||||||
|
|
||||||
@ -288,7 +285,6 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/httpd
|
|||||||
ln -s ../..%{_localstatedir}/log/httpd $RPM_BUILD_ROOT/etc/httpd/logs
|
ln -s ../..%{_localstatedir}/log/httpd $RPM_BUILD_ROOT/etc/httpd/logs
|
||||||
ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/httpd/run
|
ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/httpd/run
|
||||||
ln -s ../..%{_libdir}/httpd/modules $RPM_BUILD_ROOT/etc/httpd/modules
|
ln -s ../..%{_libdir}/httpd/modules $RPM_BUILD_ROOT/etc/httpd/modules
|
||||||
ln -s ../..%{_libdir}/httpd/build $RPM_BUILD_ROOT/etc/httpd/build
|
|
||||||
|
|
||||||
# install SYSV init stuff
|
# install SYSV init stuff
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
|
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
|
||||||
@ -312,6 +308,10 @@ sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/httpd/conf/httpd.conf|" \
|
|||||||
-e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
|
-e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
|
||||||
> $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
|
> $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
|
||||||
|
|
||||||
|
# Make ap_config_layout.h libdir-agnostic
|
||||||
|
sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
|
||||||
|
$RPM_BUILD_ROOT%{_includedir}/httpd/ap_config_layout.h
|
||||||
|
|
||||||
# Remove unpackaged files
|
# Remove unpackaged files
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.exp \
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.exp \
|
||||||
$RPM_BUILD_ROOT/etc/httpd/conf/mime.types \
|
$RPM_BUILD_ROOT/etc/httpd/conf/mime.types \
|
||||||
@ -472,7 +472,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/httpd
|
%{_includedir}/httpd
|
||||||
%{_sysconfdir}/httpd/build
|
|
||||||
%{_sbindir}/apxs
|
%{_sbindir}/apxs
|
||||||
%{_mandir}/man8/apxs.8*
|
%{_mandir}/man8/apxs.8*
|
||||||
%dir %{_libdir}/httpd/build
|
%dir %{_libdir}/httpd/build
|
||||||
@ -480,6 +479,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/httpd/build/*.sh
|
%{_libdir}/httpd/build/*.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 2 2006 Joe Orton <jorton@redhat.com> 2.2.2-4
|
||||||
|
- make -devel package multilib-safe (#192686)
|
||||||
|
|
||||||
* Thu May 11 2006 Joe Orton <jorton@redhat.com> 2.2.2-3
|
* Thu May 11 2006 Joe Orton <jorton@redhat.com> 2.2.2-3
|
||||||
- build DSOs using -z relro linker flag
|
- build DSOs using -z relro linker flag
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user